所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S9300, S9300E, S9300X V200R010C00 配置指南-QoS

本文档介绍了如何配置QoS功能,主要包括MQC配置、优先级映射配置、流量监管配置、流量整形配置、接口限速配置、拥塞避免配置、拥塞管理配置、报文过滤配置、重定向配置、流量统计配置、基于ACL的简化流策略配置和HQoS配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置禁止指定主机访问网络示例

配置禁止指定主机访问网络示例

组网需求

图9-1所示,企业用户通过Switch的接口GE2/0/1连接到外部网络设备。

每天8:30~18:00的时间段为工作时间,通过GE1/0/1接口对报文进行过滤,禁止访问外网。

图9-1  配置禁止指定主机访问网络组网图

配置思路

采用包含禁止动作的流策略方式实现报文过滤,具体配置思路如下:
  1. 配置各接口,实现企业用户能通过Switch访问外部网络。
  2. 配置时间范围,用于在ACL中引用。
  3. 配置ACL,在工作时间段禁止报文通过。
  4. 在接口GE1/0/1的入方向配置报文过滤。

操作步骤

  1. 创建VLAN并配置各接口

    # 在Switch上创建VLAN10。

    <Quidway> system-view
    [Quidway] sysname Switch
    [Switch] vlan 10
    [Switch-vlan10] quit

    # 配置Switch上接口GE1/0/1GE2/0/1为Trunk类型接口,并加入VLAN10。

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type trunk
    [Switch-GigabitEthernet1/0/1] port trunk allow-pass vlan 10
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 2/0/1
    [Switch-GigabitEthernet2/0/1] port link-type trunk
    [Switch-GigabitEthernet2/0/1] port trunk allow-pass vlan 10
    [Switch-GigabitEthernet2/0/1] quit
    说明:

    请配置LSW与Switch对接的接口为Trunk类型,并加入VLAN10。

    # 创建VLANIF10,并为VLANIF10配置IP地址192.168.1.1/24。

    [Switch] interface vlanif 10
    [Switch-Vlanif10] ip address 192.168.1.1 24
    [Switch-Vlanif10] quit
    说明:

    请配置Router与Switch对接的接口IP地址为192.168.1.2/24。

  2. 创建周期时间段working_time,时间范围为每天的8:30~18:00。

    [Switch] time-range working_time 08:30 to 18:00 working-day
    

  3. 配置ACL 3001,配置三条规则,分别为禁止源IP地址为192.168.1.10、192.168.1.11、192.168.1.12的报文在工作时间通过。

    [Switch] acl number 3001
    [Switch-acl-adv-3001] rule deny ip source 192.168.1.10 0 time-range working_time                        
    [Switch-acl-adv-3001] rule deny ip source 192.168.1.11 0 time-range working_time
    [Switch-acl-adv-3001] rule deny ip source 192.168.1.12 0 time-range working_time
    [Switch-acl-adv-3001] quit

  4. 在接口GE1/0/1的入方向配置报文过滤。

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] traffic-filter inbound acl 3001
    [Switch-GigabitEthernet1/0/1] quit

  5. 验证配置结果

    # 看设备接口入方向上应用的ACL规则和流动作信息。

    [Switch] display traffic-applied interface gigabitethernet 1/0/1 inbound
    -----------------------------------------------------------                     
    ACL applied inbound interface GigabitEthernet1/0/1                              
                                                                                    
    ACL 3001                                                                        
     rule 5 deny ip source 192.168.1.10 0 time-range working_time (match-counter 0)
    ACTIONS:                                                                        
     filter                                                                         
    -----------------------------------------------------------                     
                                                                                    
    ACL 3001                                                                        
     rule 10 deny ip source 192.168.1.11 0 time-range working_time (match-counter 0)
    ACTIONS:                                                                        
     filter                                                                         
    -----------------------------------------------------------                     
                                                                                    
    ACL 3001                                                                        
     rule 15 deny ip source 192.168.1.12 0 time-range working_time (match-counter 0)
    ACTIONS:                                                                        
     filter                                                                         
    -----------------------------------------------------------                                                
    

配置文件

  • Switch的配置文件

    #
    sysname Switch
    #
    vlan batch 10
    #
    time-range working_time 08:30 to 18:00 working-day     
    # 
    acl number 3001                                                                 
     rule 5 deny ip source 192.168.1.10 0 time-range working_time                            
     rule 10 deny ip source 192.168.1.11 0 time-range working_time                            
     rule 15 deny ip source 192.168.1.12 0 time-range working_time         
    # 
    interface Vlanif10                                                              
     ip address 192.168.1.1 255.255.255.0                                           
    #                                                                               
    interface GigabitEthernet1/0/1
     port link-type trunk                                                           
     port trunk allow-pass vlan 10                                                  
     traffic-filter inbound acl 3001                                                    
    #                                                                               
    interface GigabitEthernet2/0/1
     port link-type trunk                                                           
     port trunk allow-pass vlan 10                                                  
    #
    return
    
翻译
下载文档
更新时间:2019-08-20

文档编号:EDOC1000141522

浏览量:4907

下载量:408

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页