所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S9300, S9300E, S9300X V200R010C00 配置指南-网络管理与监控

本文档介绍了设备支持的网络管理与监控相关配置。主要内容包括:SNMP配置、RMON和RMON2配置、LLDP配置、性能管理、iPCA配置、NQA配置、业务诊断配置、镜像配置、报文捕获配置、分流配置、NetStream配置、sFlow配置、TWAMP Light配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置基于ECMP的分流示例

配置基于ECMP的分流示例

组网需求

图10-6所示,SwitchA通过接口GE2/0/1与上游分流设备连接。上游分流设备分过来的流量从接口GE2/0/1进入SwitchA。

客户希望将上游分过来的流量分配给4台报文分析服务器上进行分析,并能够保证同源同宿,分析报文内容和分流之前相同。SwitchA和报文分析服务器间只部署单纤,报文分析服务器只接收数据不发送数据,保证报文分析服务器的数据安全。

图10-6  基于ECMP的分流组网图

接口

对应的VLANIF

IP地址

GigabitEthernet 1/0/1

VLANIF 10

10.1.1.1/24

GigabitEthernet 1/0/2

VLANIF 20

10.1.2.1/24

GigabitEthernet 1/0/3

VLANIF 30

10.1.3.1/24

GigabitEthernet 1/0/4

VLANIF 40

10.1.4.1/24

GigabitEthernet 2/0/1

VLANIF 100

10.0.0.1/24

配置思路

采用如下的思路配置:
  1. 配置流量的入接口和出接口的IP地址,从而可以配置静态路由。

  2. 配置静态等价路由,实现ECMP的负载分担。

  3. 配置基于ECMP的同源同宿功能,将需要分析的报文分配到4个服务器进行分析。

  4. 配置数据完整性功能,保证需要分析的报文内容和分流之前相同。

  5. 配合单纤组网,配置单纤单向功能,保证报文分析服务器的数据安全。

操作步骤

  1. 配置各接口所属VLAN。

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] vlan batch 10 20 30 40 100
    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 10.1.1.1 24
    [SwitchA-Vlanif10] quit
    [SwitchA] interface vlanif 20
    [SwitchA-Vlanif20] ip address 10.1.2.1 24
    [SwitchA-Vlanif20] quit
    [SwitchA] interface vlanif 30
    [SwitchA-Vlanif30] ip address 10.1.3.1 24
    [SwitchA-Vlanif30] quit
    [SwitchA] interface vlanif 40
    [SwitchA-Vlanif40] ip address 10.1.4.1 24
    [SwitchA-Vlanif40] quit
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type access
    [SwitchA-GigabitEthernet1/0/1] port default vlan 10
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type access
    [SwitchA-GigabitEthernet1/0/2] port default vlan 20
    [SwitchA-GigabitEthernet1/0/2] quit
    [SwitchA] interface gigabitethernet 1/0/3
    [SwitchA-GigabitEthernet1/0/3] port link-type access
    [SwitchA-GigabitEthernet1/0/3] port default vlan 30
    [SwitchA-GigabitEthernet1/0/3] quit
    [SwitchA] interface gigabitethernet 1/0/4
    [SwitchA-GigabitEthernet1/0/4] port link-type access
    [SwitchA-GigabitEthernet1/0/4] port default vlan 40
    [SwitchA-GigabitEthernet1/0/4] quit
    

  2. 配置接口的IP地址。

    # 配置接口VLANIF100的IP地址。

    [SwitchA] interface gigabitethernet2/0/1
    [SwitchA-GigabitEthernet2/0/1] port link-type access
    [SwitchA-GigabitEthernet2/0/1] port default vlan 100
    [SwitchA-GigabitEthernet2/0/1] quit
    [SwitchA] interface vlanif 100
    [SwitchA-Vlanif100] ip address 10.0.0.1 255.255.255.0
    [SwitchA-Vlanif100] quit

    # 其它接口的IP地址的配置过程与接口VLANIF100上的配置相似,具体数据如图10-6所示,配置过程略。

  3. 配置静态等价路由。

    # 配置静态等价路由,对流量进行负载分担。

    [SwitchA] ip route-static 0.0.0.0 0 vlanif 10 10.1.1.2
    [SwitchA] ip route-static 0.0.0.0 0 vlanif 20 10.1.2.2
    [SwitchA] ip route-static 0.0.0.0 0 vlanif 30 10.1.3.2
    [SwitchA] ip route-static 0.0.0.0 0 vlanif 40 10.1.4.2
    

  4. 配置基于ECMP的同源同宿功能。

    # 配置等价路由基于同源同宿的分流功能。

    [SwitchA] ecmp load-balance diffluence

  5. 配置数据完整性。

    # 在VLANIF100接口上配置设备在接收到IP报文后在进行三层转发时不关注MAC地址功能。

    [SwitchA] interface vlanif 100
    [SwitchA-Vlanif100] ip forward-mode dstmac-independent
    [SwitchA-Vlanif100] quit
    

    # IP报文在三层转发时源MAC地址和目的MAC地址不变功能。

    [SwitchA] ip forwarding mac-unvaried
    

    # 在接口GE2/0/1上配置TTL值不变。

    [SwitchA] interface gigabitethernet2/0/1
    [SwitchA-GigabitEthernet2/0/1] set ttl unvaried 
    [SwitchA-GigabitEthernet2/0/1] quit
    
    说明:

    TTL值不变功能需要在报文的入接口配置才能生效。

  6. 配置单纤单向。

    # 在与报文分析服务器连接的GE接口上配置单纤单向。

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] undo negotiation auto
    [SwitchA-GigabitEthernet1/0/1] single-fiber enable
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] undo negotiation auto
    [SwitchA-GigabitEthernet1/0/2] single-fiber enable
    [SwitchA-GigabitEthernet1/0/2] quit
    [SwitchA] interface gigabitethernet 1/0/3
    [SwitchA-GigabitEthernet1/0/3] undo negotiation auto
    [SwitchA-GigabitEthernet1/0/3] single-fiber enable
    [SwitchA-GigabitEthernet1/0/3] quit
    [SwitchA] interface gigabitethernet 1/0/4
    [SwitchA-GigabitEthernet1/0/4] undo negotiation auto
    [SwitchA-GigabitEthernet1/0/4] single-fiber enable
    [SwitchA-GigabitEthernet1/0/4] quit
    

配置文件

SwitchA的配置文件

#
sysname SwitchA
#
vlan batch 10 20 30 40 100
#
ip forwarding mac-unvaried
#
interface Vlanif10
 ip address 10.1.1.1 255.255.255.0
#
interface Vlanif20
 ip address 10.1.2.1 255.255.255.0
#
interface Vlanif30
 ip address 10.1.3.1 255.255.255.0
#
interface Vlanif40
 ip address 10.1.4.1 255.255.255.0
#
interface Vlanif100
 ip address 10.0.0.1 255.255.255.0
 ip forward-mode dstmac-independent
#
interface GigabitEthernet1/0/1
 undo negotiation auto 
 single-fiber enable
 port link-type access
 port default vlan 10
#
interface GigabitEthernet1/0/2
 undo negotiation auto 
 single-fiber enable
 port link-type access
 port default vlan 20
#
interface GigabitEthernet1/0/3
 undo negotiation auto 
 single-fiber enable
 port link-type access
 port default vlan 30
#
interface GigabitEthernet1/0/4
 undo negotiation auto 
 single-fiber enable
 port link-type access
 port default vlan 40
#
interface GigabitEthernet2/0/1
 port link-type access
 port default vlan 100
 set ttl unvaried
#
ip route-static 0.0.0.0 0.0.0.0 Vlanif10 10.1.1.2
ip route-static 0.0.0.0 0.0.0.0 Vlanif20 10.1.2.2
ip route-static 0.0.0.0 0.0.0.0 Vlanif30 10.1.3.2
ip route-static 0.0.0.0 0.0.0.0 Vlanif40 10.1.4.2
#
ecmp load-balance diffluence
#
return
翻译
下载文档
更新时间:2019-08-21

文档编号:EDOC1000141529

浏览量:20363

下载量:402

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页