所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S9300, S9300E, S9300X V200R010C00 配置指南-网络管理与监控

本文档介绍了设备支持的网络管理与监控相关配置。主要内容包括:SNMP配置、RMON和RMON2配置、LLDP配置、性能管理、iPCA配置、NQA配置、业务诊断配置、镜像配置、报文捕获配置、分流配置、NetStream配置、sFlow配置、TWAMP Light配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置CR-LSP热备份隧道LSP Trace测试示例

配置CR-LSP热备份隧道LSP Trace测试示例

组网需求

图6-46所示的MPLS VPN网络,从SwitchA上建立一条TE隧道,目的地址为SwitchC,并配置CR-LSP热备份(hot-standby)隧道。
  • SwitchA、SwitchB、SwitchC、SwitchD都运行OSPF协议,并学习到彼此Loopback接口的32位主机路由。

  • SwitchA、SwitchB、SwitchC、SwitchD上都启用MPLS、MPLS TE和MPLS RSVP-TE。

  • SwitchA、SwitchB、SwitchC、SwitchD之间的接口都启用MPLS、MPLS TE和MPLS RSVP-TE,建立从SwitchA到SwitchC的TE隧道。

其中:
  • 主CR-LSP的路径为SwitchA-->SwitchB-->SwitchC
  • 备份CR-LSP的路径为SwitchA-->SwitchD-->SwitchC
当主CR-LSP故障时,流量切换到备份CR-LSP。当主CR-LSP故障恢复,延时15秒后再进行流量回切。

但是当备份CR-LSP出现故障不能承载主链路切换过来的流量时,需要对这条备份链路进行检测。应用NQA LSP Trace可以实现对CR-LSP热备份(hot-standby)隧道进行连通性的检测。NQA集成的备份链路的检测功能,可以对备份链路的连通性及性能状况进行实时的检测,便于链路故障的检测和定位。

说明:

请确保该场景下互联接口的STP处于未使能状态。因为在使能STP的环形网络中,如果用交换机的VLANIF接口构建三层网络,会导致某个端口被阻塞,从而导致三层业务不能正常运行。

图6-46  LSP Trace测试组网图

配置思路

采用如下思路进行LSP Trace测试的配置:

  1. SwitchA作为NQA客户端,在SwitchA上建立LSP Trace测试用例。

  2. SwitchC作为NQA服务器端。

操作步骤

  1. 配置SwitchA、SwitchB、SwitchC和SwitchD之间路由可达

    具体配置内容请参见本例的配置文件。

  2. 配置SwitchA、SwitchB、SwitchC和SwitchD的MPLS RSVP-TE

    具体配置内容请参见本例的配置文件。

  3. 配置SwitchA上建立到SwitchC的TE隧道

    具体配置内容请参见本例的配置文件。

  4. 配置SwitchA的NQA测试例

    # 使能NQA客户端,配置TE隧道的LSP Trace测试例。

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] nqa test-instance admin lsptrace
    [SwitchA-nqa-admin-lsptrace] test-type lsptrace
    [SwitchA-nqa-admin-lsptrace] lsp-type te
    [SwitchA-nqa-admin-lsptrace] lsp-tetunnel tunnel 1 hot-standby

  5. 启动测试操作

    [SwitchA-nqa-admin-lsptrace] start now

  6. 验证测试结果

    [SwitchA-nqa-admin-lsptrace] display nqa results test-instance admin lsptrace
     NQA entry(admin, lsptrace) :testflag is inactive ,testtype is lsptrace
       1 . Test 1 result   The test is finished
       Completion:success                                Attempts number:1
       Disconnect operation number:0                     Operation timeout number:0
       System busy operation number:0                    Connection fail number:0   
       Operation sequence errors number:0                RTT Status errors number:0   
       Drop operation number:0                           
       Last good path Time:2009-04-24 11:22:21.2
       1 . Hop 1    
        Send operation times: 3               Receive response times: 3    
        Min/Max/Average Completion Time: 50/60/56   
        Sum/Square-Sum  Completion Time: 170/9700
        RTD OverThresholds number: 0    
        Last Good Probe Time: 2009-04-24 11:22:20.8 
        Destination ip address:10.1.3.2 
        Lost packet ratio: 0 % 
       2 . Hop 2    
        Send operation times: 3               Receive response times: 3    
        Min/Max/Average Completion Time: 80/110/93 
        Sum/Square-Sum  Completion Time: 280/26600
        RTD OverThresholds number: 0    
        Last Good Probe Time: 2009-04-24 11:22:21.2 
        Destination ip address:10.3.3.3
        Lost packet ratio: 0 % 

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 10 30
    #
    mpls lsr-id 10.5.5.5
    mpls
     mpls te
     mpls rsvp-te
     mpls te cspf
    #
    explicit-path backup
     next hop 10.1.3.2
     next hop 10.1.4.2
     next hop 10.3.3.3
    #
    explicit-path main
     next hop 10.1.1.2
     next hop 10.1.2.2
     next hop 10.3.3.3
    #
    interface Vlanif10
     ip address 10.5.5.5 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif30
     ip address 10.1.3.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface  GigabitEthernet1/0/0
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface  GigabitEthernet2/0/0
     port hybrid pvid vlan 30
     port hybrid untagged vlan 30
    #
    interface LoopBack1
     ip address 10.5.5.5 255.255.255.255
    #
    interface Tunnel1
     ip address unnumbered interface LoopBack1
     tunnel-protocol mpls te
     destination 10.3.3.3
     mpls te tunnel-id 100
     mpls te record-route
     mpls te path explicit-path main
     mpls te path explicit-path backup secondary
     mpls te backup hot-standby mode revertive wtr 15
     mpls te backup ordinary best-effort
     mpls te commit
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.5.5.5 0.0.0.0
      network 10.1.3.0 0.0.0.255
      mpls-te enable
    #
    nqa test-instance admin lsptrace
     test-type lsptrace
     lsp-type te
     lsp-tetunnel Tunnel1 hot-standby
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 10 20
    #
    mpls lsr-id 10.2.2.2
    mpls
     mpls te
     mpls rsvp-te
     mpls te cspf
    #
    interface Vlanif10
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif20
     ip address 10.1.2.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface  GigabitEthernet1/0/0
     port hybrid pvid vlan 20
     port hybrid untagged vlan 20
    #
    interface  GigabitEthernet2/0/0
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface LoopBack1
     ip address 10.2.2.2 255.255.255.255
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.2.2.2 0.0.0.0
      network 10.1.2.0 0.0.0.255
      mpls-te enable
    #
    return
    
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 20 40
    #
    mpls lsr-id 10.3.3.3
    mpls
     mpls te
     mpls rsvp-te
     mpls te cspf
    #
    interface Vlanif20
     ip address 10.1.2.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif40
     ip address 10.1.4.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface  GigabitEthernet1/0/0
     port hybrid pvid vlan 40
     port hybrid untagged vlan 40
    #
    interface  GigabitEthernet2/0/0
     port hybrid pvid vlan 20
     port hybrid untagged vlan 20
    #
    interface LoopBack1
     ip address 10.3.3.3 255.255.255.255
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 10.1.2.0 0.0.0.255
      network 10.1.4.0 0.0.0.255
      network 10.3.3.3 0.0.0.0
      mpls-te enable
    #
    return
    
  • SwitchD的配置文件

    #
    sysname SwitchD
    #
    vlan batch 30 40
    #
    mpls lsr-id 10.4.4.4
    mpls
     mpls te
     mpls rsvp-te
     mpls te cspf
    #
    interface Vlanif30
     ip address 10.1.3.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif40
     ip address 10.1.4.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface  GigabitEthernet1/0/0
     port hybrid pvid vlan 30
     port hybrid untagged vlan 30
    #
    interface  GigabitEthernet2/0/0
     port hybrid pvid vlan 40
     port hybrid untagged vlan 40
    #
    interface LoopBack1
     ip address 10.4.4.4 255.255.255.255
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 10.4.4.4 0.0.0.0
      network 10.1.3.0 0.0.0.255
      network 10.1.4.0 0.0.0.255
      mpls-te enable
    #
    return
    
翻译
下载文档
更新时间:2019-08-21

文档编号:EDOC1000141529

浏览量:20053

下载量:402

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页