所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S9300, S9300E, S9300X V200R010C00 配置指南-网络管理与监控

本文档介绍了设备支持的网络管理与监控相关配置。主要内容包括:SNMP配置、RMON和RMON2配置、LLDP配置、性能管理、iPCA配置、NQA配置、业务诊断配置、镜像配置、报文捕获配置、分流配置、NetStream配置、sFlow配置、TWAMP Light配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置NQA阈值告警示例

配置NQA阈值告警示例

组网需求

图6-55所示,SwitchA作为客户端进行Jitter测试,对测试结果的丢包率进行监控,在测试结果中的丢包率超过阈值后向网管端发送Trap。

图6-55  NQA阈值告警组网图

配置思路

采用的配置思路如下。

  1. 配置SwitchA为Jitter测试的客户端。

  2. SwitchA上配置阈值告警相关事件。

  3. SwitchA阈值告警,并向网管发送告警消息。

操作步骤

  1. 图6-55配置各接口的IP地址并配置Switch之间路由可达

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] vlan batch 100 110
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port hybrid pvid vlan 100
    [SwitchA-GigabitEthernet1/0/1] port hybrid untagged vlan 100
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface vlanif 100
    [SwitchA-Vlanif100] ip address 10.1.1.1 24
    [SwitchA-Vlanif100] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port hybrid pvid vlan 110
    [SwitchA-GigabitEthernet1/0/2] port hybrid untagged vlan 110
    [SwitchA-GigabitEthernet1/0/2] quit
    [SwitchA] interface vlanif 110
    [SwitchA-Vlanif110] ip address 10.1.2.1 24
    [SwitchA-Vlanif110] quit
    说明:

    SwitchB的配置请参考配置文件。

  2. SwitchB上配置NQA服务器

    # 配置NQA UDP服务器端的IP地址和端口号。

    <SwitchB> system-view
    [SwitchB] nqa-server udpecho 10.1.1.2 9000

  3. SwitchA上配置告警相关事件

    [SwitchA] nqa event 10 log-trap

  4. SwitchA配置阈值告警

    [SwitchA] nqa test-instance admin jitter
    [SwitchA-nqa-admin-jitter] test-type jitter
    [SwitchA-nqa-admin-jitter] destination-address ipv4 10.1.1.2
    [SwitchA-nqa-admin-jitter] destination-port 9000
    [SwitchA-nqa-admin-jitter] frequency 5
    [SwitchA-nqa-admin-jitter] alarm 10 lost-packet-ratio absolute rising-threshold 80 10 falling-threshold 30 10
    [SwitchA-nqa-admin-jitter] quit

  5. SwitchA配置向网管发送告警。

    # 配置SNMP基本功能。

    [SwitchA] snmp-agent community read public123
    [SwitchA] snmp-agent community write private123
    [SwitchA] snmp-agent sys-info version v2c

    # 配置通过SNMP向网管端发送Trap。

    [SwitchA] snmp-agent trap enable
    [SwitchA] snmp-agent target-host trap address udp-domain 10.1.2.2 params securityname switchA

  6. 启动测试

    [SwitchA] nqa test-instance admin jitter
    [SwitchA-admin-jitter] start now

  7. 查看配置结果。

    当测试的丢包率达到配置的告警上限或下限时,网管端能看到上报的告警。

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 100 110
    #
    interface Vlanif100
     ip address 10.1.1.1 255.255.255.0
    #
    interface Vlanif110
     ip address 10.1.2.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    interface GigabitEthernet1/0/2
     port hybrid pvid vlan 110
     port hybrid untagged vlan 110
    #
    snmp-agent
    snmp-agent local-engineid 800007DB03548998F3A458                               
    snmp-agent community read cipher %^%#D]&bKCCRjC=7sTLO!f*Xcda~6Agnd7irJX,oUV%4TC^>"GXkFK4G4#Lw(Nm7Wid0O00\B:H{yDKtCCe&%^%# 
    snmp-agent community write cipher %^%#sZaU6ZfkO<4'!s9g&[X~N}|5<C<qUUqEecV%+4^RG#jH*S2%IQOPe#$Z9|Y@(<SHFyomFI$Wq<#h^ueW%^%#  
    snmp-agent sys-info version v2c v3                                             
    snmp-agent target-host trap address udp-domain 10.1.2.2 params securityname cipher %^%#.VYh22r_VPzZ5m2azPQDYh^9:]r~oIFBl[#Aq95*%^%# 
    snmp-agent trap enable                                                         
    #
    nqa event 10 log-trap
    #
    nqa test-instance admin jitter                                                     
     test-type jitter                                                                 
     destination-address ipv4 10.1.1.2 
     destination-port 9000
     alarm 10 lost-packet-ratio absolute rising-threshold 80 10 falling-threshold 30 10
    #
    return   
    
  • SwitchB的配置文件
    #
    sysname SwitchB
    #
    vlan batch 100
    #
    interface Vlanif100
     ip address 10.1.1.2 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    nqa-server udpecho 10.1.1.2 9000
    #
    return   
    
翻译
下载文档
更新时间:2019-08-21

文档编号:EDOC1000141529

浏览量:19998

下载量:402

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页