所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S9300, S9300E, S9300X V200R010C00 配置指南-网络管理与监控

本文档介绍了设备支持的网络管理与监控相关配置。主要内容包括:SNMP配置、RMON和RMON2配置、LLDP配置、性能管理、iPCA配置、NQA配置、业务诊断配置、镜像配置、报文捕获配置、分流配置、NetStream配置、sFlow配置、TWAMP Light配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置设备使用SNMPv2c与网管通信示例

配置设备使用SNMPv2c与网管通信示例

组网需求

图1-10所示,现有网络中网管NMS1和NMS2对网络中的设备进行监管。由于网络规模较大,安全性较高,但运行的业务较为繁忙,在规划时配置设备使用SNMPv2c版本与网管进行通信。现在由于扩容需要,新增一台交换机,并由网管NMS2对其进行监管。

用户希望通过利用现有的网络资源对交换机进行监管,并且对发生故障能够快速对故障定位和排除。根据用户业务需要,网管站需要对交换机的除RMON的之外的节点管理。

图1-10  配置使用SNMPv2c与网管通信组网图

配置思路

考虑到用户所在网络规模较大,安全性较高,业务较繁忙等因素,因此新增设备依然使用SNMPv2c版本。为减轻网管站的负担,选取NMS2来监管交换机,NMS1不监管交换机

采用如下的配置思路:

  1. 配置交换机的SNMP版本为SNMPv2c。

  2. 配置访问权限,使NMS2可以管理交换机上RMON之外的节点。

  3. 配置告警主机,此处配置交换机的Inform告警功能,使交换机产生的告警能够发送至NMS2。为了方便对告警信息进行定位,避免过多的无用告警对处理问题造成干扰,仅允许缺省打开的模块可以发送告警。

  4. 配置网管NMS2。

操作步骤

  1. 配置交换机的接口IP地址

    # 按图1-10所示,配置交换机的接口IP地址。

    <Quidway> system-view
    [Quidway] sysname Switch
    [Switch] vlan 100
    [Switch-vlan100] quit
    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port hybrid pvid vlan 100
    [Switch-GigabitEthernet1/0/1] port hybrid untagged vlan 100
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface vlanif 100
    [Switch-Vlanif100] ip address 10.1.2.1 24
    [Switch-Vlanif100] quit

  2. 配置交换机和网管站之间路由可达

    [Switch] ospf
    [Switch-ospf-1] area 0
    [Switch-ospf-1-area-0.0.0.0] network 10.1.2.0 0.0.0.255
    [Switch-ospf-1-area-0.0.0.0] quit
    [Switch-ospf-1] quit

  3. 配置交换机的SNMP版本为SNMPv2c

    [Switch] snmp-agent sys-info version v2c

  4. 配置访问权限

    # 配置ACL,使NMS2可以管理交换机,NMS1不允许管理交换机

    [Switch] acl 2001
    [Switch-acl-basic-2001] rule 5 permit source 10.1.1.2 0.0.0.0
    [Switch-acl-basic-2001] rule 6 deny source 10.1.1.1 0.0.0.0
    [Switch-acl-basic-2001] quit

    # 配置MIB视图,限制NMS2可以管理交换机上除RMON之外的节点。

    [Switch] snmp-agent mib-view excluded allextrmon 1.3.6.1.2.1.16

    # 配置团体名并引用ACL和MIB视图。

    [Switch] snmp-agent community write adminnms2 mib-view allextrmon acl 2001

  5. 配置告警主机

    [Switch] snmp-agent target-host inform address udp-domain 10.1.1.2 params securityname adminnms2 v2c
    [Switch] snmp-agent inform timeout 5 resend-times 6 pending 7

  6. 配置网管站(NMS2)

    在使用SNMPv2c版本的NMS上需要设置“读写团体名”。网管的配置请根据采用的网管产品参考对应的网管配置手册。

    说明:

    网管系统的认证参数配置必须和设备上保持一致,否则网管系统无法管理设备。如果设备上只配置了write团体名,那么网管端读和写团体名都用设备上配置的write团体名。

  7. 验证配置结果

    配置完成后,可以执行下面的命令,检查配置内容是否生效。

    # 查看SNMP版本。

    [Switch] display snmp-agent sys-info version
       SNMP version running in the system:                                          
               SNMPv2c SNMPv3  

    # 查看告警的目标主机。

    [Switch] display snmp-agent target-host
    Target-host NO. 1
    -----------------------------------------------------------
      IP-address    : 10.1.1.2
      Source interface : - 
      VPN instance  : - 
      Security name : %^%#uq/!YZfvW4*vf[~C|.:Cl}UqS(vXd#wwqR~5M(rU%%^%#
      Port          : 162
      Type          : inform
      Version       : v2c
      Level         : No authentication and privacy
      NMS type      : NMS
      With ext-vb   : No
    -----------------------------------------------------------

配置文件

Switch的配置文件

#
sysname Switch
#
vlan batch 100
#
acl number 2001
 rule 5 permit source 10.1.1.2 0
 rule 6 deny source 10.1.1.1 0
#
interface Vlanif100
 ip address 10.1.2.1 255.255.255.0
#
interface GigabitEthernet1/0/1
 port hybrid pvid vlan 100
 port hybrid untagged vlan 100
#
ospf 1
 area 0.0.0.0
  network 10.1.2.0 0.0.0.255
#
snmp-agent
snmp-agent local-engineid 800007DB03360102101100
snmp-agent community write cipher %^%#.T|&Whvyf$<Gd"I,wXi5SP_6~Nakk6<<+3H:N-h@aJ6d,l0md%HCeAY8~>X=>xV\JKNAL=124r839v<*%^%# mib-view allextrmon acl 2001 
snmp-agent sys-info version v2c v3
snmp-agent target-host inform address udp-domain 10.1.1.2 params securityname cipher %^%#uq/!YZfvW4*vf[~C|.:Cl}UqS(vXd#wwqR~5M(rU%%^%# v2c
snmp-agent mib-view excluded allextrmon rmon 
snmp-agent inform timeout 5
snmp-agent inform resend-times 6
snmp-agent inform pending 7    
#
return
翻译
下载文档
更新时间:2019-08-21

文档编号:EDOC1000141529

浏览量:19971

下载量:402

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页