所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S9300, S9300E, S9300X V200R010C00 配置指南-网络管理与监控

本文档介绍了设备支持的网络管理与监控相关配置。主要内容包括:SNMP配置、RMON和RMON2配置、LLDP配置、性能管理、iPCA配置、NQA配置、业务诊断配置、镜像配置、报文捕获配置、分流配置、NetStream配置、sFlow配置、TWAMP Light配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置检测从组播源到目的主机的RPF路径的测试例示例

配置检测从组播源到目的主机的RPF路径的测试例示例

组网需求

图6-49所示,在PIM-SM组播网络中,在PIM-SM组播网络中,所有Switch执行NTP时间同步协议,保证各Switch时间同步,Receiver加入组播组225.1.1.1,正常接收Source发送的组播数据。已知SwitchB是最后一跳Switch。需求:判断沿RPF路径,如何从Source到达Receiver。

解决方案:在SwitchC上执行使用NQA MTrace测试例实现MTrace功能,检测从组播源到目的主机的RPF路径。

说明:

请确保该场景下互联接口的STP处于未使能状态。因为在使能STP的环形网络中,如果用交换机的VLANIF接口构建三层网络,会导致某个端口被阻塞,从而导致三层业务不能正常运行。

图6-49  从组播源到目的主机的RPF路径测试组网图

配置思路

本例中采用的配置思路如下。

  1. SwitchC作为NQA Client,配置MTrace测试例。

  2. 启动测试例,验证检测结果。

操作步骤

  1. 配置交换机通过OSPF实现间路由可达。

    # 配置SwitchA。

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] vlan batch 110 170
    [SwitchA] interface vlanif110
    [SwitchA-Vlanif110] ip address 10.1.5.1 24
    [SwitchA-Vlanif110] quit
    [SwitchA] interface vlanif170
    [SwitchA-Vlanif170] ip address 10.1.6.3 24
    [SwitchA-Vlanif170] quit
    [SwitchA] interface gigabitethernet 1/0/0
    [SwitchA-GigabitEthernet1/0/0] port link-type trunk
    [SwitchA-GigabitEthernet1/0/0] port trunk allow-pass vlan 110
    [SwitchA-GigabitEthernet1/0/0] quit
    [SwitchA] interface gigabitethernet 3/0/0
    [SwitchA-GigabitEthernet3/0/0] port link-type trunk
    [SwitchA-GigabitEthernet3/0/0] port trunk allow-pass vlan 170
    [SwitchA-GigabitEthernet3/0/0] quit
    [SwitchA] ospf 1
    [SwitchA-ospf-1] area 0
    [SwitchA-ospf-1-area-0.0.0.0] network 10.1.5.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] network 10.1.6.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] quit
    [SwitchA-ospf-1] quit

    # 配置SwitchB。

    <Quidway> system-view
    [Quidway] sysname SwitchB
    [SwitchB] vlan batch 120 160 170
    [SwitchB] interface vlanif120
    [SwitchB-Vlanif120] ip address 10.1.4.1 24
    [SwitchB-Vlanif120] quit
    [SwitchB] interface vlanif160
    [SwitchB-Vlanif160] ip address 10.1.3.1 24
    [SwitchB-Vlanif160] quit
    [SwitchB] interface vlanif170
    [SwitchB-Vlanif170] ip address 10.1.6.2 24
    [SwitchB-Vlanif170] quit
    [SwitchB] interface gigabitethernet 1/0/0
    [SwitchB-GigabitEthernet1/0/0] port link-type trunk
    [SwitchB-GigabitEthernet1/0/0] port trunk allow-pass vlan 160
    [SwitchB-GigabitEthernet1/0/0] quit
    [SwitchB] interface gigabitethernet 2/0/0
    [SwitchB-GigabitEthernet2/0/0] port link-type trunk
    [SwitchB-GigabitEthernet2/0/0] port trunk allow-pass vlan 120
    [SwitchB-GigabitEthernet2/0/0] quit
    [SwitchB] interface gigabitethernet 3/0/0
    [SwitchB-GigabitEthernet3/0/0] port link-type trunk
    [SwitchB-GigabitEthernet3/0/0] port trunk allow-pass vlan 170
    [SwitchB-GigabitEthernet3/0/0] quit
    [SwitchB] ospf 1
    [SwitchB-ospf-1] area 0
    [SwitchB-ospf-1-area-0.0.0.0] network 10.1.3.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] network 10.1.4.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] network 10.1.6.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] quit
    [SwitchB-ospf-1] quit

    # 配置SwitchC。

    <Quidway> system-view
    [Quidway] sysname SwitchC
    [SwitchC] vlan batch 150 160
    [SwitchC] interface vlanif 150
    [SwitchC-Vlanif150] ip address 10.1.1.1 24
    [SwitchC-Vlanif150] quit
    [SwitchC] interface vlanif 160
    [SwitchC-Vlanif160] ip address 10.1.3.2 24
    [SwitchC-Vlanif160] quit
    [SwitchC] interface gigabitethernet 1/0/0
    [SwitchC-GigabitEthernet1/0/0] port link-type trunk
    [SwitchC-GigabitEthernet1/0/0] port trunk allow-pass vlan 160
    [SwitchC-GigabitEthernet1/0/0] quit
    [SwitchC] interface gigabitethernet 2/0/0
    [SwitchC-GigabitEthernet2/0/0] port link-type trunk
    [SwitchC-GigabitEthernet2/0/0] port trunk allow-pass vlan 150
    [SwitchC-GigabitEthernet2/0/0] quit
    [SwitchC] interface loopback0
    [SwitchC-LoopBack0] ip address 10.2.2.2 32
    [SwitchC-LoopBack0] quit
    [SwitchC] ospf 1
    [SwitchC-ospf-1] area 0
    [SwitchC-ospf-1-area-0.0.0.0] network 10.2.2.2 0.0.0.0
    [SwitchC-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [SwitchC-ospf-1-area-0.0.0.0] network 10.1.3.0 0.0.0.255
    [SwitchC-ospf-1-area-0.0.0.0] quit
    [SwitchC-ospf-1] quit

    # 配置SwitchD。

    <Quidway> system-view
    [Quidway] sysname SwitchD
    [SwitchD] vlan batch 110 120 130
    [SwitchD] interface vlanif 110
    [SwitchD-Vlanif110] ip address 10.1.5.2 24
    [SwitchD-Vlanif110] quit
    [SwitchD] interface vlanif 120
    [SwitchD-Vlanif120] ip address 10.1.4.2 24
    [SwitchD-Vlanif120] quit
    [SwitchD] interface vlanif 130
    [SwitchD-Vlanif130]  ip address 10.1.2.1 24
    [SwitchD-Vlanif130] quit
    [SwitchD] interface gigabitethernet 1/0/0
    [SwitchD-GigabitEthernet1/0/0] port link-type trunk
    [SwitchD-GigabitEthernet1/0/0] port trunk allow-pass vlan 110
    [SwitchD-GigabitEthernet1/0/0] quit
    [SwitchD] interface gigabitethernet 2/0/0
    [SwitchD-GigabitEthernet2/0/0] port link-type trunk
    [SwitchD-GigabitEthernet2/0/0] port trunk allow-pass vlan 120
    [SwitchD-GigabitEthernet2/0/0] quit
    [SwitchD] interface gigabitethernet 3/0/0
    [SwitchD-GigabitEthernet3/0/0] port link-type trunk
    [SwitchD-GigabitEthernet3/0/0] port trunk allow-pass vlan 130
    [SwitchD-GigabitEthernet3/0/0] quit
    [SwitchD] ospf 1
    [SwitchD-ospf-1] area 0
    [SwitchD-ospf-1-area-0.0.0.0] network 10.1.2.0 0.0.0.255
    [SwitchD-ospf-1-area-0.0.0.0] network 10.1.4.0 0.0.0.255
    [SwitchD-ospf-1-area-0.0.0.0] network 10.1.5.0 0.0.0.255
    [SwitchD-ospf-1-area-0.0.0.0] quit
    [SwitchD-ospf-1] quit

    # 配置SwitchE。

    <Quidway> system-view
    [Quidway] sysname SwitchE
    [SwitchE] vlan batch 130 140 150
    [SwitchE] interface vlanif 130
    [SwitchE-Vlanif130] ip address 10.1.2.2 24
    [SwitchE-Vlanif130] quit
    [SwitchE] interface vlanif 140
    [SwitchE-Vlanif140] ip address 10.1.0.1 24
    [SwitchE-Vlanif140] quit
    [SwitchE] interface vlanif 150
    [SwitchE-Vlanif150] ip address 10.1.1.2 24
    [SwitchE-Vlanif150] quit
    [SwitchE] interface gigabitethernet 1/0/0
    [SwitchE-GigabitEthernet1/0/0] port link-type trunk
    [SwitchE-GigabitEthernet1/0/0] port trunk allow-pass vlan 140
    [SwitchE-GigabitEthernet1/0/0] quit
    [SwitchE] interface gigabitethernet 2/0/0
    [SwitchE-GigabitEthernet2/0/0] port link-type trunk
    [SwitchE-GigabitEthernet2/0/0] port trunk allow-pass vlan 150
    [SwitchE-GigabitEthernet2/0/0] quit
    [SwitchE] interface gigabitethernet 3/0/0
    [SwitchE-GigabitEthernet3/0/0] port link-type trunk
    [SwitchE-GigabitEthernet3/0/0] port trunk allow-pass vlan 130
    [SwitchE-GigabitEthernet3/0/0] quit
    [SwitchE] ospf 1
    [SwitchE-ospf-1] area 0
    [SwitchE-ospf-1-area-0.0.0.0] network 10.1.0.0 0.0.0.255
    [SwitchE-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [SwitchE-ospf-1-area-0.0.0.0] network 10.1.2.0 0.0.0.255
    [SwitchE-ospf-1-area-0.0.0.0] quit
    [SwitchE-ospf-1] quit

  2. 配置组播网络。

    # 配置SwitchA。

    [SwitchA] multicast routing-enable
    [SwitchA] interface vlanif110
    [SwitchA-Vlanif110] pim sm
    [SwitchA-Vlanif110] quit
    [SwitchA] interface vlanif170
    [SwitchA-Vlanif170] pim sm
    [SwitchA-Vlanif170] igmp enable
    [SwitchA-Vlanif170] quit
    [SwitchA] pim
    [SwitchA-pim] quit
    

    # 配置SwitchB。

    [SwitchB] multicast routing-enable
    [SwitchB] interface vlanif120
    [SwitchB-Vlanif120] pim sm
    [SwitchB-Vlanif120] quit
    [SwitchB] interface vlanif160
    [SwitchB-Vlanif160] pim sm
    [SwitchB-Vlanif160] quit
    [SwitchB] interface vlanif170
    [SwitchB-Vlanif170] pim sm
    [SwitchB-Vlanif170] igmp enable
    [SwitchB-Vlanif170] quit

    # 配置SwitchC。

    [SwitchC] multicast routing-enable
    [SwitchC] interface vlanif 150
    [SwitchC-Vlanif150] pim sm
    [SwitchC-Vlanif150] quit
    [SwitchC] interface vlanif 160
    [SwitchC-Vlanif160] pim sm
    [SwitchC-Vlanif160] quit
    [SwitchC] interface loopback0
    [SwitchC-LoopBack0] pim sm
    [SwitchC-LoopBack0] igmp enable
    [SwitchC-LoopBack0] quit
    [SwitchC] pim
    [SwitchC-pim] c-bsr LoopBack0
    [SwitchC-pim] c-rp LoopBack0
    [SwitchC-pim] quit

    # 配置SwitchD。

    [SwitchD] multicast routing-enable
    [SwitchD] interface vlanif 110
    [SwitchD-Vlanif110] pim sm
    [SwitchD-Vlanif110] quit
    [SwitchD] interface vlanif 120
    [SwitchD-Vlanif120] pim sm
    [SwitchD-Vlanif120] quit
    [SwitchD] interface vlanif 130
    [SwitchD-Vlanif130] pim sm
    [SwitchD-Vlanif130] igmp enable
    [SwitchD-Vlanif130] quit
    [SwitchD] pim
    [SwitchD-pim] quit
    

    # 配置SwitchE。

    [SwitchE] multicast routing-enable
    [SwitchE] interface vlanif 130
    [SwitchE-Vlanif130] pim sm
    [SwitchE-Vlanif130] igmp enable
    [SwitchE-Vlanif130] quit
    [SwitchE] interface vlanif 140
    [SwitchE-Vlanif140] pim sm
    [SwitchE-Vlanif140] quit
    [SwitchE] interface vlanif 150
    [SwitchE-Vlanif150] pim sm
    [SwitchE-Vlanif150] quit
    [SwitchE] pim
    [SwitchE-pim] quit

  3. SwitchC上配置NQA MTrace测试例。

    [SwitchC] nqa test-instance admin mtrace
    [SwitchC-nqa-admin-mtrace] test-type mtrace
    [SwitchC-nqa-admin-mtrace] mtrace-source-address ipv4 10.1.0.2
    [SwitchC-nqa-admin-mtrace] destination-address ipv4 10.1.6.4
    [SwitchC-nqa-admin-mtrace] mtrace-query-type last-hop
    [SwitchC-nqa-admin-mtrace] mtrace-last-hop-address ipv4 10.1.6.2

  4. 启动测试例。

    # 在网络稳定后,启动测试例。

    [SwitchC-nqa-admin-mtrace] start now

  5. 验证测试结果。可以看到从组播源到SwitchC的RPF路径是SwitchE-SwitchD-SwitchB。

    [SwitchC-nqa-admin-mtrace] display nqa results test-instance admin mtrace
    
    NQA entry(admin, mtrace) :testflag is inactive ,testtype is mtrace
      1 . Test 1 result   The test is finished
       Completion: success                 Query Mode: max-hop
       Current Hop:3                        Current Probe:1
       SendProbe:1                          ResponseProbe:1
       Timeout Count:0                      Busy Count:0
       Drop Count:0                         Max Path Ttl:4
       Responser:10.1.0.2                Response Rtt: 62
       mtrace start time: 2009-02-07 17:36:18.1
       Last Good Probe Time: 2009-02-07 17:36:18.1
       Last Good Path Time: 2009-02-07 17:36:18.1
       1 . Hop 1
        Outgoing Interface Address: 10.1.6.2
        Incoming Interface Address: 10.1.4.1
        Prehop Router Address: 10.1.4.2
        Protocol : PIM                  Forward Code:NO_ERROR
        Forward Ttl:1                   Current Path Ttl:4
        SG Packet Count:0xffffffff      Hop Time Delay(ms):65
        Input Packet Count:9424         Output Packet Count:9815
        Input Rate(pps): --     Output Rate(pps): --
        Input Loss Rate: --     SG Loss Rate: --
       2 . Hop 2
        Outgoing Interface Address: 10.1.4.2
        Incoming Interface Address: 10.1.2.1
        Prehop Router Address: 10.1.2.2
        Protocol : PIM                  Forward Code:NO_ERROR
        Forward Ttl:1                   Current Path Ttl:3
        SG Packet Count:0xffffffff      Hop Time Delay(ms):1
        Input Packet Count:9849         Output Packet Count:9429
        Input Rate(pps): --     Output Rate(pps): --
        Input Loss Rate: --     SG Loss Rate: --
       3 . Hop 3
        Outgoing Interface Address: 10.1.2.2
        Incoming Interface Address: 10.1.0.1
        Prehop Router Address: 0.0.0.0
        Protocol : PIM                  Forward Code:NO_ERROR
        Forward Ttl:1                   Current Path Ttl:2
        SG Packet Count:0xffffffff      Hop Time Delay(ms): 0xffffffff
        Input Packet Count:109581       Output Packet Count:16529
        Input Rate(pps): --     Output Rate(pps): --
        Input Loss Rate: --     SG Loss Rate: --
    

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 110 170
    #
    multicast routing-enable
    #
    interface Vlanif110
     ip address 10.1.5.1 255.255.255.0
     pim sm
    #
    interface Vlanif170
     ip address 10.1.6.3 255.255.255.0
     pim sm
     igmp enable
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 110
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 170
    #
    ospf 1
     area 0.0.0.0
      network 10.1.5.0 0.0.0.255
      network 10.1.6.0 0.0.0.255
    #
    pim
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 120 160 170
    #
    multicast routing-enable
    #
    interface Vlanif120
     ip address 10.1.4.1 255.255.255.0
     pim sm
    #
    interface Vlanif160
     ip address 10.1.3.1 255.255.255.0
     pim sm
    #
    interface Vlanif170
     ip address 10.1.6.2 255.255.255.0
     pim sm
     igmp enable
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 160
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 120
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 170
    #
    ospf 1
     area 0.0.0.0
      network 10.1.3.0 0.0.0.255
      network 10.1.4.0 0.0.0.255
      network 10.1.6.0 0.0.0.255
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 150 160
    #
    multicast routing-enable
    #
    interface Vlanif150
     ip address 10.1.1.1 255.255.255.0
     pim sm
    #
    interface Vlanif160
     ip address 10.1.3.2 255.255.255.0
     pim sm
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 160
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 150
    #
    interface LoopBack0
     ip address 10.2.2.2 255.255.255.255
     pim sm
     igmp enable
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.1.3.0 0.0.0.255
      network 10.2.2.2 0.0.0.0
    #
    pim
     c-bsr LoopBack0
     c-rp LoopBack0
    #
    nqa test-instance admin mtrace
     test-type mtrace
     destination-address ipv4 10.1.6.4
     mtrace-last-hop-address ipv4 10.1.6.2
     mtrace-source-address ipv4 10.1.0.2 
     mtrace-query-type last-hop
    # 
    return
    
  • SwitchD的配置文件

    #
    sysname SwitchD
    #
    vlan batch 110 120 130
    #
    multicast routing-enable
    #
    interface Vlanif110
     ip address 10.1.5.2 255.255.255.0
     pim sm
    #
    interface Vlanif120
     ip address 10.1.4.2 255.255.255.0
     pim sm
    #
    interface Vlanif130
     ip address 10.1.2.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 110
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 120
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 130
    #
    ospf 1
     area 0.0.0.0
      network 10.1.2.0 0.0.0.255
      network 10.1.4.0 0.0.0.255
      network 10.1.5.0 0.0.0.255
    #
    pim
    #
    return
  • SwitchE的配置文件

    #
    sysname SwitchE
    #
    vlan batch 130 140 150
    #
    multicast routing-enable
    #
    interface Vlanif130
     ip address 10.1.2.2 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif140
     ip address 10.1.0.1 255.255.255.0
     pim sm
    #
    interface Vlanif150
     ip address 10.1.1.2 255.255.255.0
     pim sm
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 140
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 150
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 130
    #
    ospf 1
     area 0.0.0.0
      network 10.1.0.0 0.0.0.255
      network 10.1.1.0 0.0.0.255
      network 10.1.2.0 0.0.0.255
    #
    pim
    #
    return
翻译
下载文档
更新时间:2019-08-21

文档编号:EDOC1000141529

浏览量:20519

下载量:402

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页