所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S9300, S9300E, S9300X V200R010C00 配置指南-网络管理与监控

本文档介绍了设备支持的网络管理与监控相关配置。主要内容包括:SNMP配置、RMON和RMON2配置、LLDP配置、性能管理、iPCA配置、NQA配置、业务诊断配置、镜像配置、报文捕获配置、分流配置、NetStream配置、sFlow配置、TWAMP Light配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置TCP测试示例

配置TCP测试示例

组网需求

图6-34所示。使用NQA TCP测试功能测试SwitchA到SwitchC之间建立TCP连接的时间。

图6-34  TCP测试组网图

配置思路

采用如下思路进行TCP测试的配置:

  1. SwitchA作为NQA客户端,SwitchC作为NQA服务器端。

  2. 在NQA服务器上配置侦听端口号,在NQA客户端配置TCP类型的NQA测试例。

操作步骤

  1. 配置各接口的IP地址并配置交换机之间路由可达

    # 配置SwitchA。

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] vlan 100
    [SwitchA-vlan100] quit
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port hybrid pvid vlan 100
    [SwitchA-GigabitEthernet1/0/1] port hybrid untagged vlan 100
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface vlanif 100
    [SwitchA-Vlanif100] ip address 10.1.1.1 24
    [SwitchA-Vlanif100] quit
    [SwitchA] ip route-static 10.2.1.0 255.255.255.0 10.1.1.2

    # 配置SwitchB。

    <Quidway> system-view
    [Quidway] sysname SwitchB
    [SwitchB] vlan 100
    [SwitchB-vlan100] quit
    [SwitchB] vlan 110
    [SwitchB-vlan110] quit
    [SwitchB] interface gigabitethernet 1/0/1
    [SwitchB-GigabitEthernet1/0/1] port hybrid pvid vlan 100
    [SwitchB-GigabitEthernet1/0/1] port hybrid untagged vlan 100
    [SwitchB-GigabitEthernet1/0/1] quit
    [SwitchB] interface vlanif 100
    [SwitchB-Vlanif100] ip address 10.1.1.2 24
    [SwitchB-Vlanif100] quit
    [SwitchB] interface gigabitethernet 1/0/2
    [SwitchB-GigabitEthernet1/0/2] port hybrid pvid vlan 110
    [SwitchB-GigabitEthernet1/0/2] port hybrid untagged vlan 110
    [SwitchB-GigabitEthernet1/0/2] quit
    [SwitchB] interface vlanif 110
    [SwitchB-Vlanif110] ip address 10.2.1.1 24
    [SwitchB-Vlanif110] quit
    

    # 配置SwitchC。

    <Quidway> system-view
    [Quidway] sysname SwitchC
    [SwitchC] vlan 110
    [SwitchC-vlan110] quit
    [SwitchC] interface gigabitethernet 1/0/1
    [SwitchC-GigabitEthernet1/0/1] port hybrid pvid vlan 110
    [SwitchC-GigabitEthernet1/0/1] port hybrid untagged vlan 110
    [SwitchC-GigabitEthernet1/0/1] quit
    [SwitchC] interface vlanif 110
    [SwitchC-Vlanif110] ip address 10.2.1.2 24
    [SwitchC-Vlanif110] quit
    [SwitchC] ip route-static 10.1.1.0 255.255.255.0 10.2.1.1

  2. SwitchC上配置NQA服务器

    # 配置NQA服务器TCP连接侦听的IP地址和端口号。

    [SwitchC] nqa-server tcpconnect 10.2.1.2 9000

  3. SwitchA配置NQA客户端

    # 使能NQA客户端,配置TCP类型的测试例。

    [SwitchA] nqa test-instance admin tcp
    [SwitchA-nqa-admin-tcp] test-type tcp
    [SwitchA-nqa-admin-tcp] destination-address ipv4 10.2.1.2
    [SwitchA-nqa-admin-tcp] destination-port 9000 

  4. 启动测试

    [SwitchA-nqa-admin-tcp] start now

  5. 查看测试结果

    # 在SwitchA上查看NQA测试结果。

    [SwitchA-nqa-admin-tcp] display nqa results test-instance admin tcp
    
     NQA entry(admin, tcp) :testflag is inactive ,testtype is tcp
      1 . Test 1 result   The test is finished                                      
       Send operation times: 3              Receive response times: 3               
       Completion:success                   RTD OverThresholds number: 0            
       Attempts number:1                    Drop operation number:0                 
       Disconnect operation number:0        Operation timeout number:0              
       System busy operation number:0       Connection fail number:0                
       Operation sequence errors number:0   RTT Status errors number:0              
       Destination ip address:10.2.1.2                                              
       Min/Max/Average Completion Time: 46/63/52                                       
       Sum/Square-Sum  Completion Time: 156/8294                                        
       Last Good Probe Time: 2012-07-25 16:23:49.1                                  
       Lost packet ratio: 0 %                      

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 100
    #
    interface Vlanif100
     ip address 10.1.1.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    ip route-static 10.2.1.0 255.255.255.0 10.1.1.2
    #
    nqa test-instance admin tcp                                                    
     test-type tcp                                                                 
     destination-address ipv4 10.2.1.2 
     destination-port 9000
    #
    return   
    
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 100 110
    #
    interface Vlanif100
     ip address 10.1.1.2 255.255.255.0
    #
    interface Vlanif110
     ip address 10.2.1.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    interface GigabitEthernet1/0/2
     port hybrid pvid vlan 110
     port hybrid untagged vlan 110
    #
    return   
    
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 110
    #
    interface Vlanif110
     ip address 10.2.1.2 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port hybrid pvid vlan 110
     port hybrid untagged vlan 110
    #
    nqa-server tcpconnect 10.2.1.2 9000
    #
    ip route-static 10.1.1.0 255.255.255.0 10.2.1.1
    #
    return   
    
翻译
下载文档
更新时间:2019-08-21

文档编号:EDOC1000141529

浏览量:20453

下载量:402

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页