所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S9300, S9300E, S9300X V200R010C00 配置指南-网络管理与监控

本文档介绍了设备支持的网络管理与监控相关配置。主要内容包括:SNMP配置、RMON和RMON2配置、LLDP配置、性能管理、iPCA配置、NQA配置、业务诊断配置、镜像配置、报文捕获配置、分流配置、NetStream配置、sFlow配置、TWAMP Light配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置向网管端发送NQA传输延迟阈值告警示例

配置向网管端发送NQA传输延迟阈值告警示例

组网需求

图6-56所示在配置Jitter测试例时,配置阈值并启动告警功能。启动Jitter测试例,在测试结束后,当从SwitchA到SwitchC或从SwitchC到SwitchA的测试报文中,有超过设定的单向传输告警阈值,或测试报文的往返时间超过设定的双向传输阈值时SwitchA会向网管端发送一次Trap消息。通过NM Station接收到的Trap消息,网络管理人员可以清晰的看到产生告警的原因。

图6-56  向网管端发送NQA阈值告警组网图

配置思路

采用如下思路进行阈值的配置:

  1. SwitchC作为NQA测试的服务器端,并配置主机地址及端口号。

  2. SwitchA作为NQA测试的客户端,配置NQA阈值功能,并开启Trap发送开关。

  3. SwitchA上配置Jitter类型的测试例。

操作步骤

  1. 图6-56配置各接口的IP地址并配置交换机之间路由可达

    # 配置SwitchA

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] vlan 100
    [SwitchA-vlan100] quit
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port hybrid pvid vlan 100
    [SwitchA-GigabitEthernet1/0/1] port hybrid untagged vlan 100
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface vlanif 100
    [SwitchA-Vlanif100] ip address 10.1.1.1 24
    [SwitchA-Vlanif100] quit
    [SwitchA] vlan 120
    [SwitchA-vlan120] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port hybrid pvid vlan 120
    [SwitchA-GigabitEthernet1/0/2] port hybrid untagged vlan 120
    [SwitchA-GigabitEthernet1/0/2] quit
    [SwitchA] interface vlanif 120
    [SwitchA-Vlanif120] ip address 10.3.1.1 24
    [SwitchA-Vlanif120] quit
    [SwitchA] ip route-static 10.2.1.0 255.255.255.0 10.1.1.2

    # 配置SwitchB

    <Quidway> system-view
    [Quidway] sysname SwitchB
    [SwitchB] vlan 100
    [SwitchB-vlan100] quit
    [SwitchB] vlan 110
    [SwitchB-vlan110] quit
    [SwitchB] interface gigabitethernet 1/0/1
    [SwitchB-GigabitEthernet1/0/1] port hybrid pvid vlan 100
    [SwitchB-GigabitEthernet1/0/1] port hybrid untagged vlan 100
    [SwitchB-GigabitEthernet1/0/1] quit
    [SwitchB] interface vlanif 100
    [SwitchB-Vlanif100] ip address 10.1.1.2 24
    [SwitchB-Vlanif100] quit
    [SwitchB] interface gigabitethernet 1/0/2
    [SwitchB-GigabitEthernet1/0/2] port hybrid pvid vlan 110
    [SwitchB-GigabitEthernet1/0/2] port hybrid untagged vlan 110
    [SwitchB-GigabitEthernet1/0/2] quit
    [SwitchB] interface vlanif 110
    [SwitchB-Vlanif110] ip address 10.2.1.1 24
    [SwitchB-Vlanif110] quit
    

    # 配置SwitchC

    <Quidway> system-view
    [Quidway] sysname SwitchC
    [SwitchC] vlan 110
    [SwitchC-vlan110] quit
    [SwitchC] interface gigabitethernet 1/0/1
    [SwitchC-GigabitEthernet1/0/1] port hybrid pvid vlan 110
    [SwitchC-GigabitEthernet1/0/1] port hybrid untagged vlan 110
    [SwitchC-GigabitEthernet1/0/1] quit
    [SwitchC] interface vlanif 110
    [SwitchC-Vlanif110] ip address 10.2.1.2 24
    [SwitchC-Vlanif110] quit
    [SwitchC] ip route-static 10.1.1.0 255.255.255.0 10.2.1.1

  2. SwitchC上配置NQA服务器

    # 配置NQA服务器UDP侦听的IP地址和端口号。

    [SwitchC] nqa-server udpecho 10.2.1.2 9000

  3. 配置SwitchA

    # 使能NQA客户端,配置UDP Jitter类型的NQA测试例。

    [SwitchA] nqa test-instance admin jitter
    [SwitchA-nqa-admin-jitter] test-type jitter
    [SwitchA-nqa-admin-jitter] destination-address ipv4 10.2.1.2
    [SwitchA-nqa-admin-jitter] destination-port 9000 

  4. SwitchA配置NQA阈值功能

    # 在SwitchA上配置RTD阈值。

    [SwitchA-nqa-admin-jitter] threshold rtd 20

  5. SwitchA开启发送Trap的功能

    [SwitchA-nqa-admin-jitter] send-trap rtd
    [SwitchA-nqa-admin-jitter] quit

  6. 配置向网管发送Trap的功能

    [SwitchA] snmp-agent sys-info version v2c
    [SwitchA] snmp-agent community write admin123
    [SwitchA] snmp-agent target-host trap address udp-domain 10.3.1.2 params securityname switchA
    [SwitchA] snmp-agent trap enable

  7. 启动测试

    [SwitchA] nqa test-instance admin jitter
    [SwitchA-nqa-admin-jitter] start now
    [SwitchA-nqa-admin-jitter] quit

  8. 查看测试结果

    # 查看SwitchA的NQA测试结果。

    [SwitchA] display nqa results test-instance admin jitter
    
     NQA entry(admin, jitter) :testflag is inactive ,testtype is jitter             
      1 . Test 1 result   The test is finished                                      
       SendProbe:60                         ResponseProbe:60                        
       Completion:success                   RTD OverThresholds number:0             
       OWD OverThresholds SD number:0       OWD OverThresholds DS number:0          
       Min/Max/Avg/Sum RTT:2/9/2/133        RTT Square Sum:347                      
       NumOfRTT:60                          Drop operation number:0                 
       Operation sequence errors number:0   RTT Stats errors number:0               
       System busy operation number:0       Operation timeout number:0              
       Min Positive SD:1                    Min Positive DS:1                       
       Max Positive SD:7                    Max Positive DS:1                       
       Positive SD Number:8                 Positive DS Number:4                    
       Positive SD Sum:14                   Positive DS Sum:4                       
       Positive SD Square Sum:56            Positive DS Square Sum:4                
       Min Negative SD:1                    Min Negative DS:1                       
       Max Negative SD:6                    Max Negative DS:1                       
       Negative SD Number:9                 Negative DS Number:5                    
       Negative SD Sum:14                   Negative DS Sum:5                       
       Negative SD Square Sum:44            Negative DS Square Sum:5                
       Min Delay SD:1                       Min Delay DS:0                          
       Avg Delay SD:1                       Avg Delay DS:0                          
       Max Delay SD:4                       Max Delay DS:4                          
       Delay SD Square Sum:75               Delay DS Square Sum:22                  
       Packet Loss SD:0                     Packet Loss DS:0                        
       Packet Loss Unknown:0                Average of Jitter:1                     
       Average of Jitter SD:1               Average of Jitter DS:1                  
       Jitter out value:0.3257526           Jitter in value:0.1015234               
       NumberOfOWD:60                       Packet Loss Ratio: 0%                   
       OWD SD Sum:63                        OWD DS Sum:10                           
       ICPIF value: 0                       MOS-CQ value: 0                         
       TimeStamp unit: ms                   Packet Rewrite Number: 0                
       Packet Rewrite Ratio: 0%             Packet Disorder Number: 0               
       Packet Disorder Ratio: 0%            Fragment-disorder Number: 0             
       Fragment-disorder Ratio: 0%          Jitter OverThresholds SD number:0       
       Jitter OverThresholds DS number:0    OverallOverThresholds number:0    
       Start time: 2014-09-01 10:47:57+08:00                                                                                            
       End time: 2014-09-01 10:48:01+08:00  

    # 在告警缓冲区检查是否产生Trap消息(此时,网管端也应该收到这些告警)。

    <SwitchA> display trapbuffer
    Trapping buffer configuration and contents : enabled                            
    Allowed max buffer size : 1024                                                  
    Actual buffer size : 256                                                        
    Channel number : 3 , Channel name : trapbuffer                                  
    Dropped messages : 0                                                            
    Overwritten messages : 3363                                                     
    Current messages : 256 
    
    #Nov 15 2012 16:57:21+06:00 SwitchA  NQA/4/RTDTHRESHOLD:OID 1.3.6.1.4.1.2011.5.25.111.6.16 NQA entry RTD over threshold. (OwnerIndex=admin, TestName=jitter)
    #Nov 15 2012 16:57:21+06:00 SwitchA  NQA/4/SDTHRESHOLD:OID 1.3.6.1.4.1.2011.5.25.111.6.17 NQA entry OWD-SD over threshold. (OwnerIndex=admin, TestName=jitter)
    #Nov 15 2012 16:57:21+06:00 SwitchA  NQA/4/DSTHRESHOLD:OID 1.3.6.1.4.1.2011.5.25.111.6.18 NQA entry OWD-DS over threshold. (OwnerIndex=admin, TestName=jitter)

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 100 120
    #
    interface Vlanif100
     ip address 10.1.1.1 255.255.255.0
    #
    interface Vlanif120
     ip address 10.3.1.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    interface GigabitEthernet1/0/2
     port hybrid pvid vlan 120
     port hybrid untagged vlan 120
    #
    ip route-static 10.2.1.0 255.255.255.0 10.1.1.2
    #
    snmp-agent                                                                      
    snmp-agent local-engineid 800007DB0300E009877890                                
    snmp-agent community write cipher %^%#BuDX98e.>CF6_w@~U.TW&(2J*r`dw94l@E)TkK%%Zz>5(|/KEJ>]a+Qe&E-S}R/00tDR:8fy,}2LATeI%^%#              
    snmp-agent sys-info version v2c v3                                              
    snmp-agent target-host trap address udp-domain 10.3.1.2 params securityname cipher %^%#.VYh22r_VPzZ5m2azPQDYh^9:]r~oIFBl[#Aq95*%^%#  
    snmp-agent trap enable 
    #
    nqa test-instance admin jitter                                                    
     test-type jitter                                                                 
     destination-address ipv4 10.2.1.2 
     destination-port 9000 
     threshold rtd 20 
     send-trap rtd 
    #
    return   
    
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 100 110
    #
    interface Vlanif100
     ip address 10.1.1.2 255.255.255.0
    #
    interface Vlanif110
     ip address 10.2.1.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    interface GigabitEthernet1/0/2
     port hybrid pvid vlan 110
     port hybrid untagged vlan 110
    #
    return   
    
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 110
    #
    interface Vlanif110
     ip address 10.2.1.2 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port hybrid pvid vlan 110
     port hybrid untagged vlan 110
    #
    nqa-server udpecho 10.2.1.2 9000
    #
    ip route-static 10.1.1.0 255.255.255.0 10.2.1.1
    #
    return   
    
翻译
下载文档
更新时间:2019-08-21

文档编号:EDOC1000141529

浏览量:20327

下载量:402

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页