所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S9300, S9300E, S9300X V200R010C00 配置指南-网络管理与监控

本文档介绍了设备支持的网络管理与监控相关配置。主要内容包括:SNMP配置、RMON和RMON2配置、LLDP配置、性能管理、iPCA配置、NQA配置、业务诊断配置、镜像配置、报文捕获配置、分流配置、NetStream配置、sFlow配置、TWAMP Light配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
如何解决设备观察端口不足的问题

如何解决设备观察端口不足的问题

设备上的观察端口规格和1:N规格是有限的,如果当前需要连接的监控设备有很多,需要的观察端口数量超过了规格上限,一般可以通过以下两种方式解决。

  • 配置远程镜像,通过远程观察端口进行内部环回广播

    说明:

    此方案中如果配置多个内部环回口,则需要确保这些环回口加入的VLAN ID不能相同,否则会导致环路。

    图8-20  通过内部环回方式连接多监控设备组网图

    图8-20所示,网络管理员需要将镜像端口的报文镜像到4台监控设备,而SwitchB可配置观察端口数量少于4。通过远程观察端口内部环回广播的实现过程如下:

    1. 配置远程端口镜像

      <SwitchB> system-view
      [SwitchB] observe-port 1 interface gigabitethernet1/0/1 vlan 20   //配置远程观察端口,VLAN20为用于内部环回广播的VLAN
      [SwitchB] interface gigabitethernet1/0/6
      [SwitchB-GigabitEthernet1/0/6] port-mirroring to observe-port 1 both   //将镜像端口出入方向报文都镜像到内部环回用的远程观察端口
      [SwitchB-GigabitEthernet1/0/6] quit
    2. 配置内部环回功能

      [SwitchB] vlan batch 20   //用于内部环回转发,不能在VLAN20配其他业务
      [SwitchB] interface gigabitethernet1/0/1
      [SwitchB-GigabitEthernet1/0/1] mac-address learning disable   //关闭端口MAC动态学习功能,防止内部环回端口学习到其他的MAC地址,将非镜像报文在内部环回转发,同时也可以节省MAC表项资源
      [SwitchB-GigabitEthernet1/0/1] stp disable   //关闭STP功能,避免内部环回端口因收到设备自己发送的报文,设置成Discarding状态,将端口阻塞
      [SwitchB-GigabitEthernet1/0/1] port link-type access
      [SwitchB-GigabitEthernet1/0/1] port default vlan 20   //将端口加入内部环回广播用的VLAN
      [SwitchB-GigabitEthernet1/0/1] loopback internal   //将远程观察端口配置为内部环回端口
      [SwitchB-GigabitEthernet1/0/1] quit
      [SwitchB] interface gigabitethernet1/0/2
      [SwitchB-GigabitEthernet1/0/2] port link-type access
      [SwitchB-GigabitEthernet1/0/2] port default vlan 20   //将端口加入内部环回广播用的VLAN
      [SwitchB-GigabitEthernet1/0/2] quit
      [SwitchB] interface gigabitethernet1/0/3
      [SwitchB-GigabitEthernet1/0/3] port link-type access
      [SwitchB-GigabitEthernet1/0/3] port default vlan 20   //将端口加入内部环回广播用的VLAN
      [SwitchB-GigabitEthernet1/0/3] quit
      [SwitchB] interface gigabitethernet1/0/4
      [SwitchB-GigabitEthernet1/0/4] port link-type access
      [SwitchB-GigabitEthernet1/0/4] port default vlan 20   //将端口加入内部环回广播用的VLAN
      [SwitchB-GigabitEthernet1/0/4] quit
      [SwitchB] interface gigabitethernet1/0/5
      [SwitchB-GigabitEthernet1/0/5] port link-type access
      [SwitchB-GigabitEthernet1/0/5] port default vlan 20   //将端口加入内部环回广播用的VLAN
      [SwitchB-GigabitEthernet1/0/5] quit
  • 配置远程镜像,通过中间二层设备进行VLAN广播

    图8-21  通过中间二层设备连接多监控设备组网图

    图8-21所示,网络管理员需要将镜像端口的报文镜像到3台监控设备,而SwitchB可配置观察端口数量少于3。通过SwitchC进行VLAN广播的实现过程如下:

    1. 在SwitchB配置远程端口镜像

      <SwitchB> system-view
      [SwitchB] observe-port 1 interface gigabitethernet1/0/1 vlan 20   //配置远程观察端口,VLAN20为用于转发镜像报文的普通VLAN
      [SwitchB] interface gigabitethernet1/0/2
      [SwitchB-GigabitEthernet1/0/2] port-mirroring to observe-port 1 both   //将镜像端口出入方向报文都镜像到远程观察端口
      [SwitchB-GigabitEthernet1/0/2] quit
    2. 在SwitchC配置端口加入VLAN

      [SwitchC] interface gigabitethernet1/0/1
      [SwitchC-GigabitEthernet1/0/1] port link-type trunk
      [SwitchC-GigabitEthernet1/0/1] port trunk allow-pass vlan 20   //将端口加入用于转发镜像报文的VLAN20
      [SwitchC-GigabitEthernet1/0/1] quit
      [SwitchC] interface gigabitethernet1/0/2
      [SwitchC-GigabitEthernet1/0/2] port link-type access
      [SwitchC-GigabitEthernet1/0/2] port default-vlan 20   //将端口加入用于转发镜像报文的VLAN20
      [SwitchC-GigabitEthernet1/0/2] quit
      [SwitchC] interface gigabitethernet1/0/3
      [SwitchC-GigabitEthernet1/0/3] port link-type access
      [SwitchC-GigabitEthernet1/0/3] port default-vlan 20   //将端口加入用于转发镜像报文的VLAN20
      [SwitchC-GigabitEthernet1/0/3] quit
      [SwitchC] interface gigabitethernet1/0/4
      [SwitchC-GigabitEthernet1/0/4] port link-type access
      [SwitchC-GigabitEthernet1/0/4] port default-vlan 20   //将端口加入用于转发镜像报文的VLAN20
      [SwitchC-GigabitEthernet1/0/4] quit
翻译
下载文档
更新时间:2019-08-21

文档编号:EDOC1000141529

浏览量:21483

下载量:403

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页