所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S9300, S9300E, S9300X V200R010C00 配置指南-网络管理与监控

本文档介绍了设备支持的网络管理与监控相关配置。主要内容包括:SNMP配置、RMON和RMON2配置、LLDP配置、性能管理、iPCA配置、NQA配置、业务诊断配置、镜像配置、报文捕获配置、分流配置、NetStream配置、sFlow配置、TWAMP Light配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置sFlow示例

配置sFlow示例

组网需求

图12-3所示,Network1与Network2之间通过SwitchA互发流量。管理维护人员要求监控GE1/0/2接口的流量信息、转发情况以及设备的整体运行状况,及时发现异常流量,从而保证网络1的正常稳定运行。

图12-3  sFlow基本配置组网图

配置思路

配置sFlow,在SwitchA上运行sFlow Agent,通过在GE1/0/2上开启sFlow采样功能(包括Flow采样和Counter采样),sFlow Agent能够将采集到的流量统计信息通过sFlow报文从GE1/0/1发向sFlow Collector,然后sFlow Collector根据收到的sFlow报文中携带的流量信息,将网络流量状况显示出来。从而实现对GE1/0/2接口流量信息的监控。

采用如下思路配置sFlow:

  1. 配置交换机各接口IP地址。
  2. 在设备上配置sFlow Collector和sFlow Agent信息。
  3. 配置接口的Flow采样。
  4. 配置接口的Counter采样。

操作步骤

  1. 配置SwitchA的接口IP地址

    # 按图12-3所示,配置SwitchA的接口IP地址。

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] vlan batch 10 20 30
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type access
    [SwitchA-GigabitEthernet1/0/1] port default vlan 10
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 10.1.10.1 24
    [SwitchA-Vlanif10] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port hybrid pvid vlan 20
    [SwitchA-GigabitEthernet1/0/2] port hybrid untagged vlan 20
    [SwitchA-GigabitEthernet1/0/2] quit
    [SwitchA] interface vlanif 20
    [SwitchA-Vlanif20] ip address 10.1.20.1 24
    [SwitchA-Vlanif20] quit
    [SwitchA] interface gigabitethernet 1/0/3
    [SwitchA-GigabitEthernet1/0/3] port hybrid pvid vlan 30
    [SwitchA-GigabitEthernet1/0/3] port hybrid untagged vlan 30
    [SwitchA-GigabitEthernet1/0/3] quit
    [SwitchA] interface vlanif 30
    [SwitchA-Vlanif30] ip address 10.1.30.1 24
    [SwitchA-Vlanif30] quit

  2. 配置sFlow Agent和sFlow Collector信息

    # 配置sFlow Agent的IP地址。

    [SwitchA] sflow agent ip 10.1.10.1

    # 配置sFlow Collector信息:sFlow Collector的ID为2,IP地址为10.1.10.2,描述信息为netserver。

    [SwitchA] sflow collector 2 ip 10.1.10.2 description netserver

  3. 配置Flow采样

    # 配置Flow采样的采样比。

    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] sflow flow-sampling rate 4000

    # 配置经过Flow采样后,sFlow Agent输出sFlow报文的目的sFlow Collector编号为2。

    [SwitchA-GigabitEthernet1/0/2] sflow flow-sampling collector 2

  4. 配置Counter采样

    # 配置Counter采样的时间间隔为120秒。

    [SwitchA-GigabitEthernet1/0/2] sflow counter-sampling interval 120

    # 配置经过Counter采样后,sFlow Agent输出sFlow报文的目的sFlow Collector编号为2。

    [SwitchA-GigabitEthernet1/0/2] sflow counter-sampling collector 2
    [SwitchA-GigabitEthernet1/0/2] quit
    [SwitchA] quit

  5. 验证配置结果

    # 配置成功后,执行命令display sflow查看SwitchA的全局sFlow配置。

    <SwitchA> display sflow
    sFlow Version 5 Information:                                                               
    --------------------------------------------------------------------------                  
    Agent Information:                                                                         
    
         IP Address: 10.1.10.1                                                                  
     Address family: IPV4                                                                      
       Vpn-instance: NA                                                                         
    --------------------------------------------------------------------------                 
    Collector Information:                                                                     
    
       Collector ID: 2                                                                      
         IP Address: 10.1.10.2                                                                  
     Address family: IPV4                                                                      
       Vpn-instance: NA                                                                         
               Port: 6343                                                                                
      Datagram size: 1400                                                                       
           Time out: NA                                                                             
        Description: netserver                                                                    
    --------------------------------------------------------------------------                 
    Port on slot 1 Information:                                                                
    
    Interface: GE1/0/2                                     
     Flow-sample collector: 2            Counter-sample collector  : 2               
     Flow-sample rate(1/x): 4000         Counter-sample interval(s): 120             
     Flow-sample maxheader: 64                                                           
     Flow-sample direction: IN,OUT
    --------------------------------------------------------------------------    
    Port on slot 2 Information:                                                                
    --------------------------------------------------------------------------                 
    Port on slot 3 Information:                                                                
    

配置文件

SwitchA的配置文件

#
sysname SwitchA
#
vlan batch 10 20 30 
#
interface Vlanif10
 ip address 10.1.10.1 255.255.255.0
#
interface Vlanif20
 ip address 10.1.20.1 255.255.255.0
#
interface Vlanif30
 ip address 10.1.30.1 255.255.255.0
#
interface GigabitEthernet1/0/1
 port link-type access
 port default vlan 10 
#
interface GigabitEthernet1/0/2
 port hybrid pvid vlan 20
 port hybrid untagged vlan 20
 sflow counter-sampling collector 2 
 sflow counter-sampling interval 120 
 sflow flow-sampling collector 2 
 sflow flow-sampling rate 4000
#
interface GigabitEthernet1/0/3
 port hybrid pvid vlan 30
 port hybrid untagged vlan 30
# 
sflow collector 2 ip 10.1.10.2 description netserver 
# 
sflow agent ip 10.1.10.1   
#
return
翻译
下载文档
更新时间:2019-08-21

文档编号:EDOC1000141529

浏览量:21598

下载量:403

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页