所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S9300, S9300E, S9300X V200R010C00 配置指南-网络管理与监控

本文档介绍了设备支持的网络管理与监控相关配置。主要内容包括:SNMP配置、RMON和RMON2配置、LLDP配置、性能管理、iPCA配置、NQA配置、业务诊断配置、镜像配置、报文捕获配置、分流配置、NetStream配置、sFlow配置、TWAMP Light配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置IPv4原始流统计信息的输出示例

配置IPv4原始流统计信息的输出示例

组网需求

图11-3所示,企业用户部门1与部门2通过SwitchA接入到Internet网络,用户希望掌握2个部门与Internet网络的通信情况,进而分部门计费。

图11-3  NetStream组网图

配置思路

用户可以在SwitchA的GE1/0/1接口部署IPv4原始流统计信息输出功能,统计接口的出、入方向的流量信息,并上送至NetStream服务器进行后续分析,可以实现监控2个部门与Internet网络的通信情况,并为分部门计费提供依据。

采用如下配置思路:

  1. 配置SwitchA的接口IP地址。
  2. 配置NetStream采样功能。
  3. 配置NetStream的流老化。
  4. 配置NetStream原始流统计信息输出。
  5. 配置输出报文版本格式。
  6. 使能接口的NetStream统计功能。

操作步骤

  1. 图11-3标注所示,配置SwitchA的接口IP地址

    # 配置SwitchA的接口IP地址。

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] vlan batch 100 200 300 400
    [SwitchA] interface vlanif 100
    [SwitchA-Vlanif100] ip address 10.1.1.1 24
    [SwitchA-Vlanif100] quit
    [SwitchA] interface vlanif 200
    [SwitchA-Vlanif200] ip address 10.1.2.1 24
    [SwitchA-Vlanif200] quit
    [SwitchA] interface vlanif 300
    [SwitchA-Vlanif300] ip address 10.1.3.1 24
    [SwitchA-Vlanif300] quit
    [SwitchA] interface vlanif 400
    [SwitchA-Vlanif400] ip address 10.1.4.1 24
    [SwitchA-Vlanif400] quit
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type hybrid 
    [SwitchA-GigabitEthernet1/0/1] port hybrid pvid vlan 100 
    [SwitchA-GigabitEthernet1/0/1] port hybrid untagged vlan 100
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type hybrid 
    [SwitchA-GigabitEthernet1/0/2] port hybrid pvid vlan 200 
    [SwitchA-GigabitEthernet1/0/2] port hybrid untagged vlan 200
    [SwitchA-GigabitEthernet1/0/2] quit
    [SwitchA] interface gigabitethernet 1/0/3
    [SwitchA-GigabitEthernet1/0/3] port link-type hybrid 
    [SwitchA-GigabitEthernet1/0/3] port hybrid pvid vlan 300 
    [SwitchA-GigabitEthernet1/0/3] port hybrid untagged vlan 300
    [SwitchA-GigabitEthernet1/0/3] quit
    [SwitchA] interface gigabitethernet 1/0/4
    [SwitchA-GigabitEthernet1/0/4] port link-type hybrid 
    [SwitchA-GigabitEthernet1/0/4] port hybrid pvid vlan 400 
    [SwitchA-GigabitEthernet1/0/4] port hybrid untagged vlan 400
    [SwitchA-GigabitEthernet1/0/4] quit
    

  2. 配置NetStream采样功能

    # 配置GE1/0/1接口的NetStream采样功能,采样比为1200。

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] ip netstream sampler fix-packets 1200 inbound
    [SwitchA-GigabitEthernet1/0/1] ip netstream sampler fix-packets 1200 outbound
    [SwitchA-GigabitEthernet1/0/1] quit
    

  3. 配置NetStream的流老化

    # 配置不活跃流的老化时间为100秒,以及开启由TCP连接的FIN和RST报文触发老化。

    [SwitchA] ip netstream timeout inactive 100
    [SwitchA] ip netstream tcp-flag enable

  4. 配置NetStream原始流统计信息输出

    # 配置NetStream原始流统计信息输出报文源地址为10.1.2.1,目的地址为10.1.2.2,目的端口号为6000。

    [SwitchA] ip netstream export source 10.1.2.1
    [SwitchA] ip netstream export host 10.1.2.2 6000

  5. 配置输出报文版本格式

    # 配置输出报文版本为V9。

    [SwitchA] ip netstream export version 9

  6. 使能接口的NetStream统计功能

    # 使能GE1/0/1出、入接口的NetStream统计功能。

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] ip netstream inbound
    [SwitchA-GigabitEthernet1/0/1] ip netstream outbound
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] quit

  7. 验证配置结果

    # 配置成功后,NetStream服务器端可以收到设备发送的统计报文。在本端设备上可以使用display ip netstream statistics命令查看NetStream流统计信息。

    <SwitchA> display ip netstream statistics slot 1
     ===== Netstream statistics: =====                                          
     Origin/Flexible ingress entries  : 35
     Origin/Flexible ingress packets  : 381920
     Origin/Flexible ingress octets   : 125269760
     Origin/Flexible egress entries   : 0 
     Origin/Flexible egress packets   : 0 
     Origin/Flexible egress octets    : 0 
     Origin/Flexible total entries    : 35
     Handle origin entries            : 35  
     Handle As aggre entries          : 0 
     Handle ProtPort aggre entries    : 0 
     Handle SrcPrefix aggre entries   : 0 
     Handle DstPrefix aggre entries   : 0 
     Handle Prefix aggre entries      : 0 
     Handle AsTos aggre entries       : 0 
     Handle ProtPortTos aggre entries : 0 
     Handle SrcPreTos aggre entries   : 0 
     Handle DstPreTos aggre entries   : 0 
     Handle PreTos aggre entries      : 0 

配置文件

SwitchA的配置文件

#                                                                               
sysname SwitchA 
#                                                                               
vlan batch 100 200 300 400 
# 
ip netstream timeout inactive 100
ip netstream export version 9
ip netstream export source 10.1.2.1
ip netstream export host 10.1.2.2 6000
#
ip netstream tcp-flag enable
#                                                                               
interface Vlanif100                                                             
 ip address 10.1.1.1 255.255.255.0 
#                                                                               
interface Vlanif200                                                             
 ip address 10.1.2.1 255.255.255.0 
#                                                                               
interface Vlanif300                                                             
 ip address 10.1.3.1 255.255.255.0 
#                                                                               
interface Vlanif400                                                             
 ip address 10.1.4.1 255.255.255.0 
#                                                                               
interface GigabitEthernet1/0/1                                                  
 port hybrid pvid vlan 100                                                      
 port hybrid untagged vlan 100  
 ip netstream inbound
 ip netstream outbound
 ip netstream sampler fix-packets 1200 inbound
 ip netstream sampler fix-packets 1200 outbound
#                                                                               
interface GigabitEthernet1/0/2                                                  
 port hybrid pvid vlan 200                                                      
 port hybrid untagged vlan 200  
#                                                                               
interface GigabitEthernet1/0/3                                                  
 port hybrid pvid vlan 300                                                      
 port hybrid untagged vlan 300  
#                                                                               
interface GigabitEthernet1/0/4                                                  
 port hybrid pvid vlan 400                                                      
 port hybrid untagged vlan 400  
#
return
翻译
下载文档
更新时间:2019-08-21

文档编号:EDOC1000141529

浏览量:21661

下载量:403

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页