所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S9300, S9300E, S9300X V200R010C00 配置指南-网络管理与监控

本文档介绍了设备支持的网络管理与监控相关配置。主要内容包括:SNMP配置、RMON和RMON2配置、LLDP配置、性能管理、iPCA配置、NQA配置、业务诊断配置、镜像配置、报文捕获配置、分流配置、NetStream配置、sFlow配置、TWAMP Light配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置测试结果发送到FTP服务器示例

配置测试结果发送到FTP服务器示例

组网需求

图6-57所示,SwitchA作为客户端进行ICMP测试,测试的结果通过FTP发送到FTP Server。

图6-57  测试结果发送到FTP服务器组网图

配置思路

本例中采用的配置思路如下。

  1. 配置SwitchA和SwitchB接口所属的VLAN及IP地址。
  2. SwitchA配置连接FTP服务器需要的参数,使能通过FTP保存测试结果,并配置保存测试结果的相关参数。

  3. 启动测试例,将测试结果发送到FTP服务器。

  4. FTP服务器端启动FTP服务,接收测试结果。

操作步骤

  1. 图6-57配置各接口的IP地址并配置Switch之间路由可达

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] vlan batch 10 20
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port hybrid pvid vlan 20
    [SwitchA-GigabitEthernet1/0/1] port hybrid untagged vlan 20
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface vlanif 20
    [SwitchA-Vlanif20] ip address 10.1.1.11 24
    [SwitchA-Vlanif20] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port hybrid pvid vlan 10
    [SwitchA-GigabitEthernet1/0/2] port hybrid untagged vlan 10
    [SwitchA-GigabitEthernet1/0/2] quit
    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 10.1.2.1 24
    [SwitchA-Vlanif10] quit
    说明:

    SwitchB的配置请参考配置文件。

  2. SwitchA配置连接FTP服务器需要的参数

    [SwitchA] nqa-ftp-record ip-address 10.1.2.8
    [SwitchA] nqa-ftp-record username ftp
    [SwitchA] nqa-ftp-record password ftp
    [SwitchA] nqa-ftp-record filename icmp

  3. 配置通过FTP保存测试结果到文件的条数

    [SwitchA] nqa-ftp-record item-num 10010

  4. 配置通过FTP保存测试结果到文件的时间

    [SwitchA] nqa-ftp-record time 2

  5. 配置FTP传送成功向网管端发送Trap

    [SwitchA] nqa-ftp-record trap-enable

  6. SwitchA使能通过FTP保存NQA测试结果功能

    [SwitchA] nqa-ftp-record enable

  7. 使能NQA客户端,配置ICMP类型的NQA测试例

    [SwitchA] nqa test-instance admin icmp
    [SwitchA-admin-icmp] test-type icmp
    [SwitchA-admin-icmp] destination-address ipv4 10.1.1.1

  8. 启动测试例

    [SwitchA-admin-icmp] start now
    [SwitchA-admin-icmp] quit
    [SwitchA] quit

  9. FTP服务器端启动FTP服务。

    1. 配置FTP用户名、密码,需要和SwitchA上配置的一致。

    2. 配置FTP工作目录。

    3. 开启FTP服务。

  10. 查看测试结果

    # 配置成功,可以在设备上查看ICMP测试的结果。

    <SwitchA> display nqa results test-instance admin icmp
    NQA entry(admin, icmp) :testflag is inactive ,testtype is icmp                 
      1 . Test 1 result   The test is finished                                      
       Send operation times: 3              Receive response times: 3               
       Completion:success                   RTD OverThresholds number: 0            
       Attempts number:1                    Drop operation number:0                 
       Disconnect operation number:0        Operation timeout number:0              
       System busy operation number:0       Connection fail number:0                
       Operation sequence errors number:0   RTT Status errors number:0              
       Destination ip address:10.1.1.1                                              
       Min/Max/Average Completion Time: 2/3/2                                       
       Sum/Square-Sum  Completion Time: 7/17                                        
       Last Good Probe Time: 2014-01-14 08:06:29.4                                  
       Lost packet ratio: 0 % 
    

    # 在FTP服务器的工作目录下可以看到.txt文件,就是测试结果文件。

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 10 20
    #
    interface Vlanif10
     ip address 10.1.2.1 255.255.255.0
    #
    interface Vlanif20
     ip address 10.1.1.11 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port hybrid pvid vlan 20
     port hybrid untagged vlan 20
    #
    interface GigabitEthernet1/0/2
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    nqa-ftp-record trap-enable
    nqa-ftp-record ip-address 10.1.2.8
    nqa-ftp-record username ftp
    nqa-ftp-record password cipher %^%#pP]XJ%3W7Hce{[>x=r/)nQ`#!b5D3;H~*c#u3w|$%^%#
    nqa-ftp-record filename icmp
    nqa-ftp-record item-num 10010
    nqa-ftp-record time 2
    nqa-ftp-record enable
    #
    nqa test-instance admin icmp
     test-type icmp
     destination-address ipv4 10.1.1.1
    #
    return   
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 20
    #
    interface Vlanif20
     ip address 10.1.1.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port hybrid pvid vlan 20
     port hybrid untagged vlan 20
    #
    return   
    
翻译
下载文档
更新时间:2019-08-21

文档编号:EDOC1000141529

浏览量:20042

下载量:402

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页