所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S9300, S9300E, S9300X V200R010C00 配置指南-网络管理与监控

本文档介绍了设备支持的网络管理与监控相关配置。主要内容包括:SNMP配置、RMON和RMON2配置、LLDP配置、性能管理、iPCA配置、NQA配置、业务诊断配置、镜像配置、报文捕获配置、分流配置、NetStream配置、sFlow配置、TWAMP Light配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置HTTP测试示例

配置HTTP测试示例

组网需求

图6-30所示。SwitchA通过广域网和HTTP Server相连。检测SwitchA访问HTTP Server的速度。

图6-30  HTTP测试组网图

配置思路

采用如下思路进行配置:

  1. SwitchA作为NQA客户端。

  2. SwitchA上配置并启动HTTP测试例,使用NQA HTTP功能测试是否可以和指定的HTTP服务器建立连接,以及它们之间传输一个文件的时间。

操作步骤

  1. 配置SwitchA的接口地址,且和HTTP Server路由可达

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] vlan 100
    [SwitchA-vlan100] quit
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port hybrid pvid vlan 100
    [SwitchA-GigabitEthernet1/0/1] port hybrid untagged vlan 100
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface vlanif 100
    [SwitchA-Vlanif100] ip address 10.1.1.1 24
    [SwitchA-Vlanif100] quit
    [SwitchA] ospf
    [SwitchA-ospf-1] area 0
    [SwitchA-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255 
    [SwitchA-ospf-1-area-0.0.0.0] quit
    [SwitchA-ospf-1] quit
    

  2. 使能NQA客户端,配置HTTP类型的NQA测试例

    [SwitchA] nqa test-instance admin http
    [SwitchA-nqa-admin-http] test-type http
    [SwitchA-nqa-admin-http] destination-address ipv4 10.2.1.1
    [SwitchA-nqa-admin-http] http-operation get
    [SwitchA-nqa-admin-http] http-url http://www.***.com
    说明:
    配置HTTP测试例的URL必须是浏览器显示的URL地址,需要是实际合法的URL地址。这里以“http://www.***.com”举例。

  3. 启动测试

    [SwitchA-nqa-admin-http] start now

  4. 查看测试结果

    [SwitchA-nqa-admin-http] display nqa results test-instance admin http
    
     NQA entry(admin, http) :testflag is inactive ,testtype is http
      1 . Test 1 result   The test is finished
       SendProbe:3                          ResponseProbe:3
       Completion:success                   RTD OverThresholdsnumber: 0
       MessageBodyOctetsSum: 411            TargetAddress: 10.2.1.1
       DNSQueryError number: 0              HTTPError number: 0
       TcpConnError number : 0              System busy operation number:0
       DNSRTT Sum/Min/Max:0/0/0             TCPConnectRTT Sum/Min/Max: 4/1/2
       TransactionRTT Sum/Min/Max: 3/1/1
       RTT Sum/Min/Max/Avg: 7/2/3/2
       DNSServerTimeout:0  TCPConnectTimeout:0  TransactionTimeout: 0
       Lost packet ratio:0%

配置文件

SwitchA的配置文件

#
sysname SwitchA
#
vlan batch 100
#
interface Vlanif100
 ip address 10.1.1.1 255.255.255.0
#
interface GigabitEthernet1/0/1
 port hybrid pvid vlan 100
 port hybrid untagged vlan 100
#    
ospf 1       
 area 0.0.0.0     
  network 10.1.1.0 0.0.0.255  
#
nqa test-instance admin http
 test-type http
 destination-address ipv4 10.2.1.1
 http-url http://www.***.com
#
return
翻译
下载文档
更新时间:2019-08-21

文档编号:EDOC1000141529

浏览量:21459

下载量:403

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页