所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S9300, S9300E, S9300X V200R010C00 配置指南-网络管理与监控

本文档介绍了设备支持的网络管理与监控相关配置。主要内容包括:SNMP配置、RMON和RMON2配置、LLDP配置、性能管理、iPCA配置、NQA配置、业务诊断配置、镜像配置、报文捕获配置、分流配置、NetStream配置、sFlow配置、TWAMP Light配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置基于MQC的远程流镜像示例

配置基于MQC的远程流镜像示例

组网需求

图8-18所示,外部访问用户通过SwitchA访问公司的服务器,防病毒监控设备Server通过SwitchB与SwitchA相连。

现在公司官网被恶意攻击瘫痪,网络管理员希望Server能够远程对TCP端口号匹配WWW端口号的报文流进行分析,定位出恶意攻击源。

图8-18  配置远程流镜像组网图

配置思路

进行如下配置,实现Server远程监控指定TCP端口号的流量:
  1. 在SwitchA上配置接口GE1/0/2为二层远程观察端口,负责向绑定的VLAN转发镜像报文。
  2. 在SwitchA上配置流分类,匹配的报文流为TCP端口号是WWW端口号的报文流;配置流行为,将报文镜像到观察端口。
  3. 在SwitchA上配置流镜像策略,绑定创建的流分类和流行为,并在接口GE1/0/1上应用流策略。
  4. 在SwitchB上创建VLAN,关闭该VALN的MAC地址学习功能。配置接口加入VLAN,负责将观察端口发送过来的报文向Server转发。

操作步骤

  1. 在SwitchA上配置观察端口

    # 在SwitchA上配置接口GE1/0/2为二层远程观察端口,绑定的VLAN为VLAN10。

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] observe-port 1 interface gigabitethernet 1/0/2 vlan 10

    配置完成后,观察端口会将镜像报文向VLAN10进行转发,不需要在观察端口下进行接口加入VLAN的操作。

  2. 在SwitchA上配置流分类

    # 在SwitchA上创建流分类c1,并配置流分类规则为匹配TCP端口号是WWW端口号的报文。

    [SwitchA] acl number 3000
    [SwitchA-acl-adv-3000] rule permit tcp destination-port eq www
    [SwitchA-acl-adv-3000] quit
    [SwitchA] traffic classifier c1
    [SwitchA-classifier-c1] if-match acl 3000
    [SwitchA-classifier-c1] quit

  3. 在SwitchA上配置流行为

    # 在SwitchA上创建流行为b1,并配置流行为是流镜像,将指定报文流镜像到观察端口GE1/0/2

    [SwitchA] traffic behavior b1
    [SwitchA-behavior-b1] mirroring to observe-port 1
    [SwitchA-behavior-b1] quit
    说明:

    LE1D2S04SEC0单板、LE1D2X32SEC0单板、LE1D2H02QEC0单板和X系列单板外,对于其他支持配置出方向流镜像的单板,配置出方向流镜像时,不能再配置其他流行为,创建流行为时默认生成的permit动作也必须删除,否则出方向流镜像不生效。

  4. 在SwitchA上配置流策略并应用到接口上

    # 在SwitchA上创建流策略p1,将流分类和对应的流行为进行绑定,并将流策略应用到接口GE1/0/1的入方向上,对指定TCP端口号的流量进行监控。

    [SwitchA] traffic policy p1
    [SwitchA-trafficpolicy-p1] classifier c1 behavior b1
    [SwitchA-trafficpolicy-p1] quit
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] traffic-policy p1 inbound
    [SwitchA-GigabitEthernet1/0/1] return

  5. 在SwitchB上创建VLAN,配置接口加入VLAN

    # 在SwitchB上创建VLAN10,关闭该VALN的MAC地址学习功能,并将接口GE1/0/1和GE1/0/2加入VLAN10。

    说明:

    该VLAN仅用于转发镜像报文,不要使用该VLAN进行其他业务转发。如果该VLAN已存在,且已学习到MAC地址,请在系统视图下执行undo mac-address vlan vlan-id命令删除该VLAN已学习到的所有MAC地址。

    <Quidway> system-view
    [Quidway] sysname SwitchB
    [SwitchB] vlan 10
    [SwitchB-vlan10] mac-address learning disable
    [SwitchB-vlan10] quit
    [SwitchB] interface gigabitethernet 1/0/1
    [SwitchB-GigabitEthernet1/0/1] port link-type access
    [SwitchB-GigabitEthernet1/0/1] port default vlan 10
    [SwitchB-GigabitEthernet1/0/1] quit
    [SwitchB] interface gigabitethernet 1/0/2
    [SwitchB-GigabitEthernet1/0/2] port link-type trunk
    [SwitchB-GigabitEthernet1/0/2] port trunk allow-pass vlan 10
    [SwitchB-GigabitEthernet1/0/2] return

  6. 验证配置结果

    # 查看流分类的配置信息。

    <SwitchA> display traffic classifier user-defined c1
      User Defined Classifier Information:
       Classifier: c1
        Precedence: 5
        Operator: OR
        Rule(s) : if-match acl 3000

    # 查看流策略的配置信息。

    <SwitchA> display traffic policy user-defined p1
      User Defined Traffic Policy Information:
      Policy: p1
       Classifier: c1
        Operator: OR
         Behavior: b1
          Permit
          Mirroring  to observe-port 1
    

    # 查看观察端口的配置情况。

    <SwitchA> display observe-port
      ----------------------------------------------------------------------
      Index          : 1
      Untag-packet   : No
      Interface      : GigabitEthernet1/0/2
      Vlan           : 10
      ----------------------------------------------------------------------
    

    # 查看镜像端口的配置情况。

    <SwitchA> display port-mirroring
      ----------------------------------------------------------------------
      Observe-port 1 : GigabitEthernet1/0/2
      ----------------------------------------------------------------------
      Stream-mirror:
      ----------------------------------------------------------------------
           Behavior               Direction  Observe-port
      ----------------------------------------------------------------------
      1    b1                     -          Observe-port 1
      ----------------------------------------------------------------------  
    

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    observe-port 1 interface GigabitEthernet1/0/2 vlan 10
    #
    acl number 3000
     rule 5 permit tcp destination-port eq www
    #
    traffic classifier c1 operator or precedence 5
     if-match acl 3000
    #
    traffic behavior b1
     permit
     mirroring to observe-port 1
    #
    traffic policy p1 match-order config
     classifier c1 behavior b1
    #
    interface GigabitEthernet1/0/1
     traffic-policy p1 inbound
    #
    return
    
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 10
    #
    vlan 10
     mac-address learning disable
    #
    interface GigabitEthernet1/0/1
     port link-type access
     port default vlan 10
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
翻译
下载文档
更新时间:2019-08-21

文档编号:EDOC1000141529

浏览量:21531

下载量:403

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页