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OceanStor 9000 V300R006C10 文件系统特性指南 05

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故障处理

故障处理

创建快照失败

创建快照失败,导致管理员无法使用快照功能保护文件系统,对文件系统本身不会产生损害。

现象描述

登录DeviceManager选择数据保护 > 快照 > 快照单击“创建”,选择要创建快照的目录,并填入快照名称及其他参数,单击“确定”后,返回错误。

可能原因

  • 原因1:快照创建规则不满足,如快照名冲突或快照嵌套等。
  • 原因2:CM进程异常。
  • 原因3:CCDB进程异常。
  • 原因4:文件系统运行状态异常。

定位思路

图5-14   创建快照失败处理流程图

处理步骤

  • 原因1:快照创建规则不满足。
    1. 修改快照参数。

      • 提示“快照名冲突”时,修改快照名。

      • 提示“与已有快照目录嵌套”时,修改快照目录。

    2. 重新创建快照,查看是否成功。

      • 是 => 故障排除。
      • 否 => 原因2

  • 原因2:CM进程异常。
    1. 使用omuser身份通过PuTTY工具登录OceanStor 9000管理IP地址,使用su命令并输入root用户的登录密码切换到root用户,在命令行模式下,运行ps -ef |grep snas_cm,查看CM进程是否异常。

    2. 重新启动CM进程。

      在命令行模式下,输入kill -9 `ps -ef|grep snas_cm|grep -v grep|awk '{print $2}'` 命令,即可重启CM进程。

    3. 重新创建快照,查看是否成功。

      • 是 => 故障排除。
      • 否 => 原因3

  • 原因3:CCDB进程异常。
    1. 使用omuser身份通过PuTTY工具登录OceanStor 9000管理IP地址,使用su命令并输入root用户的登录密码切换到root用户,在命令行模式下,运行MmlBatch 4004 "mon ccdbmap 0",查询CCDB主节点ID。

      其中Master Ccdb Id : 1表示ccdb主节点ID为1。

      *****************CCDB MAP Start***************
      Epoch : 6
      Master Ccdb Id : 1
      RackName : h1
      Node Id : 2
      Role : 1
      State : 1
      RackName : h1
      Node Id : 1
      Role : 0
      State : 1
      RackName : h1
      Node Id : 3
      Role : 1
      State : 1
      *****************CCDB MAP End***************

    2. 执行cat /proc/monc_nodemap,查询CCDB主节点IP地址。

      根据1中查询的CCDB主节点ID,可知CCDB主节点IP地址。下面的例子中CCDB主节点IP地址为192.168.100.14。

      NODE14:~ # cat /proc/monc_nodemap 
      ***************** Node Map *****************
      Node: NodeID(3), BackIp(0x61ca640f), BirthTime(6148640756791479442), DevName(192.168.100.15), ClusterID(snassnap11431590979863), NodeType(1), RegStatus(1), FaultTime(0), DelTime(0)
      Node: NodeID(2), BackIp(0x61ca6410), BirthTime(6148640610762061891), DevName(192.168.100.16), ClusterID(snassnap11431590979863), NodeType(1), RegStatus(1), FaultTime(0), DelTime(0)
      Node: NodeID(1), BackIp(0x61ca640e), BirthTime(6148640606467511425), DevName(192.168.100.14), ClusterID(snassnap11431590979863), NodeType(1), RegStatus(1), FaultTime(0), DelTime(0)
      ************** Local Node Info *************
      Node RegStat: 1, NodeId: 1, BirthTime: 6148640606467511425, ClusterId: snassnap11431590979863, DevName: 192.168.100.14, NodeType: 1, FaultTime: 0, DelTime: 0
      NIDStat: 1(1:normal), HbStop: 0(1:stop), Ntf: 0(0:done), NIDFlg: 0(0:normal 1:map_fault 2:detect_fault)

    3. 使用omuser身份通过PuTTY工具登录CCDB主节点,使用su命令并输入root用户的登录密码切换到root用户,在命令行模式下,执行cat /proc/ccdb_statemap,查看CCDB进程的状态是否正常。

      若回显信息中result为0,且status为2,则说明CCDB进程的状态正常。

      NODE15:/home/omuser # cat /proc/ccdb_statemap 
      result:0,status:2

    4. 执行ps -ef |grep ccdb_server,查看CCDB进程。
    5. 重新启动CCDB进程。

      1. 执行以下命令,停止CCDB进程。

        /opt/huawei/deploy/bin/daemon -s /opt/huawei/snas_cluster/bin/ccdb_server

      2. 执行以下命令,重新启动CCDB进程。

        /opt/huawei/deploy/bin/daemon /opt/huawei/snas_cluster/bin/ccdb_server

    6. 重新创建快照,查看是否成功。

      • 是 => 故障排除。
      • 否 => 原因4

  • 原因4:文件系统运行状态异常。
    1. 参见“查询文件系统运行状态失败或错误”进行处理,排除故障。
    2. 重新创建快照,查看是否成功。

      • 是 => 故障排除。
      • 否 => 请联系技术服务工程师。

查询快照失败

查询快照失败,导致管理员无法查看快照信息,对文件系统本身不会产生损害。

现象描述

登录DeviceManager选择数据保护 > 快照 > 快照单击“刷新”,弹出错误。

可能原因

  • 原因1:CM进程异常。
  • 原因2:CCDB进程异常。
  • 原因3:文件系统运行状态异常。

定位思路

图5-15   查询快照失败处理流程图

处理步骤

  • 原因1:CM进程异常。
    1. 使用omuser身份通过PuTTY工具登录OceanStor 9000管理IP地址,使用su命令并输入root用户的登录密码切换到root用户,在命令行模式下,运行ps -ef |grep snas_cm,查看CM进程是否异常。

    2. 重新启动CM进程。

      在命令行模式下,输入kill -9 `ps -ef|grep snas_cm|grep -v grep|awk '{print $2}'`命令,即可重启CM进程。

    3. 重新查询快照,查看是否成功。

      • 是 => 故障排除。
      • 否 => 原因2

  • 原因2:CCDB进程异常。
    1. 使用omuser身份通过PuTTY工具登录OceanStor 9000管理IP地址,使用su命令并输入root用户的登录密码切换到root用户,在命令行模式下,运行MmlBatch 4004 "mon ccdbmap 0",查询CCDB主节点ID。

      其中Master Ccdb Id : 1表示ccdb主节点ID为1。

      *****************CCDB MAP Start***************
      Epoch : 6
      Master Ccdb Id : 1
      RackName : h1
      Node Id : 2
      Role : 1
      State : 1
      RackName : h1
      Node Id : 1
      Role : 0
      State : 1
      RackName : h1
      Node Id : 3
      Role : 1
      State : 1
      *****************CCDB MAP End***************

    2. 执行cat /proc/monc_nodemap,查询CCDB主节点IP地址。

      根据1中查询的CCDB主节点ID,可知CCDB主节点IP地址。下面的例子中CCDB主节点IP地址为192.168.100.14。

      NODE14:~ # cat /proc/monc_nodemap 
      ***************** Node Map *****************
      Node: NodeID(3), BackIp(0x61ca640f), BirthTime(6148640756791479442), DevName(192.168.100.15), ClusterID(snassnap11431590979863), NodeType(1), RegStatus(1), FaultTime(0), DelTime(0)
      Node: NodeID(2), BackIp(0x61ca6410), BirthTime(6148640610762061891), DevName(192.168.100.16), ClusterID(snassnap11431590979863), NodeType(1), RegStatus(1), FaultTime(0), DelTime(0)
      Node: NodeID(1), BackIp(0x61ca640e), BirthTime(6148640606467511425), DevName(192.168.100.14), ClusterID(snassnap11431590979863), NodeType(1), RegStatus(1), FaultTime(0), DelTime(0)
      ************** Local Node Info *************
      Node RegStat: 1, NodeId: 1, BirthTime: 6148640606467511425, ClusterId: snassnap11431590979863, DevName: 192.168.100.14, NodeType: 1, FaultTime: 0, DelTime: 0
      NIDStat: 1(1:normal), HbStop: 0(1:stop), Ntf: 0(0:done), NIDFlg: 0(0:normal 1:map_fault 2:detect_fault)

    3. 使用omuser身份通过PuTTY工具登录CCDB主节点,使用su命令并输入root用户的登录密码切换到root用户,在命令行模式下,执行cat /proc/ccdb_statemap,查看CCDB进程的状态是否正常。

      若回显信息中result为0,且status为2,则说明CCDB进程的状态正常。

      NODE15:/home/omuser # cat /proc/ccdb_statemap 
      result:0,status:2

    4. 执行ps -ef |grep ccdb_server,查看CCDB进程。
    5. 重新启动CCDB进程。

      1. 执行以下命令,停止CCDB进程。

        /opt/huawei/deploy/bin/daemon -s /opt/huawei/snas_cluster/bin/ccdb_server

      2. 执行以下命令,重新启动CCDB进程。

        /opt/huawei/deploy/bin/daemon /opt/huawei/snas_cluster/bin/ccdb_server

    6. 重新查询快照,查看是否成功。

      • 是 => 故障排除。
      • 否 => 原因3

  • 原因3:文件系统运行状态异常。
    1. 参见“查询文件系统运行状态失败或错误”进行处理,排除故障。
    2. 重新查询快照,查看是否成功。

      • 是 => 故障排除。
      • 否 => 请联系技术服务工程师。

删除快照失败

删除快照失败,导致管理员无法删除已存在的快照,对文件系统本身不会产生损害。

现象描述

登录DeviceManager选择数据保护 > 快照 > 快照勾选需要查看的快照,单击“删除”,确认风险后,单击“确定”,弹出错误提示,提示信息有“快照Id不存在”,“通信异常或系统繁忙”,删除快照失败。

可能原因

  • 原因1:CM进程异常。
  • 原因2:CCDB进程异常。
  • 原因3:文件系统运行状态异常。

定位思路

图5-16   删除快照失败处理流程图

处理步骤

  • 原因1:CM进程异常。
    1. 使用omuser身份通过PuTTY工具登录OceanStor 9000管理IP地址,使用su命令并输入root用户的登录密码切换到root用户,在命令行模式下,运行ps -ef |grep snas_cm,查看CM进程是否异常。

    2. 重新启动CM进程。

      在命令行模式下,输入kill -9 `ps -ef|grep snas_cm|grep -v grep|awk '{print $2}'`命令,即可重启CM进程。

    3. 重新删除快照,查看是否成功。

      • 是 => 故障排除。
      • 否 => 原因2

  • 原因2:CCDB进程异常。
    1. 使用omuser身份通过PuTTY工具登录OceanStor 9000管理IP地址,使用su命令并输入root用户的登录密码切换到root用户,在命令行模式下,运行MmlBatch 4004 "mon ccdbmap 0",查询CCDB主节点ID。

      其中Master Ccdb Id : 1表示ccdb主节点ID为1。

      *****************CCDB MAP Start***************
      Epoch : 6
      Master Ccdb Id : 1
      RackName : h1
      Node Id : 2
      Role : 1
      State : 1
      RackName : h1
      Node Id : 1
      Role : 0
      State : 1
      RackName : h1
      Node Id : 3
      Role : 1
      State : 1
      *****************CCDB MAP End***************

    2. 执行cat /proc/monc_nodemap,查询CCDB主节点IP地址。

      根据1中查询的CCDB主节点ID,可知CCDB主节点IP地址。下面的例子中CCDB主节点IP地址为192.168.100.14。

      NODE14:~ # cat /proc/monc_nodemap 
      ***************** Node Map *****************
      Node: NodeID(3), BackIp(0x61ca640f), BirthTime(6148640756791479442), DevName(192.168.100.15), ClusterID(snassnap11431590979863), NodeType(1), RegStatus(1), FaultTime(0), DelTime(0)
      Node: NodeID(2), BackIp(0x61ca6410), BirthTime(6148640610762061891), DevName(192.168.100.16), ClusterID(snassnap11431590979863), NodeType(1), RegStatus(1), FaultTime(0), DelTime(0)
      Node: NodeID(1), BackIp(0x61ca640e), BirthTime(6148640606467511425), DevName(192.168.100.14), ClusterID(snassnap11431590979863), NodeType(1), RegStatus(1), FaultTime(0), DelTime(0)
      ************** Local Node Info *************
      Node RegStat: 1, NodeId: 1, BirthTime: 6148640606467511425, ClusterId: snassnap11431590979863, DevName: 192.168.100.14, NodeType: 1, FaultTime: 0, DelTime: 0
      NIDStat: 1(1:normal), HbStop: 0(1:stop), Ntf: 0(0:done), NIDFlg: 0(0:normal 1:map_fault 2:detect_fault)

    3. 使用omuser身份通过PuTTY工具登录CCDB主节点,使用su命令并输入root用户的登录密码切换到root用户,在命令行模式下,执行cat /proc/ccdb_statemap,查看CCDB进程的状态是否正常。

      若回显信息中result为0,且status为2,则说明CCDB进程的状态正常。

      NODE15:/home/omuser # cat /proc/ccdb_statemap 
      result:0,status:2

    4. 执行ps -ef |grep ccdb_server,查看CCDB进程。
    5. 重新启动CCDB进程。

      1. 执行以下命令,停止CCDB进程。

        /opt/huawei/deploy/bin/daemon -s /opt/huawei/snas_cluster/bin/ccdb_server

      2. 执行以下命令,重新启动CCDB进程。

        /opt/huawei/deploy/bin/daemon /opt/huawei/snas_cluster/bin/ccdb_server

    6. 重新删除快照,查看是否成功。

      • 是 => 故障排除。
      • 否 => 原因3

  • 原因3:文件系统运行状态异常。
    1. 参见“查询文件系统运行状态失败或错误”进行处理,排除故障。
    2. 重新删除快照,查看是否成功。

      • 是 => 故障排除。
      • 否 => 请联系技术服务工程师。

创建定时快照策略失败

创建定时策略失败,将会导致管理员无法使用快照功能保护文件系统。

现象描述

登录DeviceManager创建定时快照策略后,会在弹出的“执行结果”对话框中显示创建失败信息,详细信息可以在“失败原因和建议”栏查看。如图5-17所示。

图5-17  DeviceManager界面创建定时快照策略失败界面

可能原因

  • 原因1:从“失败原因和建议”中可查看的快照嵌套、策略名称重复或目录不存在等具体原因。
  • 原因2:内部错误。

定位思路

图5-18  创建定时快照策略失败处理流程图

处理步骤

  1. 查看DeviceManager界面是否显示内部错误。

    • 是 => 联系技术服务工程师。
    • 否 => 2

  2. 根据界面提示的具体原因和建议,做相应的操作,重新创建定时快照策略,观察是否创建成功。

    • 是 => 故障排除。
    • 否 => 联系技术服务工程师。

删除定时快照策略失败

删除定时策略失败,无法停止快照的定时创建。

现象描述

登录DeviceManager执行删除定时快照策略,会在弹出的“执行结果”对话框中显示创建失败信息,详细信息可以在“失败原因和建议”栏查看。如图5-19所示。

图5-19  DeviceManager界面删除定时快照策略失败

可能原因

  • 原因1:从“失败原因和建议”中可查看的通信异常或系统繁忙等具体原因。
  • 原因2:内部错误。

定位思路

图5-20  删除定时快照策略失败处理流程图

处理步骤

  1. 查看DeviceManager界面是否显示内部错误。

    • 是 => 联系技术服务工程师。
    • 否 => 2

  2. 根据提示建议修改后,重新删除定时快照策略,观察是否成功。

    说明:

    原因为通信异常或者CM故障,可重启CM进程。

    使用omuser身份通过PuTTY工具登录OceanStor 9000管理IP地址,使用su命令并输入root用户密码切换到root用户,在命令行模式下,输入kill -9 `ps -ef|grep snas_cm|grep -v grep|awk '{print $2}'`命令,即可重启CM进程。

    • 是 => 故障排除。
    • 否 => 联系技术服务工程师。

查询定时快照策略失败

查询定时策略失败,无法查询定时快照策略的详细信息。

现象描述

登录DeviceManager查询定时快照策略总体信息或每条快照策略的详细信息时返回错误,失败的错误提示包括“通信异常或系统繁忙”“内部错误”等。如图5-21所示。

图5-21  DeviceManager界面查询定时快照策略失败

可能原因

  • 原因1:系统服务正在故障恢复。
  • 原因2:CM进程故障。
  • 原因3:CCDB进程异常。

定位思路

图5-22  查询定时快照策略失败处理流程图

处理步骤

  • 原因1:系统服务正在故障恢复。
    1. 检查MDS MAP和CA MAP状态是否异常。

      • 使用omuser身份通过PuTTY工具登录OceanStor 9000管理IP地址,使用su命令并输入root用户登录密码切换到root用户,在命令行模式下执行cat /proc/monc_mdsmap。如图5-23所示。其中“State Normal”表示状态正常,否则为正在故障恢复。
        图5-23  mdsmap状态查询结果

      • 使用omuser身份通过PuTTY工具登录OceanStor 9000管理IP地址,使用su命令并输入root用户登录密码切换到root用户,在命令行模式下执行cat /proc/monc_camap。如图5-24所示。其中“State Normal”表示状态正常,否则为正在故障恢复。
        图5-24  camap状态查询结果

    2. 以上查询的MDS MAP与CA MAP是否存在正在故障恢复状态。

      • 是 => 等待MDS MAP与CA MAP全部正常后,执行3
      • 否 => 原因2

    3. 重试查询定时快照策略是否成功。

      • 是 => 故障排除。
      • 否 => 原因2

  • 原因2:CM进程故障。
    1. 使用omuser身份通过PuTTY工具登录OceanStor 9000管理IP地址,使用su命令并输入root用户登录密码切换到root用户,在命令行模式下,运行ps -ef |grep snas_cm,查看CM进程是否异常。

      • 是 => 在命令行模式下,输入kill -9 `ps -ef|grep snas_cm|grep -v grep|awk '{print $2}'`命令,重启CM进程。
      • 否 => 原因3

    2. 重试查询定时快照策略是否成功。

      • 是 => 故障排除。
      • 否 => 原因3

  • 原因3:CCDB进程异常。
    1. 使用omuser身份通过PuTTY工具登录OceanStor 9000管理IP地址,使用su命令并输入root用户的登录密码切换到root用户,在命令行模式下,运行MmlBatch 4004 "mon ccdbmap 0",查询CCDB主节点ID。

      其中Master Ccdb Id : 1表示ccdb主节点ID为1。

      *****************CCDB MAP Start***************
      Epoch : 6
      Master Ccdb Id : 1
      RackName : h1
      Node Id : 2
      Role : 1
      State : 1
      RackName : h1
      Node Id : 1
      Role : 0
      State : 1
      RackName : h1
      Node Id : 3
      Role : 1
      State : 1
      *****************CCDB MAP End***************

    2. 执行cat /proc/monc_nodemap,查询CCDB主节点IP地址。

      根据1中查询的CCDB主节点ID,可知CCDB主节点IP地址。下面的例子中CCDB主节点IP地址为192.168.100.14。

      NODE14:~ # cat /proc/monc_nodemap 
      ***************** Node Map *****************
      Node: NodeID(3), BackIp(0x61ca640f), BirthTime(6148640756791479442), DevName(192.168.100.15), ClusterID(snassnap11431590979863), NodeType(1), RegStatus(1), FaultTime(0), DelTime(0)
      Node: NodeID(2), BackIp(0x61ca6410), BirthTime(6148640610762061891), DevName(192.168.100.16), ClusterID(snassnap11431590979863), NodeType(1), RegStatus(1), FaultTime(0), DelTime(0)
      Node: NodeID(1), BackIp(0x61ca640e), BirthTime(6148640606467511425), DevName(192.168.100.14), ClusterID(snassnap11431590979863), NodeType(1), RegStatus(1), FaultTime(0), DelTime(0)
      ************** Local Node Info *************
      Node RegStat: 1, NodeId: 1, BirthTime: 6148640606467511425, ClusterId: snassnap11431590979863, DevName: 192.168.100.14, NodeType: 1, FaultTime: 0, DelTime: 0
      NIDStat: 1(1:normal), HbStop: 0(1:stop), Ntf: 0(0:done), NIDFlg: 0(0:normal 1:map_fault 2:detect_fault)

    3. 使用omuser身份通过PuTTY工具登录CCDB主节点,使用su命令并输入root用户的登录密码切换到root用户,在命令行模式下,执行cat /proc/ccdb_statemap,查看CCDB进程的状态是否正常。

      若回显信息中result为0,且status为2,则说明CCDB进程的状态正常。

      NODE15:/home/omuser # cat /proc/ccdb_statemap 
      result:0,status:2
      • 是 => 6
      • 否 => 4

    4. 执行ps -ef |grep ccdb_server,查看CCDB进程。
    5. 重新启动CCDB进程。

      1. 执行以下命令,停止CCDB进程。

        /opt/huawei/deploy/bin/daemon -s /opt/huawei/snas_cluster/bin/ccdb_server

      2. 执行以下命令,重新启动CCDB进程。

        /opt/huawei/deploy/bin/daemon /opt/huawei/snas_cluster/bin/ccdb_server

    6. 重试查询定时快照策略是否成功。

      • 是 => 故障排除。
      • 否 => 请联系技术服务工程师。

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更新时间:2019-03-30

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