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OceanStor 9000 V300R006C10 文件系统特性指南 05

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故障处理

故障处理

介绍在使用NDMP备份特性的过程中可能遇到的故障及其处理方法,使您能更顺利地使用本特性。

NDMP备份失败

NDMP备份任务失败,将导致主要存储与次要存储之间的数据备份任务故障。

现象描述

NDMP备份任务失败提示错误如图13-16所示。
图13-16  NDMP备份失败

可能原因

  • 原因1:系统保护的目录不允许直接备份。
  • 原因2:创建文件系统快照失败。
  • 原因3:删除文件系统快照失败。
  • 原因4:其他(NBU侧主动停止备份任务、访问文件系统失败、访问磁带库失败等)。

定位思路

图13-17  设备上NDMP备份失败故障处理流程

处理步骤

  1. 检查网络是否正常。
    1. 检查网络是否正常。

      • 是 => 2
      • 否 => 1.b

    2. 重新连接线缆,再次进行备份检查业务是否恢复正常。

      • 是 => 故障排除。
      • 否 => 2

  2. 检查磁带库是否正常。
    1. 确保磁带驱动器处于up状态,再次进行备份检查业务是否恢复正常。

      • 是 => 故障排除。
      • 否 => 2.b

    2. 确保磁带库完好,再次进行备份检查业务是否恢复正常。

      • 是 => 故障排除。
      • 否 => 3

  3. 确保备份路径输入正确,再次进行备份检查业务是否恢复正常。

    • 是 => 故障排除。
    • 否 => 请联系技术服务工程师。

NDMP恢复失败

管理员执行NDMP恢复任务失败,将导致备份数据无法恢复,数据可靠性降低。

现象描述

管理员执行NDMP恢复任务失败,如图13-18所示。
图13-18  NDMP恢复任务失败

可能原因

  • 原因1:系统保护的目录不允许选择为恢复目录。
  • 原因2:其他(NBU侧主动停止恢复任务、访问文件系统失败、访问磁带库失败等)。

定位思路

图13-19  设备恢复失败故障定位流程

处理步骤

  1. 检查恢复目录是否是系统保护目录。
    1. 检查恢复目录是否是系统保护目录。

      NDMP备份特性对恢复目录存在约束,详情请参见OceanStor 9000 文件系统特性指南》中的“NDMP备份特性指南”

      • 是 => 1.b
      • 否 => 2

    2. 更换恢复目录并重新执行NDMP恢复,检查该事件是否恢复。

      • 是 => 故障排除。
      • 否 => 2

  2. 检查网络是否正常。
    1. 检查OceanStor 9000与磁带库间网络是否正常。

      • 是 => 3
      • 否 => 2.b

    2. 重新连接线缆,再次执行NDMP恢复,并检查该事件是否恢复。

      • 是 => 故障排除。
      • 否 => 3

  3. 检查磁带库是否正常。
    1. 确保磁带驱动器处于up状态,再次执行NDMP恢复,检查该事件是否恢复。

      • 是 => 故障排除。
      • 否 => 3.b

    2. 确保磁带库完好,再次执行NDMP恢复,检查该事件是否恢复。

      • 是 => 故障排除。
      • 否 => 请联系技术服务工程师。

参考信息

无。

NDMP客户端认证失败

NDMP客户端连接NDMP主机成功后,发起认证请求失败。

现象描述

NDMP客户端连接NDMP主机成功后,发起认证请求失败,如图13-20所示。
图13-20  NDMP发起认证请求失败

可能原因

  • 原因1:用户名密码输入错误。
  • 原因2:NDMP客户端认证IP被锁定。

定位思路

图13-21  NDMP认证失败故障定位流程

处理步骤

  • 原因1:用户名密码输入错误。
    1. 检查用户名和密码是否输入正确。

    2. 重新输入正确的用户名和密码,再次认证检查该故障是否恢复。

      • 是 => 故障排除。
      • 否 => 原因2

  • 原因2:NDMP客户端认证IP被锁定。
    1. 检查NDMP客户端认证IP是否被锁定。

      • 是 => 2
      • 否 => 请联系技术服务工程师。

    2. 等待认证IP解锁后再次认证检查该故障是否恢复。

      • 是 => 故障排除。
      • 否 => 请联系技术服务工程师。

备份服务器连接NDMP服务器失败

备份服务器(NDMP客户端)连接NDMP服务器(OceanStor 9000)失败。

现象描述

备份服务器连接NDMP服务器失败,显示如图13-22所示。

图13-22  备份服务器连接NDMP服务器失败处理流程

可能原因

  • 原因1:NDMP服务异常。
  • 原因2:指定端口未启用。
  • 原因3:备份服务器未添加NDMP服务器DNS。
  • 原因4:用户名与密码输入错误。

定位思路

图13-23  备份服务器连接NDMP主机失败故障定位流程

处理步骤

  • 原因1:NDMP服务异常。
    1. 登录DeviceManager
    2. 选择设置 > 存储设置 > 文件存储服务 > NDMP设置
    3. 查看“启用”前的复选框是否为勾选状态。

      如果未勾选,表明NDMP服务异常,请勾选后,单击“保存”;否则,请继续定位其他原因。

  • 原因2:指定端口未启用。
    1. 在备份服务器中,执行telnet命令查看指定端口能否访问。

      例如,在设置 > 存储设置 > 文件存储服务 > NDMP设置页面中设置的“监控端口”“10000”,则执行命令telnet xx.xx.xx.xx 10000

      • 如果显示“Connected to”,表明能正常访问,请继续定位其他原因 => 原因3

      • 否则 => 2

    2. 登录DeviceManager
    3. 选择设置 > 存储设置 > 文件存储服务 > NDMP设置
    4. 去勾选“启用”并单击“保存”
    5. 重新勾选“启用”,在“监控端口”输入指定端口号,然后单击“保存”

      检查功能是否正常。

      • 是 => 故障排除。
      • 否 => 原因3

  • 原因3:备份服务器未添加NDMP服务器DNS。

    检查备份服务器的配置文件/etc/resolv.conf中是否添加DNS,如果没有,请添加NDMP主机DNS。配置项为“nameserver DNSIP”,DNSIP为集群DNS IP,在DeviceManager设置 > 集群设置 > InfoEqualizer > 网络设置中可以查看DNS IP地址。设置好后再检测是否可以访问OceanStor 9000动态域名,用nslookup dynamicname命令检测,其中dynamicnameOceanStor 9000动态域名。

    • 是 => 故障排除。
    • 否 => 请联系技术服务工程师。

  • 原因4:用户名与密码输入错误。

    请在如图13-22所示的操作界面,重新输入用户名与密码,再次尝试连接。

    • 是 => 故障排除。
    • 否 => 请联系技术服务工程师。

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更新时间:2019-03-30

文档编号:EDOC1000162199

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