所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 8800, 7800, 6800, 5800 V200R002C50 配置指南-IP组播

本文档介绍了IP组播的配置,具体包括IP组播基础、IGMP配置、MLD配置、PIM(IPv4)配置、PIM(IPv6)配置、MSDP配置、组播VPN配置、组播路由管理(IPv4)配置、组播路由管理(IPv6)配置、IGMP Snooping配置、MLD Snooping配置、静态组播MAC地址配置、组播VLAN配置和组播网管配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置SA消息过滤示例

配置SA消息过滤示例

组网需求

图6-13所示,网络以组播方式传递业务数据,网络划分为三个PIM-SM域。组播源Source1向组播组225.1.1.0/30和226.1.1.0/30发送组播数据,组播源Source2向组播组227.1.1.0/30发送组播数据。根据业务需要,接收者HostA和HostB只接收发往组播组225.1.1.0/30和226.1.1.0/30的组播数据,而HostC则只接收发往组播组226.1.1.0/30和227.1.1.0/30的组播数据。

图6-13 配置SA消息过滤组网图

配置思路

配置MSDP,实现域间组播源信息共享;再配置SA消息过滤,使接收者只能收到相应的组播数据。

  1. 配置各Switch接口IP地址,在PIM-SM域内配置OSPF协议实现互联。

  2. 使能组播功能,并在各接口上使能PIM-SM功能,并配置BSR服务边界划分PIM-SM域,在主机侧接口上使能IGMP功能。

  3. 配置SwitchA、SwitchC和SwitchD上Loopback0接口分别作为各自PIM-SM域的C-BSR和C-RP。

  4. 在各域的RP之间建立MSDP对等体。在SwitchA和SwitchC之间建立对等体,SwitchC和SwitchD之间建立对等体。

  5. 配置SA消息过滤规则。配置SwitchC不向SwitchD转发有关(Source1,225.1.1.0/30)的SA消息,配置SwitchD不创建有关Source2的SA消息。

操作步骤

  1. 配置各Switch接口IP地址和单播路由协议。

    # 按照图6-13,在PIM-SM域内,配置各Switch接口的IP地址和掩码,配置各Switch间采用OSPF进行互连。具体配置过程略。

  2. 使能组播路由功能,并配置PIM-SM功能。

    # 在所有Switch使能组播路由功能,并在各接口上使能PIM-SM功能,在主机侧接口使能IGMP功能。以下配置以SwitchA为例,其他Switch的配置过程与SwitchA上的配置相似,配置过程略。

    [~SwitchA] multicast routing-enable
    [*SwitchA] interface vlanif 100
    [*SwitchA-Vlanif100] pim sm
    [*SwitchA-Vlanif100] igmp enable
    [*SwitchA-Vlanif100] commit
    [~SwitchA-Vlanif100] quit
    [~SwitchA] interface vlanif 101
    [~SwitchA-Vlanif101] pim sm
    [*SwitchA-Vlanif101] commit
    [~SwitchA-Vlanif101] quit
    [~SwitchA] interface vlanif 102
    [~SwitchA-Vlanif102] pim sm
    [*SwitchA-Vlanif102] commit
    [~SwitchA-Vlanif102] quit
    [~SwitchA] interface loopback 0
    [~SwitchA-LoopBack0] pim sm
    [*SwitchA-LoopBack0] commit
    [~SwitchA-LoopBack0] quit

  3. 配置BSR的服务边界,划分PIM-SM域。

    # 在SwitchC上配置BSR的服务边界,SwitchA、SwitchB、SwitchD的配置与SwitchC类似,配置过程略。

    [~SwitchC] interface vlanif 101
    [~SwitchC-Vlanif101] pim bsr-boundary
    [*SwitchC-Vlanif101] quit
    [*SwitchC] interface vlanif 103
    [*SwitchC-Vlanif103] pim bsr-boundary
    [*SwitchC-Vlanif103] quit
    [*SwitchC] interface vlanif 104
    [*SwitchC-Vlanif104] pim bsr-boundary
    [*SwitchC-Vlanif104] quit
    [*SwitchC] commit
    

  4. 配置C-BSR、C-RP的位置。

    # 在SwitchA上将Loopback0接口配置为C-BSR和C-RP。SwitchC、SwitchD上的配置过程与SwitchA上的配置相似,配置过程略。

    [~SwitchA] pim
    [*SwitchA-pim] c-bsr loopback0
    [*SwitchA-pim] c-rp loopback0
    [*SwitchC-pim] commit
    [~SwitchC-pim] quit
    

  5. 配置MSDP对等体。

    # 在SwitchA上配置MSDP对等体。

    [~SwitchA] msdp
    [*SwitchA-msdp] peer 192.168.1.2 connect-interface vlanif 101
    [*SwitchA-msdp] commit
    [~SwitchA-msdp] quit

    # 在SwitchC上配置MSDP对等体。

    [~SwitchC] msdp
    [*SwitchC-msdp] peer 192.168.1.1 connect-interface vlanif 101
    [*SwitchC-msdp] peer 10.110.5.2 connect-interface vlanif 104
    [*SwitchC-msdp] commit
    [~SwitchC-msdp] quit

    # 在SwitchD上配置MSDP对等体。

    [~SwitchD] msdp
    [*SwitchD-msdp] peer 10.110.5.1 connect-interface vlanif 104
    [*SwitchD-msdp] commit
    [~SwitchD-msdp] quit

  6. 配置SA消息过滤规则。

    # 在SwitchC上配置不向SwitchD转发有关(Source1,225.1.1.0/30)的SA消息。

    [~SwitchC] acl number 3001
    [*SwitchC-acl4-advance-3001] rule deny ip source 10.110.3.100 0 destination 225.1.1.0 0.0.0.3
    [*SwitchC-acl4-advance-3001] rule permit ip source any destination any
    [*SwitchC-acl4-advance-3001] commit
    [~SwitchC-acl4-advance-3001] quit
    [~SwitchC] msdp
    [*SwitchC-msdp] peer 10.110.5.2 sa-policy export 3001
    [*SwitchC-msdp] commit
    [~SwitchC-msdp] quit
    

    # 在SwitchD上配置不创建有关Source2的SA消息。

    [~SwitchD] acl number 2001
    [*SwitchD-acl4-basic-2001] rule deny source 10.110.6.100 0
    [*SwitchD-acl4-basic-2001] quit
    [*SwitchD] msdp
    [*SwitchD-msdp] import-source acl 2001
    [*SwitchD-msdp] quit
    [*SwitchD] commit

  7. 验证配置结果。

    # 通过使用display msdp sa-cache命令可以查看Switch上SA缓存中的(S,G)表项信息。例如:SwitchC和SwitchD上信息如下:

    [~SwitchC] display msdp sa-cache
    MSDP Source-Active Cache Information of VPN instance: public net
     MSDP Total Source-Active Cache - 8 entries
     MSDP matched 8 entries
    
    (10.110.3.100, 225.1.1.0)
     Origin RP: 10.1.1.1
     Pro: BGP, AS: ? 
     Uptime: 00:03:32, Expires: 00:05:28 
    
    (10.110.3.100, 225.1.1.1)
     Origin RP: 10.1.1.1
     Pro: BGP, AS: ?
     Uptime: 00:03:32, Expires: 00:05:28
    
    (10.110.3.100, 225.1.1.2)
     Origin RP: 10.1.1.1 
     Pro: BGP, AS: ?
     Uptime: 00:03:32, Expires: 00:05:28 
    
    (10.110.3.100, 225.1.1.3)
     Origin RP: 10.1.1.1 
     Pro: BGP, AS: ?
     Uptime: 00:03:32, Expires: 00:05:28
    
    (10.110.3.100, 226.1.1.0)
     Origin RP: 10.1.1.1
     Pro: BGP, AS: ? 
     Uptime: 00:03:32, Expires: 00:05:28
    
    (10.110.3.100, 226.1.1.1)
     Origin RP: 10.1.1.1
     Pro: BGP, AS: ?
     Uptime: 00:03:32, Expires: 00:05:28
    
    (10.110.3.100, 226.1.1.2)
     Origin RP: 10.1.1.1
     Pro: BGP, AS: ? 
     Uptime: 00:03:32, Expires: 00:05:28
    
    (10.110.3.100, 226.1.1.3)
     Origin RP: 10.1.1.1 
     Pro: BGP, AS: ?
     Uptime: 00:03:32, Expires: 00:05:28
    
    [~SwitchD] display msdp sa-cache
    MSDP Source-Active Cache Information of VPN instance: public net
     MSDP Total Source-Active Cache - 4 entries
     MSDP matched 4 entries
    
    (10.110.3.100, 226.1.1.0)
     Origin RP: 10.1.1.1
     Pro: BGP, AS: ?
     Uptime: 00:24:53, Expires: 00:05:06
    
    (10.110.3.100, 226.1.1.1)
     Origin RP: 10.1.1.1
     Pro: BGP, AS: ? 
     Uptime: 00:24:53, Expires: 00:05:06
    
    (10.110.3.100, 226.1.1.2)
     Origin RP: 10.1.1.1
     Pro: BGP, AS: ?
     Uptime: 00:24:53, Expires: 00:05:06
    
    (10.110.3.100, 226.1.1.3)
     Origin RP: 10.1.1.1
     Pro: BGP, AS: ? 
     Uptime: 00:24:53, Expires: 00:05:06
    
    

    从显示信息中可以看出,SwitchC的SA缓存中只有225.1.1.0/30和226.1.1.0/30的组播数据。SwitchD的SA缓存中只有226.1.1.0/30的组播数据。

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 100 to 102
    #
    multicast routing-enable
    #
    interface Vlanif100
     ip address 10.110.1.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif101
     ip address 192.168.1.1 255.255.255.0
     pim sm
    #
    interface Vlanif102
     ip address 10.110.2.1 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port default vlan 100
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 102
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 101
    #
    interface LoopBack0
     ip address 10.1.1.1 255.255.255.255
     pim sm
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.1 0.0.0.0
      network 10.110.1.0 0.0.0.255
      network 10.110.2.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
    #
    pim
     c-bsr LoopBack0
     c-rp LoopBack0
    #
    msdp
     peer 192.168.1.2 connect-interface Vlanif101
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 102 to 103 200
    #
    multicast routing-enable
    #
    interface Vlanif102
     ip address 10.110.2.2 255.255.255.0
     pim bsr-boundary 
     pim sm
    #
    interface Vlanif103
     ip address 192.168.2.1 255.255.255.0
     pim bsr-boundary 
     pim sm
    #
    interface Vlanif200
     ip address 10.110.3.1 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port default vlan 200
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 102
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 103
    #
    ospf 1
     area 0.0.0.0
      network 10.110.2.0 0.0.0.255
      network 10.110.3.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 101 103 to 104 300
    #
    multicast routing-enable
    #
    acl number 3001
     rule 5 deny ip source 10.110.3.100 0 destination 225.1.1.0 0.0.0.3 
     rule 10 permit ip 
    #
    interface Vlanif101
     ip address 192.168.1.2 255.255.255.0
     pim bsr-boundary 
     pim sm
    #
    interface Vlanif103
     ip address 192.168.2.2 255.255.255.0
     pim bsr-boundary 
     pim sm
    #
    interface Vlanif104
     ip address 10.110.5.1 255.255.255.0
     pim bsr-boundary 
     pim sm
    #
    interface Vlanif300
     ip address 10.110.4.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface 10GE1/0/1
     port default vlan 300
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 104
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 101
    #
    interface 10GE1/0/4
     port link-type trunk
     port trunk allow-pass vlan 103
    #
    interface LoopBack0
     ip address 10.2.2.2 255.255.255.255
     pim sm
    #
    ospf 1
     area 0.0.0.0
      network 10.2.2.2 0.0.0.0
      network 10.110.4.0 0.0.0.255
      network 10.110.5.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    pim
     c-bsr LoopBack0
     c-rp LoopBack0
    #
    msdp
     peer 192.168.1.1 connect-interface Vlanif101
     peer 10.110.5.2 connect-interface Vlanif104
     peer 10.110.5.2 sa-policy export 3001
    #
    return
  • SwitchD的配置文件

    #
    sysname SwitchD
    #
    vlan batch 104 400 500
    #
    multicast routing-enable
    #
    acl number 2001
     rule 5 deny source 10.110.6.100 0 
    #
    interface Vlanif104
     ip address 10.110.5.2 255.255.255.0
     pim bsr-boundary 
     pim sm
    #
    interface Vlanif400
     ip address 10.110.6.1 255.255.255.0
     pim sm
    #
    interface Vlanif500
     ip address 10.110.7.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface 10GE1/0/1
     port default vlan 500
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 104
    #
    interface 10GE1/0/3
     port default vlan 400
    #
    interface LoopBack0
     ip address 10.3.3.3 255.255.255.255
     pim sm
    #
    ospf 1
     area 0.0.0.0
      network 10.3.3.3 0.0.0.0
      network 10.110.5.0 0.0.0.255
      network 10.110.6.0 0.0.0.255
      network 10.110.7.0 0.0.0.255
    #
    pim
     c-bsr LoopBack0
     c-rp LoopBack0
    #
    msdp
     import-source acl 2001
     peer 10.110.5.1 connect-interface Vlanif104
    #
    return
翻译
下载文档
更新时间:2019-03-20

文档编号:EDOC1000166616

浏览量:65750

下载量:244

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页