所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 8800, 7800, 6800, 5800 V200R002C50 配置指南-IP组播

本文档介绍了IP组播的配置,具体包括IP组播基础、IGMP配置、MLD配置、PIM(IPv4)配置、PIM(IPv6)配置、MSDP配置、组播VPN配置、组播路由管理(IPv4)配置、组播路由管理(IPv6)配置、IGMP Snooping配置、MLD Snooping配置、静态组播MAC地址配置、组播VLAN配置和组播网管配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置组播静态路由衔接RPF路由示例

配置组播静态路由衔接RPF路由示例

组网需求

图7-11所示,SwitchB和SwitchC之间运行OSPF协议,与SwitchA单播路由隔离,并且每台交换机的接口上都使能了PIM-SM,Receiver能够正常接收组播源Source1的信息。要求使Receiver也能够接收组播源Source2的信息。

图7-11 配置组播静态路由衔接RPF路由组网图

配置思路

通过配置组播静态路由,沿SwitchC→SwitchB→SwitchA这条路径建立能够到达组播源Source2的RPF路由。具体配置思路如下:

  1. 配置各交换机接口的IP地址,在SwitchB、SwitchC上配置OSPF路由协议,与SwitchA单播路由隔离。

  2. 使能组播路由功能,在所有交换机的各三层接口上使能PIM-SM并配置C-BSR和C-RP,在与主机相连的三层接口上使能IGMP。配置了组播协议的基本功能之后,通过设备提供的缺省值,就可以正常建立组播分发树,组播数据沿组播分发树传给Receiver。

  3. 在SwitchB、SwitchC上配置到达组播源Source2的组播静态路由。

操作步骤

  1. 配置各交换机接口IP地址和路由协议。

    # 在各交换机上创建VLAN,并将二层物理接口加入VLAN。其他交换机的配置过程与SwitchB上的配置相似,配置过程略。

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchB
    [*HUAWEI] commit
    [~SwitchB] vlan batch 13 20 40
    [*SwitchB] interface 10ge 1/0/1
    [*SwitchB-10GE1/0/1] port link-type trunk
    [*SwitchB-10GE1/0/1] port trunk allow-pass vlan 20
    [*SwitchB-10GE1/0/1] quit
    [*SwitchB] interface 10ge 1/0/2
    [*SwitchB-10GE1/0/2] port default vlan 13
    [*SwitchB-10GE1/0/2] quit
    [*SwitchB] interface 10ge 1/0/3
    [*SwitchB-10GE1/0/3] port link-type trunk
    [*SwitchB-10GE1/0/3] port trunk allow-pass vlan 40
    [*SwitchB-10GE1/0/3] quit
    [*SwitchB] commit
    

    # 在各交换机的三层VLANIF接口配置IP地址和掩码。其他交换机的配置过程与SwitchB上的配置相似,配置过程略。

    [~SwitchB] interface vlanif 13
    [*SwitchB-Vlanif13] ip address 10.1.3.1 24
    [*SwitchB-Vlanif13] quit
    [*SwitchB] interface vlanif 20
    [*SwitchB-Vlanif20] ip address 10.1.2.2 24
    [*SwitchB-Vlanif20] quit
    [*SwitchB] interface vlanif 40
    [*SwitchB-Vlanif40] ip address 10.1.4.1 24
    [*SwitchB-Vlanif40] quit
    [*SwitchB] commit
    

    # 在SwitchB、SwitchC上配置单播路由协议OSPF。SwitchC的配置过程与SwitchB上的配置相似,配置过程略。

    [~SwitchB] ospf
    [*SwitchB-ospf-1] area 0
    [*SwitchB-ospf-1-area-0.0.0.0] network 10.1.2.0 0.0.0.255
    [*SwitchB-ospf-1-area-0.0.0.0] network 10.1.3.0 0.0.0.255
    [*SwitchB-ospf-1-area-0.0.0.0] quit
    [*SwitchB-ospf-1] quit
    [*SwitchB] commit

  2. 使能组播功能,在各接口上使能PIM-SM,在与主机相连的接口上使能IGMP。

    # 在SwitchA上使能组播功能,并在各接口上使能PIM-SM。SwitchB的配置与SwitchA类似,配置过程略。

    [~SwitchA] multicast routing-enable
    [*SwitchA] interface vlanif 11
    [*SwitchA-Vlanif11] pim sm
    [*SwitchA-Vlanif11] quit
    [*SwitchA] interface vlanif 40
    [*SwitchA-Vlanif40] pim sm
    [*SwitchA-Vlanif40] quit
    [*SwitchA] commit
    

    # 在SwitchC上使能组播功能,并在各接口上使能PIM-SM,在与主机相连的接口上使能IGMP。

    [~SwitchC] multicast routing-enable
    [*SwitchC] interface vlanif 20
    [*SwitchC-Vlanif20] pim sm
    [*SwitchC-Vlanif20] quit
    [*SwitchC] interface vlanif 12
    [*SwitchC-Vlanif12] pim sm
    [*SwitchC-Vlanif12] igmp enable
    [*SwitchC-Vlanif12] quit
    [*SwitchC] commit
    

    # 配置SwitchB的VLANIF20为C-BSR和C-RP。

    [~SwitchB] pim
    [*SwitchB-pim] c-bsr vlanif 20
    [*SwitchB-pim] c-rp vlanif 20
    [*SwitchB-pim] commit
    [~SwitchB-pim] quit
    

    # Source1(10.1.3.2/24)和Source2(10.1.5.2/24)都向组播组G(225.1.1.1)发送组播数据。Receiver加入组G,能够收到Source1发出的组播数据,收不到Source2发出的组播数据。

    # 分别在SwitchB和SwitchC上执行display multicast rpf-info 10.1.5.2命令,没有显示信息。说明交换机没有到Source2的RPF路由。

  3. 配置组播静态路由。

    # 在SwitchB上配置RPF组播静态路由,到Source2的RPF邻居为SwitchA。

    [~SwitchB] ip rpf-route-static 10.1.5.0 255.255.255.0 10.1.4.2
    [*SwitchB] commit

    # 在SwitchC上配置RPF组播静态路由,到Source2的RPF邻居为SwitchB。

    [~SwitchC] ip rpf-route-static 10.1.5.0 255.255.255.0 10.1.2.2
    [*SwitchC] commit

  4. 验证配置结果。

    # 分别在SwitchB和SwitchC上执行display multicast rpf-info 10.1.5.2命令,查看Source2的RPF信息。RPF信息显示如下。

    [~SwitchB] display multicast rpf-info 10.1.5.2
    VPN-Instance: public net
    RPF information about source: 10.1.5.2
         RPF interface: Vlanif40, RPF neighbor: 10.1.4.2
         Referenced route/mask: 10.1.5.0/24
         Referenced route type: mstatic
         Route selecting rule: preference-preferred
         Load splitting rule: disable 
    
    
    [~SwitchC] display multicast rpf-info 10.1.5.2
    VPN-Instance: public net
    RPF information about source 10.1.5.2:
         RPF interface: Vlanif20, RPF neighbor: 10.1.2.2
         Referenced route/mask: 10.1.5.0/24
         Referenced route type: mstatic
         Route selection rule: preference-preferred
         Load splitting rule: disable 

    # 在SwitchC上执行display pim routing-table命令,查看路由表信息。SwitchC上存在Source2的组播表项。Receiver正常接收来自Source2的组播数据。

    [~SwitchC] display pim routing-table
    VPN-Instance: public net
     Total 1 (*, G) entry; 2 (S, G) entries
    
     (*, 225.1.1.1)
         RP: 10.1.2.2
         Protocol: pim-sm, Flag: WC
         UpTime: 03:54:19
         Upstream interface: Vlanif20
             Upstream neighbor: 10.1.2.2
             RPF prime neighbor: 10.1.2.2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif12
                 Protocol: pim-sm, UpTime: 01:38:19, Expires: never
    
    (10.1.3.2, 225.1.1.1)     
         RP: 10.1.2.2
         Protocol: pim-sm, Flag: ACT
         UpTime: 00:00:44
         Upstream interface: Vlanif20
             Upstream neighbor: 10.1.2.2
             RPF prime neighbor: 10.1.2.2
         Downstream interface(s) information:
         Total number of downstreams: 1
              1: Vlanif12
                  Protocol: pim-sm, UpTime: 00:00:44, Expires: never
    
    (10.1.5.2, 225.1.1.1)     
         RP: 10.1.2.2
         Protocol: pim-sm, Flag: ACT
         UpTime: 00:00:44
         Upstream interface: Vlanif20
             Upstream neighbor: 10.1.2.2
             RPF prime neighbor: 10.1.2.2
         Downstream interface(s) information:
         Total number of downstreams: 1
              1: Vlanif12
                  Protocol: pim-sm, UpTime: 00:00:44, Expires: never
    

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    multicast routing-enable
    #
    vlan batch 11 40
    #
    interface Vlanif11
     ip address 10.1.5.1 255.255.255.0
     pim sm
    #
    interface Vlanif40
     ip address 10.1.4.2 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port default vlan 11
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    return 
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 13 20 40
    #
    multicast routing-enable
    #
    interface Vlanif13
     ip address 10.1.3.1 255.255.255.0
     pim sm
    #
    interface Vlanif20
     ip address 10.1.2.2 255.255.255.0
     pim sm
    #
    interface Vlanif40
     ip address 10.1.4.1 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface 10GE1/0/2
     port default vlan 13
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    ospf 1
     area 0.0.0.0
      network 10.1.2.0 0.0.0.255
      network 10.1.3.0 0.0.0.255
    #
    ip rpf-route-static 10.1.5.0 24 10.1.4.2
    #
    pim
     c-bsr Vlanif20
     c-rp Vlanif20
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 12 20
    #
    multicast routing-enable
    #
    interface Vlanif12
     ip address 10.1.1.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif20
     ip address 10.1.2.1 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface 10GE1/0/2
     port default vlan 12
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.1.2.0 0.0.0.255
    #
    ip rpf-route-static 10.1.5.0 24 10.1.2.2
    #
    return 
翻译
下载文档
更新时间:2019-03-20

文档编号:EDOC1000166616

浏览量:63541

下载量:241

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页