所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 8800, 7800, 6800, 5800 V200R002C50 配置指南-IP组播

本文档介绍了IP组播的配置,具体包括IP组播基础、IGMP配置、MLD配置、PIM(IPv4)配置、PIM(IPv6)配置、MSDP配置、组播VPN配置、组播路由管理(IPv4)配置、组播路由管理(IPv6)配置、IGMP Snooping配置、MLD Snooping配置、静态组播MAC地址配置、组播VLAN配置和组播网管配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置IGMP SSM Mapping示例

配置IGMP SSM Mapping示例

组网需求

图2-18所示,该PIM网络运行PIM-SM协议,并使用SSM模式为组成员提供组播服务。与成员主机Receiver网段相连的SwitchD的接口VLANIF13上运行IGMPv3;Receiver运行IGMPv2,并且不能升级到IGMPv3,因此该主机在加入组播组时无法指定组播源。当前网络中的SSM组地址范围是232.1.1.0/24,Source1、Source2和Source3都向该范围内的组播组发送组播数据。

Receiver要求通过一定的配置能够获得SSM服务,只接收来自Source1和Source3的组播数据,阻止来自Source2的组播数据。

图2-18 配置IGMP SSM Mapping功能组网图

配置思路

通过在SwitchD上配置IGMP SSM Mapping功能,可以实现此需求。

  1. 为了保证组播路由协议正常工作,需要配置网络中的单播路由协议,实现网络层互通。单播路由正常是组播路由协议正常工作的基础。

  2. 为了实现用户通过组播方式接收视频信息,需要在各Switch上配置基本组播功能,实现组播数据在网络中的转发。

  3. 为了使Receiver可以接收指定组播源的数据,需要在SwitchD上使能IGMP SSM Mapping功能并配置Mapping规则。

操作步骤

  1. 配置各Switch接口IP地址和单播路由协议。

    # 按照图2-18配置各交换机接口的IP地址和掩码,并配置各交换机之间采用OSPF进行互连,确保网络中各交换机间能够在网络层互通,并且各Switch之间能够借助单播路由协议实现动态路由更新。SwitchB、SwitchC和SwitchD上的配置过程与SwitchA上的配置相似,配置过程略,详见配置文件。

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 10 20 30
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type access
    [*SwitchA-10GE1/0/1] port default vlan 10
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] interface 10ge 1/0/2
    [*SwitchA-10GE1/0/2] port link-type trunk
    [*SwitchA-10GE1/0/2] port trunk allow-pass vlan 20
    [*SwitchA-10GE1/0/2] quit
    [*SwitchA] interface 10ge 1/0/3
    [*SwitchA-10GE1/0/3] port link-type trunk
    [*SwitchA-10GE1/0/3] port trunk allow-pass vlan 30
    [*SwitchA-10GE1/0/3] quit
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] ip address 10.10.1.2 24
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 20
    [*SwitchA-Vlanif20] ip address 192.168.1.1 24
    [*SwitchA-Vlanif20] quit
    [*SwitchA] interface vlanif 30
    [*SwitchA-Vlanif30] ip address 192.168.4.2 24
    [*SwitchA-Vlanif30] quit
    [*SwitchA] ospf
    [*SwitchA-ospf-1] area 0
    [*SwitchA-ospf-1-area-0.0.0.0] network 10.10.1.0 0.0.0.255
    [*SwitchA-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [*SwitchA-ospf-1-area-0.0.0.0] network 192.168.4.0 0.0.0.255
    [*SwitchA-ospf-1-area-0.0.0.0] commit
    [~SwitchA-ospf-1-area-0.0.0.0] quit
    [~SwitchA-ospf-1] quit

  2. 使能IP组播路由,并配置PIM-SM功能。

    # 在SwitchA上使能IP组播路由,并在所有接口上使能PIM-SM功能。SwitchB、SwitchC和SwitchD上的配置过程与此类似,配置过程略,详见配置文件。

    [~SwitchA] multicast routing-enable
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] pim sm
    [*SwitchA-Vlanif10] commit
    [~SwitchA-Vlanif10] quit
    [~SwitchA] interface vlanif 20
    [~SwitchA-Vlanif20] pim sm
    [*SwitchA-Vlanif20] commit
    [~SwitchA-Vlanif20] quit
    [~SwitchA] interface vlanif 30
    [~SwitchA-Vlanif30] pim sm
    [*SwitchA-Vlanif30] commit
    [~SwitchA-Vlanif30] quit
    

  3. SwitchD的成员端接口上使能IGMP,配置版本为IGMPv3。

    # 在SwitchD的成员端接口VLANIF13上使能IGMP,并配置版本为IGMPv3。

    [~SwitchD] interface vlanif 13
    [~SwitchD-Vlanif13] igmp enable
    [*SwitchD-Vlanif13] igmp version 3
    [*SwitchD-Vlanif13] commit
    [~SwitchD-Vlanif13] quit
    

  4. 使能主机侧接口的IGMP SSM Mapping功能。

    # 在SwitchD的VLANIF13上使能IGMP SSM Mapping功能。

    [~SwitchD] interface vlanif 13
    [~SwitchD-Vlanif13] igmp ssm-mapping enable
    [*SwitchD-Vlanif13] commit
    [~SwitchD-Vlanif13] quit
    

  5. 在所有Switch上配置SSM组播组地址范围。

    # 在SwitchA上配置SSM组播组地址范围为232.1.1.0/24。SwitchB、SwitchC和SwitchD上的配置过程与SwitchA上的配置类似,配置过程略,详见配置文件。

    [~SwitchA] acl number 2000
    [*SwitchA-acl4-basic-2000] rule permit source 232.1.1.0 0.0.0.255
    [*SwitchA-acl4-basic-2000] commit
    [~SwitchA-acl4-basic-2000] quit
    [~SwitchA] pim
    [*SwitchA-pim] ssm-policy 2000
    [*SwitchA-pim] commit
    [~SwitchA-pim] quit

  6. 在连接主机的Switch上配置IGMP SSM Mapping映射规则。

    # 在SwitchD上,将232.1.1.0/24范围内的组播组映射到Source1和Source3。

    [~SwitchD] igmp
    [*SwitchD-igmp] ssm-mapping 232.1.1.0 24 10.10.1.1
    [*SwitchD-igmp] ssm-mapping 232.1.1.0 24 10.10.3.1
    [*SwitchD-igmp] commit
    [~SwitchD-igmp] quit
    

  7. 验证配置结果。

    # 通过display igmp ssm-mapping group命令可以查看SwitchD上组播源和组播组的映射关系。

    [~SwitchD] display igmp ssm-mapping group
    IGMP SSM-Mapping conversion table of VPN instance: public net
     Total entries: 2    (2 entries matched)
    
     00001. (10.10.1.1, 232.1.1.0)
     00002. (10.10.3.1, 232.1.1.0)
    
     Total 2 entries matched
    
    

    可以看出,232.1.1.0/24范围内的组播组已经映射到Source1和Source3。

    # 通过display igmp group ssm-mapping命令可以查看SwitchD根据SSM Mapping规则创建的组播组信息。显示如下:

    [~SwitchD] display igmp group ssm-mapping
    IGMP SSM mapping interface group report information of VPN instance: public net
     Limited entry of this VPN instance: - 
     Vlanif13 (10.10.4.2):
      Total 1 IGMP SSM-Mapping Group reported
       Group Address   Last Reporter   Uptime      Expires
       232.1.1.1     10.10.4.1       00:01:44    00:00:26
    
    

    可以看出,Receiver已经加入组232.1.1.1。

    # 通过使用display pim routing-table命令,可以查看PIM-SM组播路由表。SwitchD上PIM-SM组播路由表信息显示如下:

    [~SwitchD] display pim routing-table
    VPN-Instance: public net
     Total 2 (S, G) entries
    
     (10.10.1.1, 232.1.1.1)
         Protocol: pim-ssm, Flag: SG_RCVR                                           
         UpTime: 00:19:40                                                           
         Upstream interface: Vlanif30                                               
             Upstream neighbor: 192.168.4.2                                         
             RPF prime neighbor: 192.168.4.2                                        
         Downstream interface(s) information:                                       
         Total number of downstreams: 1                                             
             1: Vlanif13                                                            
                 Protocol: ssm-map, UpTime: 00:19:40, Expires: -                    
    
     (10.10.3.1, 232.1.1.1)
         Protocol: pim-ssm, Flag: SG_RCVR                                           
         UpTime: 00:19:40                                                           
         Upstream interface: Vlanif21                                               
             Upstream neighbor: 192.168.3.1                                         
             RPF prime neighbor: 192.168.3.1                                        
         Downstream interface(s) information:                                       
         Total number of downstreams: 1                                             
             1: Vlanif13                                                            
                 Protocol: ssm-map, UpTime: 00:19:40, Expires: -                    
    

    可以看出,组播源10.10.1.1和10.10.3.1向组播组232.1.1.1发送组播数据,SwitchD分别从接口VLANIF30和VLANIF21接收以上两个组播源的数据。

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 10 20 30
    #
    multicast routing-enable
    #
    acl number 2000
     rule 5 permit source 232.1.1.0 0.0.0.255
    #
    interface Vlanif10
     ip address 10.10.1.2 255.255.255.0
     pim sm
    #
    interface Vlanif20
     ip address 192.168.1.1 255.255.255.0
     pim sm
    #
    interface Vlanif30
     ip address 192.168.4.2 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port default vlan 10
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    ospf 1
     area 0.0.0.0
      network 10.10.1.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
    #
    pim
     ssm-policy 2000
    #
    return
    
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 11 20 31
    #
    multicast routing-enable
    #
    acl number 2000
     rule 5 permit source 232.1.1.0 0.0.0.255
    #
    interface Vlanif11
     ip address 10.10.2.2 255.255.255.0
     pim sm
    #
    interface Vlanif20
     ip address 192.168.1.2 255.255.255.0
     pim sm
    #
    interface Vlanif31
     ip address 192.168.2.1 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port default vlan 11
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 31
    #
    ospf 1
     area 0.0.0.0
      network 10.10.2.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    pim
     ssm-policy 2000
    #
    return
    
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 12 21 31
    #
    multicast routing-enable
    #
    acl number 2000
     rule 5 permit source 232.1.1.0 0.0.0.255
    #
    interface Vlanif12
     ip address 10.10.3.2 255.255.255.0
     pim sm
    #
    interface Vlanif21
     ip address 192.168.3.1 255.255.255.0
     pim sm
    #
    interface Vlanif31
     ip address 192.168.2.2 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port default vlan 12
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 21
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 31
    #
    ospf 1
     area 0.0.0.0
      network 10.10.3.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
    #
    pim
     ssm-policy 2000
    #
    return
    
  • SwitchD的配置文件

    #
    sysname SwitchD
    #
    vlan batch 13 21 30
    #
    multicast routing-enable
    #
    acl number 2000
     rule 5 permit source 232.1.1.0 0.0.0.255
    #
    interface Vlanif13
     ip address 10.10.4.2 255.255.255.0
     pim sm
     igmp enable
     igmp version 3
     igmp ssm-mapping enable
    #
    interface Vlanif21
     ip address 192.168.3.2 255.255.255.0
     pim sm
    #
    interface Vlanif30
     ip address 192.168.4.1 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port default vlan 13
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 21
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    ospf 1
     area 0.0.0.0
      network 10.10.4.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
    #
    igmp
     ssm-mapping 232.1.1.0 255.255.255.0 10.10.1.1
     ssm-mapping 232.1.1.0 255.255.255.0 10.10.3.1
    #
    pim
     ssm-policy 2000
    #
    return
    
翻译
下载文档
更新时间:2019-03-20

文档编号:EDOC1000166616

浏览量:65830

下载量:244

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页