所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 8800, 7800, 6800, 5800 V200R002C50 配置指南-IP组播

本文档介绍了IP组播的配置,具体包括IP组播基础、IGMP配置、MLD配置、PIM(IPv4)配置、PIM(IPv6)配置、MSDP配置、组播VPN配置、组播路由管理(IPv4)配置、组播路由管理(IPv6)配置、IGMP Snooping配置、MLD Snooping配置、静态组播MAC地址配置、组播VLAN配置和组播网管配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置双向PIM(IPv6)与PIM-SM(IPv6)共存示例

配置双向PIM(IPv6)与PIM-SM(IPv6)共存示例

组网需求

在如图5-5所示的网络中,HostA希望通过双向PIM(IPv6)协议接收组播组FF1E::1的信息,HostB希望通过PIM-SM(IPv6)协议接收组播组FF2E::1的信息。

图5-5 配置双向PIM(IPv6)与PIM-SM(IPv6)共存组网图

表5-32 组网图信息表

设备

VLANIF接口/Loopback接口

IPv6地址

SwitchA

VLANIF30 FC00:0:0:2001:3::1/64
VLANIF100 FC00:0:0:2002:1::1/64
VLANIF200 FC00:0:0:2002:2::1/64
Loopback0 FC00:0:0:1::1/128

SwitchB

VLANIF10 FC00:0:0:2001:1::1/64
VLANIF100 FC00:0:0:2002:1::2/64

SwitchC

VLANIF20 FC00:0:0:2001:2::1/64
VLANIF200 FC00:0:0:2002:2::2/64

配置思路

SwitchA上分别配置为双向PIM(IPv6)和PIM-SM(IPv6)服务的动态RP,并通过ACL规则指定动态RP服务的组播组范围,可以实现双向PIM(IPv6)与PIM-SM(IPv6)在同一网络中共存。具体配置思路如下:

  1. 配置各交换机的接口IPv6地址和单播路由协议。

  2. 在所有提供组播服务的交换机上使能IPv6组播路由。

  3. 在所有提供组播服务的交换机上使能双向PIM(IPv6)功能。

  4. 在组播交换机的所有接口上使能PIM-SM(IPv6)。

  5. 在与主机直连的交换机接口上使能MLD。

  6. 配置动态RP。在SwitchA上分别配置为双向PIM服务(IPv6)和为PIM-SM(IPv6)服务的动态RP,并配置ACL过滤规则,分别匹配双向PIM(IPv6)和PIM-SM(IPv6)的RP服务的组播组范围。

操作步骤

  1. 配置各交换机的接口IPv6地址和单播路由协议。

    # 按照图5-5配置各交换机接口的IPv6地址和掩码,配置各交换机间采用OSPFv3进行互连,确保网络中各交换机间能够在网络层互通,并且之间能够借助单播路由协议实现动态路由更新。SwitchB和SwitchC的配置与SwitchA相似,配置过程略。

    # 配置SwitchA的接口加入VLAN。

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 30 100 200
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port default vlan 30
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] interface 10ge 1/0/2
    [*SwitchA-10GE1/0/2] port link-type trunk
    [*SwitchA-10GE1/0/2] port trunk allow-pass vlan 100
    [*SwitchA-10GE1/0/2] quit
    [*SwitchA] interface 10ge 1/0/3
    [*SwitchA-10GE1/0/3] port link-type trunk
    [*SwitchA-10GE1/0/3] port trunk allow-pass vlan 200
    [*SwitchA-10GE1/0/3] quit
    [*SwitchA] commit
    

    # 配置SwitchA上接口的IPv6地址。

    [~SwitchA] interface vlanif 30
    [*SwitchA-Vlanif30] ipv6 enable
    [*SwitchA-Vlanif30] ipv6 address fc00:0:0:2001:3::1 64
    [*SwitchA-Vlanif30] quit
    [*SwitchA] interface vlanif 100
    [*SwitchA-Vlanif100] ipv6 enable
    [*SwitchA-Vlanif100] ipv6 address fc00:0:0:2002:1::1 64
    [*SwitchA-Vlanif100] quit
    [*SwitchA] interface vlanif 200
    [*SwitchA-Vlanif200] ipv6 enable
    [*SwitchA-Vlanif200] ipv6 address fc00:0:0:2002:2::1 64
    [*SwitchA-Vlanif200] quit
    [*SwitchA] interface loopback0
    [*SwitchA-LoopBack0] ipv6 enable
    [*SwitchA-LoopBack0] ipv6 address fc00:0:0:1::1 128
    [*SwitchA-LoopBack0] quit
    [*SwitchA] commit

    # 配置SwitchA上的单播路由协议OSPFv3。

    [~SwitchA] ospfv3
    [*SwitchA-ospfv3-1] router-id 10.1.1.1
    [*SwitchA-ospfv3-1] quit
    [*SwitchA] interface vlanif 30
    [*SwitchA-Vlanif30] ospfv3 1 area 0
    [*SwitchA-Vlanif30] quit
    [*SwitchA] interface vlanif 100
    [*SwitchA-Vlanif100] ospfv3 1 area 0
    [*SwitchA-Vlanif100] quit
    [*SwitchA] interface vlanif 200
    [*SwitchA-Vlanif200] ospfv3 1 area 0
    [*SwitchA-Vlanif200] quit
    [*SwitchA] commit
    

  2. 在各交换机上使能IPv6组播功能和双向PIM(IPv6)功能。

    # 使能SwitchA的IPv6组播功能和双向PIM(IPv6)功能。SwitchB和SwitchC的配置与SwitchA相似,配置过程略。

    [~SwitchA] multicast ipv6 routing-enable
    [*SwitchA] pim ipv6
    [*SwitchA-pim6] bidir-pim
    [*SwitchA-pim6] commit
    [~SwitchA-pim6] quit
    

  3. 在各交换机接口上使能PIM-SM(IPv6)功能。

    # 使能SwitchA的各接口PIM-SM(IPv6)功能。SwitchB和SwitchC的配置与SwitchA相似,配置过程略。

    [~SwitchA] interface vlanif 30
    [~SwitchA-Vlanif30] pim ipv6 sm
    [*SwitchA-Vlanif30] quit
    [*SwitchA] interface vlanif 100
    [*SwitchA-Vlanif100] pim ipv6 sm
    [*SwitchA-Vlanif100] quit
    [*SwitchA] interface vlanif 200
    [*SwitchA-Vlanif200] pim ipv6 sm
    [*SwitchA-Vlanif200] quit
    [*SwitchA] interface loopback0
    [*SwitchA-LoopBack0] pim ipv6 sm
    [*SwitchA-LoopBack0] quit
    [*SwitchA] commit

  4. 在连接用户主机的接口上使能MLD。

    # 配置SwitchB。

    [~SwitchB] interface vlanif 10
    [~SwitchB-Vlanif10] mld enable
    [*SwitchB-Vlanif10] commit
    [~SwitchB-Vlanif10] quit
    

    # 配置SwitchC。

    [~SwitchC] interface vlanif 20
    [~SwitchC-Vlanif20] mld enable
    [*SwitchC-Vlanif20] commit
    [~SwitchC-Vlanif20] quit
    

  5. 配置动态RP。

    # 在SwitchA上配置不同的C-RP接口为不同的PIM(IPv6)协议服务。

    [~SwitchA] acl ipv6 number 2000
    [*SwitchA-acl6-basic-2000] rule permit source ff1e:: 64
    [*SwitchA-acl6-basic-2000] quit
    [*SwitchA] acl ipv6 number 2001
    [*SwitchA-acl6-basic-2001] rule permit source ff2e:: 64
    [*SwitchA-acl6-basic-2001] quit
    [*SwitchA] pim ipv6
    [*SwitchA-pim6] c-bsr fc00:0:0:2001:3::1
    [*SwitchA-pim6] c-rp fc00:0:0:1::1 group-policy 2000 bidir
    [*SwitchA-pim6] c-rp fc00:0:0:2001:3::1 group-policy 2001
    [*SwitchA-pim6] commit
    [~SwitchA-pim6] quit
    

  6. 验证配置结果。

    # 使用display pim ipv6 routing-table命令可以查看交换机上的PIM(IPv6)路由表。组播源(FC00:0:0:2001:3::2/64)向组播组(FF1E::1/64)、(FF2E::1/64)发送信息,HostA加入了组播组(FF1E::1/64),HostB加入了组播组(FF2E::1/64)。例如SwitchA和SwitchB上的PIM路由表信息如下:

    [~SwitchA] display pim ipv6 routing-table
     VPN-Instance: public net
     Total 2 (*, G) entries; 1 (S, G) entry
    
     (*, FF2E::1)
         RP: FC00:0:0:2001:3::1 (local)
         Protocol: pim-sm, Flag: WC
         UpTime: 00:29:14
         Upstream interface: Register
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
            1: Vlanif200
                 Protocol: pim-sm, UpTime: 00:27:04, Expires: 00:03:27
    
    
     (FC00:0:0:2001:3::2, FF2E::1)
         RP: FC00:0:0:2001:3::1 (local)
         Protocol: pim-sm, Flag: SPT LOC ACT
         UpTime: 00:00:31
         Upstream interface: Vlanif30
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
            1: Vlanif200
                 Protocol: pim-sm, UpTime: 00:00:38, Expires: 00:02:53
    
     (*, FF1E::1)
         RP: FC00:0:0:1::1 (local)
         Protocol: bidir-pim, Flag: WC ACT
         UpTime: 00:29:22
         Rpf interface: LoopBack0
             Upstream neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 2
            1: Vlanif100
                 Protocol: bidir-pim, UpTime: 00:29:42, Expires: 00:02:48
            2: LoopBack0(RPF)
                 Protocol: bidir-pim, UpTime: 00:29:42, Expires: -
    [~SwitchB] display pim ipv6 routing-table
    VPN-Instance: public net
     Total 1 (*, G) entry; 0 (S, G) entry
    
     (*, FF1E::1)
         RP: FC00:0:0:1::1
         Protocol: bidir-pim, Flag: WC ACT
         UpTime: 00:17:14
         Rpf interface: Vlanif100
             Upstream neighbor: FE80::3ABA:34FF:FEF6:7605
         Downstream interface(s) information:
         Total number of downstreams: 2
            1: Vlanif10
                 Protocol: mld, UpTime: 00:17:13, Expires: -
            2: Vlanif100(RPF)
                 Protocol: bidir-pim, UpTime: 00:17:14, Expires: - 

    由显示信息可以看出,HostA通过双向PIM协议接收到了组播组FF1E::1的信息、HostB通过PIM-SM协议接收到了组播组FF2E::1的信息。

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 30 100 200
    #
    multicast ipv6 routing-enable
    #
    acl ipv6 number 2000
     rule 5 permit source FF1E::/64
    #
    acl ipv6 number 2001
     rule 5 permit source FF2E::/64
    #
    ospfv3 1
     router-id 10.1.1.1
     area 0.0.0.0
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address FC00:0:0:2001:3::1/64
     pim ipv6 sm
     ospfv3 1 area 0.0.0.0
    #
    interface Vlanif100
     ipv6 enable
     ipv6 address FC00:0:0:2002:1::1/64
     pim ipv6 sm
     ospfv3 1 area 0.0.0.0
    #
    interface Vlanif200
     ipv6 enable
     ipv6 address FC00:0:0:2002:2::1/64
     pim ipv6 sm
     ospfv3 1 area 0.0.0.0
    #
    interface 10GE1/0/1
     port default vlan 30
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface LoopBack0
     ipv6 enable
     ipv6 address FC00:0:0:1::1/128
     pim ipv6 sm
     ospfv3 1 area 0.0.0.0
    #
    pim ipv6
     c-bsr FC00:0:0:2001:3::1
     bidir-pim
     c-rp FC00:0:0:1::1 group-policy 2000 bidir
     c-rp FC00:0:0:2001:3::1 group-policy 2001
    #
    return
    
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 10 100
    #
    multicast ipv6 routing-enable
    #
    ospfv3 1
     router-id 10.2.2.2
     area 0.0.0.0
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address FC00:0:0:2001:1::1/64
     pim ipv6 sm
     mld enable
     ospfv3 1 area 0.0.0.0
    #
    interface Vlanif100
     ipv6 enable
     ipv6 address FC00:0:0:2002:1::2/64
     pim ipv6 sm
     ospfv3 1 area 0.0.0.0
    #
    interface 10GE1/0/1
     port default vlan 10
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    pim ipv6
     bidir-pim
    #
    return
    
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 20 200
    #
    multicast ipv6 routing-enable
    #
    ospfv3 1
     router-id 10.3.3.3
     area 0.0.0.0
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address FC00:0:0:2001:2::1/64
     pim ipv6 sm
     mld enable
     ospfv3 1 area 0.0.0.0
    #
    interface Vlanif200
     ipv6 enable
     ipv6 address FC00:0:0:2002:2::2/64
     pim ipv6 sm
     ospfv3 1 area 0.0.0.0
    #
    interface 10GE1/0/1
     port default vlan 20
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    pim ipv6
     bidir-pim
    #
    return
    
翻译
下载文档
更新时间:2019-03-20

文档编号:EDOC1000166616

浏览量:62941

下载量:241

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页