所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 8800, 7800, 6800, 5800 V200R002C50 配置指南-IP组播

本文档介绍了IP组播的配置,具体包括IP组播基础、IGMP配置、MLD配置、PIM(IPv4)配置、PIM(IPv6)配置、MSDP配置、组播VPN配置、组播路由管理(IPv4)配置、组播路由管理(IPv6)配置、IGMP Snooping配置、MLD Snooping配置、静态组播MAC地址配置、组播VLAN配置和组播网管配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置PIM-DM基本网络示例

配置PIM-DM基本网络示例

组网需求

图4-25所示,该网络是一个用户比较密集的小型网络,用户主机HostA、HostB希望能够接收到Source发送的组播数据。

图4-25 配置PIM-DM基本功能的组网图

配置思路

由于网络中用户密集,可以使用PIM-DM协议为网络中的用户主机提供组播服务,使得加入同一组播组的所有用户主机能够接收组播源发往该组的组播数据。

  1. 配置交换机接口IP地址和单播路由协议。组播域内路由协议PIM依赖单播路由协议,单播路由正常是组播协议正常工作的基础。

  2. 在所有提供组播服务的交换机上使能组播路由功能。使能组播路由功能是配置PIM-DM的前提。

  3. 在交换机所有接口上使能PIM-DM功能。使能PIM-DM功能之后才能配置PIM-DM的其他功能。

  4. 在与主机侧相连的交换机接口上使能IGMP。IGMP用于维护组成员关系。叶子节点交换机通过IGMP协议来维护组成员关系列表。

操作步骤

  1. 配置各交换机接口的IP地址和单播路由协议。

    按照图4-25配置各交换机接口的IP地址和掩码,并配置各交换机之间采用OSPF进行互连,确保网络中各交换机间能够在网络层互通,并且保证它们之间能够借助单播路由协议实现动态路由更新。

    # 配置SwitchA的接口加入VLAN。SwitchB、SwitchC、SwitchD和SwitchE的配置与SwitchA相似,配置过程略。

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 10 20 30
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 10
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] interface 10ge 1/0/2
    [*SwitchA-10GE1/0/2] port default vlan 20
    [*SwitchA-10GE1/0/2] quit
    [*SwitchA] interface 10ge 1/0/3
    [*SwitchA-10GE1/0/3] port link-type trunk
    [*SwitchA-10GE1/0/3] port trunk allow-pass vlan 30
    [*SwitchA-10GE1/0/3] quit
    [*SwitchA] commit
    

    # 配置SwitchA上VLANIF接口的IP地址。SwitchB、SwitchC、SwitchD和SwitchE的配置与SwitchA相似,配置过程略。

    [~SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] ip address 192.168.5.1 24
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 20
    [*SwitchA-Vlanif20] ip address 10.110.1.1 24
    [*SwitchA-Vlanif20] quit
    [*SwitchA] interface vlanif 30
    [*SwitchA-Vlanif30] ip address 192.168.1.1 24
    [*SwitchA-Vlanif30] quit
    [*SwitchA] commit

    # 配置SwitchA上的路由协议。本例中采用OSPF协议。SwitchB、SwitchC、SwitchD和SwitchE的配置与SwitchA相似,配置过程略。

    [~SwitchA] ospf
    [*SwitchA-ospf-1] area 0
    [*SwitchA-ospf-1-area-0.0.0.0] network 10.110.1.0 0.0.0.255
    [*SwitchA-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [*SwitchA-ospf-1-area-0.0.0.0] network 192.168.5.0 0.0.0.255
    [*SwitchA-ospf-1-area-0.0.0.0] commit
    [~SwitchA-ospf-1-area-0.0.0.0] quit
    [~SwitchA-ospf-1] quit

  2. 使能组播路由功能,在各接口上使能PIM-DM功能。

    # 在所有交换机上使能组播路由功能,在各接口上使能PIM-DM功能。SwitchB、SwitchC、SwitchD和SwitchE的配置与SwitchA相似,配置过程略。

    [~SwitchA] multicast routing-enable
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] pim dm
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 20
    [*SwitchA-Vlanif20] pim dm
    [*SwitchA-Vlanif20] quit
    [*SwitchA] interface vlanif 30
    [*SwitchA-Vlanif30] pim dm
    [*SwitchA-Vlanif30] quit
    [*SwitchA] commit

  3. 在连接用户主机的接口上使能IGMP功能。

    # 在SwitchA连接用户主机的接口上使能IGMP功能。SwitchB和SwitchC的配置与SwitchA相似,配置过程略。

    [~SwitchA] interface vlanif 20
    [~SwitchA-Vlanif20] igmp enable
    [*SwitchA-Vlanif20] quit
    [*SwitchA] commit
    

  4. 验证配置结果。

    # 使用命令display pim interface命令查看接口上PIM的配置和运行情况。例如SwitchC上PIM的显示信息如下。State字段显示为up,表明接口上的PIM协议已经运行,PIM邻居已经成功建立。

    [~SwitchC] display pim interface
     VPN-Instance: public net
     Interface           State NbrCnt HelloInt     DR-Pri     DR-Address      
     Vlanif40            up         1       30          1     10.110.2.2 (local) 
     Vlanif50            up         1       30          1     192.168.3.2
    

    # 使用命令display pim routing-table查看PIM协议组播路由表。组播源(10.110.3.100/24)向组播组(225.1.1.1/24)发送信息,HostA、HostB都加入了组播组(225.1.1.1/24)。显示信息如下:

    [~SwitchA] display pim routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
    
     (*, 225.1.1.1)
         Protocol: pim-dm, Flag: WC
         UpTime: 00:00:29
         Upstream interface: NULL
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif20
                 Protocol: igmp, UpTime: 00:00:29, Expires: never
    
     (10.110.3.100, 225.1.1.1)
         Protocol: pim-dm, Flag: ACT
         UpTime: 00:00:29
         Upstream interface: Vlanif30
             Upstream neighbor: 192.168.1.2
             RPF prime neighbor: 192.168.1.2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif20
                 Protocol: pim-dm, UpTime: 00:00:29, Expires: -
    
    [~SwitchB] display pim routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
    
     (*, 225.1.1.1)
         Protocol: pim-dm, Flag: WC
         UpTime: 00:00:29
         Upstream interface: NULL
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif40
                 Protocol: igmp, UpTime: 00:00:29, Expires: never
    
     (10.110.3.100, 225.1.1.1)
         Protocol: pim-dm, Flag: ACT
         UpTime: 00:00:29
         Upstream interface: Vlanif80
             Upstream neighbor: 192.168.2.2
             RPF prime neighbor: 192.168.2.2
         Downstream interface(s) information:
         Total number of downstreams: None
    
    [~SwitchC] display pim routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
    
     (*, 225.1.1.1)
         Protocol: pim-dm, Flag: WC
         UpTime: 00:00:29
         Upstream interface: NULL
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif40
                 Protocol: igmp, UpTime: 00:00:29, Expires: never
    
     (10.110.3.100, 225.1.1.1)
         Protocol: pim-dm, Flag: ACT
         UpTime: 00:01:25
         Upstream interface: Vlanif50
             Upstream neighbor: 192.168.3.2
             RPF prime neighbor: 192.168.3.2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif40
                 Protocol: pim-dm, UpTime: 00:01:25, Expires: -
    
    [~SwitchD] display pim routing-table
     VPN-Instance: public net
     Total 0 (*, G) entry; 1 (S, G) entry
    
     (10.110.3.100, 225.1.1.1)
         Protocol: pim-dm, Flag: LOC ACT
         UpTime: 00:00:29
         Upstream interface: Vlanif70
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 2
             1: Vlanif30
                 Protocol: pim-dm, UpTime: 00:00:29, Expires: never
             2: Vlanif60
                 Protocol: pim-dm, UpTime: 00:00:26, Expires: never
    
    [~SwitchE] display pim routing-table
     VPN-Instance: public net
     Total 0 (*, G) entry; 1 (S, G) entry
    
     (10.110.3.100, 225.1.1.1)
         Protocol: pim-dm, Flag: ACT
         UpTime: 00:01:22
         Upstream interface: Vlanif60
             Upstream neighbor: 192.168.4.1
             RPF prime neighbor: 192.168.4.1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif50
                 Protocol: pim-dm, UpTime: 00:01:22, Expires: never
    

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 10 20 30
    #
    multicast routing-enable
    #
    interface Vlanif10
     ip address 192.168.5.1 255.255.255.0
     pim dm
    #
    interface Vlanif20
     ip address 10.110.1.1 255.255.255.0
     pim dm 
     igmp enable
    #
    interface Vlanif30
     ip address 192.168.1.1 255.255.255.0
     pim dm
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/0/2
     port default vlan 20
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    ospf 1
     area 0.0.0.0
      network 10.110.1.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
      network 192.168.5.0 0.0.0.255
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 40 80
    #
    multicast routing-enable
    #
    interface Vlanif40
     ip address 10.110.2.1 255.255.255.0
     pim dm
     igmp enable
    #
    interface Vlanif80
     ip address 192.168.2.1 255.255.255.0
     pim dm 
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 80
    #
    interface 10GE1/0/2
     port default vlan 40
    #
    ospf 1
     area 0.0.0.0
      network 10.110.2.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 40 50
    #
    multicast routing-enable
    #
    interface Vlanif40
     ip address 10.110.2.2 255.255.255.0
     pim dm 
     igmp enable
    #
    interface Vlanif50
     ip address 192.168.3.1 255.255.255.0
     pim dm
    #
    interface 10GE1/0/1
     port default vlan 40
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    ospf 1
     area 0.0.0.0
      network 10.110.2.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
    #
    return
  • SwitchD的配置文件

    #
    sysname SwitchD
    #
    vlan batch 30 60 70
    #
    multicast routing-enable
    #
    interface Vlanif30
     ip address 192.168.1.2 255.255.255.0
     pim dm
    #
    interface Vlanif60
     ip address 192.168.4.1 255.255.255.0
     pim dm
    #
    interface Vlanif70
     ip address 10.110.3.1 255.255.255.0
     pim dm
    #
    interface 10GE1/0/1
     port default vlan 70
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface 10GE1/0/4
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    ospf 1
     area 0.0.0.0
      network 10.110.3.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
    #
    return
  • SwitchE的配置文件

    #
    sysname SwitchE
    #
    vlan batch 10 50 60 80
    #
    multicast routing-enable
    #
    interface Vlanif10
     ip address 192.168.5.2 255.255.255.0
     pim dm
    #
    interface Vlanif50
     ip address 192.168.3.2 255.255.255.0
     pim dm
    #
    interface Vlanif60
     ip address 192.168.4.2 255.255.255.0
     pim dm
    #
    interface Vlanif80
     ip address 192.168.2.2 255.255.255.0
     pim dm
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 80
    #
    interface 10GE1/0/4
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    ospf 1
     area 0.0.0.0
      network 192.168.2.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
      network 192.168.5.0 0.0.0.255
    #
    return
翻译
下载文档
更新时间:2019-03-20

文档编号:EDOC1000166616

浏览量:62973

下载量:241

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页