所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 8800, 7800, 6800, 5800 V200R002C50 配置指南-IP组播

本文档介绍了IP组播的配置,具体包括IP组播基础、IGMP配置、MLD配置、PIM(IPv4)配置、PIM(IPv6)配置、MSDP配置、组播VPN配置、组播路由管理(IPv4)配置、组播路由管理(IPv6)配置、IGMP Snooping配置、MLD Snooping配置、静态组播MAC地址配置、组播VLAN配置和组播网管配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置基于静态RPF对等体的AS间组播示例

配置基于静态RPF对等体的AS间组播示例

组网需求

图6-11所示,网络中存在两个自治系统。每个AS包含一个或多个PIM-SM域,每个PIM-SM域拥有0个或1个组播源和接收者。要求在不改变单播拓扑的基础上实现跨域源信息的传输。

图6-11 配置基于静态RPF对等体的AS间组播组网图

配置思路

在每个PIM-SM域的RP上设置一个MSDP对等体,在MSDP对等体之间建立静态RPF对等体,从而在不改变单播拓扑的基础上实现跨域源信息的传输。

  1. 配置各Switch接口IP地址,在自治系统内配置OSPF协议,自治系统间配置EBGP,将BGP与OSPF互相引入。

  2. 使能组播功能,并在各接口上使能PIM-SM功能,在主机侧接口上使能IGMP功能。配置Loopback0接口和C-BSR、C-RP位置。SwitchC、SwitchD和SwitchF上Loopback0接口分别作为各自PIM-SM域的C-BSR和C-RP。

  3. 在各域的RP之间建立MSDP对等体。SwitchC和SwitchD之间建立MSDP对等体,SwitchC和SwitchF之间建立MSDP对等体。

  4. 为MSDP对等体指定静态RPF对等体。SwitchC的静态RPF对等体为SwitchD和SwitchF,SwitchD和SwitchF分别只有SwitchC一个静态RPF对等体。根据RPF规则,接收静态RPF对等体发来的SA消息。

操作步骤

  1. 配置各Switch接口IP地址和单播路由协议。

    # 按照图6-11,配置各Switch接口的IP地址和掩码,在自治系统内配置OSPF协议,在SwitchA和SwitchF、SwitchB和SwitchE之间配置EBGP,将BGP与OSPF互相引入。确保各Switch之间能够在网络层互通,并且Switch之间能够借助单播路由协议实现动态路由更新。具体配置过程略。

  2. 使能组播路由功能,在各接口上使能PIM-SM功能,在连接主机侧接口上使能IGMP功能。并在AS边界Switch接口上配置BSR服务边界。

    # 在所有Switch使能组播路由功能,并在各接口上使能PIM-SM功能。其他Switch的配置过程与SwitchC上的配置相似,配置过程略。

    [~SwitchC] multicast routing-enable
    [*SwitchC] interface vlanif 100
    [*SwitchC-Vlanif100] pim sm
    [*SwitchC-Vlanif100] commit
    [~SwitchC-Vlanif100] quit
    [~SwitchC] interface vlanif 400
    [~SwitchC-Vlanif400] pim sm
    [*SwitchC-Vlanif400] commit
    [~SwitchC-Vlanif400] quit

    # 在SwitchE的VLANIF102接口使能IGMP功能。SwitchG上的配置与此类似,配置过程略。

    [~SwitchE] interface vlanif 102
    [~SwitchE-Vlanif102] igmp enable
    [*SwitchE-Vlanif102] commit
    [~SwitchE-Vlanif102] quit

    # 在SwitchA的VLANIF500接口、SwitchB的VLANIF200接口、SwitchE的VLANIF200接口和SwitchF的VLANIF500接口上配置BSR服务边界。SwitchB、SwitchE和SwitchF上的配置过程与SwitchA上的配置相似,配置过程略。

    [~SwitchA] interface vlanif 500
    [~SwitchA-Vlanif500] pim bsr-boundary
    [*SwitchA-Vlanif500] commit
    [~SwitchA-Vlanif500] quit

  3. 配置Loopback0接口和C-BSR、C-RP位置。

    # 在SwitchC、SwitchD和SwitchF上配置Loopback0接口,C-BSR和C-RP的位置。SwitchD和SwitchF上的配置过程与SwitchC上的配置相似,配置过程略。

    [~SwitchC] interface loopback 0
    [*SwitchC-LoopBack0] ip address 10.1.1.1 255.255.255.255
    [*SwitchC-LoopBack0] pim sm
    [*SwitchC-LoopBack0] commit
    [~SwitchC-LoopBack0] quit
    [~SwitchC] pim
    [*SwitchC-pim] c-bsr loopback 0
    [*SwitchC-pim] c-rp loopback 0
    [*SwitchC-pim] commit
    [~SwitchC-pim] quit

  4. 配置静态RPF对等体。

    # 配置SwitchD和SwitchF作为SwitchC的静态RPF对等体。

    [~SwitchC] ip ip-prefix list-df permit 192.168.0.0 16 greater-equal 16 less-equal 32
    [*SwitchC] msdp
    [*SwitchC-msdp] peer 192.168.3.2 connect-interface vlanif100
    [*SwitchC-msdp] peer 192.168.5.1 connect-interface vlanif400
    [*SwitchC-msdp] static-rpf-peer 192.168.3.2 rp-policy list-df
    [*SwitchC-msdp] static-rpf-peer 192.168.5.1 rp-policy list-df 
    [*SwitchC-msdp] commit
    [~SwitchC-msdp] quit

    # 配置SwitchC作为SwitchD和SwitchF的静态RPF对等体。SwitchF上的配置过程和SwitchD上的配置相似,配置过程略。

    [~SwitchD] ip ip-prefix list-c permit 192.168.0.0 16 greater-equal 16 less-equal 32
    [*SwitchD] msdp
    [*SwitchD-msdp] peer 192.168.1.1 connect-interface vlanif300
    [*SwitchD-msdp] static-rpf-peer 192.168.1.1 rp-policy list-c 
    [*SwitchD-msdp] commit 
    [~SwitchD-msdp] quit 
    

  5. 验证配置结果。

    # 通过使用display bgp peer命令可以查看Switch之间BGP对等体建立情况。SwitchC上无任何信息输出,说明SwitchC与SwitchD和SwitchF之间未建立BGP对等体关系。

    # 通过使用display msdp brief命令可以查看Switch之间MSDP对等体建立情况。当PIM-SM1内组播源S1发送组播信息时,PIM-SM2和PIM-SM3内的接收者能接收到组播信息,例如SwitchC、SwitchD和SwitchF上MSDP对等体的显示信息如下:

    [~SwitchC] display msdp brief
    MSDP Peer Brief Information of VPN instance: public net
    ---------------------------------------------------------------------------------
      Configured   Up           Listen       Connect      Shutdown     Down
               2    2                0             0             0        0
    ---------------------------------------------------------------------------------
      Peer's Address     State     Up/Down time    AS          SA Count   Reset Count
      192.168.3.2        Up        01:07:08       200                 8             0
      192.168.5.1        Up        00:16:39       200                13             0
    
    
    [~SwitchD] display msdp brief
    MSDP Peer Brief Information of VPN instance: public net
    ---------------------------------------------------------------------------------
      Configured   Up           Listen       Connect      Shutdown     Down
               1    1                0             0             0        0
    ---------------------------------------------------------------------------------
      Peer's Address     State     Up/Down time    AS          SA Count   Reset Count
      192.168.1.1        Up        01:07:09       100                 8             0
    
    
    [~SwitchF] display msdp brief
    MSDP Peer Brief Information of VPN instance: public net
    ---------------------------------------------------------------------------------
      Configured   Up           Listen       Connect      Shutdown     Down 
               1    1                0             0             0        0
    ---------------------------------------------------------------------------------
      Peer's Address     State     Up/Down time    AS          SA Count   Reset Count
      192.168.4.1        Up        00:16:40       100                13             0
    
    

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 101 400 500
    #
    multicast routing-enable
    #
    interface Vlanif101
     ip address 10.110.1.1 255.255.255.0
     pim sm
    #
    interface Vlanif400
     ip address 192.168.4.2 255.255.255.0
     pim sm
    #
    interface Vlanif500
     ip address 192.168.5.2 255.255.255.0
     pim bsr-boundary
     pim sm
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 500
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 400
    #
    interface 10GE1/0/3
     port default vlan 101
    #
    bgp 100
     router-id 10.1.1.3
     peer 192.168.5.1 as-number 200
    #
     ipv4-family unicast
      import-route ospf 1
      peer 192.168.5.1 enable
    #
    ospf 1
     import-route bgp
     area 0.0.0.0
      network 10.110.1.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
      network 192.168.5.0 0.0.0.255
    #
    return
    
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 100 200
    #
    multicast routing-enable
    #
    interface Vlanif100
     ip address 192.168.1.2 255.255.255.0
     pim sm
    #
    interface Vlanif200
     ip address 192.168.2.2 255.255.255.0
     pim bsr-boundary
     pim sm
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    bgp 100
     router-id 10.1.1.2
     peer 192.168.2.1 as-number 200
    #
     ipv4-family unicast
      import-route ospf 1
      peer 192.168.2.1 enable
    #
    ospf 1
     import-route bgp
     area 0.0.0.0
      network 192.168.1.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    return
    
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 100 400
    #
    multicast routing-enable
    #
    interface Vlanif100
     ip address 192.168.1.1 255.255.255.0
     pim sm
    #
    interface Vlanif400
     ip address 192.168.4.1 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 400
    #
    interface LoopBack0
     ip address 10.1.1.1 255.255.255.255
     pim sm
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.1 0.0.0.0
      network 192.168.1.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
    #
    pim
     c-bsr LoopBack0
     c-rp LoopBack0
    #
    ip ip-prefix list-df index 10 permit 192.168.0.0 16 greater-equal 16 less-equal 32
    #
    msdp
     peer 192.168.3.2 connect-interface vlanif100
     peer 192.168.5.1 connect-interface vlanif400
     static-rpf-peer 192.168.3.2 rp-policy list-df
     static-rpf-peer 192.168.5.1 rp-policy list-df
    #
    return
    
  • SwitchD的配置文件

    #
    sysname SwitchD
    #
    vlan batch 300
    #
    multicast routing-enable
    #
    interface Vlanif300
     ip address 192.168.3.2 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    interface LoopBack0
     ip address 10.2.2.2 255.255.255.255
     pim sm
    #
    ospf 1
     area 0.0.0.0
      network 10.2.2.2 0.0.0.0
      network 192.168.3.0 0.0.0.255
    #
    pim
     c-bsr LoopBack0
     c-rp LoopBack0
    #
    ip ip-prefix list-c index 10 permit 192.168.0.0 16 greater-equal 16 less-equal 32
    #
    msdp
     peer 192.168.1.1 connect-interface vlanif300
     static-rpf-peer 192.168.1.1 rp-policy list-c
    #
    return
    
  • SwitchE的配置文件

    #
    sysname SwitchE
    #
    vlan batch 102 200 300
    #
    multicast routing-enable
    #
    interface Vlanif102
     ip address 10.110.2.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif200
     ip address 192.168.2.1 255.255.255.0
     pim bsr-boundary
     pim sm
    #
    interface Vlanif300
     ip address 192.168.3.1 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface 10GE1/0/3
     port default vlan 102
    #
    bgp 200
     router-id 10.2.2.1
     peer 192.168.2.2 as-number 100
    #
     ipv4-family unicast
      import-route ospf 1
      peer 192.168.2.2 enable
    #
    ospf 1
     import-route bgp
     area 0.0.0.0
      network 10.110.2.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
    #
    return
    
  • SwitchF的配置文件

    #
    sysname SwitchF
    #
    vlan batch 500 600
    #
    multicast routing-enable
    #
    interface Vlanif500
     ip address 192.168.5.1 255.255.255.0
     pim bsr-boundary
     pim sm
    #
    interface Vlanif600
     ip address 192.168.6.1 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 500
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 600
    #
    interface LoopBack0
     ip address 10.3.3.3 255.255.255.255
     pim sm
    #
    bgp 200
     router-id 10.3.3.3
     peer 192.168.5.2 as-number 100
    #
     ipv4-family unicast
      import-route ospf 1
      peer 192.168.5.2 enable
    #
    ospf 1
     import-route bgp
     area 0.0.0.0
      network 10.3.3.3 0.0.0.0
      network 192.168.5.0 0.0.0.255
      network 192.168.6.0 0.0.0.255
    #
    pim
     c-bsr LoopBack0
     c-rp LoopBack0
    #
    ip ip-prefix list-c index 10 permit 192.168.0.0 16 greater-equal 16 less-equal 32
    #
    msdp
     peer 192.168.4.1 connect-interface vlanif500
     static-rpf-peer 192.168.4.1 rp-policy list-c
    #
    return
  • SwitchG的配置文件

    #
    sysname SwitchG
    #
    vlan batch 103 104 600
    #
    multicast routing-enable
    #
    interface Vlanif103
     ip address 10.110.3.1 255.255.255.0
     pim sm
    #
    interface Vlanif104
     ip address 10.110.4.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif600
     ip address 192.168.6.2 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port default vlan 103
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 600
    #
    interface 10GE1/0/3
     port default vlan 104
    #
    ospf 1
     area 0.0.0.0
      network 10.110.3.0 0.0.0.255
      network 10.110.4.0 0.0.0.255
      network 192.168.6.0 0.0.0.255
    #
    return
    
翻译
下载文档
更新时间:2019-03-20

文档编号:EDOC1000166616

浏览量:63538

下载量:241

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页