所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 8800, 7800, 6800, 5800 V200R002C50 配置指南-IP组播

本文档介绍了IP组播的配置,具体包括IP组播基础、IGMP配置、MLD配置、PIM(IPv4)配置、PIM(IPv6)配置、MSDP配置、组播VPN配置、组播路由管理(IPv4)配置、组播路由管理(IPv6)配置、IGMP Snooping配置、MLD Snooping配置、静态组播MAC地址配置、组播VLAN配置和组播网管配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置MLD基本功能示例

配置MLD基本功能示例

组网需求

图3-14所示,IPv6网络中的不同用户群组成N1和N2两个末梢网络。PIM(IPv6)网络中的SwitchA连接用户网段N1,SwitchB和SwitchC连接用户网段N2。该PIM(IPv6)网络中传播视频信息使用的组播组地址为FF16::1。N1中和N2中的主机都希望通过组播方式接收视频信息。

图3-14 配置MLD基本功能组网图

配置思路

通过在Switch上配置MLD基本功能,可以实现此需求。

  1. 配置网络中的IPv6单播路由协议,实现网络层互通。单播路由正常是组播路由协议正常工作的基础。

  2. 在各Switch上配置PIM-SM(IPv6)功能,实现IPv6组播路由功能。

  3. 在连接成员主机的接口上使能MLD功能,使主机可以接收组播数据。

操作步骤

  1. 配置各Switch的接口IPv6地址和单播路由协议。

    # 在各交换机上创建VLAN,将物理接口加入VLAN,在相应的VLANIF接口上配置IPv6地址。并配置各Switch之间使用OSPFv3协议实现网络层互通。SwitchB、SwitchC、SwitchD的配置过程和SwitchA上的配置相似,配置过程略。

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 10 11
    [*SwitchA] interface 10GE 1/0/1
    [*SwitchA-10GE1/0/1] port link-type access
    [*SwitchA-10GE1/0/1] port default vlan 10
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] interface 10GE 1/0/2
    [*SwitchA-10GE1/0/2] port link-type trunk
    [*SwitchA-10GE1/0/2] port trunk allow-pass vlan 11
    [*SwitchA-10GE1/0/2] quit
    [*SwitchA] ospfv3 100
    [*SwitchA-ospfv3-100] router-id 10.1.1.1
    [*SwitchA-ospfv3-100] quit
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] ipv6 enable
    [*SwitchA-Vlanif10] ipv6 address fc00:0:0:1::1 64
    [*SwitchA-Vlanif10] ospfv3 100 area 0
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 11
    [*SwitchA-Vlanif11] ipv6 enable
    [*SwitchA-Vlanif11] ipv6 address fc00:0:0:2::1 64
    [*SwitchA-Vlanif11] ospfv3 100 area 0
    [*SwitchA-Vlanif11] quit
    [*SwitchA] commit

  2. 在各Switch上配置PIM-SM(IPv6)功能。

    # 在SwitchD上使能IPv6组播功能,在所有接口上使能PIM-SM(IPv6)功能。SwitchA、SwitchB和SwitchC上的配置过程与此类似,配置过程略。

    [~SwitchD] multicast ipv6 routing-enable
    [*SwitchD] interface vlanif 11
    [*SwitchD-Vlanif11] pim ipv6 sm
    [*SwitchD-Vlanif11] quit
    [*SwitchD] interface vlanif 21
    [*SwitchD-Vlanif21] pim ipv6 sm
    [*SwitchD-Vlanif21] quit
    [*SwitchD] interface vlanif 31
    [*SwitchD-Vlanif31] pim ipv6 sm
    [*SwitchD-Vlanif31] quit
    [*SwitchD] interface vlanif 40
    [*SwitchD-Vlanif40] pim ipv6 sm
    [*SwitchD-Vlanif40] quit
    [*SwitchD] commit

    # 配置RP。在SwitchD上配置C-BSR、C-RP。

    [~SwitchD] pim ipv6
    [*SwitchD-pim6] c-bsr fc00:0:0:7::1
    [*SwitchD-pim6] c-rp fc00:0:0:7::1
    [*SwitchD-pim6] commit
    [~SwitchD-pim6] quit
    

  3. 在连接成员主机的接口上使能MLD功能。

    # 在SwitchA的VLANIF10接口上使能MLD。SwitchB、SwitchC的配置与此类似,配置过程略。

    [~SwitchA] interface vlanif 10
    [~SwitchA-Vlanif10] mld enable
    [*SwitchA-Vlanif10] commit
    [~SwitchA-Vlanif10] quit

  4. 验证配置结果。

    # 通过使用display mld interface命令可以查看各Switch接口上MLD的配置和运行情况。例如SwitchB的VLANIF20接口上:

    [~SwitchB] display mld interface vlanif 20 verbose
    Interface information
     Vlanif20(FE80::225:9EFF:FE95:7C27):
       MLD is enabled
       Current MLD version is 2
       MLD state: up
       MLD group policy: none
       Query interval for MLD (negotiated): 125 s
       Query interval for MLD (configured): 125 s
       Other querier timeout for MLD: 0 s
       Maximum query response time for MLD: 10 s
       Last listener query time: 2 s
       Last listener query interval: 1 s
       Startup query interval: 31 s
       Startup query count: 2
       General query timer expiry (hours:minutes:seconds): 00:00:28
       Querier for MLD: FE80::225:9EFF:FE95:7C27 (this router)
       MLD activity: 2 joins, 0 dones
       Robustness (negotiated): 2
       Robustness (configured): 2
       Require-router-alert: disabled
       Send-router-alert: enabled
       Ip-source-policy: disabled  
       Query Ip-source-policy: disabled 
       Prompt-leave: disabled
       SSM-Mapping: disabled
       Startup-query-timer-expiry: off
       Other-querier-present-timer-expiry: off
      Total 1 MLD Group reported 
    

    可以看到,SwitchB是查询器,这是由于同一网段上交换机SwitchB的VLANIF20接口的IPv6地址较小。还可以看出,VLANIF20接口接收到了一个组播组的报告报文。

    # 通过display pim ipv6 routing-table命令,可以查看各交换机的PIM-SM(IPv6)组播路由表。例如SwitchA上PIM-SM(IPv6)组播路由表信息显示如下:

    [~SwitchA] display pim ipv6 routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
      
     (*, FF16::1)
         RP: FC00:0:0:7::1
         Protocol: pim-sm, Flag: WC 
         UpTime: 00:21:35 
         Upstream interface: Vlanif11 
             Upstream neighbor: FE80::225:9EFF:FE01:20E   
             RPF prime neighbor: FE80::225:9EFF:FE01:20E 
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif10 
                 Protocol: mld, UpTime: 00:21:35, Expires: -  
      
     (FC00:0:0:7::5, FF16::1)  
         RP: FC00:0:0:7::1
         Protocol: pim-sm, Flag: SPT ACT 
         UpTime: 00:22:46 
         Upstream interface: Vlanif11  
             Upstream neighbor: FE80::225:9EFF:FE01:20E  
             RPF prime neighbor: FE80::225:9EFF:FE01:20E 
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif10 
                 Protocol: pim-sm, UpTime: 00:22:47, Expires: -
    
    

    可以看出,SwitchA上有(*, FF16::1)和(FC00:0:0:7::5, FF16::1)表项,这表明VLANIF10加入了组播组FF16::1,并且能够接收到组播源FC00:0:0:7::5向该组播组发送的数据。

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 10 to 11
    #
    multicast ipv6 routing-enable
    #
    ospfv3 100
     router-id 10.1.1.1
     area 0.0.0.0
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address FC00:0:0:1::1/64
     pim ipv6 sm
     mld enable
     ospfv3 100 area 0.0.0.0 
    #
    interface Vlanif11
     ipv6 enable
     ipv6 address FC00:0:0:2::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/0/1
     port default vlan 10
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 11
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 20 to 21
    #
    multicast ipv6 routing-enable
    #
    ospfv3 100
     router-id 10.2.2.2
     area 0.0.0.0
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address FC00:0:0:3::1/64
     pim ipv6 sm
     mld enable
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif21
     ipv6 enable
     ipv6 address FC00:0:0:4::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/0/1
     port default vlan 20
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 21
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 20 31
    #
    multicast ipv6 routing-enable
    #
    ospfv3 100
     router-id 10.3.3.3
     area 0.0.0.0
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address FC00:0:0:5::1/64
     pim ipv6 sm
     mld enable
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif31
     ipv6 enable
     ipv6 address FC00:0:0:6::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/0/1
     port default vlan 20
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 31
    #
    return
  • SwitchD的配置文件

    #
    sysname SwitchD
    #
    vlan batch 11 21 31 40
    #
    multicast ipv6 routing-enable
    #
    ospfv3 100
     router-id 10.4.4.4
     area 0.0.0.0
    #
    interface Vlanif11
     ipv6 enable
     ipv6 address FC00:0:0:2::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif21
     ipv6 enable
     ipv6 address FC00:0:0:4::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif31
     ipv6 enable
     ipv6 address FC00:0:0:6::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif40
     ipv6 enable
     ipv6 address FC00:0:0:7::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 11
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 21
    #
    interface 10GE1/0/4
     port link-type trunk
     port trunk allow-pass vlan 31
    #
    pim ipv6
     c-bsr FC00:0:0:7::1
     c-rp FC00:0:0:7::1
    #
    return
翻译
下载文档
更新时间:2019-03-20

文档编号:EDOC1000166616

浏览量:63284

下载量:241

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页