所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 8800, 7800, 6800, 5800 V200R002C50 配置指南-IP组播

本文档介绍了IP组播的配置,具体包括IP组播基础、IGMP配置、MLD配置、PIM(IPv4)配置、PIM(IPv6)配置、MSDP配置、组播VPN配置、组播路由管理(IPv4)配置、组播路由管理(IPv6)配置、IGMP Snooping配置、MLD Snooping配置、静态组播MAC地址配置、组播VLAN配置和组播网管配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置ASM的PIM-SM(IPv6)网络示例

配置ASM的PIM-SM(IPv6)网络示例

组网需求

图5-1所示,该IPv6网络接入了Internet,用户主机HostA、HostB希望能够接收到Source发送的组播数据。

图5-1 配置ASM模型的PIM-SM(IPv6)域内组播组网图

表5-28 组网图信息表

设备

VLANIF接口

IPv6地址

SwitchA

VLANIF10

FC00:0:0:2001::1/64

VLANIF20

FC00:0:0:3001::1/64

VLANIF30

FC00:0:0:2002::1/64

SwitchB

VLANIF40

FC00:0:0:4001::1/64

VLANIF90

FC00:0:0:2003::1/64

SwitchC

VLANIF40

FC00:0:0:4001::2/64

VLANIF50

FC00:0:0:2004::1/64

SwitchD

VLANIF30

FC00:0:0:2002::2/64

VLANIF60

FC00:0:0:2005::1/64

VLANIF70

FC00:0:0:6001::1/64

VLANIF80

FC00:0:0:5001::1/64

SwitchE

VLANIF10

FC00:0:0:2001::2/64

VLANIF50

FC00:0:0:2004::2/64

VLANIF60

FC00:0:0:2005::2/64

VLANIF90

FC00:0:0:2003::2/64

配置思路

通过在交换机配置PIM-SM(IPv6)协议,为网络中的用户主机提供ASM服务,使得加入同一组播组的所有用户主机能够接收任意源发往该组的组播数据。

  1. 配置交换机接口IPv6地址和IPv6单播路由协议。组播域内路由协议PIM(IPv6)依赖IPv6单播路由协议,单播路由正常是组播协议正常工作的基础。

  2. 在所有提供组播服务的交换机上使能IPv6组播功能。使能IPv6组播功能是配置PIM-SM(IPv6)的前提。

  3. 在交换机所有接口上使能PIM-SM(IPv6)功能。使能PIM-SM(IPv6)功能之后才能配置PIM-SM(IPv6)的其他功能。

  4. 在与主机侧相连的交换机接口上使能MLD。接收者能通过发送MLD消息自由加入或者离开某个组播组。叶节点交换机通过MLD协议来维护组成员关系列表。

  5. 在与主机侧相连的交换机接口上使能PIM Silent(IPv6),防止恶意主机模拟发送Hello报文,增加PIM-SM(IPv6)域的安全性。

    说明:

    如果用户主机所在网段相连着多台交换机,那么这些交换机的用户主机侧接口不能使能PIM Silent(IPv6),如本图中的SwitchB、SwitchC的位置。

  6. 配置RP。在PIM-SM(IPv6)域中,RP是提供ASM服务的核心,是转发组播数据的中转站。建议RP的位置配置在组播流量分支较多的交换机上,如本图中的SwitchE的位置。

  7. 在与Internet相连的接口上配置BSR边界,自举报文不能通过该边界,使BSR只为该PIM-SM(IPv6)域服务,增加组播可控性。

操作步骤

  1. 配置各接口的IPv6地址和IPv6单播路由协议。

    # 在各交换机的接口配置IPv6地址和掩码,各交换机间采用OSPFv3进行互连,确保网络中各交换机间能够在网络层互通,并且之间能够借助IPv6单播路由协议实现动态路由更新。SwitchB、SwitchC、SwitchD和SwitchE的配置与SwitchA相似,配置过程略。

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] ospfv3 100
    [*SwitchA-ospfv3-100] router-id 10.1.1.1
    [*SwitchA-ospfv3-100] quit
    [*SwitchA] vlan batch 10 20 30
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] ipv6 enable
    [*SwitchA-Vlanif10] ipv6 address fc00:0:0:2001::1 64
    [*SwitchA-Vlanif10] ospfv3 100 area 0
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 20
    [*SwitchA-Vlanif20] ipv6 enable
    [*SwitchA-Vlanif20] ipv6 address fc00:0:0:3001::1 64
    [*SwitchA-Vlanif20] ospfv3 100 area 0
    [*SwitchA-Vlanif20] quit
    [*SwitchA] interface vlanif 30
    [*SwitchA-Vlanif30] ipv6 enable
    [*SwitchA-Vlanif30] ipv6 address fc00:0:0:2002::1 64
    [*SwitchA-Vlanif30] ospfv3 100 area 0
    [*SwitchA-Vlanif30] quit
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 10
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] interface 10ge 1/0/2
    [*SwitchA-10GE1/0/2] port link-type access
    [*SwitchA-10GE1/0/2] port default vlan 20
    [*SwitchA-10GE1/0/2] quit
    [*SwitchA] interface 10ge 1/0/3
    [*SwitchA-10GE1/0/3] port link-type trunk
    [*SwitchA-10GE1/0/3] port trunk allow-pass vlan 30
    [*SwitchA-10GE1/0/3] quit
    [*SwitchA] commit

  2. 使能IPv6组播功能,在各接口上使能PIM-SM(IPv6)功能。

    # 在所有交换机使能IPv6组播功能,在各接口上使能PIM-SM(IPv6)功能。SwitchB、SwitchC、SwitchD和SwitchE的配置与SwitchA相似,配置过程略。

    [~SwitchA] multicast ipv6 routing-enable
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] pim ipv6 sm
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 20
    [*SwitchA-Vlanif20] pim ipv6 sm
    [*SwitchA-Vlanif20] quit
    [*SwitchA] interface vlanif 30
    [*SwitchA-Vlanif30] pim ipv6 sm
    [*SwitchA-Vlanif30] quit
    [*SwitchA] commit

  3. 在连接用户主机的接口上使能MLD功能。

    # 在SwitchA连接用户主机的接口上使能MLD功能。SwitchB和SwitchC的配置与SwitchA相似,配置过程略。

    [~SwitchA] interface vlanif 20
    [~SwitchA-Vlanif20] mld enable
    [*SwitchA-Vlanif20] commit

  4. 在SwitchA接口上使能PIM Silent(IPv6)。

    [~SwitchA-Vlanif20] pim ipv6 silent
    [*SwitchA-Vlanif20] commit
    [~SwitchA-Vlanif20] quit

  5. 配置RP。

    # 在SwitchE上配置C-RP,并指定C-RP服务的组地址范围。

    [~SwitchE] acl ipv6 number 2001
    [*SwitchE-acl6-basic-2001] rule permit source ff1e::1 64
    [*SwitchE-acl6-basic-2001] quit
    [*SwitchE] pim ipv6
    [*SwitchE-pim6] c-rp fc00:0:0:2005::2 group-policy 2001
    [*SwitchE-pim6] commit

    # 在SwitchE上配置C-BSR。

    [~SwitchE-pim6] c-bsr fc00:0:0:2005::2
    [*SwitchE-pim6] commit
    [~SwitchE-pim6] quit

  6. 在SwitchD与Internet相连的接口上配置BSR边界

    [~SwitchD] interface vlanif 70
    [~SwitchD-Vlanif70] pim ipv6 bsr-boundary
    [*SwitchD-Vlanif70] commit
    [~SwitchD-Vlanif70] quit

  7. 验证配置结果。

    # 通过使用display pim ipv6 interface命令可以查看接口上PIM(IPv6)的配置和运行情况。例如SwitchC上PIM(IPv6)的显示信息如下:

    [~SwitchC] display pim ipv6 interface
     VPN-Instance: public net
     Interface           State NbrCnt HelloInt   DR-Pri     DR-Address
     Vlanif40            up    1      30         1          FE80::200:FF:FE13:21
     Vlanif50            up    1      30         1          FE80::200:FF:FE00:10(local)
    

    # 通过使用display pim ipv6 bsr-info命令可以查看交换机上BSR选举的信息。例如SwitchA和SwitchE上BSR信息分别如下(SwitchE上还显示C-BSR信息):

    [~SwitchA] display pim ipv6 bsr-info
     VPN-Instance: public net
     Elected AdminScoped BSR Count: 0
     Elected BSR Address: FC00:0:0:2005::2
         Priority: 0
         Hash mask length: 126
         State: Accept Preferred
         Uptime: 01:40:40
         Next BSR message scheduled at: 00:01:42
         C-RP Count: 1
    
    [~SwitchE] display pim ipv6 bsr-info
     VPN-Instance: public net
     Elected AdminScoped BSR Count: 0
     Elected BSR Address: FC00:0:0:2005::2
         Priority: 0
         Hash Mask length: 126
         State: Elected
         Uptime: 00:00:18
         Next BSR message scheduled at :00:01:42
         C-RP Count: 1
     Candidate AdminScoped BSR Count: 0
     Candidate BSR Address: FC00:0:0:2005::2
         Priority: 0
         Hash mask length: 126
         State:Elected
         Wait to be BSR: 0

    # 通过使用display pim ipv6 rp-info命令可以查看Switch上获取的RP信息。例如SwitchA上RP信息如下:

    [~SwitchA] display pim ipv6 rp-info
     VPN-Instance: public net
     PIM-SM BSR RP Number:1
     Group/MaskLen: FF0E::1/64
         RP: FC00:0:0:2005::2
         Priority: 192
         Uptime: 00:05:19
         Expires: 00:02:11
    

    # 通过使用display pim ipv6 routing-table命令可以查看PIM(IPv6)协议组播路由表。组播源S(FC00:0:0:5001::5/64)同时向组播组FF1E::1/64和FF1E::2/64发送组播报文。HostA需要接收组FF1E::1的信息。HostB需要接收组播源S(FC00:0:0:5001::5/64)发给组FF1E::2的信息。

    说明:

    缺省情况下,组成员端DR在收到组播源发来的第一份组播数据后就会触发SPT切换,新建(S,G)路由表项。因此,交换机上显示的(S,G)路由表项一般都是SPT切换后的(S,G)路由表项。

    [~SwitchA] display pim ipv6 routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
    
     (*, FF1E::1)
         RP: FC00:0:0:2005::2
         Protocol: pim-sm, Flag: WC
         UpTime: 00:02:15
         Upstream interface: Vlanif10
             Upstream neighbor: FE80::9D62:0:FDC5:2
             RPF prime neighbor: FE80::9D62:0:FDC5:2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif20
                 Protocol: mld, UpTime: 00:02:15, Expires:  -
    
     (FC00:0:0:5001::5, FF1E::1)
         RP: FC00:0:0:2005::2
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 00:00:11
         Upstream interface: Vlanif30
             Upstream neighbor: FE80::A01:10C:1
             RPF prime neighbor: FE80::A01:10C:1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif20
                 Protocol: pim-sm, UpTime: 00:00:11, Expires: -
    
    
    [~SwitchB] display pim ipv6 routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
    
     (*, FF1E::2)
         RP: FC00:0:0:2005::2
         Protocol: pim-sm, Flag: WC
         UpTime: 00:14:44
         Upstream interface: Vlanif90
             Upstream neighbor: FE80::33FE:0:852C:2
             RPF prime neighbor: FE80::33FE:0:852C:2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif40
                 Protocol: mld, UpTime: 00:14:44, Expires: -
    
     (FC00:0:0:5001::5, FF1E::2)
         RP: FC00:0:0:2005::2
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 00:2:42
         Upstream interface: Vlanif90
             Upstream neighbor: FE80::33FE:0:852C:2
             RPF prime neighbor: FE80::33FE:0:852C:2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif40
                 Protocol: pim-sm, UpTime: 00:14:44, Expires: -
    
    
    [~SwitchC] display pim ipv6 routing-table
     VPN-Instance: public net
     Total 0 (*, G) entry; 1 (S, G) entry
    
     (FC00:0:0:5001::5, FF1E::2)
         RP: FC00:0:0:2005::2
         Protocol: pim-sm, Flag:
         UpTime: 00:2:42
         Upstream interface: Vlanif50
             Upstream neighbor: FE80::71FE:11:21
             RPF prime neighbor: FE80::71FE:11:21
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif40
                 Protocol: pim-sm, UpTime: 00:13:46, Expires: -
    
    
    [~SwitchD] display pim ipv6 routing-table
     VPN-Instance: public net
     Total 0 (*, G) entry; 2 (S, G) entry
     (FC00:0:0:5001::5, FF1E::1)
         RP: FC00:0:0:2005::2
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 00:16:56
         Upstream interface: Vlanif80
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif30
                 Protocol: pim-sm, UpTime: 00:16:56, Expires: 00:02:34
    
     (FC00:0:0:5001::5, FF1E::2)
         RP: FC00:0:0:2005::2
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 00:02:54
         Upstream interface: Vlanif80
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
                1: Vlanif60
                 Protocol: pim-sm, UpTime: 00:02:54, Expires: 00:02:36
    
    
    [~SwitchE] display pim ipv6 routing-table
     VPN-Instance: public net
     Total 2 (*, G) entry; 2 (S, G) entry
    
     (*, FF1E::1)
         RP: FC00:0:0:2005::2(local)
         Protocol: pim-sm, Flag: WC
         UpTime: 00:02:15
         Upstream interface: Register
             Upstream neighbor: FE80::9D62:0:FDC5:2
             RPF prime neighbor: FE80::9D62:0:FDC5:2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif10
                 Protocol: pim-sm, UpTime: 00:02:15, Expires:  -
    
     (FC00:0:0:5001::5, FF1E::1)
         RP: FC00:0:0:2005::2(local)
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 00:16:56
         Upstream interface: Vlanif60
             Upstream neighbor: FE80::659:10C:3
             RPF prime neighbor: FE80::659:10C:3
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif10
                 Protocol: pim-sm, UpTime: 00:16:56, Expires: 00:02:34
    
     (*, FF1E::2)
         RP: FC00:0:0:2005::2(local)
         Protocol: pim-sm, Flag: WC
         UpTime: 00:02:15
         Upstream interface: Register
             Upstream neighbor: FE80::659:10C:3
             RPF prime neighbor: FE80::659:10C:3
         Downstream interface(s) information:
         Total number of downstreams: 2
             1: Vlanif90
                 Protocol: pim-sm, UpTime: 00:02:15, Expires:  -
             2: Vlanif50
                 Protocol: pim-sm, UpTime: 00:02:15, Expires:  -
    
     (FC00:0:0:5001::5, FF1E::2)
         RP: FC00:0:0:2005::2(local)
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 00:02:54
         Upstream interface: Vlanif60
             Upstream neighbor: FE80::659:10C:3
             RPF prime neighbor: FE80::659:10C:3
         Downstream interface(s) information:
         Total number of downstreams: 2
             1: Vlanif90
                 Protocol: pim-sm, UpTime: 00:02:15, Expires:  -
             2: Vlanif50
                 Protocol: pim-sm, UpTime: 00:02:15, Expires:  -

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 10 20 30
    #
    multicast ipv6 routing-enable
    #
    ospfv3 100
     router-id 10.1.1.1
     area 0.0.0.0 
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address FC00:0:0:2001::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address FC00:0:0:3001::1/64
     pim ipv6 silent
     pim ipv6 sm
     mld enable
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address FC00:0:0:2002::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/0/2
     port default vlan 20
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 40 90
    #
    multicast ipv6 routing-enable
    #
    ospfv3 100
     router-id 10.2.2.2 
     area 0.0.0.0 
    #
    interface Vlanif40
     ipv6 enable
     ipv6 address FC00:0:0:4001::1/64
     pim ipv6 sm
     mld enable
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif90
     ipv6 enable
     ipv6 address FC00:0:0:2003::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 90
    #
    interface 10GE1/0/2
     port default vlan 40
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 40 50
    #
    multicast ipv6 routing-enable
    #
    ospfv3 100
     router-id 10.3.3.3
     area 0.0.0.0 
    #
    interface Vlanif40
     ipv6 enable
     ipv6 address FC00:0:0:4001::2/64
     pim ipv6 sm
     mld enable
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif50
     ipv6 enable
     ipv6 address FC00:0:0:2004::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/0/1
     port default vlan 40
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    return
  • SwitchD的配置文件

    #
    sysname SwitchD
    #
    vlan batch 30 60 70 80
    #
    multicast ipv6 routing-enable
    #
    ospfv3 100
     router-id 10.4.4.4
     area 0.0.0.0 
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address FC00:0:0:2002::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif60
     ipv6 enable
     ipv6 address FC00:0:0:2005::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif70
     ipv6 enable
     ipv6 address FC00:0:0:6001::1/64
     pim ipv6 bsr-boundary
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif80
     ipv6 enable
     ipv6 address FC00:0:0:5001::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/0/1
     port default vlan 80
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 70
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface 10GE1/0/4
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    return
  • SwitchE的配置文件

    #
    sysname SwitchE
    #
    vlan batch 10 50 60 90
    #
    multicast ipv6 routing-enable
    #
    acl ipv6 number 2001
     rule 0 permit source FF1E::1/64
    #
    ospfv3 100
     router-id 10.5.5.5
     area 0.0.0.0 
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address FC00:0:0:2001::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif50
     ipv6 enable
     ipv6 address FC00:0:0:2004::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif60
     ipv6 enable
     ipv6 address FC00:0:0:2005::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif90
     ipv6 enable
     ipv6 address FC00:0:0:2003::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 90
    #
    interface 10GE1/0/4
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    pim ipv6
     c-bsr FC00:0:0:2005::2
     c-rp FC00:0:0:2005::2 group-policy 2001
    #
    return
翻译
下载文档
更新时间:2019-03-20

文档编号:EDOC1000166616

浏览量:65626

下载量:244

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页