所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 8800, 7800, 6800, 5800 V200R002C50 配置指南-IP组播

本文档介绍了IP组播的配置,具体包括IP组播基础、IGMP配置、MLD配置、PIM(IPv4)配置、PIM(IPv6)配置、MSDP配置、组播VPN配置、组播路由管理(IPv4)配置、组播路由管理(IPv6)配置、IGMP Snooping配置、MLD Snooping配置、静态组播MAC地址配置、组播VLAN配置和组播网管配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置MLD Snooping查询器示例

配置MLD Snooping查询器示例

组网需求

图10-9所示,在一个没有三层设备纯二层网络环境中,组播源Source1和Source2分别向组播组FF16::1和FF16::2发送组播数据,HostA和HostC希望接收组播组FF16::1的数据,HostB和HostD希望接收组播组FF16::2的数据。

图10-9 配置MLD Snooping查询器组网图

配置思路

在网络中各Switch上使能MLD Snooping功能,并配置某一台Switch为MLD Snooping查询器,可以实现此需求。同时为防止设备在没有二层组播转发表项时将组播数据在VLAN内广播,在所有Switch上都使能丢弃未知组播数据报文功能。

  1. 根据图10-9在所有Switch上创建VLAN并将接口加入VLAN。
  2. 在所有Switch上使能全局和VLAN的MLD Snooping功能。
  3. 选择距离组播源较近的SwitchA为MLD Snooping查询器。
  4. 在所有Switch上使能丢弃未知组播数据报文功能。

操作步骤

  1. 创建VLAN,配置接口加入VLAN。

    # 配置SwitchA。SwitchB、SwitchC和SwitchD的配置与SwitchA类似,配置过程略。

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan 10
    [*SwitchA-vlan10] quit
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port default vlan 10
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] interface 10ge 1/0/2
    [*SwitchA-10GE1/0/2] port link-type trunk
    [*SwitchA-10GE1/0/2] port trunk allow-pass vlan 10
    [*SwitchA-10GE1/0/2] quit
    [*SwitchA] interface 10ge 1/0/3
    [*SwitchA-10GE1/0/3] port default vlan 10
    [*SwitchA-10GE1/0/3] commit
    [~SwitchA-10GE1/0/3] quit

  2. 使能MLD Snooping功能。

    # 配置SwitchA。SwitchB、SwitchC和SwitchD的配置与SwitchA类似,配置过程略。

    [~SwitchA] mld snooping enable
    [*SwitchA] vlan 10
    [*SwitchA-vlan10] mld snooping enable
    [*SwitchA-vlan10] commit

  3. 配置MLD Snooping查询器。

    [~SwitchA-vlan10] mld snooping querier enable
    [*SwitchA-vlan10] commit

  4. 配置未知组播数据报文丢弃。

    # 配置SwitchA。SwitchB、SwitchC和SwitchD的配置与SwitchA类似,配置过程略。

    [~SwitchA-vlan10] multicast drop-unknown
    [*SwitchA-vlan10] commit
    [~SwitchA-vlan10] quit
    

  5. 验证配置结果。

    # 当MLD Snooping查询器开始工作之后,除查询器以外的所有设备都能收到MLD普遍组查询报文。可以通过命令查看MLD报文的统计信息,例如查看SwitchB上收到的MLD报文统计信息。

    [~SwitchB] display mld snooping statistics vlan 10
     MLD Snooping Packets Counter:
       Statistics for VLAN 10
         Receive V1 Report:          0
         Receive V2 Report:          32
         Receive V1 Query:           0
         Receive V2 Query:           30
         Receive Done:               0
         Receive Pim Hello:          0
         Send Query (S=0):           0
         Send Query (S!=0):          0
         Proxy Send General Query:               0
         Proxy Send Group-Specific Query:        0
         Proxy Send Group-Source-Specific Query: 0
         Recv Invalid Packet:                    0
         Recv Ignore Packet:                     0
    

    由显示信息可知,SwitchB上收到了MLD普遍组查询报文。SwitchA作为MLD Snooping查询器功能已生效。

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 10
    #
    mld snooping enable
    #
    vlan 10
     mld snooping enable
     mld snooping querier enable
     multicast drop-unknown
    #
    interface 10GE1/0/1
     port default vlan 10
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/0/3
     port default vlan 10
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 10
    #
    mld snooping enable
    #
    vlan 10
     mld snooping enable
     multicast drop-unknown
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/0/3
     port default vlan 10
    #
    interface 10GE1/0/4
     port default vlan 10
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 10
    #
    mld snooping enable
    #
    vlan 10
     mld snooping enable
     multicast drop-unknown
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/0/3
     port default vlan 10
    #
    return
  • SwitchD的配置文件

    #
    sysname SwitchD
    #
    vlan batch 10
    #
    mld snooping enable
    #
    vlan 10
     mld snooping enable
     multicast drop-unknown
    #
    interface 10GE1/0/1
     port default vlan 10
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
翻译
下载文档
更新时间:2019-03-20

文档编号:EDOC1000166616

浏览量:63134

下载量:241

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页