所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 8800, 7800, 6800, 5800 V200R002C50 配置指南-IP组播

本文档介绍了IP组播的配置,具体包括IP组播基础、IGMP配置、MLD配置、PIM(IPv4)配置、PIM(IPv6)配置、MSDP配置、组播VPN配置、组播路由管理(IPv4)配置、组播路由管理(IPv6)配置、IGMP Snooping配置、MLD Snooping配置、静态组播MAC地址配置、组播VLAN配置和组播网管配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置静态加入IPv4组播组示例

配置静态加入IPv4组播组示例

组网需求

图2-17所示,网络中的不同用户群组成N1和N2两个末梢网络。PIM网络中的SwitchA连接用户网段N1,SwitchB和SwitchC连接用户网段N2。该PIM网络中传播视频信息使用的组播组地址为225.1.1.1~225.1.1.5。

N1中的HostA和N2中的HostC、HostD都希望通过组播方式接收视频信息。其中接收者HostA希望长期稳定地接收组播组225.1.1.1的数据,HostC和HostD对组播组没有这样的需求。

图2-17 配置静态加入组播组组网图

配置思路

配置SwitchA与N1网段相连的接口静态加入组播组225.1.1.1,可以实现此需求。

  1. 为了保证组播路由协议正常工作,需要配置网络中的单播路由协议,实现网络层互通。单播路由正常是组播路由协议正常工作的基础。

  2. 为了实现用户通过组播方式接收视频信息,需要在各Switch上配置基本组播功能,实现组播数据在网络中的转发。

  3. 为了使价值用户HostA可以稳定接收225.1.1.1的数据,需要在SwitchA与N1网段相连的接口上配置静态加入组播组。

操作步骤

  1. 配置各交换机接口IP地址和单播路由协议。

    # 按照图2-17配置各交换机接口的IP地址和掩码,并配置各交换机之间采用OSPF进行互连,确保网络中各交换机间能够在网络层互通,并且之间能够借助单播路由协议实现动态路由更新。具体配置过程略。SwitchB、SwitchC和SwitchD上的配置过程与SwitchA上的配置相似,配置过程略,详见配置文件。

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 10 11
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type access
    [*SwitchA-10GE1/0/1] port default vlan 10
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] interface 10ge 1/0/2
    [*SwitchA-10GE1/0/2] port link-type trunk
    [*SwitchA-10GE1/0/2] port trunk allow-pass vlan 11
    [*SwitchA-10GE1/0/2] quit
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] ip address 10.110.1.1 24
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 11
    [*SwitchA-Vlanif11] ip address 192.168.1.1 24
    [*SwitchA-Vlanif11] quit
    [*SwitchA] ospf
    [*SwitchA-ospf-1] area 0
    [*SwitchA-ospf-1-area-0.0.0.0] network 10.110.1.0 0.0.0.255
    [*SwitchA-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [*SwitchA-ospf-1-area-0.0.0.0] commit
    [~SwitchA-ospf-1-area-0.0.0.0] quit
    [~SwitchA-ospf-1] quit

  2. 使能IP组播路由功能,并在所有接口上使能PIM-SM功能。

    # 在SwitchA上使能IP组播路由功能,并在所有接口上使能PIM-SM功能。SwitchB、SwitchC和SwitchD上的配置过程与此类似,配置过程略,详见配置文件。

    [~SwitchA] multicast routing-enable
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] pim sm
    [*SwitchA-Vlanif10] commit
    [~SwitchA-Vlanif10] quit
    [~SwitchA] interface vlanif 11
    [~SwitchA-Vlanif11] pim sm
    [*SwitchA-Vlanif11] commit
    [~SwitchA-Vlanif11] quit
    

  3. 配置静态RP。

    # 在SwitchA上,配置SwitchD的VLANIF40为静态RP。SwitchB、SwitchC和SwitchD上的配置过程与此类似,配置过程略,详见配置文件。

    [~SwitchA] pim
    [*SwitchA-pim] static-rp 192.168.4.1
    [*SwitchA-pim] commit
    [~SwitchA-pim] quit
    

  4. SwitchA、SwitchB和SwitchC成员端接口使能IGMP功能。

    # 配置SwitchA的VLANIF10接口使能IGMP,SwitchB和SwitchC的配置与此类似,配置过程略,详见配置文件。

    [~SwitchA] interface vlanif 10
    [~SwitchA-Vlanif10] igmp enable
    [*SwitchA-Vlanif10] commit
    [~SwitchA-Vlanif10] quit
    

  5. SwitchA的VLANIF10接口静态加入组播组225.1.1.1,使接口VLANIF10下的用户能长期稳定地接收发往组播225.1.1.1的数据。

    [~SwitchA] interface vlanif 10
    [~SwitchA-Vlanif10] igmp static-group 225.1.1.1
    [*SwitchA-Vlanif10] commit
    [~SwitchA-Vlanif10] quit
    

  6. 验证配置结果。

    # 通过display igmp interface命令可以查看各交换机接口上IGMP的配置和运行情况。例如SwitchB的VLANIF20接口上IGMP的显示信息如下:

    [~SwitchB] display igmp interface vlanif 20
    Interface information of VPN instance: public net
     Vlanif20(10.110.2.1):
       IGMP is enabled
       Current IGMP version is 2
       IGMP state: up 
       IGMP group policy: none 
       IGMP limit: - 
       Query interval for IGMP (negotiated): -
       Query interval for IGMP (configured): 60 s 
       Other querier timeout for IGMP: 0 s 
       Maximum query response time for IGMP: 10 s
       Querier for IGMP: 10.110.2.1 (this router)
      Total 2 IGMP Groups reported

    可以看出,SwitchB的VLANIF20接口已经使能了IGMP。

    # 通过display pim routing-table命令,可以查看SwitchA的接口VLANIF10是否已经静态加入组播组225.1.1.1。显示信息如下:

    [~SwitchA] display pim routing-table
    VPN-Instance: public net
     Total 1 (*, G) entry; 0 (S, G) entry
    
     (*, 225.1.1.1)
         RP: 192.168.4.1
         Protocol: pim-sm, Flag: WC
         UpTime: 00:12:17
         Upstream interface: Vlanif11
             Upstream neighbor: 192.168.1.2
             RPF prime neighbor: 192.168.1.2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif10
                 Protocol: static igmp, UpTime: 00:12:17, Expires: -

    可以看出,SwitchA上有(*,225.1.1.1)表项,且下游接口是VLANIF10,协议类型“static igmp”,表明VLANIF10静态加入组播组225.1.1.1配置成功。若SwitchA的接口VLANIF10未使能IGMP,则此处的协议类型为“static”。

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 10 to 11
    #
    multicast routing-enable
    #
    interface Vlanif10
     ip address 10.110.1.1 255.255.255.0
     pim sm
     igmp enable
     igmp static-group 225.1.1.1
    #
    interface Vlanif11
     ip address 192.168.1.1 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port default vlan 10
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 11
    #
    ospf 1
     area 0.0.0.0
      network 10.110.1.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
    #
    pim
     static-rp 192.168.4.1 
    #
    return
    
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 20 to 21
    #
    multicast routing-enable
    #
    interface Vlanif20
     ip address 10.110.2.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif21
     ip address 192.168.2.1 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port default vlan 20
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 21
    #
    ospf 1
     area 0.0.0.0
      network 10.110.2.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    pim
     static-rp 192.168.4.1 
    #
    return
    
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 20 31
    #
    multicast routing-enable
    #
    interface Vlanif20
     ip address 10.110.2.2 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif31
     ip address 192.168.3.1 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port default vlan 20
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 31
    #
    ospf 1
     area 0.0.0.0
      network 10.110.2.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
    #
    pim
     static-rp 192.168.4.1 
    #
    return
    
  • SwitchD的配置文件

    #
    sysname SwitchD
    #
    vlan batch 11 21 31 40
    #
    multicast routing-enable
    #
    interface Vlanif11
     ip address 192.168.1.2 255.255.255.0
     pim sm
    #
    interface Vlanif21
     ip address 192.168.2.2 255.255.255.0
     pim sm
    #
    interface Vlanif31
     ip address 192.168.3.2 255.255.255.0
     pim sm
    #
    interface Vlanif40
     ip address 192.168.4.1 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 11
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 21
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 31
    #
    interface 10GE1/0/4
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    ospf 1
     area 0.0.0.0
      network 192.168.1.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
    #
    pim
     static-rp 192.168.4.1 
    #
    return
    
翻译
下载文档
更新时间:2019-03-20

文档编号:EDOC1000166616

浏览量:66089

下载量:245

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页