所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 8800, 7800, 6800, 5800 V200R002C50 配置指南-IP组播

本文档介绍了IP组播的配置,具体包括IP组播基础、IGMP配置、MLD配置、PIM(IPv4)配置、PIM(IPv6)配置、MSDP配置、组播VPN配置、组播路由管理(IPv4)配置、组播路由管理(IPv6)配置、IGMP Snooping配置、MLD Snooping配置、静态组播MAC地址配置、组播VLAN配置和组播网管配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置MLD SSM Mapping示例

配置MLD SSM Mapping示例

组网需求

在如图3-15所示的IPv6组播网络中,运行PIM-SM(IPv6)协议,采用SSM模式提供IPv6组播服务。与成员主机Receiver相连的Switch接口上运行MLDv2,Receiver上的MLD的版本为v1,不支持升级到MLDv2。

当前网络中的SSM组地址范围是FF3E::/64,Source1、Source2和Source3都向该范围内的IPv6组播组发送组播数据,Receiver只希望接收来自Source1和Source3的IPv6组播数据。

图3-15 配置MLD SSM Mapping组网图

表3-10 组网图信息表

Switch

接口

VLANIF接口

IP地址

SwitchA

10GE1/0/1

VLANIF10

FC00:0:0:1::1/64

10GE1/0/2

VLANIF20

FC00:0:0:2::1/64

10GE1/0/3

VLANIF30

FC00:0:0:3::1/64

SwitchB

10GE1/0/1

VLANIF11

FC00:0:0:4::1/64

10GE1/0/2

VLANIF20

FC00:0:0:2::2/64

10GE1/0/3

VLANIF31

FC00:0:0:5::1/64

SwitchC

10GE1/0/1

VLANIF12

FC00:0:0:6::1/64

10GE1/0/2

VLANIF21

FC00:0:0:7::1/64

10GE1/0/3

VLANIF31

FC00:0:0:5::2/64

SwitchD

10GE1/0/1

VLANIF13

FC00:0:0:8::1/64

10GE1/0/2

VLANIF21

FC00:0:0:7::2/64

10GE1/0/3

VLANIF30

FC00:0:0:3::2/64

配置思路

在连接成员主机的SwitchD上配置SSM Mapping功能,实现高版本组播设备兼容低版本主机,向Receiver提供SSM服务。

  1. 配置网络中的IPv6单播路由协议,实现网络层互通。单播路由正常是组播路由协议正常工作的基础。

  2. 在各Switch上配置IPv6组播功能,实现组播数据在网络中的转发。

  3. 在SwitchD上使能MLD SSM Mapping功能,并配置映射规则。

操作步骤

  1. 配置各接口的IPv6地址和IPv6单播路由协议。

    # 在各交换机上创建VLAN,将物理接口加入VLAN,在相应的VLANIF接口上配置IPv6地址。并配置各Switch之间使用OSPFv3协议实现网络层互通。SwitchB、SwitchC、SwitchD的配置过程和SwitchA上的配置相似,配置过程略。

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 10 20 30
    [*SwitchA] interface 10GE 1/0/1
    [*SwitchA-10GE1/0/1] port link-type access
    [*SwitchA-10GE1/0/1] port default vlan 10
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] interface 10GE 1/0/2
    [*SwitchA-10GE1/0/2] port link-type trunk
    [*SwitchA-10GE1/0/2] port trunk allow-pass vlan 20
    [*SwitchA-10GE1/0/2] quit
    [*SwitchA] interface 10GE 1/0/3
    [*SwitchA-10GE1/0/3] port link-type trunk
    [*SwitchA-10GE1/0/3] port trunk allow-pass vlan 30
    [*SwitchA-10GE1/0/3] quit
    [*SwitchA] ospfv3 100
    [*SwitchA-ospfv3-100] router-id 10.1.1.1
    [*SwitchA-ospfv3-100] quit
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] ipv6 enable
    [*SwitchA-Vlanif10] ipv6 address fc00:0:0:1::1 64
    [*SwitchA-Vlanif10] ospfv3 100 area 0
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 20
    [*SwitchA-Vlanif20] ipv6 enable
    [*SwitchA-Vlanif20] ipv6 address fc00:0:0:2::1 64
    [*SwitchA-Vlanif20] ospfv3 100 area 0
    [*SwitchA-Vlanif20] quit
    [*SwitchA] interface vlanif 30
    [*SwitchA-Vlanif30] ipv6 enable
    [*SwitchA-Vlanif30] ipv6 address fc00:0:0:3::1 64
    [*SwitchA-Vlanif30] ospfv3 100 area 0
    [*SwitchA-Vlanif30] quit
    [*SwitchA] commit

  2. 在所有Switch上配置IPv6组播基本功能。

    # 在SwitchA上使能IPv6组播功能,在各接口上使能PIM-SM(IPv6)。SwitchB、SwitchC和SwitchD上的配置过程与SwitchA上的配置相似,配置过程略。

    [~SwitchA] multicast ipv6 routing-enable
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] pim ipv6 sm
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 20
    [*SwitchA-Vlanif20] pim ipv6 sm
    [*SwitchA-Vlanif20] quit
    [*SwitchA] interface vlanif 30
    [*SwitchA-Vlanif30] pim ipv6 sm
    [*SwitchA-Vlanif30] quit
    [*SwitchA] commit
    

    # 在SwitchD连接成员主机的接口VLANIF13上使能MLD功能,配置版本为MLDv2。

    [~SwitchD] interface vlanif 13
    [~SwitchD-Vlanif13] mld enable
    [*SwitchD-Vlanif13] mld version 2
    [*SwitchD-Vlanif13] commit
    [~SwitchD-Vlanif13] quit
    

  3. 在SwitchD上使能MLD SSM Mapping功能并配置Mapping规则。

    # 在SwitchD连接成员主机的VLANIF13接口上使能MLD SSM Mapping。

    [~SwitchD] interface vlanif 13
    [~SwitchD-Vlanif13] mld ssm-mapping enable
    [*SwitchD-Vlanif13] commit
    [~SwitchD-Vlanif13] quit
    

    # 在所有Switch上配置SSM组播组地址范围为FF3E::/64。SwitchB、SwitchC和SwitchD上的配置过程与SwitchA上的配置完全相同,配置过程略。

    [~SwitchA] acl ipv6 number 2000
    [*SwitchA-acl6-basic-2000] rule permit source ff3e::/64
    [*SwitchA-acl6-basic-2000] quit
    [*SwitchA] pim ipv6
    [*SwitchA-pim6] ssm-policy 2000
    [*SwitchA-pim6] commit
    [~SwitchA-pim6] quit
    

    # 在SwitchD上将FF3E::/64范围内的组播组映射到Source1和Source3。

    [~SwitchD] mld
    [*SwitchD-mld] ssm-mapping ff3e:: 64 fc00:0:0:1::2
    [*SwitchD-mld] ssm-mapping ff3e:: 64 fc00:0:0:6::2
    [*SwitchD-mld] commit
    [~SwitchD-mld] quit
    

  4. 验证配置结果。

    # 通过display mld ssm-mapping group命令,可以查看SwitchD上组播源和组地址的映射关系。

    [~SwitchD] display mld ssm-mapping group
    MLD SSM-Mapping conversion table of VPN-Instance: public net 
     Total 2 entries    2 entries matched  
    
     00001. (FC00:0:0:1::2, FF3E::) 
    
     00002. (FC00:0:0:6::2, FF3E::) 
    
     Total 2 entries matched    
    
    

    可以看出,FF3E::/64范围内的组播组已经映射到Source1和Source3。

    # Receiver加入组FF3E::1。通过使用display mld group ssm-mapping verbose命令,可以查看由SSM Mapping生成的所有组播组的详细信息。SwitchD上显示如下:

    [~SwitchD] display mld group ssm-mapping verbose
    Interface group report information of VPN-Instance: public net
     Vlanif13(FE80::225:9EFF:FE95:7C27):
      Total entry on this interface: 1
      Total 1 MLD SSM-Mapping Group reported
       Group: FF3E::1
         Uptime: 00:00:13
         Expires: 00:04:07
         Last reporter: FC00:0:0:8::2 
         Last-listener-query-counter: 0
         Last-listener-query-timer-expiry: off
         Group mode: exclude
         Version1-host-present-timer-expiry: 00:04:07
         Source list:
           Source: FC00:0:0:1::2
           Uptime: 00:00:21
           Source: FC00:0:0:6::2
           Uptime: 00:00:21
    

    可以看出,Receiver已经加入组FF3E::1。

    # 通过使用display pim ipv6 routing-table命令,可以查看PIM-SM(IPv6)组播路由表。SwitchD上PIM-SM(IPv6)组播路由表信息显示如下:

    [~SwitchD] display pim ipv6 routing-table
    VPN-Instance: public net
     Total 2 (S, G) entries
     (FC00:0:0:1::2, FF3E::1)
         Protocol: pim-ssm, Flag:SG_RCVR
         UpTime: 00:11:25
         Upstream interface: Vlanif30
             Upstream neighbor: FE80::225:9EFF:FE01:20E
             RPF prime neighbor: FE80::225:9EFF:FE01:20E
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif13
                 Protocol: ssm-map, UpTime: 00:11:25, Expires:-
    
     (FC00:0:0:6::2, FF3E::1)
         Protocol: pim-ssm, Flag:SG_RCVR
         UpTime: 00:11:25
         Upstream interface: Vlanif21
             Upstream neighbor: FE80::225:9EFF:FE95:7C2B
             RPF prime neighbor: FE80::225:9EFF:FE95:7C2B
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif13
                 Protocol: ssm-map, UpTime: 00:11:25, Expires:-
    

    可以看出,SwitchD上有(FC00:0:0:1::2, FF3E::1)和(FC00:0:0:6::2, FF3E::1)表项,协议类型为“ssm-map”,表明VLANIF13已经通过SSM Mapping加入组播组FF3E::1。组播源FC00:0:0:1::2和FC00:0:0:6::2向组播组FF3E::1发送组播数据,SwitchD分别从接口VLANIF30和VLANIF21接收以上两个组播源的数据。

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 10 20 30
    #
    multicast ipv6 routing-enable
    #
    acl ipv6 number 2000
     rule 5 permit source FF3E::/64
    #
    ospfv3 100
     router-id 10.1.1.1
     area 0.0.0.0
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address FC00:0:0:1::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address FC00:0:0:2::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address FC00:0:0:3::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/0/1
     port default vlan 10
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    pim ipv6
     ssm-policy 2000
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 11 20 31
    #
    multicast ipv6 routing-enable
    #
    acl ipv6 number 2000
     rule 5 permit source FF3E::/64 
    #
    ospfv3 100
     router-id 10.2.2.2
     area 0.0.0.0
    #
    interface Vlanif11
     ipv6 enable
     ipv6 address FC00:0:0:4::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address FC00:0:0:2::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif31
     ipv6 enable
     ipv6 address FC00:0:0:5::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/0/1
     port default vlan 11
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 31
    #
    pim ipv6
     ssm-policy 2000
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 12 21 31
    #
    multicast ipv6 routing-enable
    #
    acl ipv6 number 2000
     rule 5 permit source FF3E::/64 
    #
    ospfv3 100
     router-id 10.3.3.3
     area 0.0.0.0
    #
    interface Vlanif12
     ipv6 enable
     ipv6 address FC00:0:0:6::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif21
     ipv6 enable
     ipv6 address FC00:0:0:7::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif31
     ipv6 enable
     ipv6 address FC00:0:0:5::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/0/1
     port default vlan 12
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 21
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 31
    #
    pim ipv6
     ssm-policy 2000
    #
    return
  • SwitchD的配置文件

    #
    sysname SwitchD
    #
    vlan batch 13 21 30
    #
    multicast ipv6 routing-enable
    #
    acl ipv6 number 2000
     rule 5 permit source FF3E::/64 
    #
    ospfv3 100
     router-id 10.4.4.4
     area 0.0.0.0
    #
    interface Vlanif13
     ipv6 enable
     ipv6 address FC00:0:0:8::1/64
     pim ipv6 sm
     mld enable
     mld ssm-mapping enable
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif21
     ipv6 enable
     ipv6 address FC00:0:0:7::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address FC00:0:0:3::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/0/1
     port default vlan 13
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 21
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    mld
     ssm-mapping FF3E:: 64 FC00:0:0:1::2
     ssm-mapping FF3E:: 64 FC00:0:0:6::2
    #
    pim ipv6
     ssm-policy 2000
    #
    return
翻译
下载文档
更新时间:2019-03-20

文档编号:EDOC1000166616

浏览量:62967

下载量:241

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页