所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 8800, 7800, 6800, 5800 V200R002C50 配置指南-IP组播

本文档介绍了IP组播的配置,具体包括IP组播基础、IGMP配置、MLD配置、PIM(IPv4)配置、PIM(IPv6)配置、MSDP配置、组播VPN配置、组播路由管理(IPv4)配置、组播路由管理(IPv6)配置、IGMP Snooping配置、MLD Snooping配置、静态组播MAC地址配置、组播VLAN配置和组播网管配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置基于MSDP的Anycast RP示例

配置基于MSDP的Anycast RP示例

组网需求

图6-12所示,PIM-SM域拥有多个组播源和多个接收者。要求在PIM-SM域内建立MSDP对等体实现RP负荷分担。

图6-12 配置Anycast RP组网图

配置思路

配置基于MSDP的Anycast RP,接收者向拓扑距离最近的RP发起加入,组播源向拓扑距离最近的RP发起注册,从而实现RP负载分担。

  1. 配置各Switch接口IP地址,在PIM-SM域内配置OSPF协议实现互联。

  2. 使能组播功能,并在各接口上使能PIM-SM功能,在主机侧接口上使能IGMP功能。

  3. SwitchC和SwitchD的Loopback10接口地址相同,配置C-RP。在Loopback1接口上配置C-BSR。

  4. SwitchC和SwitchD的Loopback0接口上配置MSDP对等体。根据RPF规则,接收源RP发来的SA消息。

操作步骤

  1. 配置各Switch接口IP地址和单播路由协议。

    # 按照图6-12,在PIM-SM域内,配置各Switch接口的IP地址和掩码,配置各Switch间采用OSPF进行互连。具体配置过程略。

  2. 使能组播路由功能,并配置PIM-SM功能。

    # 在所有Switch使能组播路由功能,并在各接口上使能PIM-SM功能,在主机侧接口使能IGMP功能。其他Switch的配置过程与SwitchC上的配置相似,配置过程略。

    [~SwitchC] multicast routing-enable
    [*SwitchC] interface vlanif 104
    [*SwitchC-Vlanif104] pim sm
    [*SwitchC-Vlanif104] igmp enable
    [*SwitchC-Vlanif104] quit
    [*SwitchC] interface vlanif 101
    [*SwitchC-Vlanif101] pim sm
    [*SwitchC-Vlanif101] quit
    [*SwitchC] interface vlanif 100
    [*SwitchC-Vlanif100] pim sm
    [*SwitchC-Vlanif100] quit
    [*SwitchC] commit
    

  3. 配置Loopback1、Loopback10接口,C-BSR、C-RP的位置。

    # 在SwitchC和SwitchD上分别配置Loopback1接口地址和相同的Loopback10接口地址,在Loopback1上配置C-BSR,在Loopback10上配置C-RP。SwitchD上的配置过程与SwitchC上的配置相似,配置过程略。

    [~SwitchC] interface loopback 1
    [*SwitchC-LoopBack1] ip address 10.3.3.3 255.255.255.255
    [*SwitchC-LoopBack1] pim sm
    [*SwitchC-LoopBack1] quit
    [*SwitchC] interface loopback 10
    [*SwitchC-LoopBack10] ip address 10.1.1.1 255.255.255.255
    [*SwitchC-LoopBack10] pim sm
    [*SwitchC-LoopBack10] quit
    [*SwitchC] pim
    [*SwitchC-pim] c-bsr loopback 1
    [*SwitchC-pim] c-rp loopback 10
    [*SwitchC-pim] quit
    [*SwitchC] commit
    

  4. 配置Loopback0接口和MSDP对等体。

    # 在SwitchC上的Loopback0接口上配置MSDP对等体。

    [~SwitchC] interface loopback 0
    [*SwitchC-LoopBack0] ip address 10.5.5.5 255.255.255.255
    [*SwitchC-LoopBack0] pim sm
    [*SwitchC-LoopBack0] quit
    [*SwitchC] msdp
    [*SwitchC-msdp] originating-rp loopback0
    [*SwitchC-msdp] peer 10.2.2.2 connect-interface loopback0
    [*SwitchC-msdp] quit
    [*SwitchC] commit
    

    # 在SwitchD上的Loopback0接口上配置MSDP对等体。

    [~SwitchD] interface loopback 0
    [*SwitchD-LoopBack0] ip address 10.2.2.2 255.255.255.255
    [*SwitchD-LoopBack0] pim sm
    [*SwitchD-LoopBack0] quit
    [*SwitchD] msdp
    [*SwitchD-msdp] originating-rp loopback0
    [*SwitchD-msdp] peer 10.5.5.5 connect-interface loopback0
    [*SwitchD-msdp] quit
    [*SwitchD] commit
    

  5. 验证配置结果。

    # 通过使用display msdp brief命令可以查看Switch之间MSDP对等体建立情况。SwitchC和SwitchD上MSDP对等体的显示信息如下:

    [~SwitchC] display msdp brief
    MSDP Peer Brief Information of VPN instance: public net  
    ---------------------------------------------------------------------------------                                                   
      Configured   Up           Listen       Connect      Shutdown     Down                                                             
               1    1                0             0             0        0                                                             
    ---------------------------------------------------------------------------------                                                   
      Peer's Address     State     Up/Down time    AS          SA Count   Reset Count                                                   
      10.2.2.2               Up     00:10:17        ?(unknown)         0             0                                                   
    
    
    [~SwitchD] display msdp brief
    MSDP Peer Brief Information of VPN instance: public net  
    ---------------------------------------------------------------------------------                                                   
      Configured   Up           Listen       Connect      Shutdown     Down                                                             
               1    1                0             0             0        0                                                             
    ---------------------------------------------------------------------------------                                                   
      Peer's Address     State     Up/Down time    AS          SA Count   Reset Count                                                   
      10.5.5.5               Up     00:10:18        ?(unknown)         0             0                                                   
    
    

    # 通过使用display pim routing-table命令可以查看Switch上的PIM路由。PIM-SM域内组播源S1(10.110.5.100/24)向组播组G(225.1.1.1)发送组播信息,用户User1加入组播组G,接收发往组G的组播数据。通过比较SwitchC和SwitchD上PIM路由的显示信息,可知当前有效RP是SwitchC:S1向SwitchC注册,User1向SwitchC发起加入。

    [~SwitchC] display pim routing-table
    VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
     
     (*, 225.1.1.1)
         RP: 10.1.1.1 (local)
         Protocol: pim-sm, Flag: WC
         UpTime: 00:08:49
         Upstream interface: Register
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif104
                 Protocol: igmp, UpTime: 00:08:49, Expires: -
     
     (10.110.5.1, 225.1.1.1)
         RP: 10.1.1.1 (local)
         Protocol: pim-sm, Flag: SPT 2MSDP ACT
         UpTime: 00:07:26
         Upstream interface: Vlanif101
             Upstream neighbor: 10.110.1.2
             RPF prime neighbor: 10.110.1.2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif104
                 Protocol: pim-sm, UpTime: 00:07:26, Expires: -
    
    
    [~SwitchD] display pim routing-table

    无输出信息。

    # User1退出组播组G,S1停止向组播组G发送组播数据。使用reset pim routing-table清除SwitchC上的PIM路由表项。

    [~SwitchC] quit
    <SwitchC> reset pim routing-table group 225.1.1.1 mask 255.255.255.255 source 10.110.5.100 interface vlanif 104

    # 用户User2加入组播组G,S2(10.110.6.100/24)开始向组播组G发送组播数据。通过比较SwitchC和SwitchD上PIM路由的显示信息,可知当前有效RP是SwitchD:S2向SwitchD注册,User2向SwitchD发起加入。

    <SwitchC> display pim routing-table

    无输出信息。

    [~SwitchD] display pim routing-table
    VPN-Instance: public net  
    Total 1 (*, G) entry; 1 (S, G) entry
     
    (*, 225.1.1.1)
         RP: 10.1.1.1 (local)
         Protocol: pim-sm, Flag: WC
         UpTime: 00:07:23
         Upstream interface: Register 
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif103,
                 Protocol: igmp, UpTime: 00:07:23, Expires:-
    
     (10.110.6.100, 225.1.1.1)
         RP: 10.1.1.1 (local)
         Protocol: pim-sm, Flag: SPT 2MSDP ACT
         UpTime: 00:05:20
         Upstream interface: Vlanif102
             Upstream neighbor: 10.110.2.2
             RPF prime neighbor: 10.110.2.2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif103
                 Protocol: pim-sm, UpTime: 00:05:20, Expires: -

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 101 105
    #
    multicast routing-enable
    #
    interface Vlanif101
     ip address 10.110.1.2 255.255.255.0
     pim sm
    #
    interface Vlanif105
     ip address 10.110.5.1 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port default vlan 105
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 101
    #
    ospf 1
     area 0.0.0.0
      network 10.110.1.0 0.0.0.255
      network 10.110.5.0 0.0.0.255
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 102 106
    #
    multicast routing-enable
    #
    interface Vlanif102
     ip address 10.110.2.2 255.255.255.0
     pim sm
    #
    interface Vlanif106
     ip address 10.110.6.1 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port default vlan 106
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 102
    #
    ospf 1
     area 0.0.0.0
      network 10.110.2.0 0.0.0.255
      network 10.110.6.0 0.0.0.255
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 100 to 101 104
    #
    multicast routing-enable
    #
    interface Vlanif100
     ip address 192.168.1.1 255.255.255.0
     pim sm
    #
    interface Vlanif101
     ip address 10.110.1.1 255.255.255.0
     pim sm
    #
    interface Vlanif104
     ip address 10.110.4.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 101
    #
    interface 10GE1/0/3
     port default vlan 104
    #
    interface LoopBack0
     ip address 10.5.5.5 255.255.255.255
     pim sm
    #
    interface LoopBack1
     ip address 10.3.3.3 255.255.255.255
     pim sm
    #
    interface LoopBack10
     ip address 10.1.1.1 255.255.255.255
     pim sm
    #
    ospf 1
     area 0.0.0.0
      network 10.5.5.5 0.0.0.0
      network 10.3.3.3 0.0.0.0
      network 10.1.1.1 0.0.0.0
      network 10.110.1.0 0.0.0.255
      network 10.110.4.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
    #
    pim
     c-bsr LoopBack1
     c-rp LoopBack10
    #
    msdp
     originating-rp LoopBack0
     peer 10.2.2.2 connect-interface LoopBack0
    #
    return
  • SwitchD的配置文件

    #
    sysname SwitchD
    #
    vlan batch 102 to 103 300
    #
    multicast routing-enable
    #
    interface Vlanif102
     ip address 10.110.2.1 255.255.255.0
     pim sm
    #
    interface Vlanif103
     ip address 10.110.3.1 255.255.255.0
     pim sm
    #
    interface Vlanif300
     ip address 192.168.3.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 102
    #
    interface 10GE1/0/3
     port default vlan 103
    #
    interface LoopBack0
     ip address 10.2.2.2 255.255.255.255
     pim sm
    #
    interface LoopBack1
     ip address 10.4.4.4 255.255.255.255
     pim sm
    #
    interface LoopBack10
     ip address 10.1.1.1 255.255.255.255
     pim sm
    #
    ospf 1
     area 0.0.0.0
      network 10.2.2.2 0.0.0.0
      network 10.4.4.4 0.0.0.0
      network 10.1.1.1 0.0.0.0
      network 10.110.2.0 0.0.0.255
      network 10.110.3.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
    #
    pim
     c-bsr LoopBack1
     c-rp LoopBack10
    #
    msdp
     originating-rp LoopBack0
     peer 10.5.5.5 connect-interface LoopBack0
    #
    return
  • SwitchE的配置文件

    #
    sysname SwitchE
    #
    vlan batch 100 300
    #
    multicast routing-enable
    #
    interface Vlanif100
     ip address 192.168.1.2 255.255.255.0
     pim sm
    #
    interface Vlanif300
     ip address 192.168.3.2 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    ospf 1
     area 0.0.0.0
      network 192.168.1.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
    #
    return
翻译
下载文档
更新时间:2019-03-20

文档编号:EDOC1000166616

浏览量:62693

下载量:241

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页