所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 8800, 7800, 6800, 5800 V200R002C50 配置指南-IP组播

本文档介绍了IP组播的配置,具体包括IP组播基础、IGMP配置、MLD配置、PIM(IPv4)配置、PIM(IPv6)配置、MSDP配置、组播VPN配置、组播路由管理(IPv4)配置、组播路由管理(IPv6)配置、IGMP Snooping配置、MLD Snooping配置、静态组播MAC地址配置、组播VLAN配置和组播网管配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置组播静态路由改变RPF路由示例

配置组播静态路由改变RPF路由示例

组网需求

图7-10所示,SwitchA、SwitchB和SwitchC之间运行OSPF协议,并且接口上都使能了PIM-SM,组播源Source发出的数据能够沿SwitchA→SwitchB正常的发往Receiver。要求:组播数据沿SwitchA→SwitchC→SwitchB进行传输,减轻SwitchA→SwitchB这条链路同时承载单播业务和组播业务的负担。

图7-10 配置组播静态路由改变RPF路由组网图

配置思路

通过配置组播静态路由,改变接收组播数据的RPF接口,可实现图7-10中所示的组播业务与单播业务分离,通过两条链路进行传输,减轻单链路传输的负担。具体配置思路如下:

  1. 配置各Switch接口IP地址和OSPF单播路由协议。单播路由正常是组播协议正常工作的基础。

  2. 使能组播功能,在所有交换机的各三层接口上使能PIM-SM并配置C-BSR和C-RP,在与主机相连的接口上使能IGMP。配置了组播协议的基本功能之后,通过设备提供的缺省值,就可以正常建立组播分发树,组播数据沿组播分发树传给Receiver。

  3. SwitchB上配置RPF组播静态路由,指定RPF邻居为SwitchC,改变组播转发路径。

操作步骤

  1. 配置各Switch接口IP地址和单播路由协议。

    # 在各交换机上创建VLAN,并将二层物理接口加入VLAN。其他交换机的配置过程与SwitchB上的配置相似,配置过程略。

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchB
    [*HUAWEI] commit
    [~SwitchB] vlan batch 10 40 50
    [*SwitchB] interface 10ge 1/0/1
    [*SwitchB-10GE1/0/1] port link-type trunk
    [*SwitchB-10GE1/0/1] port trunk allow-pass vlan 10
    [*SwitchB-10GE1/0/1] quit
    [*SwitchB] interface 10ge 1/0/2
    [*SwitchB-10GE1/0/2] port link-type trunk
    [*SwitchB-10GE1/0/2] port trunk allow-pass vlan 40
    [*SwitchB-10GE1/0/2] quit
    [*SwitchB] interface 10ge 1/0/3
    [*SwitchB-10GE1/0/3] port default vlan 50
    [*SwitchB-10GE1/0/3] quit
    [*SwitchB] commit
    

    # 在各交换机的三层VLANIF接口配置IP地址和掩码。其他交换机的配置过程与SwitchB上的配置相似,配置过程略。

    [~SwitchB] interface vlanif 10
    [*SwitchB-Vlanif10] ip address 10.9.1.2 24
    [*SwitchB-Vlanif10] quit
    [*SwitchB] interface vlanif 40
    [*SwitchB-Vlanif40] ip address 10.13.1.1 24
    [*SwitchB-Vlanif40] quit
    [*SwitchB] interface vlanif 50
    [*SwitchB-Vlanif50] ip address 10.7.1.1 24
    [*SwitchB-Vlanif50] quit
    [*SwitchB] commit
    

    # 在各交换机上配置单播路由协议OSPF。其他交换机的配置过程与SwitchB上的配置相似,配置过程略。

    [~SwitchB] ospf
    [*SwitchB-ospf-1] area 0
    [*SwitchB-ospf-1-area-0.0.0.0] network 10.7.1.0 0.0.0.255
    [*SwitchB-ospf-1-area-0.0.0.0] network 10.9.1.0 0.0.0.255
    [*SwitchB-ospf-1-area-0.0.0.0] network 10.13.1.0 0.0.0.255
    [*SwitchB-ospf-1-area-0.0.0.0] quit
    [*SwitchB-ospf-1] quit
    [*SwitchB] commit

  2. 使能组播功能,在各接口上使能PIM-SM,在主机侧接口使能IGMP。

    # 在所有Switch启动组播功能,并在各接口上使能PIM-SM功能,主机侧接口上使能IGMP功能。其他交换机PIM-SM功能的配置过程与SwitchB上的配置相似,配置过程略。

    [~SwitchB] multicast routing-enable
    [*SwitchB] interface vlanif 10
    [*SwitchB-Vlanif10] pim sm
    [*SwitchB-Vlanif10] quit
    [*SwitchB] interface vlanif 40
    [*SwitchB-Vlanif40] pim sm
    [*SwitchB-Vlanif40] quit
    [*SwitchB] interface vlanif 50
    [*SwitchB-Vlanif50] pim sm
    [*SwitchB-Vlanif50] igmp enable 
    [*SwitchB-Vlanif50] quit
    [*SwitchB] commit

    # 将SwitchC的VLANIF30接口配置为C-BSR和C-RP。

    [~SwitchC] pim
    [*SwitchC-pim] c-bsr vlanif 30
    [*SwitchC-pim] c-rp vlanif 30
    [*SwitchC-pim] commit
    [~SwitchC-pim] quit

    # 在SwitchB上执行display multicast rpf-info命令,查看Source的RPF路由信息。发现当前RPF路由来源于单播,RPF邻居是SwitchA。信息显示如下:

    [~SwitchB] display multicast rpf-info 10.8.1.2
    VPN-Instance: public net
    RPF information about source: 10.8.1.2
         RPF interface: Vlanif10, RPF neighbor: 10.9.1.1
         Referenced route/mask: 10.8.1.0/24
         Referenced route type: unicast
         Route selection rule: preference-preferred
         Load splitting rule: disable

  3. 配置组播静态路由。

    # 在SwitchB上配置RPF组播静态路由,到Source的RPF邻居为SwitchC。

    [~SwitchB] ip rpf-route-static 10.8.1.0 255.255.255.0 10.13.1.2
    [*SwitchB] commit

  4. 验证配置结果。

    # 在SwitchB上执行display multicast rpf-info命令,查看Source的RPF信息。RPF信息显示如下。与配置组播静态路由前比较,RPF路由与RPF邻居已经依据静态路由更新。

    [~SwitchB] display multicast rpf-info 10.8.1.2
    VPN-Instance: public net
    RPF information about source: 10.8.1.2
         RPF interface: Vlanif40, RPF neighbor: 10.13.1.2
         Referenced route/mask: 10.8.1.0/24
         Referenced route type: mstatic
         Route selection rule: preference-preferred
         Load splitting rule: disable 
    

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 10 20 30
    #
    multicast routing-enable
    #
    interface Vlanif10
     ip address 10.9.1.1 255.255.255.0
     pim sm
    #
    interface Vlanif20
     ip address 10.8.1.1 255.255.255.0
     pim sm
    #
    interface Vlanif30
     ip address 10.12.1.1 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/0/2
     port default vlan 20
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    ospf 1
     area 0.0.0.0
      network 10.8.1.0 0.0.0.255
      network 10.9.1.0 0.0.0.255
      network 10.12.1.0 0.0.0.255
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 10 40 50
    #
    multicast routing-enable
    #
    interface Vlanif10
     ip address 10.9.1.2 255.255.255.0
     pim sm
    #
    interface Vlanif40
     ip address 10.13.1.1 255.255.255.0
     pim sm
    #
    interface Vlanif50
     ip address 10.7.1.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface 10GE1/0/3
     port default vlan 50
    #
    ospf 1
     area 0.0.0.0
      network 10.7.1.0 0.0.0.255
      network 10.9.1.0 0.0.0.255
      network 10.13.1.0 0.0.0.255
    #
    ip rpf-route-static 10.8.1.0 24 10.13.1.2
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 30 40
    #
    multicast routing-enable
    #
    interface Vlanif30
     ip address 10.12.1.2 255.255.255.0
     pim sm
    #
    interface Vlanif40
     ip address 10.13.1.2 255.255.255.0
     pim sm
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    ospf 1
     area 0.0.0.0
      network 10.12.1.0 0.0.0.255
      network 10.13.1.0 0.0.0.255
    #
    pim
     c-bsr Vlanif30
     c-rp Vlanif30
    #
    return
翻译
下载文档
更新时间:2019-03-20

文档编号:EDOC1000166616

浏览量:63418

下载量:241

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页