所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 8800, 7800, 6800, 5800 V200R002C50 配置指南-IP组播

本文档介绍了IP组播的配置,具体包括IP组播基础、IGMP配置、MLD配置、PIM(IPv4)配置、PIM(IPv6)配置、MSDP配置、组播VPN配置、组播路由管理(IPv4)配置、组播路由管理(IPv6)配置、IGMP Snooping配置、MLD Snooping配置、静态组播MAC地址配置、组播VLAN配置和组播网管配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置MSDP实现PIM-SM域间组播示例

配置MSDP实现PIM-SM域间组播示例

组网需求

图6-10所示,网络中存在两个自治系统AS。每个AS包含一个或多个PIM-SM域,每个PIM-SM域拥有0个或1个组播源和接收者。要求PIM-SM2域内的接收者Receiver既能接收到PIM-SM3域组播源S3发送的组播数据,又能接收到PIM-SM1域组播源S1发送的组播数据。

图6-10 配置PIM-SM域间组播组网图

配置思路

配置MSDP,在各个PIM-SM域的RP之间建立MSDP对等体关系,可以实现域间组播。

  1. 配置各交换机接口IP地址,为保证AS内单播路由畅通,在自治系统内配置OSPF协议。

  2. 为保证AS间单播路由畅通,在AS之间配置EBGP对等体,将BGP与OSPF互相引入。

  3. 使能组播路由功能,在各接口上使能PIM-SM功能,通过配置BSR边界划分PIM-SM域,在主机侧接口上使能IGMP功能。

  4. 配置C-BSR、C-RP。将PIM-SM1域和PIM-SM2域的RP配置在ASBR上。

  5. 在各个域的RP之间建立MSDP对等体关系。根据RPF规则,接收从到达源RP的路由下一跳发来的SA消息。

操作步骤

  1. 配置各Switch接口IP地址和单播路由协议。

    # 按照图6-10配置各Switch接口的IP地址和掩码,配置各Switch间采用OSPF进行互连。确保AS内网络层互通,且各Switch之间能够借助单播路由协议实现动态路由更新。具体配置过程略。

  2. 在AS之间配置EBGP对等体,将BGP与OSPF互相引入。

    # 在SwitchB上配置EBGP协议,并引入OSPF路由。

    [~SwitchB] bgp 100
    [*SwitchB-bgp] router-id 10.1.1.1
    [*SwitchB-bgp] peer 192.168.2.2 as-number 200
    [*SwitchB-bgp] import-route ospf 1
    [*SwitchB-bgp] commit
    [~SwitchB-bgp] quit

    # 在SwitchC上配置EBGP协议,并引入OSPF路由。

    [~SwitchC] bgp 200
    [*SwitchC-bgp] router-id 10.2.2.2
    [*SwitchC-bgp] peer 192.168.2.1 as-number 100
    [*SwitchC-bgp] import-route ospf 1
    [*SwitchC-bgp] commit
    [~SwitchC-bgp] quit

    # 在SwitchB中的OSPF中引入BGP。SwitchC上的配置过程与SwitchB上的配置相似,配置过程略。

    [~SwitchB] ospf 1
    [*SwitchB-ospf-1] import-route bgp
    [*SwitchB-ospf-1] commit
    [~SwitchB-ospf-1] quit

  3. 使能组播路由功能,在使能上使能PIM-SM功能,配置BSR服务边界,在主机侧接口上使能IGMP功能。

    # 在SwitchB上使能组播路由功能,并在各接口上使能PIM-SM功能。其他Switch的配置过程与SwitchB上的配置相似,配置过程略。

    [~SwitchB] multicast routing-enable
    [*SwitchB] interface vlanif 100
    [*SwitchB-Vlanif100] pim sm
    [*SwitchB-Vlanif100] commit
    [~SwitchB-Vlanif100] quit
    [~SwitchB] interface vlanif 200
    [~SwitchB-Vlanif200] pim sm
    [*SwitchB-Vlanif200] commit
    [~SwitchB-Vlanif200] quit
    

    # 在SwitchB的VLANIF200上配置BSR服务边界。

    [~SwitchB] interface vlanif 200
    [~SwitchB-Vlanif200] pim bsr-boundary
    [*SwitchB-Vlanif200] commit
    [~SwitchB-Vlanif200] quit

    # 在SwitchC的VLANIF200和VLANIF400上配置BSR服务边界。在SwitchE的VLANIF400上的配置BSR服务边界。配置过程与SwitchB上的配置相似,配置过程略。

    # 在SwitchD连接末梢网络的接口上使能IGMP功能。

    [~SwitchD] interface vlanif 102
    [~SwitchD-Vlanif102] igmp enable
    [*SwitchD-Vlanif102] commit
    [~SwitchD-Vlanif102] quit

  4. 配置C-BSR、C-RP。

    # 在SwitchB上创建Loopback0接口,配置C-BSR和C-RP。SwitchC和SwitchE上的配置过程与SwitchB上的配置相似,配置过程略。

    [~SwitchB] interface loopback 0
    [*SwitchB-LoopBack0] ip address 10.1.1.1 255.255.255.255
    [*SwitchB-LoopBack0] pim sm
    [*SwitchB-LoopBack0] commit
    [~SwitchB-LoopBack0] quit
    [~SwitchB] pim
    [*SwitchB-pim] c-bsr loopback 0
    [*SwitchB-pim] c-rp loopback 0
    [*SwitchB-pim] commit
    [~SwitchB-pim] quit

  5. 配置MSDP对等体。

    # 在SwitchB上配置MSDP对等体。

    [~SwitchB] msdp
    [*SwitchB-msdp] peer 192.168.2.2 connect-interface vlanif200
    [*SwitchB-msdp] commit
    [~SwitchB-msdp] quit

    # 在SwitchC上配置MSDP对等体。

    [~SwitchC] msdp
    [*SwitchC-msdp] peer 192.168.2.1 connect-interface vlanif200
    [*SwitchC-msdp] peer 192.168.4.2 connect-interface vlanif400
    [*SwitchC-msdp] commit
    [~SwitchC-msdp] quit

    # 在SwitchE上配置MSDP对等体。

    [~SwitchE] msdp
    [*SwitchE-msdp] peer 192.168.4.1 connect-interface vlanif400
    [*SwitchE-msdp] commit
    [~SwitchE-msdp] quit

  6. 验证配置结果。

    # 通过使用display bgp peer命令可以查看Switch之间BGP对等体关系。例如SwitchB、SwitchC上BGP对等体关系的显示信息如下:

    [~SwitchB] display bgp peer
    
     BGP local router ID : 10.1.1.1
     Local AS number : 100
     Total number of peers : 1                     Peers in established state : 1
    
      Peer          V   AS   MsgRcvd    MsgSent    OutQ    Up/Down          State    PrefRcv
      192.168.2.2   4   200       24         21       0    00:13:09   Established          6
    
    
    [~SwitchC] display bgp peer
    
    BGP local router ID : 10.2.2.2
     Local AS number : 200
     Total number of peers : 1                     Peers in established state : 1  
    
      Peer          V   AS    MsgRcvd    MsgSent     OutQ   Up/Down          State    PrefRcv
      192.168.2.1   4   100        18         16        0   00:12:04   Established          1
    

    # 通过使用display msdp brief命令可以查看Switch之间MSDP对等体建立情况。SwitchB、SwitchC和SwitchE上MSDP对等体建立情况的简要信息如下:

    [~SwitchB] display msdp brief
    MSDP Peer Brief Information of VPN instance: public net                            
    ---------------------------------------------------------------------------------  
      Configured   Up           Listen       Connect      Shutdown     Down          
               1    1                0             0             0        0
    ---------------------------------------------------------------------------------  
      Peer's Address     State     Up/Down time    AS          SA Count   Reset Count
      192.168.2.2        Up        00:12:27        200               13             0
    
    
    [~SwitchC] display msdp brief
    MSDP Peer Brief Information of VPN instance: public net                            
    ---------------------------------------------------------------------------------  
      Configured   Up           Listen       Connect      Shutdown     Down          
               2    2                0             0             0        0
    ---------------------------------------------------------------------------------  
      Peer's Address     State     Up/Down time    AS          SA Count   Reset Count
      192.168.2.1        Up        01:07:08        100                8             0
      192.168.4.2        Up        00:06:39        ?(unknown)        13             0
    
    
    [~SwitchE] display msdp brief
    MSDP Peer Brief Information of VPN instance: public net                            
    ---------------------------------------------------------------------------------  
      Configured   Up           Listen       Connect      Shutdown     Down          
               1    1                0             0             0        0
    ---------------------------------------------------------------------------------  
      Peer's Address     State     Up/Down time    AS          SA Count   Reset Count
      192.168.4.1        Up        00:15:32        ?(unknown)         8             0
    
    

    # 通过使用display msdp peer-status命令可以查看Switch上的MSDP对等体的详细信息。SwitchB上MSDP对等体的详细信息如下:

    [~SwitchB] display msdp peer-status
    MSDP Peer Information of VPN instance: public net
      MSDP Peer 192.168.2.2, AS 200
      Description:
      Information about connection status:
        State: Up
        Up/down time: 00:15:47
        Resets: 0
        Connection interface: Vlanif200 (192.168.2.1)
        Number of sent/received messages: 46/46
        Number of discarded output messages: 0
        Elapsed time since last connection or counters clear: 00:17:51
      Information about (Source, Group)-based SA filtering policy:
        Import policy: none
        Export policy: none
      Information about SA-Requests:
        Policy to accept SA-Request messages: none
        Sending SA-Requests status: disable
      Minimum TTL to forward SA with encapsulated data: 0
      SAs learned from this peer: 0, SA-cache maximum for the peer: none
      Input queue size: 0, Output queue size: 0
      Counters for MSDP message:
        Count of RPF check failure: 0
        Incoming/outgoing SA messages: 20/30
        Incoming/outgoing SA requests: 0/0
        Incoming/outgoing SA responses: 0/0
        Incoming/outgoing data packets: 0/0
      Peer authentication: unconfigured
      Peer authentication type: none

    # 通过使用display pim routing-table命令可以查看Switch上的PIM路由表。当PIM-SM1内组播源S1(10.110.1.2/24)和PIM-SM3内的S3(10.110.3.2/24)向组播组G(225.1.1.1)发送组播信息时,PIM-SM2内的组成员Receiver(10.110.2.2/24)能接收到相应的组播信息。SwitchB和SwitchC上的PIM路由表显示信息如下:

    [~SwitchB] display pim routing-table
    VPN-Instance: public net
     Total 0 (*, G) entry; 1 (S, G) entry
     
     (10.110.1.2, 225.1.1.1)
         RP: 10.1.1.1(local)
         Protocol: pim-sm, Flag: SPT EXT ACT
         UpTime: 00:00:42
         Upstream interface: Vlanif100
             Upstream neighbor: 192.168.1.1
             RPF prime neighbor: 192.168.1.1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif200
                 Protocol: pim-sm, UpTime: 00:00:42, Expires:-
    
    
    [~SwitchC] display pim routing-table
    VPN-Instance: public net
     Total 1 (*, G) entry; 2 (S, G) entries
     
    (*, 225.1.1.1)
         RP: 10.2.2.2(local)
         Protocol: pim-sm, Flag: WC RPT
         UpTime: 00:13:46
         Upstream interface: NULL, 
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
        Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif300,
                 Protocol: pim-sm, UpTime: 00:13:46, Expires:-
    
    (10.110.1.2, 225.1.1.1)
         RP: 10.2.2.2
         Protocol: pim-sm, Flag: SPT MSDP ACT
         UpTime: 00:00:42
         Upstream interface: Vlanif200
             Upstream neighbor: 192.168.2.1
             RPF prime neighbor: 192.168.2.1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif300
                 Protocol: pim-sm, UpTime: 00:00:42, Expires:-
    
    (10.110.3.2, 225.1.1.1)
         RP: 10.2.2.2
         Protocol: pim-sm, Flag: SPT MSDP ACT
         UpTime: 00:00:42
         Upstream interface: Vlanif400
             Upstream neighbor: 192.168.4.2
             RPF prime neighbor: 192.168.4.2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif300
                 Protocol: pim-sm, UpTime: 00:00:42, Expires:-
    

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 100 to 101
    #
    multicast routing-enable
    #
    interface Vlanif100
     ip address 192.168.1.1 255.255.255.0
     pim sm
    #
    interface Vlanif101
     ip address 10.110.1.1 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port default vlan 101
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    ospf 1
     area 0.0.0.0
      network 10.110.1.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 100 200
    #
    multicast routing-enable
    #
    interface Vlanif100
     ip address 192.168.1.2 255.255.255.0
     pim sm
    #
    interface Vlanif200
     ip address 192.168.2.1 255.255.255.0
     pim bsr-boundary
     pim sm
    #
    interface LoopBack0
     ip address 10.1.1.1 255.255.255.255
     pim sm
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    bgp 100
     router-id 10.1.1.1
     peer 192.168.2.2 as-number 200
    #
     ipv4-family unicast
      import-route ospf 1
      peer 192.168.2.2 enable
    #
    ospf 1
     import-route bgp
     area 0.0.0.0
      network 10.1.1.1 0.0.0.0
      network 192.168.1.0 0.0.0.255
    #
    pim
     c-bsr LoopBack0
     c-rp LoopBack0
    #
    msdp
     peer 192.168.2.2 connect-interface Vlanif200
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 200 300 400
    #
    multicast routing-enable
    #
    interface Vlanif200
     ip address 192.168.2.2 255.255.255.0
     pim bsr-boundary
     pim sm
    #
    interface Vlanif300
     ip address 192.168.3.1 255.255.255.0
     pim sm
    #
    interface Vlanif400
     ip address 192.168.4.1 255.255.255.0
     pim bsr-boundary
     pim sm
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 400
    #
    interface LoopBack0
     ip address 10.2.2.2 255.255.255.255
     pim sm
    #
    bgp 200
     router-id 10.2.2.2
     peer 192.168.2.1 as-number 100
    #
     ipv4-family unicast
      import-route ospf 1
      peer 192.168.2.1 enable
    #
    ospf 1
     import-route bgp
     area 0.0.0.0
      network 10.2.2.2 0.0.0.0
      network 192.168.3.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
    #
    pim
     c-bsr LoopBack0
     c-rp LoopBack0
    #
    msdp
     peer 192.168.2.1 connect-interface Vlanif200
     peer 192.168.4.2 connect-interface Vlanif400
    #
    return
  • SwitchD的配置文件

    #
    sysname SwitchD
    #
    vlan batch 102 300
    #
    multicast routing-enable
    #
    interface Vlanif102
     ip address 10.110.2.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif300
     ip address 192.168.3.2 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port default vlan 102
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    ospf 1
     area 0.0.0.0
      network 10.110.2.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
    #
    return
  • SwitchE的配置文件

    #
    sysname SwitchE
    #
    vlan batch 400 500
    #
    multicast routing-enable
    #
    interface Vlanif400
     ip address 192.168.4.2 255.255.255.0
     pim bsr-boundary
     pim sm
    #
    interface Vlanif500
     ip address 192.168.5.1 255.255.255.0
     pim sm
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 500
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 400
    #
    interface LoopBack0
     ip address 10.3.3.3 255.255.255.255
     pim sm
    # 
    ospf 1
     area 0.0.0.0
      network 10.3.3.3 0.0.0.0
      network 192.168.4.0 0.0.0.255
      network 192.168.5.0 0.0.0.255
    #
    pim
     c-bsr LoopBack0
     c-rp LoopBack0
    #
    msdp
     peer 192.168.4.1 connect-interface Vlanif400
    #
    return
  • SwitchF的配置文件

    #
    sysname SwitchF
    #
    vlan batch 103 500
    #
    multicast routing-enable
    #
    interface Vlanif103
     ip address 10.110.3.1 255.255.255.0
     pim sm
    #
    interface Vlanif500
     ip address 192.168.5.2 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port default vlan 103
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 500
    #
    ospf 1
     area 0.0.0.0
      network 10.110.3.0 0.0.0.255
      network 192.168.5.0 0.0.0.255
    #
    return
翻译
下载文档
更新时间:2019-03-20

文档编号:EDOC1000166616

浏览量:66084

下载量:245

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页