所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 8800, 7800, 6800, 5800 V200R002C50 配置指南-IP组播

本文档介绍了IP组播的配置,具体包括IP组播基础、IGMP配置、MLD配置、PIM(IPv4)配置、PIM(IPv6)配置、MSDP配置、组播VPN配置、组播路由管理(IPv4)配置、组播路由管理(IPv6)配置、IGMP Snooping配置、MLD Snooping配置、静态组播MAC地址配置、组播VLAN配置和组播网管配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置基于用户VLAN的组播VLAN功能示例

配置基于用户VLAN的组播VLAN功能示例

组网需求

图12-3所示,RouterA和SwitchA之间用于传输组播数据的业务VLAN为VLAN10,而下游用户主机HostA、HostB和HostC分别属于VLAN100、VLAN200和VLAN300,并且都需要接收组播源Source的组播数据。

要求通过配置基于用户VLAN的组播VLAN功能,对于不同用户主机多份相同的组播需求,RouterA只需要向VLAN10发送一份组播数据,减少RouterA与SwitchA之间的带宽浪费。

图12-3 配置基于用户VLAN的组播VLAN功能组网图

配置思路

采用如下的思路配置基于用户VLAN的组播VLAN功能:

  1. 在系统视图下使能IGMP Snooping。
  2. 创建用户VLAN,并在用户VLAN下使能IGMP Snooping。
  3. 创建组播VLAN,并在组播VLAN下使能IGMP Snooping。
  4. 在组播VLAN下绑定用户VLAN。
  5. 将接口分别以Access方式加入VLAN。

操作步骤

  1. 在系统视图下使能IGMP Snooping。

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] igmp snooping enable
    [*SwitchA] commit
    

  2. 创建用户VLAN,并在用户VLAN下使能IGMP Snooping功能。

    [~SwitchA] vlan 100
    [*SwitchA-vlan100] igmp snooping enable
    [*SwitchA-vlan100] quit
    [*SwitchA] vlan 200
    [*SwitchA-vlan200] igmp snooping enable
    [*SwitchA-vlan200] quit
    [*SwitchA] vlan 300
    [*SwitchA-vlan300] igmp snooping enable
    [*SwitchA-vlan300] commit
    [~SwitchA-vlan300] quit
    

  3. 创建组播VLAN,并在组播VLAN下使能IGMP Snooping功能。

    [~SwitchA] vlan 10
    [*SwitchA-vlan10] igmp snooping enable
    [*SwitchA-vlan10] multicast vlan enable
    [*SwitchA-vlan10] commit
    

  4. 在组播VLAN10下面绑定用户VLAN100、VLAN200和VLAN300。

    [~SwitchA-vlan10] multicast vlan user-vlan 100 200 300
    [*SwitchA-vlan10] commit
    [~SwitchA-vlan10] quit

  5. 将接口加入VLAN。

    # 把10GE1/0/1接口加入组播VLAN10,并允许所有用户VLAN通过。

    [~SwitchA] interface 10ge 1/0/1
    [~SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk pvid vlan 10
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 10 100 200 300 
    [*SwitchA-10GE1/0/1] commit 
    [~SwitchA-10GE1/0/1] quit

    # 把10GE1/0/210GE1/0/310GE1/0/4接口分别加入用户VLAN100、VLAN200、VLAN300。

    [~SwitchA] interface 10ge 1/0/2
    [~SwitchA-10GE1/0/2] port link-type access 
    [*SwitchA-10GE1/0/2] port default vlan 100
    [*SwitchA-10GE1/0/2] quit
    [*SwitchA] interface 10ge 1/0/3
    [*SwitchA-10GE1/0/3] port link-type access
    [*SwitchA-10GE1/0/3] port default vlan 200
    [*SwitchA-10GE1/0/3] quit
    [*SwitchA] interface 10ge 1/0/4
    [*SwitchA-10GE1/0/4] port link-type access
    [*SwitchA-10GE1/0/4] port default vlan 300
    [*SwitchA-10GE1/0/4] commit
    [~SwitchA-10GE1/0/4] quit
    
    说明:

    在RouterA上,需要保证RouterA与SwtichA相连的接口能终结VLAN的报文。您可以配置其三层子接口终结VLAN10、VLAN100、VLAN200和VLAN300。

  6. 验证配置结果,在SwitchA可以查看到组播VLAN和用户VLAN的信息。

    [~SwitchA] display multicast vlan mvlan
     Total: 1                                                        
     multicast-vlan     user-vlan number     snooping-state          
     ----------------------------------------------------------------
                 10                   3      IGMP Enable      
    [~SwitchA] display multicast vlan user-vlan 
     Total: 3                                                              
     user-vlan  snooping-state  multicast-vlan  snooping-state
     -----------------------------------------------------------------------------  
           100  IGMP Enable                10   IGMP Enable 
           200  IGMP Enable                10   IGMP Enable 
           300  IGMP Enable                10   IGMP Enable 

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 10 100 200 300
    #
    igmp snooping enable
    #
    vlan 10
     igmp snooping enable
     multicast vlan enable
     multicast vlan user-vlan 100 200 300 
    #
    vlan 100
     igmp snooping enable
    #
    vlan 200
     igmp snooping enable
    #
    vlan 300
     igmp snooping enable
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk pvid vlan 10
     port trunk allow-pass vlan 10 100 200 300
    #
    interface 10GE1/0/2
     port default vlan 100
    #
    interface 10GE1/0/3
     port default vlan 200
    #
    interface 10GE1/0/4
     port default vlan 300
    #
    return
    
翻译
下载文档
更新时间:2019-03-20

文档编号:EDOC1000166616

浏览量:65850

下载量:244

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页