所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 8800, 7800, 6800, 5800 V200R002C50 配置指南-IP组播

本文档介绍了IP组播的配置,具体包括IP组播基础、IGMP配置、MLD配置、PIM(IPv4)配置、PIM(IPv6)配置、MSDP配置、组播VPN配置、组播路由管理(IPv4)配置、组播路由管理(IPv6)配置、IGMP Snooping配置、MLD Snooping配置、静态组播MAC地址配置、组播VLAN配置和组播网管配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置双向PIM基本功能示例

配置双向PIM基本功能示例

组网需求

图4-29所示为某企业的一个园区办公网络。现要求在这个办公网络中部署合适的组播协议,使得接入网络的用户主机能够进行多方电视电话会议。

图4-29 配置双向PIM基本功能组网图

配置思路

在多方电视电话会议网络中,如果使用PIM-SM协议作为组播路由协议,当网络中接入的用户主机达到一定数量时,设备容易因转发资源的大量消耗而负担过重。为了节省设备转发资源,选取双向PIM协议作为组播路由协议,具体配置思路如下:

  1. 配置交换机接口IP地址和单播路由协议。组播域内路由协议PIM依赖单播路由协议,单播路由正常是组播协议正常工作的基础。

  2. 在所有提供组播服务的交换机上使能双向PIM。使能双向PIM功能是配置双向PIM其他功能的前提。

  3. 在交换机所有接口上使能PIM-SM功能。双向PIM协议与PIM-SM协议使用相同的邻居工作机制,只有接口使能了PIM-SM功能之后,才能建立邻居关系。

  4. 在与主机侧相连的交换机接口上使能IGMP。接收者能通过发送IGMP消息自由加入或者离开某个组播组。叶节点交换机通过IGMP协议来维护组成员关系列表。

  5. 配置RP,并指定服务的协议类型为双向PIM。在双向PIM网络中,RP是转发组播数据的中转站。建议RP的位置配置在组播流量分支较多的交换机上,如图4-29中SwitchE的位置。

操作步骤

  1. 配置各接口的IP地址和单播路由协议。

    按照图4-29配置各交换机接口的IP地址和掩码,配置各交换机间采用OSPF进行互连,确保网络中各交换机间能够在网络层互通,并且之间能够借助单播路由协议实现动态路由更新。

    # 配置SwitchA的接口加入VLAN。SwitchB、SwitchC、SwitchD和SwitchE的配置与SwitchA相似,配置过程略。

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 10 50
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port default vlan 10
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] interface 10ge 1/0/2
    [*SwitchA-10GE1/0/2] port link-type trunk
    [*SwitchA-10GE1/0/2] port trunk allow-pass vlan 50
    [*SwitchA-10GE1/0/2] quit
    [*SwitchA] commit
    

    # 配置SwitchA上VLANIF接口的IP地址。SwitchB、SwitchC、SwitchD和SwitchE的配置与SwitchA相似,配置过程略。

    [~SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] ip address 192.168.1.1 24
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 50
    [*SwitchA-Vlanif50] ip address 10.1.1.1 24
    [*SwitchA-Vlanif50] quit
    [*SwitchA] commit

    # 配置SwitchA上的单播路由协议OSPF。SwitchB、SwitchC、SwitchD和SwitchE的配置与SwitchA相似,配置过程略。

    [~SwitchA] ospf
    [*SwitchA-ospf-1] area 0
    [*SwitchA-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [*SwitchA-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [*SwitchA-ospf-1-area-0.0.0.0] commit
    [~SwitchA-ospf-1-area-0.0.0.0] quit
    [~SwitchA-ospf-1] quit

  2. 全局使能双向PIM功能,各接口上使能PIM-SM功能。

    # 在所有交换机全局使能双向PIM功能,各接口上使能PIM-SM功能。SwitchB、SwitchC、SwitchD和SwitchE的配置与SwitchA相似,配置过程略。

    [~SwitchA] multicast routing-enable
    [*SwitchA] pim
    [*SwitchA-pim] bidir-pim
    [*SwitchA-pim] quit
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] pim sm
    [*SwitchA-Vlanif10] commit
    [~SwitchA-Vlanif10] quit
    [~SwitchA] interface vlanif 50
    [~SwitchA-Vlanif50] pim sm
    [*SwitchA-Vlanif50] commit
    [~SwitchA-Vlanif50] quit
    

  3. 在连接用户主机的接口上使能IGMP功能。

    # 在SwitchA连接用户主机的接口上使能IGMP功能。SwitchB、SwitchC和SwitchD的配置与SwitchA相似,配置过程略。

    [~SwitchA] interface vlanif 10
    [~SwitchA-Vlanif10] igmp enable
    [*SwitchA-Vlanif10] commit
    [~SwitchA-Vlanif10] quit
    

  4. 配置RP。

    # 配置SwitchE的接口为C-RP接口和C-BSR接口,并指定C-RP为双向PIM协议服务。

    [~SwitchE] pim
    [~SwitchE-pim] c-bsr vlanif 60 
    [*SwitchE-pim] c-rp vlanif 60 bidir
    [*SwitchE-pim] commit
    [~SwitchE-pim] quit
    

  5. 验证配置结果。

    # 通过使用display pim bsr-info命令可以查看交换机上BSR选举的信息。例如SwitchA和SwitchE上BSR信息分别如下(SwitchE上还显示C-BSR信息):

    [~SwitchA] display pim bsr-info
     VPN-Instance: public net
     Elected AdminScoped BSR Count: 0
     Elected BSR Address: 10.1.2.2
         Priority: 0
         Hash mask length: 30
         State: Accept Preferred
         Scope: Not scoped
         Uptime: 00:05:57
         Expires: 00:01:27
         C-RP Count: 1
    
    
    [~SwitchE] display pim bsr-info
     VPN-Instance: public net
     Elected AdminScoped BSR Count: 0
     Elected BSR Address: 10.1.2.2
         Priority: 0
         Hash mask length: 30
         State: Elected
         Scope: Not scoped
         Uptime: 00:05:08
         Next BSR message scheduled at: 00:00:06
         C-RP Count: 1
     Candidate AdminScoped BSR Count: 0
     Candidate BSR Address: 10.1.2.2
         Priority: 0
         Hash mask length: 30
         State: Elected
         Scope: Not scoped   
         Wait to be BSR: 0

    通过上面显示的信息可以看出,选举出的BSR和C-BSR的IP地址都是10.1.2.2,为SwitchE接口VLANIF60的IP地址。

    # 通过使用display pim rp-info命令可以查看Switch上获取的RP信息。例如SwitchA上RP信息如下:

    [~SwitchA] display pim rp-info
     VPN-Instance: public net
     PIM-SM BSR RP Number:1
     Group/MaskLen: 224.0.0.0/4
         RP: 10.1.2.2
         Priority: 0
         Uptime: 00:10:49
         Expires: 00:01:41
         BIDIR: Y
    

    通过上面显示的信息可以看出,选举出的RP是10.1.2.2,为SwitchE接口VLANIF60的IP地址。并且选举出的RP为双向PIM协议服务。

    # 通过使用display pim df-info命令可以查看交换机上的DF信息。例如SwitchA和SwitchE上的DF信息分别如下:

    [~SwitchA] display pim df-info
     VPN-Instance: public net
     Total Number of DF = 2
    
     RP: 10.1.2.2
     Interface           DF-Address               DF-Uptime     Rpf-Interface
     Vlanif10            192.168.1.1(local)       00:25:01      N
     Vlanif50            10.1.1.2                 00:25:01      Y
    [~SwitchE] display pim df-info
     VPN-Instance: public net
     Total Number of DF = 4
    
     RP: 10.1.2.2
     Interface           DF-Address               DF-Uptime     Rpf-Interface
     Vlanif60            -                        -             Y
     Vlanif70            10.1.3.2(local)          00:31:44      N
     Vlanif50            10.1.1.2(local)          00:31:44      N
     Vlanif80            10.1.4.2(local)          00:31:44      N

    # 假设用户主机HostA、HostB、HostC和HostD通过IGMP协议都加入了组播组(225.0.0.1),通过使用display pim routing-table命令可以查看PIM协议路由表。例如SwitchA上显示信息如下:

    [~SwitchA] display pim routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 0 (S, G) entry
    
     (*, 225.0.0.1)
         RP: 10.1.2.2
         Protocol: bidir-pim, Flag: WC ACT
         UpTime: 00:36:47
         Rpf interface: Vlanif50
             Upstream neighbor: 10.1.1.2
         Downstream interface(s) information:
         Total number of downstreams: 2
            1: Vlanif10
                 Protocol: igmp, UpTime: 00:36:46, Expires: - 
            2: Vlanif50(RPF)
                 Protocol: bidir-pim, UpTime: 00:36:47, Expires: -

    通过上面显示的信息可以看出,PIM协议路由表项通过双向PIM协议生成,用户主机作为组播源发送的组播数据能够根据(*, 225.0.0.1)表项建立的双向RPT进行转发。

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 10 50
    #
    multicast routing-enable
    #
    interface Vlanif10
     ip address 192.168.1.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif50
     ip address 10.1.1.1 255.255.255.0
     pim sm 
    #
    interface 10GE1/0/1
     port default vlan 10
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
    #
    pim
     bidir-pim
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 20 60
    #
    multicast routing-enable
    #
    interface Vlanif20
     ip address 192.168.2.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif60
     ip address 10.1.2.1 255.255.255.0
     pim sm 
    #
    interface 10GE1/0/1
     port default vlan 20
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    ospf 1
     area 0.0.0.0
      network 10.1.2.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    pim
     bidir-pim
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 30 70
    #
    multicast routing-enable
    #
    interface Vlanif30
     ip address 192.168.3.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif70
     ip address 10.1.3.1 255.255.255.0
     pim sm 
    #
    interface 10GE1/0/1
     port default vlan 30
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 70
    #
    ospf 1
     area 0.0.0.0
      network 10.1.3.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
    #
    pim
     bidir-pim
    #
    return
  • SwitchD的配置文件

    #
    sysname SwitchD
    #
    vlan batch 40 80
    #
    multicast routing-enable
    #
    interface Vlanif40
     ip address 192.168.4.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif80
     ip address 10.1.4.1 255.255.255.0
     pim sm 
    #
    interface 10GE1/0/1
     port default vlan 40
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 80
    #
    ospf 1
     area 0.0.0.0
      network 10.1.4.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
    #
    pim
     bidir-pim
    #
    return
  • SwitchE的配置文件

    #
    sysname SwitchE
    #
    vlan batch 50 60 70 80
    #
    multicast routing-enable
    #
    interface Vlanif50
     ip address 10.1.1.2 255.255.255.0
     pim sm
    #
    interface Vlanif60
     ip address 10.1.2.2 255.255.255.0
     pim sm
    #
    interface Vlanif70
     ip address 10.1.3.2 255.255.255.0
     pim sm
    #
    interface Vlanif80
     ip address 10.1.4.2 255.255.255.0
     pim sm 
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 70
    #
    interface 10GE1/0/4
     port link-type trunk
     port trunk allow-pass vlan 80
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.1.2.0 0.0.0.255
      network 10.1.3.0 0.0.0.255
      network 10.1.4.0 0.0.0.255
    #
    pim
     c-bsr Vlanif60
     bidir-pim
     c-rp Vlanif60 bidir
    #
    return
翻译
下载文档
更新时间:2019-03-20

文档编号:EDOC1000166616

浏览量:63086

下载量:241

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页