所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 8800, 7800, 6800, 5800 V200R002C50 配置指南-IP组播

本文档介绍了IP组播的配置,具体包括IP组播基础、IGMP配置、MLD配置、PIM(IPv4)配置、PIM(IPv6)配置、MSDP配置、组播VPN配置、组播路由管理(IPv4)配置、组播路由管理(IPv6)配置、IGMP Snooping配置、MLD Snooping配置、静态组播MAC地址配置、组播VLAN配置和组播网管配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置基于PIM(IPv6)协议的Anycast RP示例

配置基于PIM(IPv6)协议的Anycast RP示例

组网需求

图5-3所示,Receiver1和Receiver2在网络中通过组播方式接收视频点播信息。当网络中负载较大或流量过于集中时,出现过RP压力过大、RP失效后路由收敛较慢等问题。Receiver2希望能够就近加入RP,从而快速接收到组播数据。

图5-3 配置基于PIM(IPv6)协议的Anycast RP组网图

表5-30 组网图信息表

设备

VLANIF接口/Loopback接口

IPv6地址

SwitchA

VLANIF10 FC00:0:0:3001::1/64
VLANIF20 FC00:0:0:2001::1/64

SwitchB

VLANIF50 FC00:0:0:2002::1/64

SwitchC

VLANIF20 FC00:0:0:2001::2/64
VLANIF40 FC00:0:0:2003::1/64
Loopback0 FC00:0:0:1::1/128
Loopback1 FC00:0:0:2::2/128

SwitchD

VLANIF40 FC00:0:0:2003::2/64
VLANIF50 FC00:0:0:2002::2/64
VLANIF60 FC00:0:0:3003::1/64
Loopback0 FC00:0:0:1::1/128
Loopback1 FC00:0:0:3::3/128

配置思路

配置基于PIM(IPv6)的Anycast RP,可以缓解单个RP的压力,并实现主机的就近加入。

  1. 配置各交换机的接口IP地址,采用OSPFv3协议实现网络层互通。

  2. 使能组播功能,在各接口启动PIM-SM(IPv6)功能。

  3. 在交换机与主机侧相连的接口使能MLD功能。

  4. 配置SwitchC和SwitchD的Loopback0接口为C-RP和C-BSR。

  5. 配置SwitchC和SwitchD的Loopback0接口为Anycast RP。

  6. 配置SwitchC和SwitchD的Loopback1接口为各自的Anycast RP本地地址。

  7. 配置SwitchC和SwitchD互为Anycast RP对等体。

操作步骤

  1. 配置各接口的IP地址和单播路由协议。

    # 按照图5-3配置各交换机接口的IP地址和掩码,配置各交换机间采用OSPFv3进行互连,确保网络中各交换机间能够在网络层互通,并且之间能够借助单播路由协议实现动态路由更新。SwitchB、SwitchC和SwitchD的配置与SwitchA相似,配置过程略,详见配置文件。

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] ospfv3 100
    [*SwitchA-ospfv3-100] router-id 10.1.1.1
    [*SwitchA-ospfv3-100] quit
    [*SwitchA] vlan batch 10 20
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type access
    [*SwitchA-10GE1/0/1] port default vlan 10
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] interface 10ge 1/0/2
    [*SwitchA-10GE1/0/2] port link-type trunk
    [*SwitchA-10GE1/0/2] port trunk allow-pass vlan 20
    [*SwitchA-10GE1/0/2] quit
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] ipv6 enable
    [*SwitchA-Vlanif10] ipv6 address fc00:0:0:3001::1 64
    [*SwitchA-Vlanif10] ospfv3 100 area 0
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 20
    [*SwitchA-Vlanif20] ipv6 enable
    [*SwitchA-Vlanif20] ipv6 address fc00:0:0:2001::1 64
    [*SwitchA-Vlanif20] ospfv3 100 area 0
    [*SwitchA-Vlanif20] quit
    [*SwitchA] commit

  2. 使能IPv6组播功能,在各接口上使能PIM-SM(IPv6)功能。

    # 在所有交换机使能IPv6组播功能,在各接口上使能PIM-SM(IPv6)功能。SwitchB、SwitchC和SwitchD的配置与SwitchA相似,配置过程略,详见配置文件。

    [~SwitchA] multicast ipv6 routing-enable
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] pim ipv6 sm
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 20
    [*SwitchA-Vlanif20] pim ipv6 sm
    [*SwitchA-Vlanif20] quit
    [*SwitchA] commit

  3. 在交换机与主机侧相连的接口使能MLD功能。

    # 在SwitchC和SwitchD与主机侧相连的接口使能MLD功能。

    # 配置SwitchC。

    [~SwitchC] interface vlanif 30
    [~SwitchC-Vlanif30] mld enable
    [*SwitchC-Vlanif30] quit
    [*SwitchC] commit

    # 配置SwitchD。

    [~SwitchD] interface vlanif 60
    [~SwitchD-Vlanif60] mld enable
    [*SwitchD-Vlanif60] quit
    [*SwitchD] commit

  4. 配置SwitchC和SwitchD的Loopback0接口为C-RP和C-BSR。

    # 配置SwitchC。

    [~SwitchC] pim ipv6
    [*SwitchC-pim6] c-bsr fc00:0:0:1::1
    [*SwitchC-pim6] c-rp fc00:0:0:1::1
    [*SwitchC-pim6] quit
    [*SwitchC] commit

    # 配置SwitchD。

    [~SwitchD] pim ipv6
    [*SwitchD-pim6] c-bsr fc00:0:0:1::1
    [*SwitchD-pim6] c-rp fc00:0:0:1::1
    [*SwitchD-pim6] quit
    [*SwitchD] commit

  5. 配置SwitchC和SwitchD的Loopback0接口为Anycast RP。

    # 配置SwitchC。

    [~SwitchC] pim ipv6
    [~SwitchC-pim6] anycast-rp fc00:0:0:1::1
    [*SwitchC-pim6-anycast-rp-fc00:0:0:1::1] quit
    [*SwitchC-pim6] quit
    [*SwitchC] commit

    # 配置SwitchD。

    [~SwitchD] pim ipv6
    [~SwitchD-pim6] anycast-rp fc00:0:0:1::1
    [*SwitchD-pim6-anycast-rp-fc00:0:0:1::1] quit
    [*SwitchD-pim6] quit
    [*SwitchD] commit

  6. 配置SwitchC和SwitchD的Loopback1接口为各自的Anycast RP本地地址。

    # 配置SwitchC。

    [~SwitchC] pim ipv6
    [~SwitchC-pim6] anycast-rp fc00:0:0:1::1
    [~SwitchC-pim6-anycast-rp-fc00:0:0:1::1] local-address fc00:0:0:2::2
    [*SwitchC-pim6-anycast-rp-fc00:0:0:1::1] quit
    [*SwitchC-pim6] quit
    [*SwitchC] commit

    # 配置SwitchD。

    [~SwitchD] pim ipv6
    [~SwitchD-pim6] anycast-rp fc00:0:0:1::1
    [~SwitchD-pim6-anycast-rp-fc00:0:0:1::1] local-address fc00:0:0:3::3
    [*SwitchD-pim6-anycast-rp-fc00:0:0:1::1] quit
    [*SwitchD-pim6] quit
    [*SwitchD] commit

  7. 配置SwitchC和SwitchD互为Anycast RP对等体。

    # 配置SwitchC。

    [~SwitchC] pim ipv6
    [~SwitchC-pim6] anycast-rp fc00:0:0:1::1
    [~SwitchC-pim6-anycast-rp-fc00:0:0:1::1] peer fc00:0:0:3::3
    [*SwitchC-pim6-anycast-rp-fc00:0:0:1::1] quit
    [*SwitchC-pim6] quit
    [*SwitchC] commit

    # 配置SwitchD。

    [~SwitchD] pim ipv6
    [~SwitchD-pim6] anycast-rp fc00:0:0:1::1
    [~SwitchD-pim6-anycast-rp-fc00:0:0:1::1] peer fc00:0:0:2::2
    [*SwitchD-pim6-anycast-rp-fc00:0:0:1::1] quit
    [*SwitchD-pim6] quit
    [*SwitchD] commit

  8. 验证配置结果。

    # 通过使用display pim ipv6 rp-info命令可以查看SwitchC和SwitchD上的RP信息。

    [~SwitchC] display pim ipv6 rp-info
     VPN-Instance: public net
     PIM-SM BSR RP Number:1
     Group/MaskLen: FF00::/8
         RP: FC00:0:0:1::1 (local)
         Priority: 192
         Uptime: 00:06:34
         Expires: 00:01:56
    
    [~SwitchD] display pim ipv6 rp-info
     VPN-Instance: public net
     PIM-SM BSR RP Number:1
     Group/MaskLen: FF00::/8
         RP: FC00:0:0:1::1 (local)
         Priority: 192
         Uptime: 00:06:34
         Expires: 00:01:56
    

    由以上显示信息可知,SwitchC和SwitchD都作为网络中的RP,可以相互转发组播源注册信息。

    # 通过使用display pim ipv6 routing-table命令可以查看交换机上的PIM表项。PIM-SM域内组播源Source(FC00:0:0:3001::2/64)向组播组G(FF2E::1)发送组播信息,用户Receiver2加入组播组G,接收发往组G的组播数据。Source向SwitchC注册,Receiver2向SwitchD发起加入。

    [~SwitchC] display pim ipv6 routing-table
     VPN-Instance: public net
     Total 0 (*, G) entry; 1 (S, G) entry
    
     (FC00:0:0:3001::2, FF2E::1)
         RP: FC00:0:0:1::1 (local)
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 00:00:38
         Upstream interface: Register
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif30
                 Protocol: pim-sm, UpTime: 00:01:25, Expires: -
    
    
    [~SwitchD] display pim ipv6 routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
    
     (*, FF2E::1)
         RP: FC00:0:0:1::1 (local)
         Protocol: pim-sm, Flag: WC
         UpTime: 00:01:25
         Upstream interface: Register
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif60
                 Protocol: pim-sm, UpTime: 00:01:25, Expires: -
    
     (FC00:0:0:3001::2, FF2E::1)
         RP: FC00:0:0:1::1 (local)
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 00:00:02
         Upstream interface: Register
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif60
                 Protocol: pim-sm, UpTime: 00:00:02, Expires: -
    
    

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 10 20
    #
    multicast ipv6 routing-enable
    #
    ospfv3 100
     router-id 10.1.1.1
     area 0.0.0.0
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address FC00:0:0:3001::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address FC00:0:0:2001::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/0/1
     port default vlan 10
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 50
    #
    multicast ipv6 routing-enable
    #
    ospfv3 100
     router-id 10.2.2.2
     area 0.0.0.0
    #
    interface Vlanif50
     ipv6 enable
     ipv6 address FC00:0:0:2002::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 20 30 40
    #
    multicast ipv6 routing-enable
    #
    ospfv3 100
     router-id 10.3.3.3
     area 0.0.0.0
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address FC00:0:0:2001::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address FC00:0:0:3002::1/64
     pim ipv6 sm
     mld enable
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif40
     ipv6 enable
     ipv6 address FC00:0:0:2003::1/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface 10GE1/0/3
     port default vlan 30
    #
    interface LoopBack0
     ipv6 enable
     ipv6 address FC00:0:0:1::1/128
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface LoopBack1
     ipv6 enable
     ipv6 address FC00:0:0:2::2/128
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    pim ipv6
     c-bsr FC00:0:0:1::1
     c-rp FC00:0:0:1::1
     anycast-rp FC00:0:0:1::1
      local-address FC00:0:0:2::2
      peer FC00:0:0:3::3
    #
    return
  • SwitchD的配置文件

    #
    sysname SwitchD
    #
    vlan batch 40 50 60
    #
    multicast ipv6 routing-enable
    #
    ospfv3 100
     router-id 10.4.4.4
     area 0.0.0.0
    #
    interface Vlanif40
     ipv6 enable
     ipv6 address FC00:0:0:2003::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif50
     ipv6 enable
     ipv6 address FC00:0:0:200FC00:0:0:2::2/64
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface Vlanif60
     ipv6 enable
     ipv6 address FC00:0:0:3003::1/64
     pim ipv6 sm
     mld enable
     ospfv3 100 area 0.0.0.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    interface 10GE1/0/2
     port default vlan 60
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface LoopBack0
     ipv6 enable
     ipv6 address FC00:0:0:1::1/128
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    interface LoopBack1
     ipv6 enable
     ipv6 address FC00:0:0:3::3/128
     pim ipv6 sm
     ospfv3 100 area 0.0.0.0
    #
    pim ipv6
     c-bsr FC00:0:0:1::1
     c-rp FC00:0:0:1::1
     anycast-rp FC00:0:0:1::1
      local-address FC00:0:0:3::3
      peer FC00:0:0:2::2
    #
    return
    
翻译
下载文档
更新时间:2019-03-20

文档编号:EDOC1000166616

浏览量:65977

下载量:244

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页