所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 8800, 7800, 6800, 5800 V200R002C50 配置指南-IP组播

本文档介绍了IP组播的配置,具体包括IP组播基础、IGMP配置、MLD配置、PIM(IPv4)配置、PIM(IPv6)配置、MSDP配置、组播VPN配置、组播路由管理(IPv4)配置、组播路由管理(IPv6)配置、IGMP Snooping配置、MLD Snooping配置、静态组播MAC地址配置、组播VLAN配置和组播网管配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置IPv6组播负载分担示例

配置IPv6组播负载分担示例

组网需求

图8-8所示的IPv6组播网络中,与HostA相连的SwitchE到组播源Source之间存在3条等价路由。默认的RPF检查规则会选取其中的一条进行组播数据的传输,若组播流量过大,可能会出现网络拥塞,影响组播业务。要求通过配置IPv6组播负载分担,实现组播数据可以在多条等价路由上进行分流。

图8-8 配置组播负载分担组网图

表8-10 组网图信息表

Switch

接口

VLANIF接口

IP地址

SwitchA

10GE1/0/1 VLANIF20

FC00:0:0:2::1/64

10GE1/0/2 VLANIF30

FC00:0:0:3::1/64

10GE1/0/3 VLANIF40

FC00:0:0:4::1/64

10GE1/0/4 VLANIF10

FC00:0:0:1::1/64

Loopback0

FC00:1:1:1::1/128

SwitchB

10GE1/0/1

VLANIF20

FC00:0:0:2::2/64

10GE1/0/2

VLANIF60

FC00:0:0:5::1/64

SwitchC

10GE1/0/1

VLANIF30

FC00:0:0:3::2/64

10GE1/0/2

VLANIF80

FC00:0:0:6::1/64

SwitchD

10GE1/0/1

VLANIF40

FC00:0:0:4::2/64

10GE1/0/2

VLANIF100

FC00:0:0:7::1/64

SwitchE

10GE1/0/1

VLANIF60

FC00:0:0:5::2/64

10GE1/0/2

VLANIF80

FC00:0:0:6::2/64

10GE1/0/3

VLANIF100

FC00:0:0:7::2/64

10GE1/0/4

VLANIF140

FC00:0:0:8::1/64

配置思路

采用如下的思路配置组播负载分担:

  1. 配置各交换机的接口IPv6地址。

  2. 配置IPv6单播路由协议IS-IS(IPv6),使所有交换机单播互通,且所有路由开销相同。

  3. 在所有交换机上使能IPv6组播路由功能,并在各接口上使能PIM-SM(IPv6),将SwitchA的环回接口配置为RP。

  4. 为了保证组播业务的稳定可靠,在SwitchE上配置稳定优先的IPv6组播负载分担。

  5. HostA需要长期接收某些组播组的数据。配置SwitchE的主机侧接口以静态方式批量加入组播组。

操作步骤

  1. 配置各交换机接口的IPv6地址

    # 在各交换机上创建VLAN,并将二层物理接口加入VLAN。以下为SwitchA的配置示例,SwitchB、SwitchC、SwitchD和SwitchE上的配置与SwitchA相似,配置过程略。

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 10 20 30 40
    [*SwitchA] interface 10ge 1/0/4
    [*SwitchA-10GE1/0/4] port link-type access
    [*SwitchA-10GE1/0/4] port default vlan 10
    [*SwitchA-10GE1/0/4] quit
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 20
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] interface 10ge 1/0/2
    [*SwitchA-10GE1/0/2] port link-type trunk
    [*SwitchA-10GE1/0/2] port trunk allow-pass vlan 30
    [*SwitchA-10GE1/0/2] quit
    [*SwitchA] interface 10ge 1/0/3
    [*SwitchA-10GE1/0/3] port link-type trunk
    [*SwitchA-10GE1/0/3] port trunk allow-pass vlan 40
    [*SwitchA-10GE1/0/3] quit
    [*SwitchA] commit

    # 在各交换机的三层接口配置IPv6地址和掩码。以下为SwitchA的配置示例,SwitchB、SwitchC、SwitchD和SwitchE上的配置与SwitchA相似,配置过程略。

    [~SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] ipv6 enable
    [*SwitchA-Vlanif10] ipv6 address fc00:0:0:1::1 64
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 20
    [*SwitchA-Vlanif20] ipv6 enable
    [*SwitchA-Vlanif20] ipv6 address fc00:0:0:2::1 64
    [*SwitchA-Vlanif20] quit
    [*SwitchA] interface vlanif 30
    [*SwitchA-Vlanif30] ipv6 enable
    [*SwitchA-Vlanif30] ipv6 address fc00:0:0:3::1 64
    [*SwitchA-Vlanif30] quit
    [*SwitchA] interface vlanif 40
    [*SwitchA-Vlanif40] ipv6 enable
    [*SwitchA-Vlanif40] ipv6 address fc00:0:0:4::1 64
    [*SwitchA-Vlanif40] quit
    [*SwitchA] interface loopback0
    [*SwitchA-LoopBack0] ipv6 enable
    [*SwitchA-LoopBack0] ipv6 address fc00:1:1:1::1 128
    [*SwitchA-LoopBack0] quit
    [*SwitchA] commit

  2. 配置IS-IS(IPv6)协议,使所有交换机单播互通,且所有路由开销相同

    # 以下为SwitchA的配置示例,SwitchB、SwitchC、SwitchD和SwitchE上的配置与SwitchA相似,配置过程略。

    [~SwitchA] isis
    [*SwitchA-isis-1] ipv6 enable topology standard
    [*SwitchA-isis-1] network-entity 10.0000.0000.0001.00
    [*SwitchA-isis-1] quit
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] isis ipv6 enable
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 20
    [*SwitchA-Vlanif20] isis ipv6 enable
    [*SwitchA-Vlanif20] quit
    [*SwitchA] interface vlanif 30
    [*SwitchA-Vlanif30] isis ipv6 enable
    [*SwitchA-Vlanif30] quit
    [*SwitchA] interface vlanif 40
    [*SwitchA-Vlanif40] isis ipv6 enable
    [*SwitchA-Vlanif40] quit
    [*SwitchA] interface loopback0
    [*SwitchA-LoopBack0] isis ipv6 enable
    [*SwitchA-LoopBack0] quit
    [*SwitchA] commit

  3. 在所有交换机上使能IPv6组播功能,并在各接口上使能PIM-SM(IPv6)

    # 以下为SwitchA的配置示例,SwitchB、SwitchC、SwitchD和SwitchE上的配置与SwitchA相似,配置过程略。

    [~SwitchA] multicast ipv6 routing-enable
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] pim ipv6 sm
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 20
    [*SwitchA-Vlanif20] pim ipv6 sm
    [*SwitchA-Vlanif20] quit
    [*SwitchA] interface vlanif 30
    [*SwitchA-Vlanif30] pim ipv6 sm
    [*SwitchA-Vlanif30] quit
    [*SwitchA] interface vlanif 40
    [*SwitchA-Vlanif40] pim ipv6 sm
    [*SwitchA-Vlanif40] quit
    [*SwitchA] interface loopback 0
    [*SwitchA-LoopBack0] pim ipv6 sm
    [*SwitchA-LoopBack0] quit
    [*SwitchA] commit

  4. 在SwitchA上配置RP

    # 配置SwitchA的Loopback0接口地址为RP地址。

    [~SwitchA] pim ipv6
    [*SwitchA-pim6] c-bsr fc00:1:1:1::1
    [*SwitchA-pim6] c-rp fc00:1:1:1::1
    [*SwitchA-pim6] quit
    [*SwitchA] commit

  5. 在SwitchE上配置稳定优先的IPv6组播负载分担

    [~SwitchE] multicast ipv6 load-splitting stable-preferred
    [*SwitchE] commit

  6. 配置SwitchE的主机侧接口以静态方式批量加入组播组

    # 配置接口VLANIF140以静态方式加入组播组FF13::1~FF13::3。

    [~SwitchE] interface vlanif 140
    [~SwitchE-Vlanif140] mld static-group ff13::1 inc-step-mask 128 number 3
    [*SwitchE-Vlanif140] quit
    [*SwitchE] commit

  7. 验证稳定优先的IPv6组播负载分担的配置结果

    # Source(FC00:0:0:1::2/64)向组播组FF13::1~FF13::3发送组播数据。HostA能够收到Source发出的组播数据。在SwitchE上查看PIM(IPv6)路由表的概要信息。

    [~SwitchE] display pim ipv6 routing-table brief
     VPN-Instance: public net
     Total 3 (*, G) entries; 3 (S, G) entries
    
      00001.(*, FF13::1)
           Upstream interface:Vlanif60
           Number of downstream:1
      00002.(FC00:0:0:1::2, FF13::1)
           Upstream interface:Vlanif60
           Number of downstream:1
      00003.(*, FF13::2)
           Upstream interface:Vlanif80
           Number of downstream:1
      00004.(FC00:0:0:1::2, FF13::2)
           Upstream interface:Vlanif80
           Number of downstream:1
      00005.(*, FF13::3)
           Upstream interface:Vlanif100
           Number of downstream:1
      00006.(FC00:0:0:1::2, FF13::3)
           Upstream interface:Vlanif100
           Number of downstream:1

    (*,G)和(S,G)表项平均分布在三条等价路由上,上游接口分别为VLANIF60、VLANIF80和VLANIF100。

    说明:

    负载分担算法对(*,G)和(S,G)表项分别处理,且处理规则相同。

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 10 20 30 40
    #
    multicast ipv6 routing-enable
    #
    isis 1
     network-entity 10.0000.0000.0001.00
     #
     ipv6 enable topology standard
     #
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address FC00:0:0:1::1/64
     pim ipv6 sm
     isis ipv6 enable 1
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address FC00:0:0:2::1/64
     pim ipv6 sm
     isis ipv6 enable 1
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address FC00:0:0:3::1/64
     pim ipv6 sm
     isis ipv6 enable 1
    #
    interface Vlanif40
     ipv6 enable
     ipv6 address FC00:0:0:4::1/64
     pim ipv6 sm
     isis ipv6 enable 1
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface 10GE1/0/4
     port default vlan 10
    #
    interface LoopBack0
     ipv6 enable
     ipv6 address FC00:1:1:1::1/128
     pim ipv6 sm
     isis ipv6 enable 1
    #
    pim ipv6
     c-bsr FC00:1:1:1::1
     c-rp FC00:1:1:1::1
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 20 60
    #
    multicast ipv6 routing-enable
    #
    isis 1
     network-entity 10.0000.0000.0002.00
     #
     ipv6 enable topology standard
     #
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address FC00:0:0:2::2/64
     pim ipv6 sm
     isis ipv6 enable 1
    #
    interface Vlanif60
     ipv6 enable
     ipv6 address FC00:0:0:5::1/64
     pim ipv6 sm
     isis ipv6 enable 1
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    return 
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 30 80
    #
    multicast ipv6 routing-enable
    #
    isis 1
     network-entity 10.0000.0000.0003.00
     #
     ipv6 enable topology standard
     #
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address FC00:0:0:3::2/64
     pim ipv6 sm
     isis ipv6 enable 1
    #
    interface Vlanif80
     ipv6 enable
     ipv6 address FC00:0:0:6::1/64
     pim ipv6 sm
     isis ipv6 enable 1
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 80
    #
    return
  • SwitchD的配置文件

    #
    sysname SwitchD
    #
    vlan batch 40 100
    #
    multicast ipv6 routing-enable
    #
    isis 1
     network-entity 10.0000.0000.0004.00
     #
     ipv6 enable topology standard
     #
    #
    interface Vlanif40
     ipv6 enable
     ipv6 address FC00:0:0:4::2/64
     pim ipv6 sm
     isis ipv6 enable 1
    #
    interface Vlanif100
     ipv6 enable
     ipv6 address FC00:0:0:7::1/64
     pim ipv6 sm
     isis ipv6 enable 1
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    return
  • SwitchE的配置文件

    #
    sysname SwitchE
    #
    vlan batch 60 80 100 140
    #
    multicast ipv6 routing-enable
    multicast ipv6 load-splitting stable-preferred
    #
    isis 1
     network-entity 10.0000.0000.0005.00
     #
     ipv6 enable topology standard
     #
    #
    interface Vlanif60
     ipv6 enable
     ipv6 address FC00:0:0:5::2/64
     pim ipv6 sm
     isis ipv6 enable 1
    #
    interface Vlanif80
     ipv6 enable
     ipv6 address FC00:0:0:6::2/64
     pim ipv6 sm
     isis ipv6 enable 1
    #
    interface Vlanif100
     ipv6 enable
     ipv6 address FC00:0:0:7::2/64
     pim ipv6 sm
     isis ipv6 enable 1
    #
    interface Vlanif140
     ipv6 enable
     ipv6 address FC00:0:0:8::1/64
     pim ipv6 sm
     mld static-group FF13::1 inc-step-mask 128 number 3
     isis ipv6 enable 1
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 80
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface 10GE1/0/4
     port default vlan 140
    #
    return
翻译
下载文档
更新时间:2019-03-20

文档编号:EDOC1000166616

浏览量:65735

下载量:244

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页