所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 8800, 7800, 6800, 5800 V200R002C50 配置指南-IP组播

本文档介绍了IP组播的配置,具体包括IP组播基础、IGMP配置、MLD配置、PIM(IPv4)配置、PIM(IPv6)配置、MSDP配置、组播VPN配置、组播路由管理(IPv4)配置、组播路由管理(IPv6)配置、IGMP Snooping配置、MLD Snooping配置、静态组播MAC地址配置、组播VLAN配置和组播网管配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置IGMP Snooping查询器示例

配置IGMP Snooping查询器示例

组网需求

图9-10所示,在一个没有三层设备纯二层网络环境中,组播源Source1和Source2分别向组播组224.1.1.1和225.1.1.1发送组播数据。HostA和HostC加入组播组224.1.1.1,HostB和HostD则加入组播组225.1.1.1,所有接收者均使用IGMPv2。希望通过IGMP Snooping实现二层网络中组播数据的传输。

图9-10 配置IGMP Snooping查询器组网图

配置思路

在网络中各Switch上使能IGMP Snooping功能,并配置某一台Switch为IGMP Snooping查询器,可以实现此需求。同时为防止设备在没有二层组播转发表项时将组播数据在VLAN内广播,在所有Switch上都使能丢弃未知组播数据报文功能。

  1. 根据图9-10在所有Switch上创建VLAN并将接口加入VLAN。
  2. 在所有Switch上使能全局和VLAN的IGMP Snooping功能。
  3. 选择距离组播源较近的SwitchA为IGMP Snooping查询器。
  4. 在所有Switch上使能丢弃未知组播数据报文功能。

操作步骤

  1. 在所有Switch上创建VLAN并将接口加入VLAN。

    # 配置SwitchA。

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan 10
    [*SwitchA-vlan10] quit
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port default vlan 10
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] interface 10ge 1/0/2
    [*SwitchA-10GE1/0/2] port link-type trunk
    [*SwitchA-10GE1/0/2] port trunk allow-pass vlan 10
    [*SwitchA-10GE1/0/2] quit
    [*SwitchA] interface 10ge 1/0/3
    [*SwitchA-10GE1/0/3] port default vlan 10
    [*SwitchA-10GE1/0/3] commit
    [~SwitchA-10GE1/0/3] quit

    # SwitchB、SwitchC、SwitchD的配置与此类似,不再赘述。

  2. 在所有Switch上使能全局和VLAN的IGMP Snooping功能。

    # 配置SwitchA。

    [~SwitchA] igmp snooping enable
    [*SwitchA] vlan 10
    [*SwitchA-vlan10] igmp snooping enable
    [*SwitchA-vlan10] commit
    [~SwitchA-vlan10] quit

    # SwitchB、SwitchC、SwitchD的配置与此类似,不再赘述。

  3. 配置SwitchA为查询器。

    [~SwitchA] vlan 10
    [~SwitchA-vlan10] igmp snooping querier enable
    [*SwitchA-vlan10] commit
    [~SwitchA-vlan10] quit

  4. 在所有Switch上使能丢弃未知组播数据报文功能。

    # 配置SwitchA。

    [~SwitchA] vlan 10
    [~SwitchA-vlan10] multicast drop-unknown
    [*SwitchA-vlan10] commit
    [~SwitchA-vlan10] quit
    

    # SwitchB、SwitchC、SwitchD的配置与此类似,不再赘述。

  5. 验证配置结果。

    # 当IGMP Snooping查询器开始工作之后,除查询器以外的所有设备都能收到IGMP普遍组查询报文。可以通过命令查看IGMP报文的统计信息,例如查看SwitchB上收到的IGMP报文统计信息。

    [~SwitchB] display igmp snooping statistics vlan 10
     IGMP Snooping Packets Counter:                                                  
       Statistics for VLAN 10                                                       
         Receive V1 Report:          0                                                  
         Receive V2 Report:          32                                                 
         Receive V3 Report:          0                                                  
         Receive V1 Query:           0                                                  
         Receive V2 Query:         30                              
         Receive V3 Query:           0                                                  
         Receive Leave:              0                                                  
         Receive Pim Hello:          0                                                  
         Send Query (S=0):           0                                                  
         Send Query (S!=0):          -                                                  
         Proxy Send General Query:                0                                   
         Proxy Send Group-Specific Query:         0                                   
         Proxy Send Group-Source-Specific Query:  0                                   
    

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 10
    #
    igmp snooping enable
    #
    vlan 10
     igmp snooping enable
     igmp snooping querier enable
     multicast drop-unknown
    #
    interface 10GE1/0/1
     port default vlan 10
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/0/3
     port default vlan 10
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 10
    #
    igmp snooping enable
    #
    vlan 10
     igmp snooping enable
     multicast drop-unknown
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/0/3
     port default vlan 10
    #
    interface 10GE1/0/4
     port default vlan 10
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 10
    #
    igmp snooping enable
    #
    vlan 10
     igmp snooping enable
     multicast drop-unknown
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE1/0/3
     port default vlan 10
    #
    return
  • SwitchD的配置文件

    #
    sysname SwitchD
    #
    vlan batch 10
    #
    igmp snooping enable
    #
    vlan 10
     igmp snooping enable
     multicast drop-unknown
    #
    interface 10GE1/0/1
     port default vlan 10
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
翻译
下载文档
更新时间:2019-03-20

文档编号:EDOC1000166616

浏览量:62974

下载量:241

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页