所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 8800, 7800, 6800, 5800 V200R002C50 配置指南-IP组播

本文档介绍了IP组播的配置,具体包括IP组播基础、IGMP配置、MLD配置、PIM(IPv4)配置、PIM(IPv6)配置、MSDP配置、组播VPN配置、组播路由管理(IPv4)配置、组播路由管理(IPv6)配置、IGMP Snooping配置、MLD Snooping配置、静态组播MAC地址配置、组播VLAN配置和组播网管配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置IGMP Snooping Over VXLAN示例

配置IGMP Snooping Over VXLAN示例

组网需求

部署IGMP Snooping Over VXLAN可以解决组播流量在VXLAN网络的广播域BD(Bridge Domain)内泛洪的问题,使得组播流量在VXLAN网络的入节点就可以根据用户点播情况按需转发。

图9-13所示,某企业在不同的数据中心中都拥有自己的VM,服务器1上的VM1属于VLAN 10,服务器2上的VM1属于VLAN 10,服务器3上的VM1属于VLAN 20。其中服务器1上的VM为组播源,服务器2、服务器3上的VM为组播用户。现需要通过VXLAN和IGMP Snooping实现不同数据中心之间用户VM1点播服务器1上组播源VM1提供的业务。

图9-13 配置IGMP Snooping Over VXLAN组网图
表9-9 接口的IP地址

设备

接口

IP地址

Device1

10GE1/0/1

192.168.1.1/24

LoopBack0

1.1.1.1/32

Device2

10GE1/0/1

192.168.2.1/24

LoopBack0

2.2.2.2/32

Device3

10GE1/0/1

192.168.3.1/24

LoopBack0

3.3.3.3/32

Device4

10GE1/0/1

192.168.1.2/24

10GE1/0/2

192.168.2.2/24

10GE1/0/3

192.168.3.2/24

LoopBack0

4.4.4.4/32

配置思路

采用如下思路配置IGMP Snooping Over VXLAN:
  1. 在Device1、Device2、Device3和Device4上配置路由协议,保证网络三层互通。
  2. 在Device1、Device2和Device3上配置VXLAN业务接入点,实现区分业务流量。
  3. 在Device1、Device2、Device3和Device4上使能EVPN作为VXLAN控制平面功能,配置Device4作为RR反射器与Device1、Device2、Device3之间建立BGP EVPN对等体关系,在Device1、Device2和Device3上配置EVPN实例、并配置头端复制功能,使得Device1与Device2、Device1与Device3之间建立VXLAN隧道。
  4. 在所有业务接入点Device1、Device2和Device3的全局和广播域BD内使能IGMP Snooping,在与组播源相连的Device1的广播域BD内使能IGMP Snooping Proxy,实现VXLAN网络的二层组播功能。

数据准备

为完成此配置例,需准备如下的数据:

  • VM所属的VLAN ID分别是VLAN 10和VLAN 20。
  • 网络中设备互连的接口IP地址,详细数据请参见表9-9
  • 广播域BD ID是BD 10。
  • VXLAN网络标识VNI ID是VNI 10。

操作步骤

  1. 配置路由协议

    # 配置Device1。Device2、Device3和Device4的配置与Device1类似,这里不再赘述。具体配置请参考配置文件

    <HUAWEI> system-view
    [~HUAWEI] sysname Device1
    [*HUAWEI] commit
    [~Device1] interface loopback 0
    [*Device1-LoopBack0] ip address 1.1.1.1 32
    [*Device1-LoopBack0] quit
    [*Device1] interface 10ge 1/0/1
    [*Device1-10GE1/0/1] undo portswitch
    [*Device1-10GE1/0/1] ip address 192.168.1.1 24
    [*Device1-10GE1/0/1] quit
    [*Device1] bgp 100
    [*Device1-bgp] peer 192.168.1.2 as-number 400
    [*Device1-bgp] network 1.1.1.1 32
    [*Device1-bgp] quit
    [*Device1] commit

  2. 配置VXLAN隧道模式并使能VXLAN的ACL扩展功能(仅CE6870EI设备需要配置此步骤)

    # 配置Device1。Device2、Device3的配置与Device1类似,这里不再赘述。具体配置请参考配置文件

    [~Device1] ip tunnel mode vxlan
    [*Device1] assign forward nvo3 acl extend enable
    [*Device1] commit
    
    说明:

    配置VXLAN隧道模式、使能VXLAN的ACL扩展功能后,需要保存配置并重启设备才能生效,您可以选择立即重启或完成所有配置后再重启。

  3. 分别在Device1、Device2、Device3上配置业务接入点

    # 配置Device1。Device2、Device3的配置与Device1类似,这里不再赘述。具体配置请参考配置文件

    [~Device1] bridge-domain 10
    [*Device1-bd10] quit
    [*Device1] interface 10ge 1/0/2.1 mode l2
    [*Device1-10GE1/0/2.1] encapsulation dot1q vid 10
    [*Device1-10GE1/0/2.1] bridge-domain 10
    [*Device1-10GE1/0/2.1] quit
    [*Device1] commit

  4. 配置VXLAN隧道
    1. 使能EVPN作VXLAN控制平面

      # 配置Device1。Device2、Device3和Device4的配置与Device1类似,这里不再赘述。具体配置请参考配置文件

      [~Device1] evpn-overlay enable
      [*Device1] commit

    2. 在Device4上建立与Device1、Device2和Device3之间的BGP EVPN对等体关系,并配置反射器功能,指定Device1、Device2和Device3作为反射器的客户机

      # 在Device4上配置BGP EVPN对等体关系,并配置反射器功能。
      [~Device4] bgp 100 instance evpn1
      [*Device4-bgp-instance-evpn1] peer 1.1.1.1 as-number 100
      [*Device4-bgp-instance-evpn1] peer 1.1.1.1 connect-interface LoopBack0
      [*Device4-bgp-instance-evpn1] peer 2.2.2.2 as-number 100
      [*Device4-bgp-instance-evpn1] peer 2.2.2.2 connect-interface LoopBack0
      [*Device4-bgp-instance-evpn1] peer 3.3.3.3 as-number 100
      [*Device4-bgp-instance-evpn1] peer 3.3.3.3 connect-interface LoopBack0
      [*Device4-bgp-instance-evpn1] l2vpn-family evpn
      [*Device4-bgp-instance-evpn1-af-evpn] peer 1.1.1.1 enable
      [*Device4-bgp-instance-evpn1-af-evpn] peer 1.1.1.1 reflect-client
      [*Device4-bgp-instance-evpn1-af-evpn] peer 2.2.2.2 enable
      [*Device4-bgp-instance-evpn1-af-evpn] peer 2.2.2.2 reflect-client
      [*Device4-bgp-instance-evpn1-af-evpn] peer 3.3.3.3 enable
      [*Device4-bgp-instance-evpn1-af-evpn] peer 3.3.3.3 reflect-client
      [*Device4-bgp-instance-evpn1-af-evpn] undo policy vpn-target
      [*Device4-bgp-instance-evpn1-af-evpn] quit
      [*Device4-bgp-instance-evpn1] quit
      [*Device4] commit

    3. 在Device1、Device2和Device3上建立与Device4之间的BGP EVPN对等体关系

      # 在Device1上配置BGP EVPN对等体关系。Device2、Device3的配置与Device1类似,这里不再赘述。具体配置请参考配置文件
      [~Device1] bgp 100 instance evpn1
      [*Device1-bgp-instance-evpn1] peer 4.4.4.4 as-number 100
      [*Device1-bgp-instance-evpn1] peer 4.4.4.4 connect-interface LoopBack0
      [*Device1-bgp-instance-evpn1] l2vpn-family evpn
      [*Device1-bgp-instance-evpn1-af-evpn] peer 4.4.4.4 enable
      [*Device1-bgp-instance-evpn1-af-evpn] quit
      [*Device1-bgp-instance-evpn1] quit
      [*Device1] commit

    4. 在Device1、Device2和Device3上配置EVPN实例

      # 配置Device1。Device2、Device3的配置与Device1类似,这里不再赘述。具体配置请参考配置文件

      [~Device1] bridge-domain 10
      [*Device1-bd10] vxlan vni 10
      [*Device1-bd10] evpn
      [*Device1-bd10-evpn] route-distinguisher 10:1
      [*Device1-bd10-evpn] vpn-target 10:1
      [*Device1-bd10-evpn] vpn-target 11:1 export-extcommunity
      [*Device1-bd10-evpn] quit
      [*Device1-bd10] quit
      [*Device1] commit

    5. 在Device1、Device2、Device3上使能头端复制功能

      # 配置Device1。Device2、Device3的配置与Device1类似,这里不再赘述。具体配置请参考配置文件

      [~Device1] interface nve 1
      [*Device1-Nve1] source 1.1.1.1
      [*Device1-Nve1] mac-address 0000-5e00-0101
      [*Device1-Nve1] vni 10 head-end peer-list protocol bgp
      [*Device1-Nve1] quit
      [*Device1] commit

  5. 配置IGMP Snooping Over VXLAN
    1. 全局和广播域BD内使能IGMP Snooping

      # 配置Device1。Device2、Device3的配置与Device1类似,这里不再赘述。具体配置请参考配置文件

      [~Device1] igmp snooping enable
      [*Device1] bridge-domain 10
      [*Device1-bd10] igmp snooping enable
      [*Device1-bd10] quit
      [*Device1] commit

    2. 广播域BD内使能IGMP Snooping Proxy

      # 配置Device1。

      [~Device1] bridge-domain 10
      [*Device1-bd10] igmp snooping proxy
      [*Device1-bd10] quit
      [*Device1] commit

  6. 检查配置结果

    上述配置成功后,在Device1、Device2、Device3上执行display vxlan tunnel命令可查看到VXLAN隧道的信息。以Device1的显示为例。

    [~Device1] display vxlan tunnel
    Number of vxlan tunnel : 2
    Tunnel ID   Source                Destination           State  Type     Uptime
    -----------------------------------------------------------------------------------
    4026531841  1.1.1.1               2.2.2.2               up     dynamic  00:14:45
    4026531842  1.1.1.1               3.3.3.3               up     dynamic  00:09:42
    

    配置完成后,服务器2和服务器3上的VM可以点播服务器1上的VM发出的组播流量,流量在VXLAN网络中按需转发。在Device1、Device2、Device3上执行display igmp snooping port-info命令可查看到组播成员端口信息。以Device3的显示为例。

    [~Device3] display igmp snooping port-info bridge-domain 10 verbose 
    The port information of Group 235.1.1.1 on Bridge-domain 10:
      Time of this group has been up : 00:01:34
    
      The port information of (*, 235.1.1.1):
        Time of this source has been up : 00:01:34
        Port Table on this source(*):
        Source flags: IGMP
        List of ports in include mode :
          No.1
            Port name : 10GE1/0/2.1(VID:20)
            Time of this port has been up as a host-port : 00:01:35
            Remain time of port expire as dynamic host-port : --
            Host-port flags : Dynamic
        There are 1 port(s) in include mode.
    

配置文件

  • Device1的配置文件(CE6870EI)

    #
    sysname Device1
    #
    assign forward nvo3 acl extend enable
    #
    evpn-overlay enable
    #
    igmp snooping enable
    #
    bridge-domain 10
     vxlan vni 10
     igmp snooping enable
     igmp snooping proxy
     evpn
      route-distinguisher 10:1
      vpn-target 10:1 export-extcommunity
      vpn-target 11:1 export-extcommunity
      vpn-target 10:1 import-extcommunity
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 192.168.1.1 255.255.255.0
    #
    interface 10GE1/0/2.1 mode l2
     encapsulation dot1q vid 10
     bridge-domain 10
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
    #
    interface Nve1
     source 1.1.1.1
     vni 10 head-end peer-list protocol bgp
     mac-address 0000-5e00-0101
    #
    bgp 100
     peer 192.168.1.2 as-number 400
     #
     ipv4-family unicast
      network 1.1.1.1 255.255.255.255
      peer 192.168.1.2 enable
    #
    bgp 100 instance evpn1
     peer 4.4.4.4 as-number 100
     peer 4.4.4.4 connect-interface LoopBack0
     #
     l2vpn-family evpn
      policy vpn-target
      peer 4.4.4.4 enable
    #
    return
  • Device1的配置文件(除CE6870EI之外的款型)

    #
    sysname Device1
    #
    evpn-overlay enable
    #
    igmp snooping enable
    #
    bridge-domain 10
     vxlan vni 10
     igmp snooping enable
     igmp snooping proxy
     evpn
      route-distinguisher 10:1
      vpn-target 10:1 export-extcommunity
      vpn-target 11:1 export-extcommunity
      vpn-target 10:1 import-extcommunity
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 192.168.1.1 255.255.255.0
    #
    interface 10GE1/0/2.1 mode l2
     encapsulation dot1q vid 10
     bridge-domain 10
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
    #
    interface Nve1
     source 1.1.1.1
     vni 10 head-end peer-list protocol bgp
     mac-address 0000-5e00-0101
    #
    bgp 100
     peer 192.168.1.2 as-number 400
     #
     ipv4-family unicast
      network 1.1.1.1 255.255.255.255
      peer 192.168.1.2 enable
    #
    bgp 100 instance evpn1
     peer 4.4.4.4 as-number 100
     peer 4.4.4.4 connect-interface LoopBack0
     #
     l2vpn-family evpn
      policy vpn-target
      peer 4.4.4.4 enable
    #
    return
  • Device2的配置文件(CE6870EI)

    #
    sysname Device2
    #
    assign forward nvo3 acl extend enable
    #
    evpn-overlay enable
    #
    igmp snooping enable
    #
    bridge-domain 10
     vxlan vni 10
     igmp snooping enable
     evpn
      route-distinguisher 40:1
      vpn-target 10:1 export-extcommunity
      vpn-target 11:1 export-extcommunity
      vpn-target 10:1 import-extcommunity
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 192.168.2.1 255.255.255.0
    #
    interface 10GE1/0/2.1 mode l2
     encapsulation dot1q vid 10
     bridge-domain 10
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
    #
    interface Nve1
     source 2.2.2.2
     vni 10 head-end peer-list protocol bgp
     mac-address 0000-5e00-0202
    #
    bgp 200
     peer 192.168.2.2 as-number 400
     #
     ipv4-family unicast
      network 2.2.2.2 255.255.255.255
      peer 192.168.2.2 enable
    #
    bgp 100 instance evpn1
     peer 4.4.4.4 as-number 100
     peer 4.4.4.4 connect-interface LoopBack0
     #
     l2vpn-family evpn
      policy vpn-target
      peer 4.4.4.4 enable
    #
    return
  • Device2的配置文件(除CE6870EI之外的款型)

    #
    sysname Device2
    #
    evpn-overlay enable
    #
    igmp snooping enable
    #
    bridge-domain 10
     vxlan vni 10
     igmp snooping enable
     evpn
      route-distinguisher 40:1
      vpn-target 10:1 export-extcommunity
      vpn-target 11:1 export-extcommunity
      vpn-target 10:1 import-extcommunity
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 192.168.2.1 255.255.255.0
    #
    interface 10GE1/0/2.1 mode l2
     encapsulation dot1q vid 10
     bridge-domain 10
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
    #
    interface Nve1
     source 2.2.2.2
     vni 10 head-end peer-list protocol bgp
     mac-address 0000-5e00-0202
    #
    bgp 200
     peer 192.168.2.2 as-number 400
     #
     ipv4-family unicast
      network 2.2.2.2 255.255.255.255
      peer 192.168.2.2 enable
    #
    bgp 100 instance evpn1
     peer 4.4.4.4 as-number 100
     peer 4.4.4.4 connect-interface LoopBack0
     #
     l2vpn-family evpn
      policy vpn-target
      peer 4.4.4.4 enable
    #
    return
  • Device3的配置文件(CE6870EI)

    #
    sysname Device3
    #
    assign forward nvo3 acl extend enable
    #
    evpn-overlay enable
    #
    igmp snooping enable
    #
    bridge-domain 10
     vxlan vni 10
     igmp snooping enable
     evpn
      route-distinguisher 20:1
      vpn-target 20:1 export-extcommunity
      vpn-target 11:1 export-extcommunity
      vpn-target 20:1 import-extcommunity
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 192.168.3.1 255.255.255.0
    #
    interface 10GE1/0/2.1 mode l2
     encapsulation dot1q vid 20
     bridge-domain 10
    #
    interface LoopBack0
     ip address 3.3.3.3 255.255.255.255
    #
    interface Nve1
     source 3.3.3.3
     vni 10 head-end peer-list protocol bgp
     mac-address 0000-5e00-0303
    #
    bgp 300
     peer 192.168.3.2 as-number 400
     #
     ipv4-family unicast
      network 3.3.3.3 255.255.255.255
      peer 192.168.3.2 enable
    #
    bgp 100 instance evpn1
     peer 4.4.4.4 as-number 100
     peer 4.4.4.4 connect-interface LoopBack0
     #
     l2vpn-family evpn
      policy vpn-target
      peer 4.4.4.4 enable
    #
    return
  • Device3的配置文件(除CE6870EI之外的款型)

    #
    sysname Device3
    #
    evpn-overlay enable
    #
    igmp snooping enable
    #
    bridge-domain 10
     vxlan vni 10
     igmp snooping enable
     evpn
      route-distinguisher 20:1
      vpn-target 20:1 export-extcommunity
      vpn-target 11:1 export-extcommunity
      vpn-target 20:1 import-extcommunity
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 192.168.3.1 255.255.255.0
    #
    interface 10GE1/0/2.1 mode l2
     encapsulation dot1q vid 20
     bridge-domain 10
    #
    interface LoopBack0
     ip address 3.3.3.3 255.255.255.255
    #
    interface Nve1
     source 3.3.3.3
     vni 10 head-end peer-list protocol bgp
     mac-address 0000-5e00-0303
    #
    bgp 300
     peer 192.168.3.2 as-number 400
     #
     ipv4-family unicast
      network 3.3.3.3 255.255.255.255
      peer 192.168.3.2 enable
    #
    bgp 100 instance evpn1
     peer 4.4.4.4 as-number 100
     peer 4.4.4.4 connect-interface LoopBack0
     #
     l2vpn-family evpn
      policy vpn-target
      peer 4.4.4.4 enable
    #
    return
  • Device4的配置文件

    #
    sysname Device4
    #
    evpn-overlay enable
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 192.168.1.2 255.255.255.0
    #
    interface 10GE1/0/2
     undo portswitch
     ip address 192.168.2.2 255.255.255.0
    #
    interface 10GE1/0/3
     undo portswitch
     ip address 192.168.3.2 255.255.255.0
    #
    interface LoopBack0
     ip address 4.4.4.4 255.255.255.255
    #
    bgp 400
     peer 192.168.1.1 as-number 100
     peer 192.168.2.1 as-number 200
     peer 192.168.3.1 as-number 300
     #
     ipv4-family unicast
      network 4.4.4.4 255.255.255.255
      peer 192.168.2.1 enable
      peer 192.168.3.1 enable
      peer 192.168.4.1 enable
    #
    bgp 100 instance evpn1
     peer 1.1.1.1 as-number 100
     peer 1.1.1.1 connect-interface LoopBack0
     peer 2.2.2.2 as-number 100
     peer 2.2.2.2 connect-interface LoopBack0
     peer 3.3.3.3 as-number 100
     peer 3.3.3.3 connect-interface LoopBack0
     #
     l2vpn-family evpn
      undo policy vpn-target
      peer 1.1.1.1 enable
      peer 1.1.1.1 reflect-client
      peer 2.2.2.2 enable
      peer 2.2.2.2 reflect-client
      peer 3.3.3.3 enable
      peer 3.3.3.3 reflect-client
    #
    return
翻译
下载文档
更新时间:2019-03-20

文档编号:EDOC1000166616

浏览量:65609

下载量:244

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页