所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 8800, 7800, 6800, 5800 V200R002C50 配置指南-IP组播

本文档介绍了IP组播的配置,具体包括IP组播基础、IGMP配置、MLD配置、PIM(IPv4)配置、PIM(IPv6)配置、MSDP配置、组播VPN配置、组播路由管理(IPv4)配置、组播路由管理(IPv6)配置、IGMP Snooping配置、MLD Snooping配置、静态组播MAC地址配置、组播VLAN配置和组播网管配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置基于接口的组播VLAN功能示例

配置基于接口的组播VLAN功能示例

组网需求

在如图12-4所示的网络中,SwitchA上的10GE1/0/1接口连接路由器,10GE1/0/210GE1/0/3接口下的业务分别批发给ISP1和ISP2,ISP1和ISP2分别通过组播VLAN2和组播VLAN3传输组播数据。10GE1/0/210GE1/0/3接口下用户VLAN重复,都为VLAN10。

为了防止不同ISP的组播报文会发送到不属于此ISP的用户,影响到ISP的利益,要求通过基于接口的组播VLAN功能,指定属于本ISP的组播数据只转发到连接本ISP用户的接口。

图12-4 配置基于接口的组播VLAN功能组网图

配置思路

采用如下的思路配置基于接口组播VLAN功能:

  1. 在系统视图下使能IGMP Snooping功能。
  2. 创建用户VLAN10,并在用户VLAN下使能IGMP Snooping。
  3. 创建组播VLAN2和组播VLAN3,并在组播VLAN下使能IGMP Snooping。
  4. 10GE1/0/2接口和10GE1/0/3接口下对组播VLAN和用户VLAN分别进行绑定。
  5. 将接口加入VLAN。

操作步骤

  1. 创建用户VLAN10,并在用户VLAN下使能IGMP Snooping功能。

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] igmp snooping enable
    [*SwitchA] vlan 10
    [*SwitchA-vlan10] igmp snooping enable
    [*SwitchA-vlan10] commit
    [~SwitchA-vlan10] quit

  2. 配置组播VLAN2和组播VLAN3,并在组播VLAN下使能IGMP Snooping功能。

    [~SwitchA] vlan 2
    [*SwitchA-vlan2] igmp snooping enable
    [*SwitchA-vlan2] quit
    [*SwitchA] vlan 3
    [*SwitchA-vlan3] igmp snooping enable
    [*SwitchA-vlan3] commit
    [~SwitchA-vlan3] quit

  3. 10GE1/0/2接口和10GE1/0/3接口下分别对组播VLAN和用户VLAN进行绑定。

    [~SwitchA] interface 10ge 1/0/2
    [~SwitchA-10GE1/0/2] multicast layer-2 bind vlan 10 mvlan 2
    [*SwitchA-10GE1/0/2] quit
    [*SwitchA] interface 10ge 1/0/3
    [*SwitchA-10GE1/0/3] multicast layer-2 bind vlan 10 mvlan 3
    [*SwitchA-10GE1/0/3] commit
    [~SwitchA-10GE1/0/3] quit

  4. 10GE1/0/1接口加入组播VLAN,将10GE1/0/210GE1/0/3加入用户VLAN。

    # 以Trunk方式把10GE1/0/1加入组播VLAN2和组播VLAN3。

    [~SwitchA] interface 10ge 1/0/1
    [~SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 2 3 
    [*SwitchA-10GE1/0/1] commit
    [~SwitchA-10GE1/0/1] quit

    # 把10GE1/0/210GE1/0/3接口分别以Trunk方式加入用户VLAN10。

    [~SwitchA] interface 10ge 1/0/2
    [~SwitchA-10GE1/0/2] port link-type trunk
    [*SwitchA-10GE1/0/2] port trunk allow-pass vlan 10
    [*SwitchA-10GE1/0/2] quit
    [*SwitchA] interface 10ge 1/0/3
    [*SwitchA-10GE1/0/3] port link-type trunk
    [*SwitchA-10GE1/0/3] port trunk allow-pass vlan 10
    [*SwitchA-10GE1/0/3] commit
    [~SwitchA-10GE1/0/3] quit

  5. 验证配置结果。

    SwitchA上是使用display multicast layer-2 bind命令查看接口下用户VLAN与组播VLAN的绑定信息。

    [~SwitchA] display multicast layer-2 bind
     ------------------------------------------------------------------- 
     Port                          Startvlan        Endvlan        Mvlan
     ------------------------------------------------------------------- 
     10GE1/0/2                           10             --            2
     10GE1/0/3                           10             --            3
     ------------------------------------------------------------------- 
     Total Table(s) : 2

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 2 to 3 10
    #
    igmp snooping enable
    #
    vlan 2
     igmp snooping enable
    #
    vlan 3
     igmp snooping enable
    #
    vlan 10
     igmp snooping enable
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 to 3
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
     multicast layer-2 bind vlan 10 mvlan 2
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 10
     multicast layer-2 bind vlan 10 mvlan 3
    #
    return
    
翻译
下载文档
更新时间:2019-03-20

文档编号:EDOC1000166616

浏览量:66025

下载量:244

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页