所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 8800, 7800, 6800, 5800 V200R002C50 配置指南-IP组播

本文档介绍了IP组播的配置,具体包括IP组播基础、IGMP配置、MLD配置、PIM(IPv4)配置、PIM(IPv6)配置、MSDP配置、组播VPN配置、组播路由管理(IPv4)配置、组播路由管理(IPv6)配置、IGMP Snooping配置、MLD Snooping配置、静态组播MAC地址配置、组播VLAN配置和组播网管配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置双向PIM(IPv6)基本功能示例

配置双向PIM(IPv6)基本功能示例

组网需求

图5-4所示的某企业的园区办公网络为IPv6网络。现要求在这个办公网络中部署合适的组播协议,使得接入网络的用户主机能够进行多方电视电话会议。

图5-4 配置双向PIM(IPv6)基本功能组网图

表5-31 组网图信息表

设备

VLANIF接口

IPv6地址

SwitchA

VLANIF10 FC00:0:0:3001::1/64
VLANIF50 FC00:0:0:2001::1/64

SwitchB

VLANIF20 FC00:0:0:3002::1/64
VLANIF60 FC00:0:0:2002::1/64

SwitchC

VLANIF30 FC00:0:0:3003::1/64
VLANIF70 FC00:0:0:2003::1/64

SwitchD

VLANIF40 FC00:0:0:3004::1/64
VLANIF80 FC00:0:0:2004::1/64

SwitchE

VLANIF50 FC00:0:0:2001::2/64
VLANIF60 FC00:0:0:2002::2/64
VLANIF70 FC00:0:0:2003::2/64
VLANIF80 FC00:0:0:2004::2/64

配置思路

在多方电视电话会议网络中,如果使用PIM-SM(IPv6)协议作为IPv6组播路由协议,当网络中接入的用户主机达到一定数量时,设备容易因转发资源的大量消耗而负担过重。为了节省设备转发资源,选取双向PIM(IPv6)协议作为IPv6组播路由协议,具体配置思路如下:

  1. 配置交换机接口IPv6地址和IPv6单播路由协议。保证IPv6单播路由正常工作。

  2. 在所有交换机上使能双向PIM(IPv6)。使能双向PIM(IPv6)功能是配置双向PIM(IPv6)其他功能的前提。

  3. 在交换机所有接口上使能PIM-SM(IPv6)功能。双向PIM(IPv6)协议与PIM-SM(IPv6)协议使用相同的邻居工作机制,只有接口使能了PIM-SM(IPv6)功能之后,才能建立邻居关系。

  4. 在与主机侧相连的交换机接口上使能MLD。保证接收者能接入组播网络。

  5. 在SwitchE上配置RP,并指定服务的协议类型为双向PIM(IPv6)。一般将RP配置在组播流量分支较多的设备上。

操作步骤

  1. 配置各接口的IPv6地址和IPv6单播路由协议。

    # 按照图5-4配置各交换机接口的IPv6地址和掩码,配置各交换机间采用OSPFv3进行互连,确保网络中各交换机间能够在网络层互通,并且之间能够借助IPv6单播路由协议实现动态路由更新。SwitchB、SwitchC、SwitchD和SwitchE的配置与SwitchA相似,配置过程略。

    # 配置SwitchA的接口加入VLAN。

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 10 50
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port default vlan 10
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] interface 10ge 1/0/2
    [*SwitchA-10GE1/0/2] port link-type trunk
    [*SwitchA-10GE1/0/2] port trunk allow-pass vlan 50
    [*SwitchA-10GE1/0/2] quit
    [*SwitchA] commit
    

    # 配置SwitchA上VLANIF接口的IPv6地址。

    [~SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] ipv6 enable
    [*SwitchA-Vlanif10] ipv6 address fc00:0:0:3001::1 64
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 50
    [*SwitchA-Vlanif50] ipv6 enable
    [*SwitchA-Vlanif50] ipv6 address fc00:0:0:2001::1 64
    [*SwitchA-Vlanif50] quit
    [*SwitchA] commit

    # 配置SwitchA上的单播路由协议OSPFv3。

    [~SwitchA] ospfv3
    [*SwitchA-ospfv3-1] router-id 10.1.1.1
    [*SwitchA-ospfv3-1] quit
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] ospfv3 1 area 0
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 50
    [*SwitchA-Vlanif50] ospfv3 1 area 0
    [*SwitchA-Vlanif50] quit
    [*SwitchA] commit

  2. 全局使能双向PIM(IPv6)功能,各接口上使能PIM-SM(IPv6)功能。

    # 在所有交换机全局使能双向PIM(IPv6)功能,各接口上使能PIM-SM(IPv6)功能。SwitchB、SwitchC、SwitchD和SwitchE的配置与SwitchA相似,配置过程略。

    [~SwitchA] multicast ipv6 routing-enable
    [*SwitchA] pim ipv6
    [*SwitchA-pim6] bidir-pim
    [*SwitchA-pim6] quit
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] pim ipv6 sm
    [*SwitchA-Vlanif10] commit
    [~SwitchA-Vlanif10] quit
    [~SwitchA] interface vlanif 50
    [~SwitchA-Vlanif50] pim ipv6 sm
    [*SwitchA-Vlanif50] commit
    [~SwitchA-Vlanif50] quit
    

  3. 在连接用户主机的接口上使能MLD功能。

    # 在SwitchA连接用户主机的接口上使能MLD功能。SwitchB、SwitchC和SwitchD的配置与SwitchA相似,配置过程略。

    [~SwitchA] interface vlanif 10
    [~SwitchA-Vlanif10] mld enable
    [*SwitchA-Vlanif10] commit
    [~SwitchA-Vlanif10] quit
    

  4. 配置RP。

    # 配置SwitchE的接口VLANIF60(接口的IPv6地址是FC00:0:0:2002::2)为C-RP接口和C-BSR接口,并指定C-RP为双向PIM(IPv6)协议服务。

    [~SwitchE] pim ipv6
    [*SwitchE-pim6] c-bsr fc00:0:0:2002::2 
    [*SwitchE-pim6] c-rp fc00:0:0:2002::2 bidir
    [*SwitchE-pim6] commit
    [~SwitchE-pim6] quit
    

  5. 验证配置结果。

    # 通过使用display pim ipv6 bsr-info命令可以查看交换机上BSR选举的信息。例如SwitchA和SwitchE上BSR信息分别如下(SwitchE上还显示C-BSR信息):

    [~SwitchA] display pim ipv6 bsr-info
     VPN-Instance: public net
     Elected AdminScoped BSR Count: 0
     Elected BSR Address: FC00:0:0:2002::2
         Priority: 0
         Hash mask length: 126
         State: Accept Preferred
         Uptime: 01:40:40
         Expires: 00:01:42
         C-RP Count: 1
    
    
    [~SwitchE] display pim ipv6 bsr-info
     VPN-Instance: public net
     Elected AdminScoped BSR Count: 0
     Elected BSR Address: FC00:0:0:2002::2
         Priority: 0
         Hash mask length: 126
         State: Elected
         Uptime: 00:00:18
         Next BSR message scheduled at :00:01:42
         C-RP Count: 1
     Candidate AdminScoped BSR Count: 0
     Candidate BSR Address: FC00:0:0:2002::2
         Priority: 0
         Hash mask length: 126
         State:Elected
         Wait to be BSR: 0

    通过上面显示的信息可以看出,选举出的BSR和C-BSR的IPv6地址都是FC00:0:0:2002::2,为SwitchE的接口VLANIF60的IPv6地址。

    # 通过使用display pim ipv6 rp-info命令可以查看Switch上获取的RP信息。例如SwitchA上RP信息如下:

    [~SwitchA] display pim ipv6 rp-info
     VPN-Instance: public net
     PIM-SM BSR RP Number: 1
     Group/MaskLen: FF00::/8
         RP: FC00:0:0:2002::2
         Priority: 192
         Uptime: 00:45:13
         Expires: 00:02:17
         BIDIR: Y
    

    通过上面显示的信息可以看出,选举出的RP是FC00:0:0:2002::2,为SwitchE的接口VLANIF60的IPv6地址。并且选举出的RP为双向PIM协议(IPv6)服务。

    # 通过使用display pim ipv6 df-info命令可以查看交换机上的DF信息。例如SwitchA和SwitchE上的DF信息分别如下:

    [~SwitchA] display pim ipv6 df-info
     VPN-Instance: public net
     Total Number of DF = 2
    
     RP: FC00:0:0:2002::2
     Interface           DF-Address                            DF-Uptime     Rpf-Interface
     Vlanif10            FE80::225:9E00:C895:7C21(local)       22:25:01      N
     Vlanif50            FE80::2E0:3FFF:FE27:AE05              22:25:01      Y
    [~SwitchE] display pim ipv6 df-info
     VPN-Instance: public net
     Total Number of DF = 4
    
     RP: FC00:0:0:2002::2
     Interface           DF-Address                                DF-Uptime     Rpf-Interface
     Vlanif50            FE80::2E0:3FFF:FE27:AE05(local)           22:31:44      N
     Vlanif60            -                                         -             Y
     Vlanif70            FE80::1E2:4CFD:FE23:BC01(local)           22:31:44      N
     Vlanif80            FE80::324:2D23:DF18:2F3D(local)           22:31:44      N

    # 假设用户主机HostA、HostB、HostC和HostD通过MLD协议都加入了组播组(FF1E::1),通过使用display pim ipv6 routing-table命令可以查看PIM(IPv6)协议路由表。例如SwitchA上显示信息如下:

    [~SwitchA] display pim ipv6 routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 0 (S, G) entry
    
     (*, FF1E::1)
         RP: FC00:0:0:2002::2
         Protocol: bidir-pim, Flag: WC
         UpTime: 22:36:47
         Rpf interface: Vlanif50
             Upstream neighbor: FE80::2E0:3FFF:FE27:AE05
         Downstream interface(s) information:
         Total number of downstreams: 2
            1: Vlanif10
                 Protocol: mld, UpTime: 22:36:46, Expires: - 
            2: Vlanif50(RPF)
                 Protocol: bidir-pim, UpTime: 22:36:47, Expires: -

    通过上面显示的信息可以看出,PIM(IPv6)协议路由表项通过双向PIM(IPv6)协议生成,用户主机作为组播源发送的组播数据能够根据(*, FF1E::1)表项建立的双向RPT进行转发。

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 10 50
    #
    multicast ipv6 routing-enable
    #
    ospfv3 1
     router-id 10.1.1.1
     area 0.0.0.0
    #
    interface Vlanif10
     ipv6 enable
     ipv6 address FC00:0:0:3001::1/64
     pim ipv6 sm
     mld enable
     ospfv3 1 area 0.0.0.0
    #
    interface Vlanif50
     ipv6 enable
     ipv6 address FC00:0:0:2001::1/64
     pim ipv6 sm 
     ospfv3 1 area 0.0.0.0
    #
    interface 10GE1/0/1
     port default vlan 10
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    pim ipv6
     bidir-pim
    #
    return
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 20 60
    #
    multicast ipv6 routing-enable
    #
    ospfv3 1
     router-id 10.2.2.2
     area 0.0.0.0
    #
    interface Vlanif20
     ipv6 enable
     ipv6 address FC00:0:0:3002::1/64
     pim ipv6 sm
     mld enable
     ospfv3 1 area 0.0.0.0
    #
    interface Vlanif60
     ipv6 enable
     ipv6 address FC00:0:0:2002::1/64
     pim ipv6 sm 
     ospfv3 1 area 0.0.0.0
    #
    interface 10GE1/0/1
     port default vlan 20
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    pim ipv6
     bidir-pim
    #
    return
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 30 70
    #
    multicast ipv6 routing-enable
    #
    ospfv3 1
     router-id 10.3.3.3
     area 0.0.0.0
    #
    interface Vlanif30
     ipv6 enable
     ipv6 address FC00:0:0:3003::1/64
     pim ipv6 sm
     mld enable
     ospfv3 1 area 0.0.0.0
    #
    interface Vlanif70
     ipv6 enable
     ipv6 address FC00:0:0:2003::1/64
     pim ipv6 sm 
     ospfv3 1 area 0.0.0.0
    #
    interface 10GE1/0/1
     port default vlan 30
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 70
    #
    pim ipv6
     bidir-pim
    #
    return
  • SwitchD的配置文件

    #
    sysname SwitchD
    #
    vlan batch 40 80
    #
    multicast ipv6 routing-enable
    #
    ospfv3 1
     router-id 10.4.4.4
     area 0.0.0.0
    #
    interface Vlanif40
     ipv6 enable
     ipv6 address FC00:0:0:3004::1/64
     pim ipv6 sm
     mld enable
     ospfv3 1 area 0.0.0.0
    #
    interface Vlanif80
     ipv6 enable
     ipv6 address FC00:0:0:2004::1/64
     pim ipv6 sm 
     ospfv3 1 area 0.0.0.0
    #
    interface 10GE1/0/1
     port default vlan 40
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 80
    #
    pim ipv6
     bidir-pim
    #
    return
  • SwitchE的配置文件

    #
    sysname SwitchE
    #
    vlan batch 50 60 70 80
    #
    multicast ipv6 routing-enable
    #
    ospfv3 1
     router-id 10.5.5.5
     area 0.0.0.0
    #
    interface Vlanif50
     ipv6 enable
     ipv6 address FC00:0:0:2001::2/64
     pim ipv6 sm
     ospfv3 1 area 0.0.0.0
    #
    interface Vlanif60
     ipv6 enable
     ipv6 address FC00:0:0:2002::2/64
     pim ipv6 sm
     ospfv3 1 area 0.0.0.0
    #
    interface Vlanif70
     ipv6 enable
     ipv6 address FC00:0:0:2003::2/64
     pim ipv6 sm
     ospfv3 1 area 0.0.0.0
    #
    interface Vlanif80
     ipv6 enable
     ipv6 address FC00:0:0:2004::2/64
     pim ipv6 sm
     ospfv3 1 area 0.0.0.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 70
    #
    interface 10GE1/0/4
     port link-type trunk
     port trunk allow-pass vlan 80
    #
    pim ipv6
     c-bsr FC00:0:0:2002::2
     bidir-pim
     c-rp FC00:0:0:2002::2 bidir
    #
    return
翻译
下载文档
更新时间:2019-03-20

文档编号:EDOC1000166616

浏览量:63799

下载量:242

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页