所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

CloudEngine 8800, 7800, 6800, 5800 V200R002C50 配置指南-IP组播

本文档介绍了IP组播的配置,具体包括IP组播基础、IGMP配置、MLD配置、PIM(IPv4)配置、PIM(IPv6)配置、MSDP配置、组播VPN配置、组播路由管理(IPv4)配置、组播路由管理(IPv6)配置、IGMP Snooping配置、MLD Snooping配置、静态组播MAC地址配置、组播VLAN配置和组播网管配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置IGMP基本功能示例

配置IGMP基本功能示例

组网需求

图2-16所示,网络中的不同用户群组成N1和N2两个末梢网络。PIM网络中的SwitchA连接用户网段N1,SwitchB和SwitchC连接用户网段N2。该PIM网络中传播视频信息使用的组播组地址为225.1.1.1~225.1.1.5。

N1中的HostA和N2中的HostC都希望通过组播方式接收视频信息。接收者HostA只购买了组播组225.1.1.1对应的节目,HostC则购买了所有组播组对应的节目。因此,需要在Switch上进行相关配置,使得HostA只能接收组播组225.1.1.1的视频信息,而HostC则没有限制。

图2-16 配置IGMP的基本功能组网图

配置思路

通过在交换机上配置IGMP基本功能以及限制SwitchA与N1网段相连接口加入的组播组范围,可以实现此需求。

  1. 为了保证组播路由协议正常工作,需要先配置网络中的单播路由协议,实现网络层互通。单播路由正常是组播路由协议正常工作的基础。
  2. 为了实现用户通过组播方式接收视频信息,需要在各Switch上配置基本组播功能,实现组播数据在网络中的转发。
  3. 为了使HostA只接收组播组225.1.1.1的视频信息,需要对HostA能接收的组播数据进行限制。可以通过在SwitchA与N1网段相连的接口上配置组播过滤策略,实现对组播数据的过滤。

操作步骤

  1. 配置各交换机接口IP地址和单播路由协议。

    # 按照图2-16配置各交换机接口的IP地址和掩码,并配置各交换机之间采用OSPF进行互连,确保网络中各交换机间能够在网络层互通,并且之间能够借助单播路由协议实现动态路由更新。SwitchB、SwitchC和SwitchD上的配置过程与SwitchA上的配置相似,配置过程略,详见配置文件。

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 10 11
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type access
    [*SwitchA-10GE1/0/1] port default vlan 10
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] interface 10ge 1/0/2
    [*SwitchA-10GE1/0/2] port link-type trunk
    [*SwitchA-10GE1/0/2] port trunk allow-pass vlan 11
    [*SwitchA-10GE1/0/2] quit
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] ip address 10.110.1.1 24
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 11
    [*SwitchA-Vlanif11] ip address 192.168.1.1 24
    [*SwitchA-Vlanif11] quit
    [*SwitchA] ospf
    [*SwitchA-ospf-1] area 0
    [*SwitchA-ospf-1-area-0.0.0.0] network 10.110.1.0 0.0.0.255
    [*SwitchA-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [*SwitchA-ospf-1-area-0.0.0.0] commit
    [~SwitchA-ospf-1-area-0.0.0.0] quit
    [~SwitchA-ospf-1] quit

  2. 使能IP组播路由功能,并在所有接口上使能PIM-SM功能。

    # 在SwitchA上使能IP组播路由功能,在所有接口上使能PIM-SM功能。SwitchB、SwitchC和SwitchD上的配置过程与此类似,配置过程略,详见配置文件。

    [~SwitchA] multicast routing-enable
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] pim sm
    [*SwitchA-Vlanif10] commit
    [~SwitchA-Vlanif10] quit
    [~SwitchA] interface vlanif 11
    [~SwitchA-Vlanif11] pim sm
    [*SwitchA-Vlanif11] commit
    [~SwitchA-Vlanif11] quit
    

  3. 配置静态RP。

    # 在SwitchA上,配置SwitchD的VLANIF40为静态RP。SwitchB、SwitchC和SwitchD上的配置过程与此类似,配置过程略,详见配置文件。

    [~SwitchA] pim
    [*SwitchA-pim] static-rp 192.168.4.2
    [*SwitchA-pim] commit
    [~SwitchA-pim] quit
    

  4. SwitchA、SwitchB、SwitchC成员端接口上使能IGMP功能。

    # 在SwitchA的VLANIF10接口上使能IGMP功能。SwitchB和SwitchC上的配置过程与此类似,配置过程略,详见配置文件。

    [~SwitchA] interface vlanif 10
    [~SwitchA-Vlanif10] igmp enable
    [*SwitchA-Vlanif10] commit
    [~SwitchA-Vlanif10] quit

  5. 配置SwitchA的VLANIF10接口只能加入组播组225.1.1.1。

    # 先创建ACL,配置其规则为允许组播组225.1.1.1的报文通过,然后在SwitchA的VLANIF10接口上应用该策略。

    [~SwitchA] acl number 2001
    [*SwitchA-acl4-basic-2001] rule permit source 225.1.1.1 0
    [*SwitchA-acl4-basic-2001] commit
    [~SwitchA-acl4-basic-2001] quit
    [~SwitchA] interface vlanif 10
    [~SwitchA-Vlanif10] igmp group-policy 2001
    [*SwitchA-Vlanif10] commit
    [~SwitchA-Vlanif10] quit
    

  6. 验证配置结果。

    # 通过使用display igmp interface命令可以查看各交换机接口上IGMP的配置和运行情况。

    SwitchA的VLANIF10接口上IGMP的显示信息如下:

    [~SwitchA] display igmp interface vlanif 10
    Interface information of VPN instance: public net
     Vlanif10(10.110.1.1):
       IGMP is enabled
       Current IGMP version is 2
       IGMP state: up 
       IGMP group policy: 2001 
       IGMP limit: - 
       Query interval for IGMP (negotiated): -
       Query interval for IGMP (configured): 60 s 
       Other querier timeout for IGMP: 0 s 
       Maximum query response time for IGMP: 10 s
       Querier for IGMP: 10.110.1.1 (this router)
      Total 1 IGMP Group reported

    可以看出,SwitchA的VLANIF10接口已经使能了IGMP,并且应用了acl number为2001的组播组过滤策略。还可以看出,VLANIF10接口接收到了一个组播组的报告报文。

    SwitchB上的VLANIF20接口上IGMP的显示信息如下:

    [~SwitchB] display igmp interface vlanif 20
    Interface information of VPN instance: public net
     Vlanif20(10.110.2.1):
       IGMP is enabled
       Current IGMP version is 2
       IGMP state: up 
       IGMP group policy: none 
       IGMP limit: - 
       Query interval for IGMP (negotiated): -
       Query interval for IGMP (configured): 60 s 
       Other querier timeout for IGMP: 0 s 
       Maximum query response time for IGMP: 10 s
       Querier for IGMP: 10.110.2.1 (this router)
      Total 2 IGMP Groups reported

    可以看到,SwitchB是查询器,这是因为同一网段上组播交换机SwitchB的VLANIF20接口的IP地址较小。还可以看出,VLANIF20接口接收到了两个组播组的报告报文。

    # 通过display pim routing-table命令,可以查看各交换机的PIM-SM路由表。

    SwitchB和SwitchC所在的共享网段,SwitchB竞选为组播数据的转发者。SwitchB上PIM-SM路由表信息显示如下:

    [~SwitchB] display pim routing-table
     VPN-Instance: public net
     Total 2 (*, G) entries; 2 (S, G) entries
    
     (*, 225.1.1.1)
         RP: 192.168.4.2
         Protocol: pim-sm, Flag: WC
         UpTime: 00:21:35
         Upstream interface: Vlanif21
             Upstream neighbor: 192.168.2.2
             RPF prime neighbor: 192.168.2.2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif20
                 Protocol: igmp, UpTime: 00:21:35, Expires: - 
    
     (193.3.5.2, 225.1.1.1)
         RP: 192.168.4.2 
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 00:42:46
         Upstream interface: Vlanif21
             Upstream neighbor: 192.168.2.2
             RPF prime neighbor: 192.168.2.2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif20
                 Protocol: pim-sm, UpTime: 00:21:35, Expires: - 
    
     (*, 225.1.1.2)
         RP: 192.168.4.2
         Protocol: pim-sm, Flag: WC 
         UpTime: 00:06:02 
         Upstream interface: Vlanif21
             Upstream neighbor: 192.168.2.2
             RPF prime neighbor: 192.168.2.2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif20 
                 Protocol: igmp, UpTime: 00:06:02, Expires: - 
    
     (193.3.5.2, 225.1.1.2)
         RP: 192.168.4.2
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 00:15:12
         Upstream interface: Vlanif21 
             Upstream neighbor: 192.168.2.2
             RPF prime neighbor: 192.168.2.2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif20 
                 Protocol: pim-sm, UpTime: 00:06:04, Expires: - 
    
    

    可以看出,SwitchB上有(*, 225.1.1.1)和(193.3.5.2, 225.1.1.1)表项,还有(*, 225.1.1.2)和(193.3.5.2, 225.1.1.2)表项。这表明VLANIF20加入了组播组225.1.1.1和225.1.1.2,并且能够接收到组播源193.3.5.2向这两个组播组发送的数据。

    SwitchA上PIM-SM路由表信息显示如下:

    [~SwitchA] display pim routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
    
     (*, 225.1.1.1)
         RP: 192.168.4.2
         Protocol: pim-sm, Flag: WC
         UpTime: 00:21:35 
         Upstream interface: Vlanif11
             Upstream neighbor: 192.168.1.2
             RPF prime neighbor: 192.168.1.2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif10
                 Protocol: igmp, UpTime: 00:21:35, Expires: - 
    
     (193.3.5.2, 225.1.1.1)
         RP: 192.168.4.2
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 00:42:46
         Upstream interface: Vlanif11
             Upstream neighbor: 192.168.1.2
             RPF prime neighbor: 192.168.1.2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif10
                 Protocol: pim-sm, UpTime: 00:21:35, Expires: - 
    
    

    可以看出,SwitchA上只有(*, 225.1.1.1)和(193.3.5.2, 225.1.1.1)表项,这是因为SwitchA的VLANIF10接口上配置了组播组过滤策略。

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    vlan batch 10 to 11
    #
    multicast routing-enable
    #
    acl number 2001
     rule 5 permit source 225.1.1.1 0
    #
    interface Vlanif10
     ip address 10.110.1.1 255.255.255.0
     pim sm
     igmp enable
     igmp group-policy 2001
    #
    interface Vlanif11
     ip address 192.168.1.1 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port default vlan 10
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 11
    #
    ospf 1
     area 0.0.0.0
      network 10.110.1.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
    #
    pim
     static-rp 192.168.4.2 
    #
    return
    
  • SwitchB的配置文件

    #
    sysname SwitchB
    #
    vlan batch 20 to 21
    #
    multicast routing-enable
    #
    interface Vlanif20
     ip address 10.110.2.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif21
     ip address 192.168.2.1 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port default vlan 20
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 21
    #
    ospf 1
     area 0.0.0.0
      network 10.110.2.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    pim
     static-rp 192.168.4.2 
    #
    return
    
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    vlan batch 20 31
    #
    multicast routing-enable
    #
    interface Vlanif20
     ip address 10.110.2.2 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif31
     ip address 192.168.3.1 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port default vlan 20
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 31
    #
    ospf 1
     area 0.0.0.0
      network 10.110.2.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
    #
    pim
     static-rp 192.168.4.2 
    #
    return
    
  • SwitchD的配置文件

    #
    sysname SwitchD
    #
    vlan batch 11 21 31 40
    #
    multicast routing-enable
    #
    interface Vlanif11
     ip address 192.168.1.2 255.255.255.0
     pim sm
    #
    interface Vlanif21
     ip address 192.168.2.2 255.255.255.0
     pim sm
    #
    interface Vlanif31
     ip address 192.168.3.2 255.255.255.0
     pim sm
    #
    interface Vlanif40
     ip address 192.168.4.2 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 11
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 21
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 31
    #
    interface 10GE1/0/4
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    ospf 1
     area 0.0.0.0
      network 192.168.1.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
    #
    pim
     static-rp 192.168.4.2 
    #
    return
    
翻译
下载文档
更新时间:2019-03-20

文档编号:EDOC1000166616

浏览量:65725

下载量:244

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页