所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R011C10 配置指南-IP业务

本文档介绍了IP业务的配置,具体包括IP地址配置、ARP配置、DHCP配置、DHCP策略VLAN配置、DNS配置、mDNS网关配置、mDNS中继配置、UDP Helper配置、IP性能优化配置、IPv6基础配置、DHCPv6配置、IPv6 DNS配置、IPv6 over IPv4隧道配置和IPv4 over IPv6隧道配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置Super-VLAN下的DHCP服务器示例

配置Super-VLAN下的DHCP服务器示例

组网需求

图5-13所示,某公司拥有两个部门,为了节省IP地址,部门A和部门B规划为同一网段;为了提升业务安全性,将不同部门的用户划分到不同VLAN中。企业管理员为了方便统一管理,希望部门内终端通过DHCP服务器动态获取IP地址。同时,由于业务需要,不同部门间的用户需要实现三层互通。

说明:

S5720EI、S5720HI、S5720S-SI、S5720SI、S5730S-EI、S5730SI、S6720EI、S6720S-EI、S6720SI和S6720S-SI支持Super-VLAN。

图5-13  配置Super-VLAN下的DHCP服务器组网图

配置思路

  1. 在Switch上配置Sub-VLAN,实现不同Sub-VLAN间的二层隔离。同时,不同Sub-VLAN采用同一个网段,节省了IP地址。

  2. 在Switch上配置Super-VLAN的Proxy ARP,实现Sub-VLAN间的三层互通。

  3. 在Super-VLAN上配置DHCP服务器,实现为部门A和部门B的终端动态分配IP地址。

操作步骤

  1. 配置接口加入VLAN,创建VLAN2并向VLAN2中加入GE0/0/1和GE0/0/2;创建VLAN3并向VLAN3中加入GE0/0/3和GE0/0/4

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 2 to 4
    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type access
    [Switch-GigabitEthernet0/0/1] port default vlan 2
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type access
    [Switch-GigabitEthernet0/0/2] port default vlan 2
    [Switch-GigabitEthernet0/0/2] quit
    [Switch] interface gigabitethernet 0/0/3
    [Switch-GigabitEthernet0/0/3] port link-type access
    [Switch-GigabitEthernet0/0/3] port default vlan 3
    [Switch-GigabitEthernet0/0/3] quit
    [Switch] interface gigabitethernet 0/0/4
    [Switch-GigabitEthernet0/0/4] port link-type access
    [Switch-GigabitEthernet0/0/4] port default vlan 3
    [Switch-GigabitEthernet0/0/4] quit

  2. 配置Super-VLAN,实现VLAN聚合。

    # 配置Super-VLAN。

    [Switch] vlan 4
    [Switch-vlan4] aggregate-vlan
    [Switch-vlan4] access-vlan 2 to 3
    [Switch-vlan4] quit
    

    # 配置VLANIF。

    [Switch] interface vlanif 4
    [Switch-Vlanif4] ip address 10.1.1.12 255.255.255.0
    [Switch-Vlanif4] quit
    

  3. 配置Proxy ARP

    [Switch] interface vlanif 4
    [Switch-Vlanif4] arp-proxy inter-sub-vlan-proxy enable
    [Switch-Vlanif4] quit
    

  4. 在接口VLANIF4上配置基于接口地址池的DHCP服务器,实现为Sub-VLAN下的终端动态分配IP地址。

    [Switch] dhcp enable
    [Switch] interface vlanif 4
    [Switch-Vlanif4] dhcp select interface
    [Switch-Vlanif4] quit
    

  5. 检查配置结果

    配置完成后,执行命令display ip pool interface vlanif4,查看地址池的分配情况,“Used”字段表示已经分配出去的IP地址数量。

    [Switch] display ip pool interface vlanif4
      Pool-name        : Vlanif4
      Pool-No          : 0
      Lease            : 1 Days 0 Hours 0 Minutes
      Domain-name      : -
      DNS-server0      : -
      NBNS-server0     : -
      Netbios-type     : -
      Position         : Interface
      Status           : Unlocked
      Gateway-0        : 10.1.1.12
      Network          : 10.1.1.0
      Mask             : 255.255.255.0
      VPN instance     : --
      Logging          : Disable
      Conflicted address recycle interval: -
      Address Statistic: Total       :253       Used        :4                      
                         Idle        :249       Expired     :0                      
                         Conflict    :0         Disabled     :0                      
                                                                                    
     -------------------------------------------------------------------------------
      Network section
             Start           End       Total    Used Idle(Expired) Conflict Disabled
     -------------------------------------------------------------------------------
          10.1.1.1      10.1.1.254     253       4        249(0)       0     0
     -------------------------------------------------------------------------------

配置文件

Switch的配置文件

#
sysname Switch
#
vlan batch 2 to 4
#
dhcp enable
#
vlan 4
 aggregate-vlan
 access-vlan 2 to 3
#
interface Vlanif4
 ip address 10.1.1.12 255.255.255.0
 arp-proxy inter-sub-vlan-proxy enable
 dhcp select interface
#
interface GigabitEthernet0/0/1
 port link-type access
 port default vlan 2
#
interface GigabitEthernet0/0/2
 port link-type access
 port default vlan 2
#
interface GigabitEthernet0/0/3
 port link-type access
 port default vlan 3
#
interface GigabitEthernet0/0/4
 port link-type access
 port default vlan 3
#
return
翻译
下载文档
更新时间:2019-03-28

文档编号:EDOC1000178148

浏览量:65054

下载量:1550

平均得分:
本文档适用于这些产品
相关文档
相关版本
Share
上一页 下一页