所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R011C10 配置指南-IP业务

本文档介绍了IP业务的配置,具体包括IP地址配置、ARP配置、DHCP配置、DHCP策略VLAN配置、DNS配置、mDNS网关配置、mDNS中继配置、UDP Helper配置、IP性能优化配置、IPv6基础配置、DHCPv6配置、IPv6 DNS配置、IPv6 over IPv4隧道配置和IPv4 over IPv6隧道配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置设备作为DHCP服务器示例(基于接口地址池)

配置设备作为DHCP服务器示例(基于接口地址池)

组网需求

图5-10所示,某企业为办公终端规划了两个网段,网段10.1.1.0/24内PC为员工固定办公终端,网段10.1.2.0/24供企业出差人员临时接入网络。为方便管理员统一,希望企业终端能够自动获取IP地址和DNS服务器IP地址(当用户希望以域名方式访问时需要配置域名解析的DNS服务器)。其中,企业管理者的办公PC(Client_1)由于业务需要,希望使用固定IP地址为10.1.1.100/24。

图5-10  配置设备作为DHCP服务器组网图

配置思路

基于接口地址池的DHCP服务器的配置思路如下:

通过在Switch上配置DHCP服务器,实现为企业的两个网段内终端动态分配IP地址和DNS服务器地址。其中,网段10.1.1.0/24内PC为员工固定办公终端,IP地址租期配置为30天,并通过DHCP静态方式为DHCP Client_1分配固定IP地址(10.1.1.100/24);网段10.1.2.0/24供企业出差人员临时接入网络,IP地址租期配置为2天。

操作步骤

  1. 使能DHCP服务

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] dhcp enable

  2. 配置接口加入VLAN

    # 配置GE0/0/1接口加入VLAN10。

    [Switch] vlan batch 10 to 11
    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type hybrid
    [Switch-GigabitEthernet0/0/1] port hybrid pvid vlan 10
    [Switch-GigabitEthernet0/0/1] port hybrid untagged vlan 10
    [Switch-GigabitEthernet0/0/1] quit

    # 配置GE0/0/2加接口入VLAN11。

    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type hybrid
    [Switch-GigabitEthernet0/0/2] port hybrid pvid vlan 11
    [Switch-GigabitEthernet0/0/2] port hybrid untagged vlan 11
    [Switch-GigabitEthernet0/0/2] quit

  3. 配置VLANIF接口IP地址

    # 配置VLANIF10接口地址。

    [Switch] interface vlanif 10
    [Switch-Vlanif10] ip address 10.1.1.1 24
    [Switch-Vlanif10] quit

    # 配置VLANIF11接口地址。

    [Switch] interface vlanif 11
    [Switch-Vlanif11] ip address 10.1.2.1 24
    [Switch-Vlanif11] quit

  4. 配置接口地址池

    # 配置VLANIF10接口下的客户端从接口地址池中获取IP地址和相关网络参数。

    [Switch] interface vlanif 10
    [Switch-Vlanif10] dhcp select interface
    [Switch-Vlanif10] dhcp server gateway-list 10.1.1.1
    [Switch-Vlanif10] dhcp server lease day 30
    [Switch-Vlanif10] dhcp server domain-name huawei.com
    [Switch-Vlanif10] dhcp server dns-list 10.1.3.1
    [Switch-Vlanif10] dhcp server static-bind ip-address 10.1.1.100 mac-address 286e-d488-b684
    [Switch-Vlanif10] quit

    # 配置VLANIF11接口下的客户端从接口地址池中获取IP地址和相关网络参数。

    [Switch] interface vlanif 11
    [Switch-Vlanif11] dhcp select interface
    [Switch-Vlanif11] dhcp server gateway-list 10.1.2.1
    [Switch-Vlanif11] dhcp server lease day 2
    [Switch-Vlanif11] dhcp server domain-name huawei.com
    [Switch-Vlanif11] dhcp server dns-list 10.1.3.1
    [Switch-Vlanif11] quit

  5. 配置DHCP数据保存功能,设备发生故障时,可以在系统重启后,执行命令dhcp server database recover,从存储设备文件恢复DHCP数据。

    [Switch] dhcp server database enable

  6. 验证配置结果

    # 在Switch上执行命令display ip pool来查看接口地址池的分配情况,“Used”字段显示已经分配出去的IP地址数量。假设企业员工固定办公终端有100个,出差人员接入3个。

    [Switch] display ip pool interface vlanif10
      Pool-name        : Vlanif10
      Pool-No          : 0
      Lease            : 30 Days 0 Hours 0 Minutes
      Domain-name      : huawei.com
      DNS-server0      : 10.1.3.1
      NBNS-server0     : -
      Netbios-type     : -
      Position         : Interface
      Status           : Unlocked
      Gateway-0        : 10.1.1.1
      Network          : 10.1.1.0
      Mask             : 255.255.255.0
      VPN instance     : --
      Logging          : Disable
      Conflicted address recycle interval: -
      Address Statistic: Total       :253       Used        :100
                         Idle        :153       Expired     :0
                         Conflict    :0         Disabled     :0
    
     -------------------------------------------------------------------------------
      Network section
             Start           End       Total    Used Idle(Expired) Conflict Disabled
     -------------------------------------------------------------------------------
            10.1.1.1      10.1.1.254     253     100        153(0)       0     0
     -------------------------------------------------------------------------------
    [Switch] display ip pool interface vlanif11
      Pool-name        : Vlanif11
      Pool-No          : 1
      Lease            : 2 Days 0 Hours 0 Minutes
      Domain-name      : huawei.com
      DNS-server0      : 10.1.3.1
      NBNS-server0     : -
      Netbios-type     : -
      Position         : Interface
      Status           : Unlocked
      Gateway-0        : 10.1.2.1
      Network          : 10.1.2.0
      Mask             : 255.255.255.0
      VPN instance     : --
      Logging          : Disable
      Conflicted address recycle interval: -
      Address Statistic: Total       :253       Used        :3
                         Idle        :250       Expired     :0
                         Conflict    :0         Disabled     :0
    
     -------------------------------------------------------------------------------
      Network section
             Start           End       Total    Used Idle(Expired) Conflict Disabled
     -------------------------------------------------------------------------------
            10.1.1.1      10.1.1.254    253       3        250(0)       0     0
     -------------------------------------------------------------------------------

    在Client_1(操作系统以Windows 7为例)上查看IP地址信息,可以看到Client_1已经获取到IP地址10.1.1.100/24。

    C:\Documents and Settings\Administrator>ipconfig
    
    Windows IP Configuration
    
    
    Ethernet adapter Local Area Connection 2:
    
       Connection-specific DNS Suffix  . :
       IPv4 Address. . . . . . . . . . . : 10.1.1.100
       Subnet Mask . . . . . . . . . . . : 255.255.254.0
       Default Gateway . . . . . . . . . : 10.1.1.1

    在其他DHCP客户端(以10.1.1.0/24网段中操作系统为Windows 7的某终端为例)上查看IP地址信息,可以看到已经成功获取到IP地址。

    C:\Documents and Settings\Administrator>ipconfig
    
    Windows IP Configuration
    
    
    Ethernet adapter Local Area Connection 2:
    
       Connection-specific DNS Suffix  . :
       IPv4 Address. . . . . . . . . . . : 10.1.1.51
       Subnet Mask . . . . . . . . . . . : 255.255.254.0
       Default Gateway . . . . . . . . . : 10.1.1.1

配置文件

Switch的配置文件

#
sysname Switch
#
vlan batch 10 to 11
#
dhcp enable
#
dhcp server database enable
# 
interface Vlanif10
 ip address 10.1.1.1 255.255.255.0
 dhcp select interface
 dhcp server gateway-list 10.1.1.1
 dhcp server static-bind ip-address 10.1.1.100 mac-address 286e-d488-b684
 dhcp server lease day 30 hour 0 minute 0
 dhcp server dns-list 10.1.3.1
 dhcp server domain-name huawei.com
#
interface Vlanif11
 ip address 10.1.2.1 255.255.255.0
 dhcp select interface
 dhcp server gateway-list 10.1.2.1
 dhcp server lease day 2 hour 0 minute 0
 dhcp server dns-list 10.1.3.1
 dhcp server domain-name huawei.com
#
interface GigabitEthernet0/0/1
 port link-type hybrid
 port hybrid pvid vlan 10
 port hybrid untagged vlan 10
#
interface GigabitEthernet0/0/2
 port link-type hybrid
 port hybrid pvid vlan 11
 port hybrid untagged vlan 11
#
return
翻译
下载文档
更新时间:2019-03-28

文档编号:EDOC1000178148

浏览量:64677

下载量:1543

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页