所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R011C10 配置指南-IP业务

本文档介绍了IP业务的配置,具体包括IP地址配置、ARP配置、DHCP配置、DHCP策略VLAN配置、DNS配置、mDNS网关配置、mDNS中继配置、UDP Helper配置、IP性能优化配置、IPv6基础配置、DHCPv6配置、IPv6 DNS配置、IPv6 over IPv4隧道配置和IPv4 over IPv6隧道配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置VRRP备份组对接NLB服务器群集示例(通过物理链路环回方法)

配置VRRP备份组对接NLB服务器群集示例(通过物理链路环回方法)

组网需求

图4-29所示,交换机Switch_1和Switch_2通过接口GE0/0/2相连的心跳线组成VRRP备份组,其中Switch_1为主、Switch_2为备。Switch_1和Switch_2上的接口GE0/0/1分别与两台NLB服务器直连。NLB服务器群集工作在组播模式下,群集IP地址为10.128.246.252/24,对应的群集MAC地址为03bf-0a80-f6fc。Switch与客户端Client之间路由可达。

用户希望网络中客户端Client访问NLB服务器群集时,VRRP备份组能够将发往群集IP地址的报文发送给群集中的所有NLB服务器。

图4-29  VRRP备份组对接组播模式的NLB服务器群集

配置思路

通过物理链路环回方法实现对接的配置思路如下:

  1. 配置与NLB服务器直连的接口GE0/0/1加入VLAN100。
  2. 配置心跳线接口GE0/0/2加入VLAN100。
  3. 去使能自环接口GE0/0/4和GE0/0/5的STP/RSTP/VBST/MSTP功能,并以Access类型分别加入VLAN100和VLAN200。
  4. 配置三层接口VLANIF200的VRRP虚拟IP地址,该VRRP虚拟IP地址作为NLB服务器群集的网关。
  5. 配置静态ARP表项。静态ARP表项的IP地址为群集IP地址,MAC地址为群集组播MAC,出接口为自环口上NLB服务器群集网关VLAN所在的接口。
  6. 连接自环接口GE0/0/4和GE0/0/5

操作步骤

  1. 配置与NLB直连的接口GE0/0/1

    # 在Switch_1上配置接口GE0/0/1加入VLAN100。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch_1
    [Switch_1] vlan batch 100 200
    [Switch_1] interface gigabitethernet 0/0/1
    [Switch_1-GigabitEthernet0/0/1] port link-type access
    [Switch_1-GigabitEthernet0/0/1] port default vlan 100
    [Switch_1-GigabitEthernet0/0/1] quit
    

    # 在Switch_2上配置接口GE0/0/1加入VLAN100。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch_2
    [Switch_2] vlan batch 100 200
    [Switch_2] interface gigabitethernet 0/0/1
    [Switch_2-GigabitEthernet0/0/1] port link-type access
    [Switch_2-GigabitEthernet0/0/1] port default vlan 100
    [Switch_2-GigabitEthernet0/0/1] quit
    

  2. 配置心跳线接口GE0/0/2加入VLAN100

    # 在Switch_1上配置接口GE0/0/2加入VLAN100。

    [Switch_1] interface gigabitethernet 0/0/2
    [Switch_1-GigabitEthernet0/0/2] port link-type trunk 
    [Switch_1-GigabitEthernet0/0/2] port trunk allow-pass vlan 100
    [Switch_1-GigabitEthernet0/0/2] quit
    

    # 在Switch_2上配置接口GE0/0/2加入VLAN100。

    [Switch_2] interface gigabitethernet 0/0/2
    [Switch_2-GigabitEthernet0/0/2] port link-type trunk 
    [Switch_2-GigabitEthernet0/0/2] port trunk allow-pass vlan 100
    [Switch_2-GigabitEthernet0/0/2] quit
    
    说明:

    心跳线接口不能加入自环口上网关所在的VLAN,防止流量在VRRP备份组设备间循环。例如,该举例中GE0/0/2不能加入VLAN200。

  3. 配置自环接口GE0/0/4和GE0/0/5

    # 在Switch_1上去使能接口GE0/0/4和GE0/0/5的STP/RSTP/VBST/MSTP功能。

    [Switch_1] interface gigabitethernet 0/0/4
    [Switch_1-GigabitEthernet0/0/4] undo stp enable
    [Switch_1-GigabitEthernet0/0/4] quit
    [Switch_1] interface gigabitethernet 0/0/5
    [Switch_1-GigabitEthernet0/0/5] undo stp enable
    [Switch_1-GigabitEthernet0/0/5] quit

    # 在Switch_1上配置接口GE0/0/4和GE0/0/5以Access类型分别加入VLAN100和VLAN200。

    [Switch_1] interface gigabitethernet 0/0/4
    [Switch_1-GigabitEthernet0/0/4] port link-type access
    [Switch_1-GigabitEthernet0/0/4] port default vlan 100
    [Switch_1-GigabitEthernet0/0/4] quit
    [Switch_1] interface gigabitethernet 0/0/5
    [Switch_1-GigabitEthernet0/0/5] port link-type access
    [Switch_1-GigabitEthernet0/0/5] port default vlan 200
    [Switch_1-GigabitEthernet0/0/5] quit

    # 在Switch_2上去使能接口GE0/0/4和GE0/0/5的STP/RSTP/VBST/MSTP功能。

    [Switch_2] interface gigabitethernet 0/0/4
    [Switch_2-GigabitEthernet0/0/4] undo stp enable
    [Switch_2-GigabitEthernet0/0/4] quit
    [Switch_2] interface gigabitethernet 0/0/5
    [Switch_2-GigabitEthernet0/0/5] undo stp enable
    [Switch_2-GigabitEthernet0/0/5] quit

    # 在Switch_2上配置接口GE0/0/4和GE0/0/5以Access类型分别加入VLAN100和VLAN200。

    [Switch_2] interface gigabitethernet 0/0/4
    [Switch_2-GigabitEthernet0/0/4] port link-type access
    [Switch_2-GigabitEthernet0/0/4] port default vlan 100
    [Switch_2-GigabitEthernet0/0/4] quit
    [Switch_2] interface gigabitethernet 0/0/5
    [Switch_2-GigabitEthernet0/0/5] port link-type access
    [Switch_2-GigabitEthernet0/0/5] port default vlan 200
    [Switch_2-GigabitEthernet0/0/5] quit

  4. 配置NLB服务器群集网关的IP地址

    # 在Switch_1上创建VRRP备份组1,配置Switch_1在该备份组中的优先级为120。

    [Switch_1] interface vlanif 200
    [Switch_1-Vlanif200] ip address 10.128.246.10 24
    [Switch_1-Vlanif200] vrrp vrid 1 virtual-ip 10.128.246.250
    [Switch_1-Vlanif200] vrrp vrid 1 priority 120 
    [Switch_1-Vlanif200] quit

    # 在Switch_2上创建VRRP备份组1,配置Switch_2在该备份组中的优先级为缺省优先级100。

    [Switch_2] interface vlanif 200
    [Switch_2-Vlanif200] ip address 10.128.246.11 24
    [Switch_2-Vlanif200] vrrp vrid 1 virtual-ip 10.128.246.250
    [Switch_2-Vlanif200] quit
    说明:
    • 三层接口VLANIF200下配置的VRRP虚拟IP地址(10.128.246.250)作为NLB服务器群集的网关。
    • 为减少网络负担,建议将NLB服务器群集的网关与其他服务器的网关分开。

      这是因为在以上组网中,本端设备发往NLB服务器群集的流量会通过心跳线发往对端设备,并经过对端设备的自环线。此时,如果其他服务器与NLB服务器具有相同网关,会导致其他服务器也收到发往NLB服务器群集的流量,给网络增加负担。例如:由Switch_1发往群集IP的流量会通过心跳线发往Switch_2。在Switch_2上,由自环口GE0/0/4通过自环线到达GE0/0/5。如果此时Switch_2上的非NLB服务器的网关也是VLANIF200。该流量就会由自环口GE0/0/5发往非NLB服务器。

  5. 配置静态ARP表项

    # 在Switch_1上配置静态ARP表项的IP地址为群集IP地址10.128.246.252,MAC地址为群集组播MAC地址03bf-0a80-f6fc,出接口为VLAN200所在的接口GE0/0/5

    [Switch_1] arp static 10.128.246.252 03bf-0a80-f6fc vid 200 interface gigabitethernet 0/0/5

    # 在Switch_2上配置静态ARP表项的IP地址为群集IP地址10.128.246.252,MAC地址为群集组播MAC地址03bf-0a80-f6fc,出接口为VLAN200所在的接口GE0/0/5

    [Switch_2] arp static 10.128.246.252 03bf-0a80-f6fc vid 200 interface gigabitethernet 0/0/5

  6. 连接自环接口GE0/0/4和GE0/0/5

    上述配置完成后,在Switch_1和Switch_2上分别进行物理连线。

  7. 验证配置结果

    上述配置完成后,发往NLB服务器群集IP地址的报文Server_1和Server_2都能收到。

配置文件

  • Switch_1的配置文件

    #
    sysname Switch_1
    #
    vlan batch 100 200
    #                                                                               
    interface Vlanif200
     ip address 10.128.246.10 255.255.255.0 
     vrrp vrid 1 virtual-ip 10.128.246.250
     vrrp vrid 1 priority 120
    #                                                                               
    interface GigabitEthernet0/0/1                                                 
     port link-type access                                                          
     port default vlan 100                                                 
    # 
    interface GigabitEthernet0/0/2                                                 
     port link-type trunk                                                           
     port trunk allow-pass vlan 100                                                 
    #                                                                               
    interface GigabitEthernet0/0/4                                                
     port link-type access                                                          
     port default vlan 100                                                          
     stp disable                                                                    
    # 
    interface GigabitEthernet0/0/5                                                
     port link-type access                                                          
     port default vlan 200                                                          
     stp disable                                                                    
    # 
    arp static 10.128.246.252 03bf-0a80-f6fc vid 200 interface GigabitEthernet0/0/5
    #  
    return
    
  • Switch_2的配置文件

    #
    sysname Switch_2
    #
    vlan batch 100 200
    #                                                                               
    interface Vlanif200
     ip address 10.128.246.11 255.255.255.0 
     vrrp vrid 1 virtual-ip 10.128.246.250
    #                                                                               
    interface GigabitEthernet0/0/1                                                 
     port link-type access                                                          
     port default vlan 100                                                
    # 
    interface GigabitEthernet0/0/2                                                 
     port link-type trunk                                                           
     port trunk allow-pass vlan 100                                                 
    #                                                                               
    interface GigabitEthernet0/0/4                                                
     port link-type access                                                          
     port default vlan 100                                                          
     stp disable                                                                    
    # 
    interface GigabitEthernet0/0/5                                                
     port link-type access                                                          
     port default vlan 200                                                          
     stp disable                                                                    
    # 
    arp static 10.128.246.252 03bf-0a80-f6fc vid 200 interface GigabitEthernet0/0/5
    #  
    return
    
翻译
下载文档
更新时间:2019-03-28

文档编号:EDOC1000178148

浏览量:60076

下载量:1484

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页