所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R011C10 配置指南-IP业务

本文档介绍了IP业务的配置,具体包括IP地址配置、ARP配置、DHCP配置、DHCP策略VLAN配置、DNS配置、mDNS网关配置、mDNS中继配置、UDP Helper配置、IP性能优化配置、IPv6基础配置、DHCPv6配置、IPv6 DNS配置、IPv6 over IPv4隧道配置和IPv4 over IPv6隧道配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置路由式Proxy ARP示例

配置路由式Proxy ARP示例

组网需求

图4-24所示,某企业的子公司A和子公司B位于不同城市,且所使用的IP地址部署为同一个网段(172.16.0.0/16)。连接子公司A的Switch_1与连接子公司B的Switch_2之间路由可达。由于两个子公司之间被设备间隔,属于不同的广播域,因此无法在同一个局域网内实现互通;子公司的主机没有配置默认网关,无法实现跨网段互通。现在公司需要在不改变主机配置的情况下,实现两个子公司之间的通信。

图4-24  配置路由式Proxy ARP组网图

配置思路

采用如下的配置思路实现子公司A和子公司B之间互通:

  1. 在Switch_1上将连接子公司A的接口划分到VLAN10,在Switch_2上将连接子公司B的接口划分到VLAN20。

  2. 在子公司A和子公司B的VLANIF接口上使能路由式Proxy ARP功能,实现子公司A和子公司B互通。

操作步骤

  1. 创建VLAN,将接口加入VLAN,并配置接口的IP地址

    # 配置Switch_1。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch_1
    [Switch_1] vlan batch 10
    [Switch_1] interface gigabitethernet 0/0/1
    [Switch_1-GigabitEthernet0/0/1] port link-type access
    [Switch_1-GigabitEthernet0/0/1] port default vlan 10
    [Switch_1-GigabitEthernet0/0/1] quit
    [Switch_1] interface vlanif 10
    [Switch_1-Vlanif10] ip address 172.16.1.1 24
    

    # 配置Switch_2。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch_2
    [Switch_2] vlan batch 20
    [Switch_2] interface gigabitethernet 0/0/1
    [Switch_2-GigabitEthernet0/0/1] port link-type access
    [Switch_2-GigabitEthernet0/0/1] port default vlan 20
    [Switch_2-GigabitEthernet0/0/1] quit
    [Switch_2] interface vlanif 20
    [Switch_2-Vlanif20] ip address 172.16.2.1 24
    

  2. 配置路由式Proxy ARP

    # 配置Switch_1。

    [Switch_1-Vlanif10] arp-proxy enable
    [Switch_1-Vlanif10] quit

    # 配置Switch_2。

    [Switch_2-Vlanif20] arp-proxy enable
    [Switch_2-Vlanif20] quit

  3. 验证配置结果

    # 在Switch_1上查看VLANIF10接口的ARP表项,可以看到VLANIF10接口的IP地址对应的MAC地址。

    [Switch_1] display arp interface vlanif 10
    IP ADDRESS      MAC ADDRESS     EXPIRE(M) TYPE        INTERFACE   VPN-INSTANCE                                                      
                                              VLAN/CEVLAN                                                                               
    ------------------------------------------------------------------------------                                                      
    172.16.1.1      101b-5441-5bf6            I -         Vlanif10                                                                     
    ------------------------------------------------------------------------------                                                      
    Total:1         Dynamic:0       Static:0     Interface:1  

    # 在子公司A选取一台主机Host_1(IP地址:172.16.1.2/16,操作系统以Windows 7为例),在子公司B选取一台主机Host_2(IP地址:172.16.2.2/16)。在主机Host_1上Ping主机Host_2的IP地址,可以Ping通。

    C:\Documents and Settings\Administrator> ping 172.16.2.2
    Pinging 172.16.2.2 with 32 bytes of data:
    Reply from 172.16.2.2: bytes=32 time<1ms TTL=128
    Reply from 172.16.2.2: bytes=32 time<1ms TTL=128
    Reply from 172.16.2.2: bytes=32 time<1ms TTL=128
    Reply from 172.16.2.2: bytes=32 time<1ms TTL=128
    
    Ping statistics for 172.16.2.2:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 0ms, Maximum = 0ms, Average = 0ms

    # 在Host_1上查看ARP表,可以看到主机Host_2的IP地址对应的MAC地址是Switch_1的VLANIF10接口的MAC地址,可见Host_1和Host_2之间是通过ARP代理实现互通的。

    C:\Documents and Settings\Administrator> arp -a
    Interface: 172.16.1.2 --- 0xd
      Internet Address      Physical Address      Type
      172.16.2.2            101b-5441-5bf6        dynamic
    ...

配置文件

  • Switch_1的配置文件

    #
    sysname Switch_1
    #
    vlan batch 10
    #
    interface Vlanif10
     ip address 172.16.1.1 255.255.255.0
     arp-proxy enable
    #
    interface GigabitEthernet0/0/1
     port link-type access
     port default vlan 10
    #
    return
    
  • Switch_2的配置文件

    #
    sysname Switch_2
    #
    vlan batch 20
    #
    interface Vlanif20
     ip address 172.16.2.1 255.255.255.0
     arp-proxy enable
    #
    interface GigabitEthernet0/0/1
     port link-type access
     port default vlan 20
    #
    return
    
翻译
下载文档
更新时间:2019-03-28

文档编号:EDOC1000178148

浏览量:60179

下载量:1490

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页