所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R011C10 配置指南-IP业务

本文档介绍了IP业务的配置,具体包括IP地址配置、ARP配置、DHCP配置、DHCP策略VLAN配置、DNS配置、mDNS网关配置、mDNS中继配置、UDP Helper配置、IP性能优化配置、IPv6基础配置、DHCPv6配置、IPv6 DNS配置、IPv6 over IPv4隧道配置和IPv4 over IPv6隧道配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置VLAN间Proxy ARP示例

配置VLAN间Proxy ARP示例

组网需求

图4-26所示,公司研发部和市场部的IP地址处于同一网段,但部署在不同的VLAN中。用户希望研发部和市场部的用户之间可以互相访问。

图4-26  配置VLAN间Proxy ARP组网图

配置思路

VLAN间Proxy ARP的配置思路如下:

  1. 配置Super-VLAN和Sub-VLAN,并将接口加入Sub-VLAN。

  2. 配置Super-VLAN的VLANIF接口的IP地址,并使能VLAN间Proxy ARP功能。

操作步骤

  1. 配置Super-VLAN和Sub-VLAN,并将接口加入Sub-VLAN

    # 创建Sub-VLAN2,并将接口加入Sub-VLAN2。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 2
    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type access
    [Switch-GigabitEthernet0/0/1] port default vlan 2
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type access
    [Switch-GigabitEthernet0/0/2] port default vlan 2
    [Switch-GigabitEthernet0/0/2] quit
    

    # 创建Sub-VLAN3,并将接口加入Sub-VLAN3。

    [Switch] vlan batch 3
    [Switch] interface gigabitethernet 0/0/3
    [Switch-GigabitEthernet0/0/3] port link-type access
    [Switch-GigabitEthernet0/0/3] port default vlan 3
    [Switch-GigabitEthernet0/0/3] quit
    [Switch] interface gigabitethernet 0/0/4
    [Switch-GigabitEthernet0/0/4] port link-type access
    [Switch-GigabitEthernet0/0/4] port default vlan 3
    [Switch-GigabitEthernet0/0/4] quit
    

    # 创建Super-VLAN4,并将Sub-VLAN2和Sub-VLAN3加入Super-VLAN4。

    [Switch] vlan 4
    [Switch-vlan4] aggregate-vlan
    [Switch-vlan4] access-vlan 2
    [Switch-vlan4] access-vlan 3
    [Switch-vlan4] quit

  2. 配置Super-VLAN的VLANIF接口的IP地址,并使能VLAN间Proxy ARP功能

    [Switch] interface vlanif 4
    [Switch-Vlanif4] ip address 10.10.10.1 24
    [Switch-Vlanif4] arp-proxy inter-sub-vlan-proxy enable
    [Switch-Vlanif4] quit

  3. 配置主机的IP地址

    # 配置Host_1的IP地址为10.10.10.2/24。

    # 配置Host_2的IP地址为10.10.10.3/24。

    # 配置Host_3的IP地址为10.10.10.4/24。

    # 配置Host_4的IP地址为10.10.10.5/24。

  4. 验证配置结果

    # 在Switch上查看VLANIF4接口的ARP表项,可以看到VLANIF4接口的IP地址对应的MAC地址。

    [Switch] display arp interface vlanif 4
    IP ADDRESS      MAC ADDRESS     EXPIRE(M) TYPE        INTERFACE   VPN-INSTANCE                                                      
                                              VLAN/CEVLAN                                                                               
    ------------------------------------------------------------------------------                                                      
    10.10.10.1      101b-5441-5bf6            I -         Vlanif4                                                                     
    ------------------------------------------------------------------------------                                                      
    Total:1         Dynamic:0       Static:0     Interface:1  

    # 在主机Host_1(操作系统以Windows 7为例)上Ping主机Host_3的IP地址,可以Ping通。

    C:\Documents and Settings\Administrator> ping 10.10.10.4
    Pinging 10.10.10.4 with 32 bytes of data:
    Reply from 10.10.10.4: bytes=32 time<1ms TTL=128
    Reply from 10.10.10.4: bytes=32 time<1ms TTL=128
    Reply from 10.10.10.4: bytes=32 time<1ms TTL=128
    Reply from 10.10.10.4: bytes=32 time<1ms TTL=128
    
    Ping statistics for 10.10.10.4:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 0ms, Maximum = 0ms, Average = 0ms

    # 在Host_1上查看ARP表,可以看到主机Host_3的IP地址对应的MAC地址是Switch的VLANIF4接口的MAC地址,可见Host_1和Host_3之间是通过ARP代理实现互通的。

    C:\Documents and Settings\Administrator> arp -a
    Interface: 10.10.10.2 --- 0xd
      Internet Address      Physical Address      Type
      10.10.10.4            101b-5441-5bf6        dynamic
    ...

配置文件

Switch的配置文件

#
sysname Switch
#
vlan batch 2 to 4
#
vlan 4
 aggregate-vlan
 access-vlan 2 to 3
#
interface Vlanif4
 ip address 10.10.10.1 255.255.255.0
 arp-proxy inter-sub-vlan-proxy enable
#
interface GigabitEthernet0/0/1
 port link-type access
 port default vlan 2
#
interface GigabitEthernet0/0/2
 port link-type access
 port default vlan 2
#
interface GigabitEthernet0/0/3
 port link-type access
 port default vlan 3
#
interface GigabitEthernet0/0/4
 port link-type access
 port default vlan 3
#
return
翻译
下载文档
更新时间:2019-03-28

文档编号:EDOC1000178148

浏览量:60307

下载量:1490

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页