所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R011C10 配置指南-IP业务

本文档介绍了IP业务的配置,具体包括IP地址配置、ARP配置、DHCP配置、DHCP策略VLAN配置、DNS配置、mDNS网关配置、mDNS中继配置、UDP Helper配置、IP性能优化配置、IPv6基础配置、DHCPv6配置、IPv6 DNS配置、IPv6 over IPv4隧道配置和IPv4 over IPv6隧道配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置IPv6 DNS客户端示例

配置IPv6 DNS客户端示例

组网需求

图14-2所示,设备SwitchA作为IPv6 DNS Client和IPv6 DNS Server配合,用户希望SwitchA通过域名(huawei.com)能够访问IPv6地址为fc00:2::1/64的主机。

在SwitchA上配置SwitchB和SwitchC的静态IPv6 DNS表项,用户希望SwitchA能够使用域名(SwitchB和SwitchC)对设备进行管理。

图14-2  配置IPv6 DNS组网图

配置思路

IPv6 DNS的配置思路如下:

  1. 在SwitchA上配置静态DNS表项,实现以域名方式与SwitchB和SwitchC进行通信的功能。

  2. 在SwitchA上配置动态DNS功能,实现SwitchA以动态DNS查询方式与IPv6 DNS服务器进行通信的功能。

  3. 在SwitchA配置域名后缀,实现SwitchA可以实现域名后缀列表功能。

  4. 配置Switch上的路由,实现各设备之间的路由可达。

操作步骤

  1. 配置SwitchA

    # 配置IPv6功能。

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] ipv6 
    [SwitchA] vlan 101
    [SwitchA-vlan101] quit
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type hybrid
    [SwitchA-GigabitEthernet0/0/1] port hybrid pvid vlan 101
    [SwitchA-GigabitEthernet0/0/1] port hybrid untagged vlan 101
    [SwitchA-GigabitEthernet0/0/1] quit 
    [SwitchA] interface vlanif 101 
    [SwitchA-Vlanif101] ipv6 enable
    [SwitchA-Vlanif101] ipv6 address fc00:1::1/64
    [SwitchA-Vlanif101] quit 

    # 配置静态IPv6 DNS表项。

    [SwitchA] ipv6 host SwitchB fc00:1::2
    [SwitchA] ipv6 host SwitchC fc00:2::3

    # 使能DNS域名解析功能。

    [SwitchA] dns resolve

    # 配置IPv6 DNS Server的IPv6地址。

    [SwitchA] dns server ipv6 fc00:3::2

    # 配置域名后缀“.net”。

    [SwitchA] dns domain net

    # 配置域名后缀“.com”。

    [SwitchA] dns domain com
    [SwitchA] quit
    说明:

    若要完成对域名的解析,还需要配置SwitchA至IPv6 DNS Server的路由。路由的配置方法请参见S1720, S2700, S5700, S6720 V200R011C10 配置指南-IP单播路由》 静态路由配置 中的“静态路由配置举例”。

  2. 验证配置结果

    # 在设备SwitchA上执行ping ipv6 huawei.com命令,可以ping通,且对应的目的地址为fc00:2::1。

    <SwitchA> ping ipv6 huawei.com
      Resolved Host ( huawei.com -> FC00:2::1 )                                       
      PING huawei.com : 56  data bytes, press CTRL_C to break                       
        Reply from FC00:2::1                                                          
        bytes=56 Sequence=1 hop limit=63  time = 56 ms                              
        Reply from FC00:2::1                                                          
        bytes=56 Sequence=2 hop limit=63  time = 14 ms                              
        Reply from FC00:2::1                                                          
        bytes=56 Sequence=3 hop limit=63  time = 50 ms                              
        Reply from FC00:2::1                                                          
        bytes=56 Sequence=4 hop limit=63  time = 7 ms                               
        Reply from FC00:2::1                                                          
        bytes=56 Sequence=5 hop limit=63  time = 7 ms                               
                                                                                    
      --- huawei.com ping statistics ---                                            
        5 packet(s) transmitted                                                     
        5 packet(s) received                                                        
        0.00% packet loss                                                           
        round-trip min/avg/max = 7/26/56 ms 

    # 在SwitchA用display ipv6 host命令可以查看到静态IPv6 DNS表项中主机名和IPv6地址的对应关系。

    <SwitchA> display ipv6 host
    Host              Age        Flags   IPv6Address (es)
    SwitchB           0          static  FC00:1::2
    SwitchC           0          static  FC00:2::3

    # 在SwitchA用display dns ipv6 dynamic-host命令可以查看到动态缓存区中的动态IPv6 DNS表项信息。

    <SwitchA> display dns ipv6 dynamic-host
    No  Domain-name           Ipv6address          TTL 
    1   huawei.com            FC00:2::1            3579  
    说明:

    显示信息中的TTL表示该表项存在的时间,单位是秒。

配置文件

  • SwitchA的配置文件

    #
    sysname SwitchA
    #
    ipv6
    #
    vlan batch 101
    #
    ipv6 host SwitchB FC00:1::2
    ipv6 host SwitchC FC00:2::3
    #
    dns resolve
    dns server ipv6 FC00:3::2
    dns domain net
    dns domain com
    #
    interface Vlanif101
     ipv6 enable
     ipv6 address FC00:1::1/64
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 101
     port hybrid untagged vlan 101
    #                                                                               
    ipv6 route-static FC00:2:: 64 FC00:1::2                                             
    ipv6 route-static FC00:3:: 64 FC00:1::2   
    #
    return
    
  • SwitchB的配置文件

    #
    sysname SwitchB
    #                                                                               
    ipv6 
    #
    vlan batch 100 to 101
    #
    interface Vlanif100
     ipv6 enable
     ipv6 address FC00:2::2/64
    #
    interface Vlanif101
     ipv6 enable
     ipv6 address FC00:1::2/64
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 101
     port hybrid untagged vlan 101
    #
    interface GigabitEthernet0/0/2
     port link-type hybrid
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #                                                                               
    ipv6 route-static FC00:3:: 64 FC00:2::3  
    #
    return
    
  • SwitchC的配置文件

    #
    sysname SwitchC
    #
    ipv6
    #
    vlan batch 100 to 101
    #
    interface Vlanif100
     ipv6 enable
     ipv6 address FC00:2::3/64
    #
    interface Vlanif101
     ipv6 enable
     ipv6 address FC00:3::1/64
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 101
     port hybrid untagged vlan 101
    #
    interface GigabitEthernet0/0/2
     port link-type hybrid
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #                                                                               
    ipv6 route-static FC00:1:: 64 FC00:2::2  
    #
    return
    
翻译
下载文档
更新时间:2019-03-28

文档编号:EDOC1000178148

浏览量:59520

下载量:1475

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页