所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R011C10 配置指南-QoS

本文档介绍了如何配置QoS功能,主要包括MQC配置、优先级映射配置、流量监管配置、流量整形配置、接口限速配置、拥塞避免配置、拥塞管理配置、报文过滤配置、重定向配置、流量统计配置、基于ACL的简化流策略配置和HQoS配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置在指定时间段进行限速示例

配置在指定时间段进行限速示例

组网需求

图7-12所示,企业用户通过Switch的接口GE0/0/2连接到外部网络设备。

每天8:30~18:00的时间段为工作时间,对员工访问外网的速率进行限制,要求工作时间访问外网的速率不超过4Mbit/s。

图7-12  配置在指定时间段进行限速组网图

配置思路

采用匹配时间段的流策略方式实现限速,具体配置思路如下:
  1. 配置各接口,实现企业用户能通过Switch访问外部网络。
  2. 配置时间范围,用于在ACL中引用。
  3. 配置ACL,匹配指定时间段通过设备的流量。
  4. 配置流策略,对于符合ACL规则的报文进行限速。
  5. 在接口GE0/0/1的入方向应用流策略。

操作步骤

  1. 创建VLAN并配置各接口

    # 在Switch上创建VLAN10。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan 10
    [Switch-vlan10] quit

    # 配置Switch上接口GE0/0/1GE0/0/2为Trunk类型接口,并加入VLAN10。

    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type trunk
    [Switch-GigabitEthernet0/0/1] port trunk allow-pass vlan 10
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type trunk
    [Switch-GigabitEthernet0/0/2] port trunk allow-pass vlan 10
    [Switch-GigabitEthernet0/0/2] quit
    说明:

    请配置LSW与Switch对接的接口为Trunk类型,并加入VLAN10。

    # 创建VLANIF10,并为VLANIF10配置IP地址192.168.1.1/24。

    [Switch] interface vlanif 10
    [Switch-Vlanif10] ip address 192.168.1.1 24
    [Switch-Vlanif10] quit
    说明:

    请配置Router与Switch对接的接口IP地址为192.168.1.2/24。

  2. 创建周期时间段working_time,时间范围为工作日的8:30~18:00。

    [Switch] time-range working_time 08:30 to 18:00 working-day
    

  3. 配置ACL 2001,配置三条规则,分别限制源IP地址为192.168.1.10、192.168.1.11、192.168.1.12的报文在工作时间的带宽。

    [Switch] acl number 2001
    [Switch-acl-basic-2001] rule permit source 192.168.1.10 0 time-range working_time 
    [Switch-acl-basic-2001] rule permit source 192.168.1.11 0 time-range working_time
    [Switch-acl-basic-2001] rule permit source 192.168.1.12 0 time-range working_time
    [Switch-acl-basic-2001] quit

  4. 配置匹配ACL 2001的流分类规则,实现对报文的分类。

    [Switch] traffic classifier c1
    [Switch-classifier-c1] if-match acl 2001
    [Switch-classifier-c1] quit

  5. 配置流行为,限制访问外网速率不超过4Mbit/s。

    [Switch] traffic behavior b1
    [Switch-behavior-b1] car cir 4096
    [Switch-behavior-b1] quit

  6. 配置流策略,并在接口GE0/0/1的入方向应用该策略。

    [Switch] traffic policy p1
    [Switch-trafficpolicy-p1] classifier c1 behavior b1
    [Switch-trafficpolicy-p1] quit
    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] traffic-policy p1 inbound
    [Switch-GigabitEthernet0/0/1] quit

  7. 验证配置结果

    # 查看流分类的配置信息。

    [Switch] display traffic classifier user-defined c1
      User Defined Classifier Information:                                          
       Classifier: c1                                                               
        Operator: OR                                                                
        Rule(s) : if-match acl 2001   

    # 查看流策略的配置信息。

    [Switch] display traffic policy user-defined p1
      User Defined Traffic Policy Information:                                      
      Policy: p1                                                                    
       Classifier: c1                                                               
        Operator: OR                                                                
         Behavior: b1                                                               
          Committed Access Rate:                                                    
            CIR 4096 (Kbps), CBS 512000 (Byte)                                      
            PIR 4096 (Kbps), PBS 512000 (Byte)
            Green Action   : pass                                                   
            Yellow Action  : pass                                                   
            Red Action     : discard      

配置文件

  • Switch的配置文件

    #
    sysname Switch
    #
    vlan batch 10
    #
    time-range working_time 08:30 to 18:00 working-day     
    #
    acl number 2001  
     rule 5 permit source 192.168.1.10 0 time-range working_time
     rule 10 permit source 192.168.1.11 0 time-range working_time
     rule 15 permit source 192.168.1.12 0 time-range working_time
    #
    traffic classifier c1 operator or
     if-match acl 2001
    #
    traffic behavior b1
     car cir 4096 pir 4096 cbs 512000 pbs 512000 green pass yellow pass red discard 
    #
    traffic policy p1 match-order config
     classifier c1 behavior b1
    #
    interface Vlanif10                                                              
     ip address 192.168.1.1 255.255.255.0                                           
    #                                                                               
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
     traffic-policy p1 inbound
    #                                                                               
    interface GigabitEthernet0/0/2
     port link-type trunk                                                           
     port trunk allow-pass vlan 10                                                  
    #
    return
    
翻译
下载文档
更新时间:2019-03-28

文档编号:EDOC1000178152

浏览量:14390

下载量:880

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页