所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R011C10 配置指南-QoS

本文档介绍了如何配置QoS功能,主要包括MQC配置、优先级映射配置、流量监管配置、流量整形配置、接口限速配置、拥塞避免配置、拥塞管理配置、报文过滤配置、重定向配置、流量统计配置、基于ACL的简化流策略配置和HQoS配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置流量整形示例

配置流量整形示例

组网需求

Switch通过接口GE0/0/2与路由器互连,来自网络侧的业务有语音、视频、数据,携带的802.1p优先级分别为6、5、2,这些业务可经由路由器和Switch到达用户,如图7-14所示。由于来自企业园区网的流量速率大于Router接口的速率,出接口GE0/0/2处可能会发生带宽抖动。为减少带宽抖动,同时保证各类业务带宽要求,现要求如下:

  • 接口带宽限制为10000kbit/s。

  • 语音带宽限制为3000kbit/s,最大不超过5000kbit/s。

  • 视频带宽限制为5000kbit/s,最大不超过8000kbit/s。

  • 数据带宽限制为2000kbit/s,最大不超过3000kbit/s。

图7-14  流量整形配置组网图

配置思路

采用如下的思路配置流量整形:
  1. 创建VLAN,并配置各接口,使用户能够通过Switch访问网络。
  2. 配置接口信任报文的802.1p优先级。

  3. 配置接口整形功能,限制接口带宽。

  4. 配置端口队列整形功能,限制语音、视频、数据三类业务的带宽。

操作步骤

  1. 创建VLAN并配置各接口

    # 创建VLAN 10。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 10
    

    # 将接口GE0/0/1、GE0/0/2的接入类型分别配置为trunk,并分别将接口GE0/0/1、GE0/0/2加入VLAN 10。

    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type trunk
    [Switch-GigabitEthernet0/0/1] port trunk allow-pass vlan 10
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type trunk
    [Switch-GigabitEthernet0/0/2] port trunk allow-pass vlan 10
    [Switch-GigabitEthernet0/0/2] quit

    # 创建VLANIF10,并配置网段地址10.10.10.2/24。

    [Switch] interface vlanif 10
    [Switch-Vlanif10] ip address 10.10.10.2 255.255.255.0
    [Switch-Vlanif10] quit
    说明:

    请在Router上的与Switch对接的接口上配置IP地址10.10.10.1/24。

  2. 配置接口信任报文的类型

    说明:

    S5720EI、S5720HI、S6720EI、S6720S-EI优先级映射的配置请参见配置优先级映射S1720GFR、S1720GW-E、S1720GWR-E、S1720X-E、S2720EI、S2750EI、S5700LI、S5700S-LI、S5710-X-LI、S5720LI、S5720S-LI、S5720SI、S5720S-SI、S5730SI、S5730S-EI、S6720LI、S6720S-LI、S6720SI、S6720S-SI优先级映射的配置请参见配置优先级映射

    本步骤中的配置适用于S1720GFR、S1720GW-E、S1720GWR-E、S1720X-E、S2720EI、S2750EI、S5700LI、S5700S-LI、S5710-X-LI、S5720LI、S5720S-LI、S5720SI、S5720S-SI、S5730SI、S5730S-EI、S6720LI、S6720S-LI、S6720SI、S6720S-SI

    # 配置接口信任报文的802.1p优先级。

    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] trust 8021p
    [Switch-GigabitEthernet0/0/1] quit

  3. 配置接口整形

    # 在Switch上配置接口整形,将接口速率限制在10000kbit/s。

    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] qos lr outbound cir 10000
    

  4. 配置端口队列整形

    # 在Switch上配置端口队列整形,使语音、视频、数据业务的带宽分别限制为3000kbit/s、5000kbit/s、2000kbit/s,最大分别不超过5000kbit/s、8000kbit/s、3000kbit/s。

    [Switch-GigabitEthernet0/0/2] qos queue 6 shaping cir 3000 pir 5000
    [Switch-GigabitEthernet0/0/2] qos queue 5 shaping cir 5000 pir 8000
    [Switch-GigabitEthernet0/0/2] qos queue 2 shaping cir 2000 pir 3000
    [Switch-GigabitEthernet0/0/2] quit
    

  5. 验证配置结果

    # 配置成功后,从接口GE0/0/2发出的报文保证速率为10000kbit/s;语音业务保证速率为3000kbit/s,不超过5000kbit/s;视频业务保证速率为5000kbit/s,不超过8000kbit/s;数据业务保证速率为2000kbit/s,不超过3000kbit/s。

配置文件

  • Switch的配置文件
    #
    sysname Switch
    #
    vlan batch 10
    #
    interface Vlanif10
     ip address 10.10.10.2 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
     trust 8021p 
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 10 
     qos lr outbound cir 10000 cbs 1250000
     qos queue 2 shaping cir 2000 pir 3000
     qos queue 5 shaping cir 5000 pir 8000
     qos queue 6 shaping cir 3000 pir 5000
    #
    return
    
翻译
下载文档
更新时间:2019-03-28

文档编号:EDOC1000178152

浏览量:14596

下载量:883

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页