所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R011C10 配置指南-QoS

本文档介绍了如何配置QoS功能,主要包括MQC配置、优先级映射配置、流量监管配置、流量整形配置、接口限速配置、拥塞避免配置、拥塞管理配置、报文过滤配置、重定向配置、流量统计配置、基于ACL的简化流策略配置和HQoS配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置拥塞避免和拥塞管理综合示例

配置拥塞避免和拥塞管理综合示例

组网需求

Switch通过接口GE0/0/3与Router互连,来自Internet的业务有语音、视频、数据,携带的802.1p优先级分别为6、5、2,这些业务可经由Router和Switch到达用户,如图8-13所示。由于Switch入接口GE0/0/3的速率大于出接口GE0/0/1、GE0/0/2的速率,在这两个出接口处可能会发生拥塞。

为了减轻网络拥塞造成的影响,保证用户对于高优先级、低延迟业务的服务要求,配置需求如表8-4表8-5所述。

表8-4  拥塞避免配置参数

业务类型

颜色

阈值下限(%)

阈值上限(%)

丢弃概率

语音

绿

80

100

10

视频

60

80

20

数据

40

60

40

表8-5  拥塞管理配置参数

业务类型

服务等级

WDRR

语音

EF

0

视频

AF3

100

数据

AF1

50

图8-13  拥塞避免和拥塞管理配置组网图

配置思路

采用如下的思路配置:
  1. 配置各接口所属的VLAN,实现各设备间链路互通。

  2. Switch上创建并配置DiffServ域,将802.1p优先级映射为PHB行为并着色,并在Switch入接口上绑定DiffServ域。

  3. Switch上配置WRED模板,并在出接口应用WRED模板。

  4. Switch出接口上配置各服务等级队列的调度参数。

操作步骤

  1. 配置各接口所属的VLAN,使各设备间链路互通。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 2 5 6
    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type trunk
    [Switch-GigabitEthernet0/0/1] port trunk allow-pass vlan 2 5 6
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type trunk
    [Switch-GigabitEthernet0/0/2] port trunk allow-pass vlan 2 5 6
    [Switch-GigabitEthernet0/0/2] quit
    [Switch] interface gigabitethernet 0/0/3
    [Switch-GigabitEthernet0/0/3] port link-type trunk
    [Switch-GigabitEthernet0/0/3] port trunk allow-pass vlan 2 5 6
    [Switch-GigabitEthernet0/0/3] quit
    

  2. 配置基于简单流分类的优先级映射

    说明:

    S5720EI、S5720HI、S6720EI、S6720S-EI优先级映射的配置请参见配置优先级映射S1720GFR、S1720GW-E、S1720GWR-E、S1720X-E、S2720EI、S2750EI、S5700LI、S5700S-LI、S5710-X-LI、S5720LI、S5720S-LI、S5720SI、S5720S-SI、S5730SI、S5730S-EI、S6720LI、S6720S-LI、S6720SI、S6720S-SI优先级映射的配置请参见配置优先级映射

    本步骤中的配置适用于S5720EI、S5720HI、S6720EI、S6720S-EI

    # 创建DiffServ域ds1,将802.1p优先级6、5、2分别映射为PHB行为EF、AF3、AF1,并分别将颜色标记为绿色、黄色、红色。

    [Switch] diffserv domain ds1
    [Switch-dsdomain-ds1] 8021p-inbound 6 phb ef green
    [Switch-dsdomain-ds1] 8021p-inbound 5 phb af3 yellow
    [Switch-dsdomain-ds1] 8021p-inbound 2 phb af1 red
    [Switch-dsdomain-ds1] quit
    

    # 在Switch入接口GE0/0/3上绑定DiffServ域。

    [Switch] interface gigabitethernet 0/0/3
    [Switch-GigabitEthernet0/0/3] trust upstream ds1
    [Switch-GigabitEthernet0/0/3] trust 8021p inner
    [Switch-GigabitEthernet0/0/3] quit

  3. 配置拥塞避免

    # 在Switch上创建WRED模板wred1,并配置wred1的三色报文参数。

    [Switch] drop-profile wred1
    [Switch-drop-wred1] color green low-limit 80 high-limit 100 discard-percentage 10
    [Switch-drop-wred1] color yellow low-limit 60 high-limit 80 discard-percentage 20
    [Switch-drop-wred1] color red low-limit 40 high-limit 60 discard-percentage 40
    [Switch-drop-wred1] quit
    

    # 在Switch出接口GE0/0/1、GE0/0/2上应用WRED模板wred1。

    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] qos wred wred1
    [Switch-GigabitEthernet0/0/1] qos queue 5 wred wred1
    [Switch-GigabitEthernet0/0/1] qos queue 3 wred wred1
    [Switch-GigabitEthernet0/0/1] qos queue 1 wred wred1
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] qos wred wred1
    [Switch-GigabitEthernet0/0/2] qos queue 5 wred wred1
    [Switch-GigabitEthernet0/0/2] qos queue 3 wred wred1
    [Switch-GigabitEthernet0/0/2] qos queue 1 wred wred1
    [Switch-GigabitEthernet0/0/2] quit

  4. 配置拥塞管理

    # 在Switch的报文出接口GE0/0/1、GE0/0/2上配置各服务等级队列的调度参数。

    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] qos drr
    [Switch-GigabitEthernet0/0/1] qos queue 5 drr weight 0
    [Switch-GigabitEthernet0/0/1] qos queue 3 drr weight 100
    [Switch-GigabitEthernet0/0/1] qos queue 1 drr weight 50
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] qos drr
    [Switch-GigabitEthernet0/0/2] qos queue 5 drr weight 0
    [Switch-GigabitEthernet0/0/2] qos queue 3 drr weight 100
    [Switch-GigabitEthernet0/0/2] qos queue 1 drr weight 50
    [Switch-GigabitEthernet0/0/2] quit
    

  5. 验证配置结果

    # 查看DiffServ域ds1的配置信息。

    [Switch] display diffserv domain name ds1
    diffserv domain name:ds1
     8021p-inbound 0 phb be green
     8021p-inbound 1 phb af1 green
     8021p-inbound 2 phb af1 red
     8021p-inbound 3 phb af3 green
     8021p-inbound 4 phb af4 green
     8021p-inbound 5 phb af3 yellow
     8021p-inbound 6 phb ef green
     8021p-inbound 7 phb cs7 green
     8021p-outbound be green map 0
    ......

    # 查看WRED模板配置信息。

    [Switch] display drop-profile name wred1
    Drop-profile[1]: wred1
    Queue depth    : default
    Color     Low-limit   High-limit  Discard-percentage
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    Green     80          100         10
    Yellow    60          80          20
    Red       40          60          40
    Non-tcp   100         100         100
    -----------------------------------------------------------------
    
    说明:

    S5720HI的显示信息中包含Queue depth字段。

    S5720HI的显示信息中不包含Non-tcp字段。

配置文件

  • Switch的配置文件

    #
    sysname Switch
    #
    vlan batch 2 5 to 6
    #
    diffserv domain ds1
     8021p-inbound 2 phb af1 red
     8021p-inbound 5 phb af3 yellow
     8021p-inbound 6 phb ef green
    #
    drop-profile wred1
     color green low-limit 80 high-limit 100 discard-percentage 10
     color yellow low-limit 60 high-limit 80 discard-percentage 20
     color red low-limit 40 high-limit 60 discard-percentage 40
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 5 to 6
     qos drr
     qos queue 1 drr weight 50
     qos queue 3 drr weight 100
     qos queue 5 drr weight 0
     qos wred wred1
     qos queue 1 wred wred1
     qos queue 3 wred wred1
     qos queue 5 wred wred1
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 2 5 to 6
     qos drr
     qos queue 1 drr weight 50
     qos queue 3 drr weight 100
     qos queue 5 drr weight 0
     qos wred wred1
     qos queue 1 wred wred1
     qos queue 3 wred wred1
     qos queue 5 wred wred1
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 2 5 to 6
     trust upstream ds1
     trust 8021p inner
    #
    return
    
翻译
下载文档
更新时间:2019-03-28

文档编号:EDOC1000178152

浏览量:14677

下载量:887

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页