所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R011C10 配置指南-QoS

本文档介绍了如何配置QoS功能,主要包括MQC配置、优先级映射配置、流量监管配置、流量整形配置、接口限速配置、拥塞避免配置、拥塞管理配置、报文过滤配置、重定向配置、流量统计配置、基于ACL的简化流策略配置和HQoS配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置拥塞管理综合示例

配置拥塞管理综合示例

组网需求

图8-12所示,Switch通过接口GE0/0/3与路由器互连,来自Internet的业务有语音、视频、数据,携带的802.1p优先级分别为7、5、2,这些业务可经由路由器和Switch到达用户,为了减轻网络拥塞造成的影响,保证用户对于高优先级、低延迟业务的服务要求,配置需求如下表所述。

表8-3  拥塞管理配置参数

业务类型

服务等级

WRR权重

语音

CS7

0

视频

EF

20

数据

AF2

10

图8-12  拥塞管理配置组网图

配置思路

采用如下的思路配置:
  1. 配置各接口所属的VLAN,使各设备间链路互通。

  2. 配置接口信任报文的802.1p优先级。

  3. 配置调度模板并且在接口上应用。

操作步骤

  1. 配置各接口所属的VLAN,使各设备间链路互通。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 10 20 30
    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type trunk
    [Switch-GigabitEthernet0/0/1] port trunk allow-pass vlan 10 20 30
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type trunk
    [Switch-GigabitEthernet0/0/2] port trunk allow-pass vlan 10 20 30
    [Switch-GigabitEthernet0/0/2] quit
    [Switch] interface gigabitethernet 0/0/3
    [Switch-GigabitEthernet0/0/3] port link-type trunk
    [Switch-GigabitEthernet0/0/3] port trunk allow-pass vlan 10 20 30
    [Switch-GigabitEthernet0/0/3] quit
    

  2. 配置接口信任报文的类型

    说明:

    S5720EI、S5720HI、S6720EI、S6720S-EI优先级映射的配置请参见配置优先级映射S1720GFR、S1720GW-E、S1720GWR-E、S1720X-E、S2720EI、S2750EI、S5700LI、S5700S-LI、S5710-X-LI、S5720LI、S5720S-LI、S5720SI、S5720S-SI、S5730SI、S5730S-EI、S6720LI、S6720S-LI、S6720SI、S6720S-SI优先级映射的配置请参见配置优先级映射

    本步骤中的配置适用于S1720GFR、S1720GW-E、S1720GWR-E、S1720X-E、S2720EI、S2750EI、S5700LI、S5700S-LI、S5710-X-LI、S5720LI、S5720S-LI、S5720SI、S5720S-SI、S5730SI、S5730S-EI、S6720LI、S6720S-LI、S6720SI、S6720S-SI

    # 配置接口信任报文的802.1p优先级。

    [Switch] interface gigabitethernet 0/0/3
    [Switch-GigabitEthernet0/0/3] trust 8021p
    [Switch-GigabitEthernet0/0/3] quit
    

  3. 配置拥塞管理

    # 创建调度模板,并配置队列调度参数。

    [Switch] qos schedule-profile p1
    [Switch-qos-schedule-profile-p1] qos wrr
    [Switch-qos-schedule-profile-p1] qos queue 7 wrr weight 0
    [Switch-qos-schedule-profile-p1] qos queue 5 wrr weight 20
    [Switch-qos-schedule-profile-p1] qos queue 2 wrr weight 10
    [Switch-qos-schedule-profile-p1] quit
    

    # 在Switch的出接口GE0/0/1、GE0/0/2上应用调度模板。

    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] qos schedule-profile p1
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] qos schedule-profile p1
    [Switch-GigabitEthernet0/0/2] quit
    

  4. 验证配置结果

    # 查看调度模板和队列调度参数。

    [Switch] qos schedule-profile p1
    [Switch-qos-schedule-profile-p1] display this
    #
     qos schedule-profile p1
       qos queue 2 wrr weight 10
       qos queue 5 wrr weight 20
       qos queue 7 wrr weight 0 
    #
    return
    

配置文件

  • Switch的配置文件

    #
    sysname Switch
    #
    vlan batch 10 20 30
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 20 30
     qos schedule-profile p1
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 10 20 30
     qos schedule-profile p1
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 10 20 30
     trust 8021p
    #
     qos schedule-profile p1
       qos queue 2 wrr weight 10
       qos queue 5 wrr weight 20
       qos queue 7 wrr weight 0
    #
    return
    
翻译
下载文档
更新时间:2019-03-28

文档编号:EDOC1000178152

浏览量:14407

下载量:881

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页