所选语种没有对应资源,请选择:

本站点使用Cookies,继续浏览表示您同意我们使用Cookies。Cookies和隐私政策>

提示

尊敬的用户,您的IE浏览器版本过低,为获取更好的浏览体验,请升级您的IE浏览器。

升级

S1720, S2700, S5700, S6720 V200R011C10 配置指南-QoS

本文档介绍了如何配置QoS功能,主要包括MQC配置、优先级映射配置、流量监管配置、流量整形配置、接口限速配置、拥塞避免配置、拥塞管理配置、报文过滤配置、重定向配置、流量统计配置、基于ACL的简化流策略配置和HQoS配置。
评分并提供意见反馈 :
华为采用机器翻译与人工审校相结合的方式将此文档翻译成不同语言,希望能帮助您更容易理解此文档的内容。 请注意:即使是最好的机器翻译,其准确度也不及专业翻译人员的水平。 华为对于翻译的准确性不承担任何责任,并建议您参考英文文档(已提供链接)。
配置基于ACL的流量统计示例

配置基于ACL的流量统计示例

组网需求

图12-5所示,PC1的MAC地址为0000-0000-0003,它连接在SwitchGE0/0/1端口上,实现与其他设备的互连互通。现希望Switch对源MAC为0000-0000-0003的报文进行流量统计。

图12-5  配置流量统计组网图

配置思路

通过ACL匹配指定源MAC主机的报文实现对其进行流量统计,具体配置思路如下:
  1. 配置各接口,实现Switch与Router、PC1互通。
  2. 配置ACL规则,匹配源MAC为0000-0000-0003的报文。
  3. 在接口GE0/0/1入方向配置流量统计,对该接口收到的源MAC为0000-0000-0003的报文进行统计。

操作步骤

  1. 创建VLAN并配置各接口

    # 在Switch上创建VLAN20。

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan 20
    [Switch-vlan20] quit
    

    # 配置接口GE0/0/1为Access类型接口,接口GE0/0/2为Trunk类型接口,并将GE0/0/1GE0/0/2加入VLAN20。

    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type access
    [Switch-GigabitEthernet0/0/1] port default vlan 20
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type trunk
    [Switch-GigabitEthernet0/0/2] port trunk allow-pass vlan 20
    [Switch-GigabitEthernet0/0/2] quit
    

    # 创建VLANIF20,并配置IP地址10.10.10.2/24。

    [Switch] interface vlanif 20
    [Switch-Vlanif20] ip address 10.10.10.2 24
    [Switch-Vlanif20] quit
    
    说明:

    请配置Router与Switch对接的接口IP地址为10.10.10.1/24。

  2. 配置ACL规则

    # 在Switch上创建编码为4000的二层ACL,匹配源MAC为0000-0000-0003的报文。

    [Switch] acl 4000
    [Switch-acl-L2-4000] rule permit source-mac 0000-0000-0003 ffff-ffff-ffff
    [Switch-acl-L2-4000] quit
    

  3. 配置流量统计

    # 在接口GE0/0/1入方向配置基于ACL的流量统计。

    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] traffic-statistic inbound acl 4000 by-bytes
    [Switch-GigabitEthernet0/0/1] quit
    

  4. 验证配置结果

    # 查看设备接口入方向上应用的ACL规则和流动作信息。

    [Switch] display traffic-applied interface gigabitethernet 0/0/1 inbound
    -----------------------------------------------------------                     
    ACL applied inbound interface GigabitEthernet0/0/1                              
                                                                                    
    ACL 4000                                                                        
     rule 5 permit source-mac 0000-0000-0003                                        
    ACTIONS:                                                                        
     statistic by bytes                                                             
    -----------------------------------------------------------      

    # 查看流量统计信息。

    [Switch] display traffic-statistics interface gigabitethernet 0/0/1 inbound acl 4000
    ---------------------------------------------------------------------------                                                         
    Interface GigabitEthernet0/0/1                                                                                                      
     ACL:4000 Rule:5                                                                                                                    
         matched:681.575M Bytes, passed:681.575M Bytes, dropped:0 Bytes   
    

配置文件

  • Switch的配置文件

    #
    sysname Switch
    #
    vlan batch 20
    #
    acl number 4000
     rule 5 permit source-mac 0000-0000-0003 
    #
    interface Vlanif20
     ip address 10.10.10.2 255.255.255.0
    #                                                                               
    interface GigabitEthernet0/0/1
     port link-type access                                                           
     port default vlan 20                                                   
     traffic-statistic inbound acl 4000 by-bytes                                                       
    #                                                                               
    interface GigabitEthernet0/0/2
     port link-type trunk                                                           
     port trunk allow-pass vlan 20                                                   
    #
    return
    
翻译
下载文档
更新时间:2019-03-28

文档编号:EDOC1000178152

浏览量:14689

下载量:887

平均得分:
本文档适用于这些产品
相关文档
相关版本
分享
上一页 下一页